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Chapter 1 - Introduction 

About Navicat Data Modeler 

Navicat Data Modeler is a powerful and easy-to-use GUI tool for creating and manipulating database models. It 

enables users to design database structures, reverse engineer, forward engineer, generate SQL files and print models 

to files, etc. 

Navicat Data Modeler is available on three platforms - Microsoft Windows, macOS and Linux. Here are some highlights 

of Navicat Data Modeler: 

 Create and manipulate conceptual/logical/physical models. 

 Support various database systems: MySQL, MariaDB, Oracle, PostgreSQL, SQLite and SQL Server (including 

cloud databases like Amazon RDS, Amazon Redshift, Alibaba Cloud, Microsoft Azure). 

 Reverse engineer databases/schemas or tables/views to a model. 

 Forward engineer a physical model to a SQL file or a database/schema. 

 Create and edit table structures directly. 

 Support Navicat Cloud. 

For details, visit our website: https://www.navicat.com 

System Requirements 

Windows 

 Microsoft Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10, Server 2008, Server 2012, 

Server 2016, Server 2019 

macOS 

 macOS 10.12 Sierra, macOS 10.13 High Sierra, macOS 10.14 Mojave, macOS 10.15 Catalina, macOS 11 Big 

Sur 

Linux 

 Debian 9 or later, Ubuntu 16.04 or later, CentOS 7 or later, Fedora 26 or later, Linux Mint 18 or later 

Supported Databases 

 MySQL - 3.23, 4.0, 4.1, 5.0, 5.1, 5.5, 5.6, 5.7, 8.0 

 MariaDB - 5.1, 5.2, 5.3, 5.5, 10.0, 10.1, 10.2, 10.3 

 SQL Server - 2000, 2005, 2008, 2008 R2, 2012, 2014, 2016, 2017 and SQL Azure 

https://www.navicat.com/
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 Oracle - 8i Release 1, 8i Release 2, 8i Release 3, 9i Release 1, 9i Release 2, 10g Release 1, 10g Release 2, 

11g Release 1, 11g Release 2, 12c Release 1, 12c Release 2, 18c 

 PostgreSQL - 7.3, 7.4, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, 9.2, 9.3, 9.4, 9.5, 9.6, 10.0, 11.0 

 SQLite 3 

Installation 

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation. 

Installation for Download Version 

1. Download Navicat Data Modeler Windows version. 

2. Open the .exe file. 

3. Click Next at the Welcome Screen. 

4. Read the License Agreement. Accept it and click Next. 

5. Accept the location of the program icons by clicking Next. If you wish to change the destination of the folder for 

Navicat Data Modeler program click Browse. 

6. Follow the remaining steps. 

Installation for CD Version 

1. Load the Navicat Data Modeler CD Installation disk into the CD-ROM drive. 

2. Open the .exe file. 

3. Click Next at the Welcome Screen. 

4. Read the License Agreement. Accept it and click Next. 

5. Accept the location of the program icons by clicking Next. If you wish to change the destination of the folder for 

Navicat Data Modeler program click Browse. 

6. Follow the remaining steps. 

Registration 

When the trial period is finished, Navicat Data Modeler requires a license key or a subscription plan to continue using 

the features. 

Note: Perpetual License and Subscription Plan cannot be used at the same Navicat Data Modeler. Before changing 

the registration method, you need to deactivate the license key or sign out your Navicat ID. 
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Perpetual License 

If you have purchased a perpetual license, you will receive a license key for activating Navicat Data Modeler. 

In the Perpetual License section, paste your license key (16 digits) and click the Activate button. Navicat Data 

Modeler contacts our licensing server to activate the license key. If the activation process is successful, the license key 

details are displayed. 

Manual Activation 

Manual activation is available when your computer does not have an internet connection. You will need another 

computer with an internet connection to complete this activation process. 

1. If the online activation is failed, click Manual Activation. 

2. Copy the Request Code in the Copy the Request Code Here: box. 

3. Open web browser on a computer with an internet connection and then go to 

https://customer.navicat.com/manual_activate.php. 

4. Paste/Enter the Request Code into the left box. 

5. Click Get Activation Code. 

6. Copy the generated Activation Code in the right box. 

7. Go back to the computer where you are activating Navicat Data Modeler. 

8. Paste the Activation Code into the Paste the Activation Code Here: box. 

9. Click Activate. 

Subscription Plan 

If you have subscribed a plan, you can sign in your Navicat ID to use Navicat Data Modeler during the subscription 

term. 

Note: Navicat ID is the Email address that you used to subscribe the plan. 

In the Subscription section, provide your Navicat ID and Password. After signed in, the subscription plan details are 

displayed. 

Navicat Data Modeler contacts our licensing server once per hour to auto reload the plan by default. If you have 

updated your plan in the portal site, you can use the Reload Plan button to force reloading the new plan. 

Note: Each Navicat ID can connect to only one Navicat Data Modeler. If you sign in your Navicat ID in another Navicat 

Data Modeler, you will be signed out from the current Navicat Data Modeler. 
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Migration / Upgrade 

Migrate Navicat Data Modeler to a new computer 

1. In Navicat Data Modeler, choose Help -> Registration. 

2. [Perpetual License] Click Deactivate to online deactivate the license key. 

3. [Subscription Plan] Click Sign Out to sign out your Navicat ID. 

4. Uninstall Navicat Data Modeler from the existing computer. 

5. Re-install Navicat Data Modeler in the new computer. 

Upgrade Navicat Data Modeler 

If you want to upgrade an installed copy of Navicat Data Modeler to the latest release, please choose Help -> Check 

For Updates to start the Updater. It will automatically check your installed version. If there is a new version, simply 

follow the steps in the Updater to upgrade your Navicat Data Modeler. It will replace your previous Navicat Data 

Modeler and your current settings will remain unchanged. 

Or, you can submit your registered email address on the Customer Center to download the latest version installer. 

End-User License Agreement 

Note: For the License Agreement of Navicat Cloud service, please click here. 

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT 

BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN 

ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE 

INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE 

AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE 

SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME 

BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS, 

THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE. 

THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD. 

HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN. 

1. Definitions 

a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual 

who is a natural person and not a corporation, company, partnership or association or other entity or 

organization (ii) the individual who is a student, faculty or staff member at an educational institution, 

and (iii) staff of a non-profit organization or charity organization only. For purposes of this definition, 

"educational institution" means a public or private school, college, university and other post secondary 

https://customer.navicat.com/
http://legal.navicat.com/navicatcloud/NavicatCloudLicenseAgreement.rtf
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educational establishment. A non-profit organization is an organization whose primary objective is to 

support an issue or matter of private interest or public concern for non-commercial purposes. 

b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review 

and evaluate the Software, only. 

c. "PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any. 

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in 

each case, supplied by PremiumSoft herewith, and corresponding documentation, associated media, 

printed materials, and online or electronic documentation. 

e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the 

SOFTWARE ("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation 

purposes for a period of fourteen (14) days following the initial installation of the UNREGISTERED 

SOFTWARE. At the end of the trial period ("TRIAL PERIOD"), the USER must either register the 

SOFTWARE or remove it from his system. The UNREGISTERED SOFTWARE may be freely copied 

and distributed to other users for their evaluation. 

f. "Navicat Essentials" means a version of the Software, so identified, to be used for commercial 

purpose. 

2. License Grants 

The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA: 

a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and 

store the Software on a storage device, such as a network server, used only to install the Software on 

your other computers over an internal network, provided you have a license for each separate 

computer on which the Software is installed and run. Except as otherwise provided in Section 2(b), a 

license for the Software may not be shared, installed or used concurrently on different computers. 

b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the 

computer on which the Software is installed may make a second copy of the Software and install it on 

either a portable computer or a computer located at his or her home for his or her exclusive use, 

provided that: 

A. the second copy of the Software on the portable or home computer (i) is not used at the same 

time as the copy of the Software on the primary computer and (ii) is used by the primary user 

solely as allowed for such version or edition (such as for educational use only), 

B. the second copy of the Software is not installed or used after the time such user is no longer 

the primary user of the primary computer on which the Software is installed. 

c. In the event the Software is distributed along with other PremiumSoft software products as part of a 

suite of products (collectively, the "Studio"), the license of the Studio is licensed as a single product 
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and none of the products in the Studio, including the Software, may be separated for installation or use 

on more than one computer. 

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You 

must reproduce on any such copy all copyright notices and any other proprietary legends on the 

original copy of the Software. You may not sell or transfer any copy of the Software made for backup 

purposes. 

e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at 

any time, upon reasonable notice. In the event that such audit reveals any use of the Software by you 

other than in full compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all 

reasonable expenses related to such audit in addition to any other liabilities you may incur as a result 

of such non-compliance. 

f. Your license rights under this EULA are non-exclusive. 

3. License Restrictions 

a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or 

electronically transfer the Software from one computer to another or over a network. 

b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer, 

disassemble, or otherwise reduce the Software to a human-perceivable form. 

c. Unless otherwise provided herein, you may not rent, lease, or sublicense the Software. 

d. Other than with respect to a Trial / Demo Version, Non-commercial Lite Version or a Not For Resale 

Version of the Software, you may permanently transfer all of your rights under this EULA only as part 

of a sale or transfer, provided you retain no copies, you transfer all of the Software (including all 

component parts, the media and printed materials, any upgrades, this EULA, the serial numbers, and, 

if applicable, all other software products provided together with the Software), and the recipient agrees 

to the terms of this EULA. If the Software is an upgrade, any transfer must include all prior versions of 

the Software from which you are upgrading. If the copy of the Software is licensed as part of the whole 

Studio (as defined above), the Software shall be transferred only with and as part of the sale or transfer 

of the whole Studio, and not separately. You may retain no copies of the Software. You may not sell or 

transfer any Trial / Demo Version, Non-commercial Lite Version or Not For Resale Version of the 

Software. 

e. Unless otherwise provided herein, you may not modify the Software or create derivative works based 

upon the Software. 

f. Non-commercial Versions of the Software may not be used for, or distributed to any party for, any 

commercial purpose. 

g. Unless otherwise provided herein, you shall not 
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A. in the aggregate, install or use more than one copy of the Trial / Demo Version and 

Non-commercial Lite Version of the Software, 

B. download the Trial / Demo Version and Non-commercial Lite Version of the Software under 

more than one username, 

C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo 

Version of the Software for an aggregate period in excess of the trial period for one license to 

such Trial / Demo Version, 

D. disclose the results of software performance benchmarks obtained using the Trial / Demo 

Version or Non-commercial Lite Version to any third party without PremiumSoft prior written 

consent, or 

E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of 

determining whether to purchase a license to a commercial or education version of the 

software; provided, however, notwithstanding the foregoing, you are strictly prohibited from 

installing or using the Trial / Demo Version or Non-commercial Lite Version of the Software for 

any commercial training purpose. 

h. You may only use the Not for Resale Version of the Software to review and evaluate the Software. 

i. You may receive the Software in more than one medium but you shall only install or use one medium. 

Regardless of the number of media you receive, you may use only the medium that is appropriate for 

the server or computer on which the Software is to be installed. 

j. You may receive the Software in more than one platform but you shall only install or use one platform. 

k. You shall not use the Software to develop any application having the same primary function as the 

Software. 

l. In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you 

must destroy all copies of the Software (with all other rights of both parties and all other provisions of 

this EULA surviving any such termination). 

m. This program may include Oracle Instant Client (OCI). You agree that you shall 

1. not use of the Oracle Instant Client to the business operations; 

2. not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual 

or entity; 

a. make the Programs available in any manner to any third party for use in the third 

party's business operations; and 

b. title to the Programs from passing to the end user or any other party; 
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3. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the 

Programs except for a sufficient number of copies of each Program for your licensed use and 

one copy of each Program media; 

4. discontinue use and destroy or return to all copies of the Oracle Instant Client and 

documentation after termination of the Agreement; 

5. not pubish any results of benchmark tests run on the Programs; 

6. comply fully with all relevant export laws and regulations of the United States and other 

applicable export and import laws to assure that neither the Oracle Instant Client, nor any 

direct product thereof, are exported, directly or indirectly, in violation of applicable laws; 

7. allow PremiumSoft to audit your use of the Oracle Instant Client; 

4. Upgrades 

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license 

exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your 

earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person 

or entity unless such transfer is pursuant to Section 3. 

5. Ownership 

The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, 

title and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent 

work and as an underlying work serving as a basis for any application you may develop), and all copies thereof. All 

rights not specifically granted in this EULA, including Federal and International Copyrights, are reserved by 

PremiumSoft and its suppliers. 

6. LIMITED WARRANTY AND DISCLAIMER 

a. Except with respect to Trial / Demo Version, Non-commercial Lite Version and Not For Resale Version 

of the Software, PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as 

evidenced by a copy of your receipt): the physical media on which the Software is furnished will be free 

from defects in materials and workmanship under normal use. The Software is provided "as is". 

PremiumSoft makes no warranties, express or implied, arising from course of dealing or usage of trade, 

or statutory, as to any matter whatsoever. 

b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version, 

Non-commercial Lite version and the Not for Resale version of the Software. Trial / Demo version, 

Non-commercial Lite version and the Not for Resale version of the Software are provided "as is". 

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo 

version, Non-commercial Lite version and Not for Resale version, PremiumSoft and its suppliers 

disclaim all other warranties and representations, whether express, implied, or otherwise, including the 
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warranties of merchantability or fitness for a particular purpose. Also, there is no warranty of 

non-infringement and title or quiet enjoyment. PremiumSoft does not warrant that the Software is 

error-free or will operate without interruption. The Software is not designed, intended or licensed for 

use in hazardous environments requiring fail-safe controls, including without limitation, the design, 

construction, maintenance or operation of nuclear facilities, aircraft navigation or communication 

systems, air traffic control, and life support or weapons systems. PremiumSoft specifically disclaims 

any express or implied warranty of fitness for such purposes. 

d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in 

duration to thirty (30) days from the date of delivery. 

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or 

employees shall create a warranty or in any way increase the scope of ANY warranty PROVIDED 

HEREIN. 

7. LIMITATION OF LIABILITY 

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental, 

punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or 

access data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability 

to use, the Software and based on any theory of liability including breach of contract, breach of warranty, 

tort (including negligence), product liability or otherwise, even if PremiumSoft or its representatives have been 

advised of the possibility of such damages. 

8. Third Party Software 

The Software may contain third party software which requires notices and/or additional terms and conditions. By 

accepting this EULA, you are also accepting the additional terms and conditions of the third party software. 

9. General 

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA. 

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and 

supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that 

any varying or additional terms contained in any purchase order or other written notification or document issued by 

you in relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to 

exercise any of its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those 

rights or of the breach. 

If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision 

will be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full 

force and effect. 

10. Basis of Bargain 
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The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of 

the agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an 

economic basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the 

benefit of PremiumSoft's licensors. 

11. Term 

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA. 

This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to 

comply with any term of this License. 

"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or 

statutory, as to any matter whatsoever. In particular, any and all warranties or merchantability, fitness for a 

particular purpose or non-infringement of third party rights are expressly excluded. 

12. Governing Law 

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive 

jurisdiction and venue sitting in Hong Kong to resolve any disputes arising under this EULA. 

Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If 

you desire to contact the Licensor for any other reason, please contact support@navicat.com. 

PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of 

PremiumSoft CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, 

product names and logos may be the trademarks or registered trademarks of their respective owners. You may not 

remove or alter any trademark, trade names, product names, logo, copyright or other proprietary notices, legends, 

symbols or labels in the Software. This EULA does not authorize you to use PremiumSoft or its licensors names or 

any of their respective trademarks. 
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Chapter 2 – User Interface 

Welcome Window 

When you start Navicat Data Modeler, a Welcome Window will pop up. In this window, you can choose to create a new 

model, open an existing model file, etc. After logged into Navicat Cloud, the Welcome Window divided into two parts: 

Local and Cloud. You can access or save models in the local computer and Navicat Cloud. 

 

Create a new model 

1. Click New Model in the Welcome Window. 

2. Select the model type and other settings. 

Create a new model from a database 

1. Choose Tools -> Import from Database. 

2. Follow the Import from Database wizard steps. 

Open an existing model 

1. Click Open Model in the Welcome Window. 

2. Choose a model file to open. 

Clear the history of the recent opened models 

1. Choose File -> Recent Models -> Clear History from the menu bar. 
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Main Window 

The Main Window consists of a toolbar, several panes and a diagram canvas for you to design your model. A model file 

can have more than one diagram. Each diagram is represented by a tab in the model. To create a new diagram, choose 

File -> New Diagram from the menu bar. 

 

 Toolbar 

The Toolbar is located near the top of the Main Window. The buttons display in the toolbar depend on the model type 

(physical, logical and conceptual). You can use the toolbar to perform some basic tasks, such as adding tables, entities 

or views, applying Auto Layout feature, etc. 

 Explorer Pane 

The Explorer pane has two tabs: Model and Diagram. The Model tab holds all schemas, tables, views or entities in the 

model, including those used in each individual diagram. You can simply drag an object from the Model tab and drop to 

the active diagram canvas. The Diagram tab holds all the objects (tables, views, layers, notes, images, relations, etc) 

added to the active diagram. If the Explorer pane is hidden, choose View -> Show Explorer from the menu bar. 

 History Pane 

The History pane shows all the actions that you have taken. Simply click an action to restore that state. If the History 

pane is hidden, choose View -> Show Explorer and Show History from the menu bar. 

 Properties Pane 
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The Properties pane includes the Model, Diagram and Object tabs for setting default properties for your model. You 

can edit the properties settings of the model, the active diagram and the selected objects quickly. If the Properties pane 

is hidden, choose View -> Show Properties from the menu bar. 

Option Description 

Begin Arrow Style The style of the arrow's back. 

Black and White Check this box to change the diagram color to black and white. 

Bold Check this box or press CTRL+B to bold the table, view, entity, foreign key, 

relation or shape. 

Border Color The color of the shape's border. 

Cap Style The cap style of the line/arrow. 

Case Sensitivity The case sensitivity of the table or view names. Available only for MySQL 

and MariaDB physical models. 

Color The color of the object. 

Dash Style The dash style of the line/arrow. 

Database Name The database name of the table/view. 

Database Type The database type of the model. 

Database Version The database version of the model. 

Default Database The default database of the model. 

Default Schema The default schema of the model. 

Diagram Notation The notation of the diagram. The notation options are depended on the 

model type. 

End Arrow Style The style of the arrow's front. 

Entity Font Name The font name of the entities. 

Entity Font Size The font size of the entities. 

Font Bold Check this box to bold the note/label font. 

Font Color The font color of the note, label or layer. 

Font Italic Check this box to apply an italic style to the note or label font. 

Font Name The font name of the note, label or layer. 

Font Size The font size of the note, label or layer. 

Height The height of the object. 

Height (pages) The height of the diagram (number of papers). 

Join Style The join style of the line/arrow. 

Left The number of pixels from the object to the left side of the canvas. 

Model Type The type of the model. 

Model Version The version of Navicat Data Modeler that used to create the model. 

Name The name of the object. 

Opacity The transparency of the image/shape. The value for this can be between 0 

and 100. Use 100 for opacity and 0 for transparent. 

Referenced Cardinality The foreign key/relation cardinality of the referenced (parent) table or entity. 

Referencing Cardinality The foreign key/relation cardinality of the referencing (child) table or entity. 

Schema Name The schema name of the table/view. 
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Show Database Name Check this box to show the database names of the tables/views in the 

diagram. 

Show Entity Comment Check this box to show the entity comments in the diagram. 

Show Field Comment Check this box to show the field comments in the diagram. 

Show name Check this box to show the name of the foreign key, relation or shape. 

Show Schema Name Check this box to show the schema names of the tables/views in the 

diagram. 

Show Table Comment Check this box to show the table comments in the diagram. 

Show View 

Relationships 

Check this box to show the relationship line of the view. 

Table Font Name The font name of the tables. 

Table Font Size The font size of the tables. 

Top The number of pixels from the object to the top of the canvas. 

Visible Check this box to show the foreign key/relation lines. 

Width The width of the object. 

Width (pages) The width of the diagram (number of papers). 

 Overview Pane 

The Overview pane displays the whole active diagram in the canvas. To zoom in or zoom out the selected area of the 

diagram, adjust the slider. Same effect can be achieved with keyboard shortcuts: 

Zoom In: [CTRL++] or [CTRL+Mousewheel Up] 

Zoom out: [CTRL+-] or [CTRL+Mousewheel Down] 

If the Overview pane is hidden, choose View -> Show Properties and Show Overview from the menu bar. 

 Diagram Canvas 

You can design your diagram on the Diagram Canvas. All added objects can be moved (by dragging them with mouse 

or by keyboard), resized, aligned to the grid, etc. 
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Chapter 3 – Navicat Cloud 

About Navicat Cloud 

Navicat Cloud provides a cloud service for synchronizing model files and virtual group information from Navicat Data 

Modeler, other Navicat family members, different machines and different platforms. All the Navicat Cloud objects are 

located under different projects. You can share the project to other Navicat Cloud accounts for collaboration. 

Navicat Cloud could not connect and access your databases. By which it means, it could only store your connection 

settings, queries, model files, and virtual group; your database passwords and data (e.g. tables, views, etc) will not be 

stored to Navicat Cloud. 

Note: PremiumSoft will keep all synchronized files strictly confidential, and all employees are prohibited from 

viewing/accessing content of files you may store in your Navicat Cloud account. 

Create a new account 

1. In the Welcome Window, click Create Navicat ID. Or, in the Main Window, click Sign In and click Create 

Navicat ID. 

2. Enter the required information and click Sign Up button. A verification email will send to your email address. 

3. Click the link in the email to verify the new account. 

Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center. 

Sign in Navicat Cloud 

1. In the Welcome Window, enter your Navicat ID and Password. Or, in the Main Window, click Sign In and 

enter your Navicat ID and Password. 

2. Click Sign In button. 

3. If you enabled two-step verification in Navicat Cloud Portal site, a code will be sent to your phone via your 

mobile app. Enter the received code to sign in. 

Open a model from Navicat Cloud 

1. Choose File -> Open from Navicat Cloud from the menu bar. 

2. Select a model file and click Open. 

Save a model to Navicat Cloud 

1. Choose File -> Save to Navicat Cloud from the menu bar. 

2. Enter the Model Name. 

https://cloud.navicat.com/
https://cloud.navicat.com/
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3. Click Save. 

Save a cloud model to local machine 

1. Choose File -> Save to Local from the menu bar. 

2. Enter the file name and choose the saving path. 

3. Click Save. 

Sign out Navicat Cloud 

1. Choose File -> Navicat Cloud from the menu bar. 

2. Click your email in the User Info pane and choose Sign Out. 

Manage Navicat Cloud 

After logged into Navicat Cloud, you can open the Navicat Cloud window by choosing File -> Navicat Cloud from the 

menu bar. In the Navicat Cloud window, you can view the account details and manage the models and virtual groups 

that stored in Navicat Cloud. 

The left User Info pane shows the account details and the cloud usage. The right Navicat Cloud Activity pane shows 

the project members and activities. If the Navicat Cloud Activity pane is hidden, you can click the  button to show it. 

Note: A model file or a virtual group counts for one unit. 

 

Change your avatar 

1. Click the avatar in the User Info pane. 
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2. Choose an image file. 

Manage your Navicat Cloud account 

1. Click your email in the User Info pane and choose Manage Account. 

2. A browser will open with Navicat Cloud Portal site. 

Upgrade the Navicat Cloud plan 

1. Click Upgrade. 

2. A browser will open with Navicat Cloud Portal site. 

Create a project 

1. Select Navicat Cloud. 

2. Click New Project. 

Add members to a project 

1. Select a project. 

2. Right-click it and select Collaborate with. 

3. Click Add Members. 

4. Enter the members' Navicat ID. 

5. Select the member role. 

6. Click Add. 

Member Roles  Privileges 

Owner Read Objects, Write Objects, Manage Members and Delete Project 

Admin Read Objects, Write Objects and Manage Members 

Member Read Objects and Write Objects 

Guest Read Objects 

Note: Each time can add up to 10 members. Use comma or enter to separate the members in the edit box. 

Manage members in a project 

1. Select a project. 

2. Right-click it and select Collaborate with. 

3. Click Apply after changes. 

https://cloud.navicat.com/
https://cloud.navicat.com/
https://cloud.navicat.com/
https://cloud.navicat.com/
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Note: If you are the Owner or Admin, you can click the x button to remove the member. 

Rename a project 

1. Select a project. 

2. Right-click it and select Rename. 

3. Enter the project name. 

Quit a project 

1. Select a project. 

2. Right-click it and select Quit Project. 

Delete a project 

1. Select a project. 

2. Right-click it and select Delete Project. 

Rename a model 

1. Select a model file. 

2. Right-click it and select Rename. 

3. Enter the model name. 

Delete a model 

1. Select a model file. 

2. Right-click it and select Delete Model. 

Create a virtual group 

1. Click New Group. 

2. Enter the group name. 

Move a model to a virtual group 

1. Select a model file. 

2. Right-click it and select Manage Group -> Move To. 

Move a model to the top-level from a virtual group 

3. Select a model file. 
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1. Right-click it and select Manage Group -> Exclude From Group. 

Rename a virtual group 

1. Select a virtual group. 

2. Right-click it and select Rename Group. 

3. Enter the group name. 

Delete a virtual group 

1. Select a virtual group. 

2. Right-click it and select Delete Group. 
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Chapter 4 – Physical Models 

Create Physical Models 

Navicat Data Modeler allows you to create physical models, including tables, fields, views, foreign key constraints and 

other physical properties of the database/schema. 

To create a physical model, select File -> New Model from the menu bar. In the New Model window, choose Physical 

as Model Type and select the target Database and Version. 

 

You can also use the following features to create a physical model: 

 Import from Database - reverse engineer from existing databases/schemas or ODBC data source. 

 Model Conversion - convert from a logical/conceptual model. 

After creating a physical model, you can compare and synchronize it to an existing database/schema or export it to a 

SQL file. 

Add Databases / Schemas to Physical Model 

When creating a new model, a database/schema (named Default) is automatically created and it is the default 

database/schema. All newly added objects (tables and views) are belonged to the default database/schema. 

You can view all databases/schemas with their objects as tree structure on the Explorer's Model tab. 
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The pop-up menu options of a database/schema in the Explorer's Model tab include: 

Option Description 

New Database / New 

Schema 

Create a database/schema. 

Delete Database / 

Delete Schema 

Delete the selected database/schema including its objects from the model. 

The default database/schema cannot be deleted. 

Rename Change the name of the database/schema. 

Set As Default 

Database / Set As 

Default Schema 

Set the selected database/schema as the default database/schema. 

 

Add Tables to Physical Model 

To add a new table, click the  Table button from the toolbar and click anywhere on the canvas. To add an existing 

table from the Explorer's Model tab, simply drag and drop the selected table from the Model tab to the canvas. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

Note: If you right-click a field, you can choose to add, insert, delete, rename the field and set the field as primary key. 
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The pop-up menu options of the table object in the canvas include: 

Option Description 

Design Table Edit the table structure in a Table Designer, e.g. fields, indexes, foreign 

keys, etc. 

Add Related Objects Add all related tables/views to the selected table. 

Add Field Add fields to the existing table. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Tables Select all tables in the diagram. 

Delete Delete a table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Table Designer 

Table Designer is the basic Navicat Data Modeler tool for working with tables. It allows you to create, edit and drop 

table's fields, indexes, foreign keys, and much more. 

Note: The tabs and options in the designer depend on the diagram database type and version you are chosen. 

In the Fields tab, you can search a field name by pressing CTRL+F. 
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Add Views 

Add Views to Physical Model 

To add a new view, click the  View button from the toolbar and click anywhere on the canvas. To add an existing 

view from the Explorer's Model tab, simply drag and drop the selected view from the Model tab to the canvas. 

Note: If you right-click the view connector, you can choose to add or delete vertices and change its color, or go to the 

source view or the target table. 

 

The pop-up menu options of the view object in the canvas include: 

Option Description 

Design View Edit the view structure in a View Designer. 

Add Related Objects Add all related tables/views to the selected view. 

Cut Remove the view from the diagram and put it on the clipboard. 

Copy Copy the view from the diagram to the clipboard. 
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Paste Paste the content from the clipboard into the diagram. 

Select All Views Select all views in the diagram. 

Delete Delete a view from the diagram or from both diagram and model. 

Rename Change the name of the view. 

Color Change the color of the view. 

Size to Fit Resize the view automatically to fit its contents. 

Bring to Front Bring the view to the foreground. 

Send to Back Move the view to the background. 

View Designer 

View Designer is the basic Navicat Data Modeler tool for working with views. In View Designer, you can build the 

views visually using View Builder or edit the view's Definition directly. 

Note: The tabs and options in the designer depend on the diagram database type and version you are chosen. 

 

 

Work with View Builder (Available only in Non-Essentials Version) 

Navicat Data Modeler provides a useful tool called View Builder for building views visually. It allows you to create and 

edit views without knowledge of SQL. Even if you are familiar with SQL, the convenient and fluent graphical interface 

makes it easier to create relations and visualize the view. 

In View Designer, click the  View Builder button to open the visual View Builder. 

All database objects are displayed on the left Object pane. Whereas on the middle pane, it is divided into two portions: 

the upper Diagram pane, and the lower Criteria pane. When building the view, you can view the auto-generated SQL 

on the right SQL pane. 
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Add Objects to View 

The first step is to decide which tables and views you need to add to the view. 

To add tables and views to the view, use one of the following methods: 

 Drag them from the Object pane to the Diagram pane. 

 Double-click them on the Object pane. 

You can set aliases for tables, views and subqueries by double-clicking the object title on the Diagram pane and 

entering the name to use as an alias for the object name. 

After you have added objects to the diagram, you can use the FROM tab to adjust the view to your needs. 

 To change the object, click the object and select an identifier. 

 To add the table alias, click <Alias>. 

 

You can right-click an object on the Diagram pane and select Remove, or simply press DELETE key to remove the 

selected object from the view. 

When you remove an object, View Builder automatically removes joins that involve that object. 

Choose Output Fields 
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To include fields in the view, use one of the following methods: 

 Check the left checkbox of a field name you want to add to the view on the Diagram pane. 

 To include all the fields for an object, check the * checkbox on the Diagram pane. 

 To add all fields for all objects, click  on the SELECT tab and select All fields(*). 

The selected fields display on the SELECT tab. You can specify additional output field options. 

 Check the DISTINCT checkbox to force the view to return distinct results. 

 To add the field alias, click <Alias> and enter the name. 

 Click the identifier and select the Aggregate function. 

 Use the up arrow and down arrow buttons to change the order of fields. 

Set Field Association 

View Builder will automatically join the tables as per the foreign key relations. If you want to associate database objects 

manually, just select a field from an object and drag it to a field in another object. A connector line appears between the 

two objects to visually represent the relationship and the join type. 

There are two views to show the connector lines: Table Relation and Field Relation. The Field Relation view allows 

you to identify matching fields in two tables, while the Table Relation view displays the join relationship between the 

two tables. 

All joins is initially created as INNER JOIN by default. To change the association, click or double-click the connector line 

on the Diagram pane or click the JOIN keyword on the FROM tab, and then select a join type. If a join type is not listed, 

you can enter a customized one in the Custom textbox. 

 

To remove a join, right-click the connector line and select Remove. 
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To modify the join condition, right-click a connector line and select Edit Join, or click the condition on the FROM tab. 

 

The pop-up menu options of the FROM tab: 

Option Description 

Insert Add an identifier, an expression or a subquery. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the identifier, expression or subquery. 

Clear and Convert to 

USING Clause 

Remove the ON condition and convert it to USING clause. 

Clear and Convert to ON 

Clause 

Remove the USING condition and convert it to ON clause. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Set Filter Criteria 

When retrieving data, you may want to set up a filtering expression. To filter data returned by the view, right-click a field 

on the Diagram pane and select WHERE and an operator. 

The condition is added to the WHERE tab. You can edit the value there by clicking <Value>. If you want to add a 

condition with parentheses, click . You can change a logical operator (and/or) by clicking it. Use the up arrow and 

down arrow buttons to change the order of conditions. 

 

The pop-up menu options of the WHERE tab: 

Option Description 

Toggle Negator Reverse the meaning of the condition. 

Insert Add a condition. 

Insert Custom Add a custom condition. 



 30 

 

Insert Bracket Add a pair of parentheses. 

Remove Remove the condition. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Group Resulting Data 

You can set the conditions for grouping records by right-clicking a field in the Diagram pane and selecting GROUP BY 

-> Add Fields. 

The condition is added to the GROUP BY tab. Use the up arrow and down arrow buttons to change the order of fields. 

On the HAVING tab, you can filter summarized data or grouped data. Select the identifiers, operators, aggregate or 

enter expressions to include in the condition. Use the up arrow and down arrow buttons to change the order of 

conditions. 

The pop-up menu options of the HAVING tab: 

Option Description 

Toggle Negator Reverse the meaning of the condition. 

Insert Add a condition. 

Insert Custom Add a custom condition. 

Insert Bracket Add a pair of parentheses. 

Remove Remove the condition. 

Group with Bracket Add parentheses to group the selected conditions. 

Ungroup Remove the parentheses. 

Sort Resulting Data 

You can set the way of sorting records by right-clicking a field on the Diagram pane and selecting ORDER BY -> ASC 

or DESC. The condition will be added to the ORDER BY tab. 

Limit Resulting Data 

On the LIMIT tab, you can limit your view results to those that fall within a specified range. 

Offset 

Specify the number of records to be skipped. It is optional. 

Limit 

Specify the number of records to be displayed. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Add Expressions/Subqueries 
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You can add an expression or a subquery to further limit the view results. On the FROM tab, click  and select the 

Expression/Subquery tab. 

After entered an expression or a subquery, confirm editing by pressing the ENTER key. It will be added to the Diagram 

pane indicates that the statement contains an expression or a subquery and identifies the columns it is on. 

 

By clicking the b utton, you will be switched to a subquery layer where you can build it visually in the same way as 

the main query. 

You can always go back to the main query by clicking (Main Query). 

View Generated SQL 

The SQL pane presents a read-only, formatted representation of the SQL generated by View Builder. You can copy the 

SQL that appears in the SQL pane for use in other tools. In a subquery layer, you can enable Show Current Layer 

Only to show the subquery SQL. 

Zoom In/Zoom Out 

Navicat Data Modeler has the ability to zoom in or zoom out the diagram. Right-click anywhere on the Diagram pane 

and select Zoom -> Zoom In/Zoom Out/100%. The same effect can be achieved with keyboard shortcuts. 

Zoom In: [CTRL+=] 

Zoom Out: [CTRL+-] 

Reset: [CTRL+0] 

Edit View's Definition 

In Definition tab, you can create and edit the SELECT statement SQL for a view. Navicat Data Modeler provides a 

wide range advanced features for editing the view definition, such as compelling code editing capabilities, smart 

code-completion, sql formatting, and more. 

Hint: SELECT statement will be automatically generated while you build in View Builder. 

Beautify SQL (Available only in Non-Essentials Version) 

To format messy SQL code into a well-structured script, you can click the  Beautify SQL button. 

Code Completion (Available only in Non-Essentials Version) 
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Code completion feature in Navicat Data Modeler pops up a list of suggestions as you type your SQL statement in the 

editor. It assists you with statement completion and the available properties of database objects, for example 

databases, tables, fields, views etc with their appropriate icons and information. 

To invoke code completion, just simply press '.' for the available properties of database object currently in the scope. 

When the suggestion list appears, press TAB to insert the first item. You can also select the needed item using UPPER 

ARROW or DOWN ARROW and then press TAB or ENTER. 

 

In addition, code completion can be invoked by typing a character or pressing ESC / CTRL+SPACE on your keyboard 

for SQL keywords/database objects. 

Hint: Resize the suggestion list by dragging the lower right corner. 

You can enable or disable the code completion feature in Options. 

Clipboard Stack 

When you copy or cut some codes as usual in the editor, the copied content will also be added to Clipboard Stack. 

Clipboard Stack can store up to 10 items and use the last-in-first-out logic. To paste an item from Clipboard Stack, you 

can press CTRL+SHIFT+V. Press CTRL+SHIFT+V multiple times to cycle through Clipboard Stack. 

Code Folding 

Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in SQL 

Editor. 

A block of code that can be folded is indicated by an icon  to the left of the first line of the block. A vertical line 

extends from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon  

to left of the code block. You can fold the block by clicking  or expand it by clicking . 
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Brace Highlight 

Navicat Data Modeler supports to highlight the matching brace in the editor, i.e. () . 

Note: The cursor must be on a brace to show the highlight. 

 

Find and Replace 

Find 

The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find from the menu or 

press CTRL+F, and then enter a search string. 

 

The search starts at the cursor's current position to the end of the file. 

To find the next occurrence, just simply click Next or press F3. 

Replace 

To open the Replace bar, simply check the Replace box. Then, enter the text you want to search and replace. 

Click the Replace button to replace the first occurrence. 



 34 

 

Click the Replace All button to replace all occurrences automatically. 

 

There are some additional options for Find and Replace, click : 

Option Description 

Highlight All Highlight all matches in the editor. 

Incremental Search Find matched text for the search string as each character is typed. 

Regular Expression Search regular expressions. 

Whole Word Return the objects that match the entire word of the search string. 

Zoom In/Zoom Out 

Navicat Data Modeler has the ability to zoom in or zoom out the SQL in the editor. 

Zoom In: [CTRL++] or [CTRL+Mousewheel Up] 

Zoom out: [CTRL+-] or [CTRL+Mousewheel Down] 

Reset: [CTRL+0] 

Add Foreign Keys to Physical Model 

To add a foreign key, click the  Foreign Key button from the toolbar and drag and drop a field from the child table 

to the parent table. To show/hide the linked name label, simply check/uncheck the Show name option in the Properties 

pane. 

When you move your mouse over a foreign key connector, the border of the parent and the child tables turn to green 

and blue respectively. Also, the referenced fields and the referencing fields are highlighted. 

 

The pop-up menu options of the foreign key in the canvas include: 
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Option Description 

Design Relation Edit the foreign key in a Table Designer. 

Cardinality on 

table_name1 

Set the cardinality on table_name1: None, One and Only One, Many, One or 

Many, Zero or One, Zero or Many. 

Cardinality on 

table_name2 

Set the cardinality on table_name2: None, One and Only One, Many, One or 

Many, Zero or One, Zero or Many. 

Add Vertex Add a vertex on a foreign key connector. 

Delete Vertex Delete a vertex on a foreign key connector. 

Delete All Vertices Delete all vertices on a foreign key connector. 

Go to Source Go to and select the source (child) table. 

Go to Target Go to and select the target (parent) table. 

Paste Paste the content from the clipboard into the diagram. 

Select All Relations Select all foreign keys in the diagram. 

Delete from Diagram 

and Model 

Delete a foreign key from both diagram and model. 

Color Change the color of the foreign key. 
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Chapter 5 – Logical Models 

Create Logical Models 

Navicat Data Modeler allows you to create logical models, including entities, attributes and relations. 

To create a logical model, select File -> New Model from the menu bar. In the New Model window, choose Logical as 

Model Type. 

 

You can also use the following features to create a logical model: 

 Import from Database - reverse engineer from existing databases/schemas or ODBC data source. 

 Model Conversion - convert from a physical/conceptual model. 

Add Entities to Logical Model 

To add a new entity, click the  Entity button from the toolbar and click anywhere on the canvas. To add an existing 

entity from the Explorer's Model tab, simply drag and drop the selected entity from the Model tab to the canvas. 

For Default diagram notation, the  icon means the attribute is a primary key. The  icon indicates that the 

attribute serves as an index. 

Note: If you right-click an attribute, you can choose to add, insert, delete, rename the attribute and set the attribute as 

primary key. 



 37 

 

 

The pop-up menu options of the entity object in the canvas include: 

Option Description 

Design Entity Edit the entity structure in an Entity Designer, e.g. attributes and relations. 

Add Related Objects Add all related entities to the selected entity. 

Add Attribute Add attributes to the existing entity. 

Cut Remove the entity from the diagram and put it on the clipboard. 

Copy Copy the entity from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Entities Select all entities in the diagram. 

Delete Delete an entity from the diagram or from both diagram and model. 

Rename Change the name of the entity. 

Color Change the color of the entity. 

Size to Fit Resize the entity automatically to fit its contents. 

Bring to Front Bring the entity to the foreground. 

Send to Back Move the entity to the background. 

Entity Designer 

Entity Designer is the basic Navicat Data Modeler tool for working with entities. It allows you to create, edit and drop 

entity's attributes, relations, etc. 

In the Attributes tab, you can search an attribute name by pressing CTRL+F. 
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Add Relations to Logical Model 

To add a relation, click the  Relation button from the toolbar and drag and drop an attribute from the child entity to 

the parent entity. To show/hide the linked name label, simply check/uncheck the Show name option in the Properties 

pane. 

When you move your mouse over a relation connector, the border of the parent and the child entities turn to green and 

blue respectively. Also, the referenced attributes and the referencing attributes are highlighted. 

 

The pop-up menu options of the relation in the canvas include: 

Option Description 

Design Relation Edit the relation in an Entity Designer. 

Cardinality on 

entity_name1 

Set the cardinality on entity_name1: None, One and Only One, Many, One or Many, 

Zero or One, Zero or Many. 

Cardinality on 

entity_name2 

Set the cardinality on entity_name2: None, One and Only One, Many, One or Many, 

Zero or One, Zero or Many. 
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Add Vertex Add a vertex on a relation connector. 

Delete Vertex Delete a vertex on a relation connector. 

Delete All Vertices Delete all vertices on a relation connector. 

Go to Source Go to and select the source (child) entity. 

Go to Target Go to and select the target (parent) entity. 

Paste Paste the content from the clipboard into the diagram. 

Select All Relations Select all relations in the diagram. 

Delete from Diagram and 

Model 

Delete a relation from both diagram and model. 

Color Change the color of the relation. 
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Chapter 6 - Conceptual Models 

Create Conceptual Models 

Navicat Data Modeler allows you to create conceptual models, including entities and relations. 

To create a conceptual model, select File -> New Model from the menu bar. In the New Model window, choose 

Conceptual as Model Type. 

 

You can also use the following features to create a conceptual model: 

 Import from Database - reverse engineer from existing databases/schemas or ODBC data source. 

 Model Conversion - convert from a physical/logical model. 

Add Entities to Conceptual Model 

To add a new entity, click the  Entity button from the toolbar and click anywhere on the canvas. To add an existing 

entity from the Explorer's Model tab, simply drag and drop the selected entity from the Model tab to the canvas. 

 

The pop-up menu options of the entity object in the canvas include: 

Option Description 
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Add Related Objects Add all related entities to the selected entity. 

Cut Remove the entity from the diagram and put it on the clipboard. 

Copy Copy the entity from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Entities Select all entities in the diagram. 

Delete Delete an entity from the diagram or from both diagram and model. 

Rename Change the name of the entity. 

Color Change the color of the entity. 

Size to Fit Resize the entity automatically to fit its contents. 

Bring to Front Bring the entity to the foreground. 

Send to Back Move the entity to the background. 

 

Add Relations to Conceptual Model 

To add a relation, click the  Relation button from the toolbar and drag the child entity and drop to the parent entity. 

To show/hide the linked name label, simply check/uncheck the Show name option in the Properties pane. 

When you move your mouse over a relation connector, the border of the parent and the child entities turn to green and 

blue respectively. 

 

The pop-up menu options of the relation in the canvas include: 

Option Description 

Cardinality on 

entity_name1 

Set the cardinality on entity_name1: None, One and Only One, Many, 

One or Many, Zero or One, Zero or Many. 

Cardinality on 

entity_name2 

Set the cardinality on entity_name2: None, One and Only One, Many, 

One or Many, Zero or One, Zero or Many. 

Add Vertex Add a vertex on a relation connector. 

Delete Vertex Delete a vertex on a relation connector. 

Delete All Vertices Delete all vertices on a relation connector. 

Go to Source Go to and select the source (child) entity. 

Go to Target Go to and select the target (parent) entity. 
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Paste Paste the content from the clipboard into the diagram. 

Select All Relations Select all relations in the diagram. 

Delete from Diagram 

and Model 

Delete a relation from both diagram and model. 

Color Change the color of the relation. 
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Chapter 7 – Diagram Layout 

Work with Diagram Canvas 

Show Grid 

To turn the grid on in the diagram canvas, choose View -> Show Grid from the menu. 

Snap to Grid 

To align objects on the canvas with the grid, choose View -> Snap To Grid from the menu. 

Change Diagram Notation 

To change the notation of the diagram, choose Diagram -> Diagram Notation from the menu. 

Note: The options depend on the diagram type you are chosen. 

Option Description 

Default The default notation style used in Navicat Data Modeler. 

Simple A simple notation style. The table, view or entity objects will only show the name. 

IE (Crow's Foot) Crow's Foot notation style. 

IDEF1X The ICAM DEFinition language information modeling method. 

UML Universal Modeling Language style. 

Classic A classic notation style. 

Black and White Change the color of the diagram to black and white. 

Show Database 

Name 

Show the database names of the tables and views in the diagram. 

Show Schema Name Show the schema names of the tables and views in the diagram. 

 

Change Diagram Dimensions 

To change the number of pages used in the diagram, choose Diagram -> Diagram Dimensions from the menu bar 

and set the Width and the Height. 

Align Objects 

To align objects on the canvas, select more than one object (tables, entities, views, notes, labels, images or shapes), 

then right-click and select Alignment -> Align Left, Align Center, Align Right, Align Top, Align Middle or Align 

Bottom. 

Change Objects Distribution 

To distribute objects on the canvas, select more than one object (tables, entities, views, notes, labels, images or 

shapes), then right-click and select Distribute -> Horizontal or Vertical. 
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Change Page Setup 

To change paper size, orientation and margins, choose File -> Page Setup. 

Add Labels 

Labels are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. To add a new label, click the  Label button from the toolbar and click anywhere on the canvas. 

 

The pop-up menu options of the label object in the canvas include: 

Option Description 

Edit Change the content of the label. 

Cut Remove the label from the diagram and put it on the clipboard. 

Copy Copy the label from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Labels Select all labels in the diagram. 

Delete Delete a label from the diagram. 

Size to Fit Resize the label automatically to fit its contents. 

Bring to Front Bring the label to the foreground. 

Send to Back Move the label to the background. 

 

Add Notes 

Notes are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. To add a new note, click the  Note button from the toolbar and click anywhere on the canvas. 
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The pop-up menu options of the note object in the canvas include: 

Option Description 

Edit Change the content of the note. 

Cut Remove the note from the diagram and put it on the clipboard. 

Copy Copy the note from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Notes Select all notes in the diagram. 

Delete Delete a note from the diagram. 

Color Change the color of the note. 

Size to Fit Resize the note automatically to fit its contents. 

Bring to Front Bring the note to the foreground. 

Send to Back Move the note to the background. 

 

Add Images 

You can insert images (BMP, JPG, JPEG or PNG files) to your model for design or identification purposes. To add a 

new image, click the  Image button from the toolbar and click anywhere on the canvas. Then, select an image file 

in the Open dialog box. 

 

The pop-up menu options of the image object in the canvas include: 

Option Description 

Reset Size Reset the size of the image to its original size. 

Reset Aspect Ratio Maintain the image original width to height ratio. 
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Cut Remove the image the diagram and put it on the clipboard. 

Copy Copy the image from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Images Select all images in the diagram. 

Delete Delete an image from the diagram. 

Bring to Front Bring the image to the foreground. 

Send to Back Move the image to the background. 

 

Add Shapes 

Navicat Data Modeler includes some pre-defined shapes for creating database model diagrams: line, arrow, rectangle, 

ellipse, user, database, cloud, trigger, server, desktop or mobile. To add a new shape, click the  Shape button from 

the toolbar and choose the type of shape. Then, click anywhere on the canvas. To show/hide the linked name label, 

simply check/uncheck the Show name option in the Properties pane. 

 

The pop-up menu options of the shape object in the canvas include: 

Option Description 

Reset Aspect Ratio Maintain the shape original width to height ratio. 

Only for rectangle, ellipse, user, database, cloud, trigger, server, 

desktop and mobile. 

Cut Remove the shape from the diagram and put it on the clipboard. 

Copy Copy the shape from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Shapes Select all the shapes in the diagram. 

Delete Delete a shape from the diagram. 

Color Change the color of the shape. 

Border Color Change the color of the shape's border. 

Only for rectangle, ellipse, user, database, cloud, trigger, server, 

desktop and mobile. 

Begin Arrow Style Change the style of the arrow's back. 

Only for arrow. 

End Arrow Style Change the style of the arrow's front. 
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Only for arrow. 

Add Vertex Add a vertex on a line or arrow. 

Only for line and arrow. 

Delete Vertex Delete a vertex on a line or arrow. 

Only for line and arrow. 

Delete All Vertices Delete all vertices on a line or arrow. 

Only for line and arrow. 

Bring to Front Bring the shape to the foreground. 

Send to Back Move the shape to the background. 

 

Add Layers 

Layers are used to help organize objects (e.g. tables, notes, images, etc) on the canvas. You can add all related 

objects to the same layer. For example, you may choose to add all your sales related tables to one layer. To add a new 

layer, click the  Layer button from the toolbar and click anywhere on the canvas. 

 

The pop-up menu options of the layer object in the canvas include: 

Option Description 

Cut Remove the layer from the diagram and put it on the clipboard. 

Copy Copy the layer from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Layers Select all layers in the diagram. 

Delete Delete a layer from the diagram. 

Color Change the color of the layer. 

Size to Fit Resize the layer automatically to fit its contents. 

Bring to Front Bring the layer to the foreground. 

Send to Back Move the layer to the background. 
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Chapter 8 - Reverse Engineering (Available only 

in Non-Essentials Version) 

Import from Database 

The Import from Database feature allows you to load already existing database structures to create new diagrams. It 

supports to import MySQL, MariaDB, PostgreSQL, Oracle, SQLite, SQL Server tables/views, and also from ODBC data 

source. If the model is logical or conceptual, all views will covert to entities after the import process. To start the Import 

from Database wizard, choose Tools -> Import from Database from the menu bar. 

If it is the first time you open the wizard, you require to establish your server connection before selecting the connection. 

Click the Manage Connection button to create, edit or delete connections. 

Create Connection 

Choose Manage Connections -> New Connection to start the setup. 

 MySQL/MariaDB/PostgreSQL/Oracle/SQLite/SQL Server 

 ODBC 

Note: Navicat Data Modeler authorizes you to make connection to remote server running on different platform, i.e. 

Windows, macOS, Linux and UNIX. 

Edit Connection 

To edit a connection information 

 Select an existing connection. 

 Choose Manage Connections -> Edit Connection. 

Delete Connection 

To delete a connection 

 Select an existing connection. 

 Choose Manage Connections -> Delete Connection. 

Import Connection Settings 

To import Navicat (e.g. Navicat Premium) connection settings 

 Choose Manage Connections -> Import Connections from Navicat. 

 Select the connections and click OK. 

https://navicat.com/products/navicat-premium
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Note: Available only when Navicat (e.g. Navicat Premium) is installed in the current machine. If the connection exists, 

the newly created connection will be named as e.g. "connection_name Copy #". 

After selecting the connection, you are allowed to choose databases, schemas, tables or views to import. If your 

diagram is logical and conceptual, views will be imported as entities. Click Start to start the import process. 

Database Connections 

Connect to Database Servers 

You can create a connection to connect your server: MySQL, MariaDB, PostgreSQL, Oracle, SQLite, SQL Server. 

Note: The tabs in the connection properties window depend on the database type you are chosen. 

 General Settings 

 Advanced Settings 

 Databases Settings 

 SSL Settings 

 SSH Settings 

 HTTP Settings 

General Settings 

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database 

login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) / HTTP is another solution. 

Note: The following options depend on the connection server type and sort in ascending order. 

Add To 

After you logged in the Navicat Cloud feature, you can choose to save the connection to My Connections or a project in 

Navicat Cloud. 

Authentication 

SQL Server 

Authentication 

Use login records to validate the connection. Users must provide their 

server login: User Name and Password. 

Windows 

Authentication 

When a user connects through a Windows user account, SQL Server 

validates the account name and password using the Windows principal 

token in the operating system. 

Connection Name 
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Enter a friendly name to best describe your connection. 

Connection Type 

Basic In Basic mode, it connects to Oracle through the Oracle Call Interface (OCI). 

Enter the Host and Port. Set the Service Name/SID which the user 

connects when making connection. Select the corresponding radio button. 

TNS In TNS mode, it connects to Oracle server using an alias entry from a 

tnsnames.ora file through the Oracle Call Interface (OCI). User needs to 

provide the Net Service Name. 

OCI is an application programming interface that allows an application developer to use a third-generation language's 

native procedure or function calls to access the Oracle database server and control all phases of SQL statement 

execution. OCI is a library of standard database access and retrieval functions in the form of a dynamic-link library. See 

also: OCI options 

Database File 

Specify the initial database file. If the HTTP Tunnel is enabled, you need to enter an absolute file path of the database 

file in your web server. 

Host 

A host name where the database is situated or the IP address of the server. 

Initial Database 

Set the initial database which user connects when making connection. 

Password 

Password for connecting to the database server. 

Port 

A TCP/IP port for connecting to the database server. 

Sync User Name with Navicat Cloud 

When editing a connection in Navicat Cloud, you can choose to synchronize the user name. 

Type 

Existing Database File Connect to an existing database in the Database File. 

New SQLite 3 Create a new SQLite 3 database in the Database File. 

New SQLite 2 Create a new SQLite 2 database in the Database File. 

User Name 

User name for connecting to the database server. 
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Advanced Settings 

Note: The following options depend on the connection server type and sort in ascending order. 

Encoding 

Choose a codepage for converting data to display in Navicat Data Modeler UI. 

Encrypted 

Enable this option and provide Password when connecting to an encrypted SQLite database. 

Native Client Driver 

Choose the SQL Server Native Client used for the connection. 

OS authentication 

Use OS user login credentials to authenticate database users. 

Role 

Indicate that the database user is connecting with either the Default, SYSOPER or SYSDBA system privilege. 

Use compression 

Use compression protocol. It is used if both client and server support zlib compression, and the client requests 

compression. 

Use encryption 

Use encryption for SQL Server connection. 

Use named pipe, socket 

Use socket file for localhost connection. 

Databases Settings 

In the Databases tab, you can set which databases will be shown in the Import from Database window. It is not 

obligatory. To start working with custom database settings, check Use custom database list. Then, check the 

preferable databases in the Database column. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server and MariaDB. 

Add a hidden database to the list 

1. Click the Add Database to List button. 

2. Enter the database name. 
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3. Check the newly added database in the database list. 

Remove a database from the list 

1. Select the database in the database list. 

2. Click the Remove Database from List button. 

Note: The database will be just removed from the database list box, it will still exist in the server. 

SSL Settings 

Secure Sockets Layer (SSL) is a protocol for transmitting private documents via the Internet. To get a secure 

connection, the first thing you need to do is to install OpenSSL Library and download Database Source. 

Note: Available only for MySQL, PostgreSQL and MariaDB. Support from PostgreSQL 8.4 or later. 

MySQL and MariaDB Connections 

To provide authentication details, enable Use Authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Certificate 

The SSL certificate file in PEM format to use for establishing a secure connection. 

CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Verify CA Certificate Name 

Check the server's Common Name value in the certificate that the server sends to the client. 

Specified Cipher 

A list of permissible ciphers to use for SSL encryption. 

PostgreSQL Connection 

Choose the SSL Mode: 

require Only try an SSL connection. 

verify-ca Only try an SSL connection, and verify that the server certificate is issued by 

a trusted CA. 

verify-full Only try an SSL connection, verify that the server certificate is issued by a 
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trusted CA and that the server hostname matches that in the certificate. 

To provide authentication details, enable Use Authentication and fill in the required information: 

Client Key 

The path of the client private key. 

Client Certificate 

The path of the client certificate. 

CA Certificate 

The path of the trusted certificate authorities. 

Certificate Revocation List 

The file path of the SSL certificate revocation list (CRL). 

SSH Settings 

Secure SHell (SSH) is a program to log in into another computer over a network, execute commands on a remote 

server, and move files from one machine to another. It provides strong authentication and secure encrypted 

communications between two hosts, known as SSH Port Forwarding (Tunneling), over an insecure network. 

Typically, it is employed as an encrypted version of Telnet. 

In a Telnet session, all communications, including username and password, are transmitted in plain-text, allowing 

anyone to listen-in on your session and steal passwords and other information. Such sessions are also susceptible to 

session hijacking, where a malicious user takes over your session once you have authenticated. SSH serves to prevent 

such vulnerabilities and allows you to access a remote server's shell without compromising security. 

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server and MariaDB. 

Please make sure that the parameter - "AllowTcpForwarding" in the Linux server must be set to value "yes", otherwise, 

the SSH port forwarding will be disabled. To look for the path: /etc/ssh/sshd_config. By default, the SSH port forwarding 

should be enabled. Please double check the value settings. 

Even the server support SSH tunnel, however, if the port forwarding being disabled, Navicat Data Modeler cannot 

connect via SSH Port 22. 

Host 

A host where SSH server is activated. 

Note: The host name in the General tab should be set relatively to the SSH server which provided by your database 

hosting company. 

Port 
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A port where SSH server is activated, by default it is 22. 

User Name 

A user on SSH server machine. (It is not a user of database server.) 

Authentication Method 

Password Provide the SSH server user Password. 

Public Key Private Key 

It is used together with your public key. The private key should be readable 

only by you. 

Passphrase 

A passphrase is exactly like a password, except that it applies to the keys 

you are generating and not an account. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

HTTP Settings 

HTTP Tunneling is a method for connecting to a server that uses the same protocol (http://) and the same port (port 80) 

as a web server does. It is used while your ISPs do not allow direct connections, but allows establishing HTTP 

connections. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Uploading the Tunneling Script 

To use this connection method, first thing you need to do is to upload the tunneling script to the web server where your 

server is located. 

Note: ntunnel_mysql.php (for both MySQL and MariaDB), ntunnel_pgsql.php or ntunnel_sqlite.php is available in 

the Navicat Data Modeler installation folder. 

Setting up HTTP Tunnel 

The following instruction guides you through the process of configuring a HTTP connection. 

1. Select the HTTP tab and enable Use HTTP Tunnel. 

2. Enter URL of the tunneling script, e.g. http://www.navicat.com/ntunnel_mysql.php . 

3. If your server installed a Web Application Firewall, you can check the Encode outgoing query with base64 

option. 

4. If the tunneling script is hosted in a password protected server or you have to access internet over a proxy 

server, you can provide the required authentication details in Authentication or Proxy tab. 
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Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

ODBC Connections 

You can create an ODBC connection to connect your ODBC data source. The following instruction guides you through 

the process of creating a new ODBC connection. 

Setting Up an ODBC Data Source Connection 

1. On the Control Panel, select Administrative Tools. 

2. Select Data Sources (ODBC). 

3. Select User DSN tab. 

 

4. Click Add. 

5. Select the correct ODBC driver you wish and click Finish. 
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6. Enter the required information. 

7. Select OK to see your ODBC Driver in the list. 

Connecting to ODBC data source in Navicat Data Modeler 

Connection Name 

A friendly name to best describe your connection. 

Data Source 

A data source name. 

User Name 

User name for connecting to the data source. 

Password 

Password for connecting to the data source. 
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Chapter 9 - Forward Engineering (Available only 

in Non-Essentials Version) 

Forward Engineer Physical Model 

Navicat Data Modeler provides two forward engineering tools for you to generate physical databases or a script file 

from a physical model. 

 Synchronize to Database - compare and synchronize to an actual database. 

 Export SQL - generate a SQL file with customized settings. 

Synchronize to Database 

The Synchronize to Database feature allows you to compare a model with an existing database or schema, states the 

differences between their structures, and offers synchronizing the structures in model to the target connection. To start 

the Synchronize to Database wizard, choose Tools -> Synchronize to Database from the menu bar. 

Note: This feature is only available for Physical Models. 

Choose Connections 

The first step is to define connections, databases and/or schemas for the source model and the target connection. 

You can click the Manage Connection button to view and edit connections in Navicat Data Modeler. See Database 

Connections for details. 

Choose Comparing Options 

Then, click the Options button to select the comparing options for the synchronization process. 

Note: The following options depend on the diagram database type you are chosen. 

Compare auto increment value 

Check this option if you want to compare the auto increment values of tables. 

Compare character set 

Check this option if you want to compare the character sets of tables. 

Compare checks 

Check this option if you want to compare checks. 

Compare collation 
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Check this option if you want to compare the collations of tables. 

Compare definers 

Check this option if you want to compare the definers of views. 

Compare excludes 

Check this option if you want to compare excludes. 

Compare foreign keys 

Check this option if you want to compare table foreign keys. 

Compare identity last value 

Check this option if you want to compare the identity last values of tables. 

Compare indexes 

Check this option if you want to compare indexes. 

Compare owners 

Check this option if you want to compare the owners of the objects. 

Compare partitions 

Check this option if you want to compare table partitions. 

Compare primary keys 

Check this option if you want to compare table primary keys. 

Compare rules 

Check this option if you want to compare rules. 

Compare storage 

Check this option if you want to compare table storages. 

Compare table options 

Check this option if you want to compare other table options. 

Compare tables 

Check this option if you want to compare tables. 

Compare triggers 
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Check this option if you want to compare triggers. 

Compare uniques 

Check this option if you want to compare uniques. 

Compare views 

Check this option if you want to compare views. 

Drop with CASCADE 

Check this option if you want to drop the dependent database objects with the CASCADE option. 

Identifier Case Sensitivity 

Ignore or consider the case of identifiers when mapping, or use the server default setting. 

Start Comparison 

Click the Compare button to compare the source model and the target database. 

View Comparison Results 

After comparing structures, the tree view shows the differences between the source and target databases or schemas. 

All objects are checked in the tree view by default. Uncheck the objects you do not want to apply to the target. You can 

expand the table objects to view the detailed structure. 

 

You can choose to group the objects in the tree views by object types or operations by selecting Group by Object 

Type or Group by Operation. 

Operation Description 
 

Object exists in both source and target databases/schemas, but they have 

different definition. The target object will be modified based on the source 

object. 
 

Object does not exist in the target database/schema. It will be created in the 

target. 
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Object does not exist in the source database/schema. The target object will 

be deleted. 
 

Object exists in both source and target databases/schemas and they have 

identical definition. No operation will be applied. 

When you selected an object in the tree view, the DDL Comparison tab shows the DDL statements of that object in the 

source and the target, and the Deployment Script tab shows the detailed SQL statements of the object that will be 

executed in the target databases. 

 

Click the Deploy button to show the scripts of all selected objects. 

Edit & Execute Selected Scripts 

You can view all scripts that will be executed in the target database in the Deployment Script tab. 

Deployment Options 

Button 

Description 

Deployment Options Continue on error - Ignore errors that are encountered during the 

execution process if necessary. 

Edit Script Open the Edit Deployment Script window to rearrange the order of 

the scripts. 

Copy Script to Clipboard Copy all scripts from the Deployment Script tab to the clipboard. 

In the Edit Deployment Script window, use the arrow buttons to move the scripts. 
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Then, click the Execute button to execute the scripts. The window will display the execution progress, execution time, 

and success or failure messages. 

Export SQL 

After finishing your model, you can save table structures and relations from the model into a script file. The Export SQL 

feature generates a SQL file for the script. To start the Export SQL feature, choose Tools -> Export SQL from the 

menu bar. 

Note: This feature is only available for Physical Models. 

General Properties 

File 

Set the output file name and location. 

Objects 

Choose objects in the model you wish to export. 

Advanced Properties 

Note: The following options depend on the diagram database type you are chosen. 

Include auto increment 

Include table auto increment values in the SQL file with this option is on. 

Include character set 

Include table and field character set in the SQL file with this option is on. 

Include checks 

Include checks in the SQL file with this option is on. 
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Include collation 

Include table collation in the SQL file with this option is on. 

Include Drop SQL 

Include drop object SQL statements in the SQL file with this option in on. 

Include Drop With CASCADE 

Include drop object SQL statements with the CASCADE option in the SQL file with this option in on. 

Include excludes 

Include excludes in the SQL file with this option is on. 

Include foreign keys 

Include foreign keys in the SQL file with this option is on. 

Include indexes 

Include indexes in the SQL file with this option is on. 

Include primary keys 

Include primary keys in the SQL file with this option is on. 

Include rules 

Include rules in the SQL file with this option is on. 

Include schema 

Include the schema names in the SQL file with this option is on. Otherwise, only object names are included in SQL 

statements. 

Include triggers 

Include triggers in the SQL file with this option is on. 

Include uniques 

Include uniques in the SQL file with this option is on. 

Server Version 

Select the server version for the SQL file. 

  



 63 

 

Chapter 10 - Other Advanced Tools 

Useful Features 

Navicat Data Modeler provides variety of tools that improve user experience when working on models. 

 Model Conversion 

 Auto Layout 

 Print and Export Model 

 Search Filter 

 Dark Theme 

 Full Screen Mode 

Model Conversion 

Navicat Data Modeler allows you to convert your models from one database type to another database type and also 

from one model type to another model type, e.g. MariaDB 10.0 physical model to PostgreSQL 9.0 physical model, 

Oracle 10g physical model to a logical model, a conceptual model to MySQL 5.0 physical model. 

During the conversion, all data types are converted automatically. The conversion process does not change the SQL 

syntax of views if converting from one database type to another. If you covert a physical model to logical/conceptual 

model, all views will be converted to entities. If the target database version is MySQL 4.0 or below, all views will be 

removed. 

To convert an opened model file, choose File -> Convert Model To. Then, choose the Model Type and select the 

target Database and Version if necessary. 

Auto Layout (Available only in Non-Essentials Version) 

To automatically arrange objects on the canvas, click the  Auto Layout button. To change the Auto Layout format 

settings, simply choose Diagram -> Auto Layout with from the menu and set the following options: 

Auto Diagram Dimension 

Choose the suitable diagram dimension automatically. 

Auto Size Tables To Fit 

Resize the table to fit its content automatically. 

Quality 
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The quality of the auto layout output. 

Object Distance 

The distance between the objects in the diagram. 

Print & Export Model 

Preview a model 

To preview the pages before printing, simply click the  Print Preview button. The model can be printed to the 

printer or exported to various file formats. 

Print to a printer 

Choose File -> Print to send your diagram directly to the printer. You can set the printer option in the pop-up window. 

Export to a file 

Choose File -> Export To and choose the file format to create a PDF, PNG, SVG or JPG file of your diagram. 

Search Filter 

Object Filter allows you to filter models in Navicat Cloud Window and tables, entities or views in the canvas that 

names contain the filter string. 

Just specify a filter string in the Search text box. To remove the filter, simply delete the filter string. 

Tree Filter allows you to filter tree structure in Explorer or in View Designer that names contain the filter string. 

Click on the tree to focus and specify a filter string directly. To remove the filter, simply delete the filter string. 
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Dark Theme 

In Dark Theme, Navicat Data Modeler uses a darker color palette for all windows, views, menus, and controls. It works 

on all supported version of Windows. 

To change your theme, choose Tools -> Options -> General. Then, select Dark. 
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Full Screen Mode 

Edit the model using the whole screen. The title bar that normally displays as part of the Navicat Data Modeler 

application will be hidden while in this mode. 

Choose View -> Full Screen in the menu bar or simply press F11 to start the full screen mode. 

When the full screen mode is cancelled, the Navicat Data Modeler window will be returned to its previous state. 
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Chapter 11 - Configurations 

Options Settings 

Navicat Data Modeler provides several options for customizing its user interface and performance. 

To open the Options window, choose Tools -> Options from the menu bar. 

General 

General 

Theme 

Choose to use the theme of your Windows OS or a Dark theme. 

Hint: Restart Navicat Data Modeler to take effect. 

Show toolbar caption 

Show text on toolbar buttons in Navicat Data Modeler. Otherwise, only buttons will be presented. 

Hint: Restart Navicat Data Modeler to take effect. 

 

Check for updates on startup 

Check this option to allow Navicat Data Modeler checks for new version when it starts. 

Usage Data 

Share Usage Data 

Check this option to let your device sends us information about how you use Navicat Data Modeler to help us improve it. 

You can view the information being shared by clicking the Usage Data button. 

Model 

Hint: Restart Navicat Data Modeler to take effect. 

Highlight Objects 

With this option is on, when a mouse cursor hovers over an object, Navicat Data Modeler will highlight its border with 

blue color 

Highlight with Relation 
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With this option is on, when a mouse cursor hovers over a table, a entity or a view, Navicat Data Modeler will highlight 

it’s foreign keys, relations or view relations with blue or green color indicating relationships with other objects. 

Guess Field Type 

With this option is on, Navicat Data Modeler will predict field types when you design fields/attributes in tables or entities. 

Query 

Use code completion (Available only in Non-Essentials Edition) 

When you type the . (dot) symbol or a character, the editor will offer you a pop-up list that showing some suggestions 

for the code completion. 

Auto update code completion info (Available only in Non-Essentials Edition) 

With this option is on, Navicat Data Modeler will get the latest database information for the code completion from your 

model. You can click Clear Code Completion Info to delete the information for code completion feature that stored on 

your device. 

Editor 

General 

Show line number 

Display line numbers at the left side of the editor for easily reference. 

Use code folding 

Code folding allows codes to collapse as a block and only the first line displayed in the editor. 

Use brace highlighting 

Highlight the pair of braces when your cursor moves to either one brace for easily reference. 

Use syntax highlighting 

Syntax highlight helps viewing codes clearly. Codes are highlighted in the editor with different colors and fonts 

according to the categories they belong to. This feature can be limited by setting the maximum file size (e.g. 10) in 

Disable if file size is larger than (MB) to increase performance. 

Use word wrap 

Enable the word wrap mode in the editor. 

Tab Width 
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Enter the number of characters that a tab occupies, e.g. 5. 

See Edit View's Definition. 

Font and Colors 

Editor Font 

Define the font and its size used by editors. 

Colors 

Format your queries in the editor with colored syntax highlighting to improve readability. Set font colors to mark out 

different text fragments: Common, Keyword, String, Number, Comment and Background. Click on the color boxes and 

choose your desired color from the Color-Selection dialog window. 

File Locations 

You can change the Profiles Location path for storing the internal files of Navicat Data Modeler. 

Proxy 

Use proxy 

Check this option to use proxy for the activation process. Choose the Proxy Type and enter Host, Port, User Name 

and Password. 

Environment 

Hint: Restart Navicat Data Modeler to take effect. 

OCI library (oci.dll) 

Specify the location of the OCI library (oci.dll) for Oracle connection. By default, it is set to the bundled one in Navicat 

Data Modeler installation folder. 

Oracle Instant Client is the simplest way to deploy a full Oracle Client application built with OCI, OCCI, JDBC-OCI, or 

ODBC drivers. It provides the necessary Oracle Client libraries in a small set of files. You can also download Oracle 

Client / Oracle Instant Client through - 

Oracle Client 

Oracle Instant Client 

Download the appropriate Instant Client packages for your platform and the CPU. All installations REQUIRE the Basic 

or Basic Lite package. Unzip the packages and set the path points to it.  

http://www.oracle.com/technetwork/database/enterprise-edition/downloads/index.html
http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html
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Chapter 12 - Hints and Tips 

Model Hints and Tips 

Navicat Data Modeler provides some useful hints to work on the model more effectively. 

Locate Object in the Diagram Canvas 

Object selected in the Explorer's Diagram tab will be highlighted in the Diagram Canvas. 

Double-click an object in the Explorer's Diagram tab will jump to the corresponding object in the Diagram Canvas. 

Delete Object from Model 

Select an object in the Diagram Canvas and press SHIFT+DELETE. 

Open Table/Entity/View Designer 

Double-click a table/entity/view in the Explorer's Model Tab or the Diagram Canvas. 

Get Table/View Structure (SQL Statement) 

Select and copy a table/view in the Diagram Canvas, and paste it to other text editors. 

Design Field without Table/Entity Designer 

Select and click a table/entity name and press TAB/DOWN ARROW to add/edit fields. Navicat Data Modeler will predict 

field types according to field names you entered. 

Note: Available only for Physical Models and Logical Models. 

INTEGER/int/int4/NUMBER 

 suffix "id", "no" (if it is the first column, it will be predicted as a primary key) 

 suffix "num" 

 "qty", "number" 

 exactly "age", "count" 

DECIMAL(10,2)/decimal(10,2)/NUMBER/REAL/money 

 suffix "price", "cost", "salary" 

FLOAT/double/float8/NUMBER/REAL/float 

 "size", "height", "width", "length", "weight", "speed", "distance" 
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DATE/datetime/date/TEXT/datetime2 

 "date", "time" 

VARCHAR(255)/varchar(255)/VARCHAR2(255)/TEXT 

 other field names 

Enter * before the field name to recognize as primary key. e.g. *itemNo:int. 

Enter : between field name and field type to custom field type, e.g. itemName:varchar(255). 

Reorder Field 

Select a table/entity in Diagram Canvas, then press and hold the SHIFT key. Use  to drag the field to a desired 

location. 

Delete Field 

Select a table/entity in Diagram Canvas, then press and hold the SHIFT key. Use  to drag the desired field out of 

the table/entity. 

Add Vertex to Foreign Key/Relation/Line/Arrow 

Select a foreign key/relation/line/arrow in Diagram Canvas. Press and hold the SHIFT key and click on it to add vertex. 

Delete Vertex on Foreign Key/Relation/Line/Arrow 

Select a foreign key/relation/line/arrow in Diagram Canvas. Press and hold the SHIFT key and click on the vertex. 

Switch to Hand Mode 

Press and hold the SPACE key, then move the diagram. 

Select a Page in Print Preview 

Press and hold the SHIFT key, then point to a page to show the page number. 

Press and hold the SHIFT key, then click a page to jump to the corresponding page in Diagram Canvas. 
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Chapter 13 - Hot Keys 

Model Hot Keys 

Keys Action 

CTRL+N New Model 

CTRL+D New Diagram in Model 

CTRL+S Save Model 

CTRL+Z Undo 

CTRL+Y Redo 

CTRL+X Cut 

CTRL+C Copy 

CTRL+V Paste 

CTRL+SHIFT+V Paste from Clipboard Stack 

F11 Full Screen 

CTRL+P Print 

ESC Select 

H Move Diagram 

T New Table/Entity 

V New View 

R New Foreign Key/Relation 

A New Label 

N New Note 

I New Image 

L New Layer 

CTRL+B Bold Selected Table, Entity, View, Foreign Key, 

Relation or Shape 

CTRL++ or CTRL+Mousewheel Up Zoom In 

CTRL+- or CTRL+Mousewheel Down Zoom Out 

CTRL+0 Reset Zoom 

ALT+RIGHT Next Diagram 

CTRL+TAB Next Window 

 

 


	Chapter 1 - Introduction
	About Navicat Data Modeler
	Installation
	Registration
	Migration / Upgrade
	End-User License Agreement

	Chapter 2 – User Interface
	Welcome Window
	Main Window

	Chapter 3 – Navicat Cloud
	About Navicat Cloud
	Manage Navicat Cloud

	Chapter 4 – Physical Models
	Create Physical Models
	Add Databases / Schemas to Physical Model
	Add Tables to Physical Model
	Add Views
	Add Views to Physical Model
	Work with View Builder (Available only in Non-Essentials Version)
	Edit View's Definition

	Add Foreign Keys to Physical Model

	Chapter 5 – Logical Models
	Create Logical Models
	Add Entities to Logical Model
	Add Relations to Logical Model

	Chapter 6 - Conceptual Models
	Create Conceptual Models
	Add Entities to Conceptual Model
	Add Relations to Conceptual Model

	Chapter 7 – Diagram Layout
	Work with Diagram Canvas
	Add Labels
	Add Notes
	Add Images
	Add Shapes
	Add Layers

	Chapter 8 - Reverse Engineering (Available only in Non-Essentials Version)
	Import from Database
	Database Connections
	Connect to Database Servers
	General Settings
	Advanced Settings
	Databases Settings
	SSL Settings
	SSH Settings
	HTTP Settings

	ODBC Connections

	Chapter 9 - Forward Engineering (Available only in Non-Essentials Version)
	Forward Engineer Physical Model
	Synchronize to Database
	Export SQL

	Chapter 10 - Other Advanced Tools
	Useful Features
	Model Conversion
	Auto Layout (Available only in Non-Essentials Version)
	Print & Export Model
	Search Filter
	Dark Theme
	Full Screen Mode

	Chapter 11 - Configurations
	Options Settings
	General
	Model
	Query
	Editor
	File Locations
	Proxy
	Environment

	Chapter 12 - Hints and Tips
	Model Hints and Tips

	Chapter 13 - Hot Keys
	Model Hot Keys


