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Chapter 1 - Introduction 

About Navicat Data Modeler 

Navicat Data Modeler is a powerful and easy-to-use GUI tool for creating and manipulating database models. It 

enables users to design database structures, reverse engineer, forward engineer, generate SQL files and print models 

to files, etc. 

Navicat Data Modeler is available on three platforms - Microsoft Windows, macOS and Linux. Here are some highlights 

of Navicat Data Modeler: 

 Create and manipulate conceptual/logical/physical models. 

 Support various database systems: MySQL, MariaDB, Oracle, PostgreSQL and SQLite (including Amazon 

RDS and Amazon Redshift). 

 Reverse engineer databases/schemas or tables/views to a model. 

 Forward engineer a physical model to a SQL file or a database/schema. 

 Create and edit table structures directly. 

 Support Navicat Cloud. 

For details, visit our website: https://www.navicat.com 

System Requirements 

Windows 

 Microsoft Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10, Server 2008, Server 2012, 

Server 2016 

macOS 

 Mac OS X 10.10 Yosemite, Mac OS X 10.11 El Capitan, macOS 10.12 Sierra, macOS 10.13 High Sierra 

Linux 

 Ubuntu 12.04, Ubuntu 14.04, Ubuntu 16.04, Ubuntu 18.04, CentOS 6.7, CentOS 7, Fedora 22, Fedora 23, 

Fedora 26, Linux Mint 13, Linux Mint 17.3, openSUSE 13.2, openSUSE 42.1, Debian 9 

Supported Databases 

 MySQL - 3.23, 4.0, 4.1, 5.0, 5.1, 5.5, 5.6 

 MariaDB - 5.1, 5.2, 5.3, 5.5, 10.0, 10.1 

https://www.navicat.com/
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 Oracle - 8i Release 1, 8i Release 2, 8i Release 3, 9i Release 1, 9i Release 2, 10g Release 1, 10g Release 2, 

11g Release 1, 11g Release 2, 12c Release 1 

 PostgreSQL - 7.3, 7.4, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, 9.2, 9.3, 9.4, 9.5 

 SQLite 3 

Installation 

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation. 

Note: For user who has been trying our unregistered version, just simply key in the Registration Key (16 digit) on the 

pop up Registration screen. 

Installation for Download Version 

1. Download Navicat Data Modeler Linux version. 

2. Open the gzip file. 

3. Extract the file into anywhere you wish. 

4. Run the start_modeler file to start your Navicat Data Modeler. Please note that it would take a while for 

starting-up. 

5. A Registration screen will then pop up, key in the Registration Key ((16 digit) and click Activate to online 

activate the key. 

Installation for CD Version 

1. Load the Navicat Data Modeler CD Installation disk into the CD-ROM drive. 

2. Open the gzip file. 

3. Extract the file into anywhere you wish. 

4. Run the start_modeler file to start your Navicat Data Modeler. Please note that it would take a while for 

starting-up. 

5. A Registration screen will then pop up, key in the Registration Key ((16 digit) and click Activate to online 

activate the key. 

Migrate Navicat Data Modeler to new computer 

1. In Navicat Data Modeler, choose Help -> Registration from the main menu and click Deactivate to online 

deactivate the key. 

2. Uninstall Navicat Data Modeler from the existing computer. 
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3. Re-install Navicat Data Modeler in the new computer. 

Upgrade Navicat Data Modeler 

If you want to upgrade an installed copy of Navicat Data Modeler to the latest release, please choose Help -> Check 

For Updates to start the Updater. It will automatically check your installed version. If there is a new version, simply 

follow the steps in the Updater to upgrade your Navicat Data Modeler. It will replace your previous Navicat Data 

Modeler and your current settings will remain unchanged. 

Or, you can submit your registered email address on the Customer Center to download the latest version installer. 

End-User License Agreement 

Note: For the License Agreement of Navicat Cloud service, please click here. 

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT 

BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN 

ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE 

INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE 

AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE 

SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME 

BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS, 

THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE. 

THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD. 

HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN. 

1. Definitions 

a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual 

who is a natural person and not a corporation, company, partnership or association or other entity or 

organization (ii) the individual who is a student, faculty or staff member at an educational institution, 

and (iii) staff of a non-profit organization or charity organization only. For purposes of this definition, 

"educational institution" means a public or private school, college, university and other post secondary 

educational establishment. A non-profit organization is an organization whose primary objective is to 

support an issue or matter of private interest or public concern for non-commercial purposes. 

b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review 

and evaluate the Software, only. 

c. "PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any. 

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in 

each case, supplied by PremiumSoft herewith, and corresponding documentation, associated media, 

printed materials, and online or electronic documentation. 

https://customer.navicat.com/
http://legal.navicat.com/navicatcloud/NavicatCloudLicenseAgreement.rtf
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e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the 

SOFTWARE ("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation 

purposes for a period of thirty (30) days following the initial installation of the UNREGISTERED 

SOFTWARE. At the end of the trial period ("TRIAL PERIOD"), the USER must either register the 

SOFTWARE or remove it from his system. The UNREGISTERED SOFTWARE may be freely copied 

and distributed to other users for their evaluation. 

f. "Navicat Essentials" means a version of the Software, so identified, to be used for commercial 

purpose. 

2. License Grants 

The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA: 

a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and 

store the Software on a storage device, such as a network server, used only to install the Software on 

your other computers over an internal network, provided you have a license for each separate 

computer on which the Software is installed and run. Except as otherwise provided in Section 2(b), a 

license for the Software may not be shared, installed or used concurrently on different computers. 

b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the 

computer on which the Software is installed may make a second copy of the Software and install it on 

either a portable computer or a computer located at his or her home for his or her exclusive use, 

provided that: 

A. the second copy of the Software on the portable or home computer (i) is not used at the same 

time as the copy of the Software on the primary computer and (ii) is used by the primary user 

solely as allowed for such version or edition (such as for educational use only), 

B. the second copy of the Software is not installed or used after the time such user is no longer 

the primary user of the primary computer on which the Software is installed. 

c. In the event the Software is distributed along with other PremiumSoft software products as part of a 

suite of products (collectively, the "Studio"), the license of the Studio is licensed as a single product 

and none of the products in the Studio, including the Software, may be separated for installation or use 

on more than one computer. 

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You 

must reproduce on any such copy all copyright notices and any other proprietary legends on the 

original copy of the Software. You may not sell or transfer any copy of the Software made for backup 

purposes. 

e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at 

any time, upon reasonable notice. In the event that such audit reveals any use of the Software by you 

other than in full compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all 
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reasonable expenses related to such audit in addition to any other liabilities you may incur as a result 

of such non-compliance. 

f. Your license rights under this EULA are non-exclusive. 

3. License Restrictions 

a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or 

electronically transfer the Software from one computer to another or over a network. 

b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer, 

disassemble, or otherwise reduce the Software to a human-perceivable form. 

c. Unless otherwise provided herein, you may not rent, lease, or sublicense the Software. 

d. Other than with respect to a Trial / Demo Version, Non-commercial Lite Version or a Not For Resale 

Version of the Software, you may permanently transfer all of your rights under this EULA only as part 

of a sale or transfer, provided you retain no copies, you transfer all of the Software (including all 

component parts, the media and printed materials, any upgrades, this EULA, the serial numbers, and, 

if applicable, all other software products provided together with the Software), and the recipient agrees 

to the terms of this EULA. If the Software is an upgrade, any transfer must include all prior versions of 

the Software from which you are upgrading. If the copy of the Software is licensed as part of the whole 

Studio (as defined above), the Software shall be transferred only with and as part of the sale or transfer 

of the whole Studio, and not separately. You may retain no copies of the Software. You may not sell or 

transfer any Trial / Demo Version, Non-commercial Lite Version or Not For Resale Version of the 

Software. 

e. Unless otherwise provided herein, you may not modify the Software or create derivative works based 

upon the Software. 

f. Non-commercial Versions of the Software may not be used for, or distributed to any party for, any 

commercial purpose. 

g. Unless otherwise provided herein, you shall not 

A. in the aggregate, install or use more than one copy of the Trial / Demo Version and 

Non-commercial Lite Version of the Software, 

B. download the Trial / Demo Version and Non-commercial Lite Version of the Software under 

more than one username, 

C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo 

Version of the Software for an aggregate period in excess of the trial period for one license to 

such Trial / Demo Version, 
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D. disclose the results of software performance benchmarks obtained using the Trial / Demo 

Version or Non-commercial Lite Version to any third party without PremiumSoft prior written 

consent, or 

E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of 

determining whether to purchase a license to a commercial or education version of the 

software; provided, however, notwithstanding the foregoing, you are strictly prohibited from 

installing or using the Trial / Demo Version or Non-commercial Lite Version of the Software for 

any commercial training purpose. 

h. You may only use the Not for Resale Version of the Software to review and evaluate the Software. 

i. You may receive the Software in more than one medium but you shall only install or use one medium. 

Regardless of the number of media you receive, you may use only the medium that is appropriate for 

the server or computer on which the Software is to be installed. 

j. You may receive the Software in more than one platform but you shall only install or use one platform. 

k. You shall not use the Software to develop any application having the same primary function as the 

Software. 

l. In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you 

must destroy all copies of the Software (with all other rights of both parties and all other provisions of 

this EULA surviving any such termination). 

m. This program may include Oracle Instant Client (OCI). You agree that you shall 

1. not use of the Oracle Instant Client to the business operations; 

2. not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual 

or entity; 

a. make the Programs available in any manner to any third party for use in the third 

party's business operations; and 

b. title to the Programs from passing to the end user or any other party; 

3. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the 

Programs except for a sufficient number of copies of each Program for your licensed use and 

one copy of each Program media; 

4. discontinue use and destroy or return to all copies of the Oracle Instant Client and 

documentation after termination of the Agreement; 

5. not pubish any results of benchmark tests run on the Programs; 
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6. comply fully with all relevant export laws and regulations of the United States and other 

applicable export and import laws to assure that neither the Oracle Instant Client, nor any 

direct product thereof, are exported, directly or indirectly, in violation of applicable laws; 

7. allow PremiumSoft to audit your use of the Oracle Instant Client; 

4. Upgrades 

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license 

exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your 

earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person 

or entity unless such transfer is pursuant to Section 3. 

5. Ownership 

The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, 

title and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent 

work and as an underlying work serving as a basis for any application you may develop), and all copies thereof. All 

rights not specifically granted in this EULA, including Federal and International Copyrights, are reserved by 

PremiumSoft and its suppliers. 

6. LIMITED WARRANTY AND DISCLAIMER 

a. Except with respect to Trial / Demo Version, Non-commercial Lite Version and Not For Resale Version 

of the Software, PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as 

evidenced by a copy of your receipt): the physical media on which the Software is furnished will be free 

from defects in materials and workmanship under normal use. The Software is provided "as is". 

PremiumSoft makes no warranties, express or implied, arising from course of dealing or usage of trade, 

or statutory, as to any matter whatsoever. 

b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version, 

Non-commercial Lite version and the Not for Resale version of the Software. Trial / Demo version, 

Non-commercial Lite version and the Not for Resale version of the Software are provided "as is". 

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo 

version, Non-commercial Lite version and Not for Resale version, PremiumSoft and its suppliers 

disclaim all other warranties and representations, whether express, implied, or otherwise, including the 

warranties of merchantability or fitness for a particular purpose. Also, there is no warranty of 

non-infringement and title or quiet enjoyment. PremiumSoft does not warrant that the Software is 

error-free or will operate without interruption. The Software is not designed, intended or licensed for 

use in hazardous environments requiring fail-safe controls, including without limitation, the design, 

construction, maintenance or operation of nuclear facilities, aircraft navigation or communication 

systems, air traffic control, and life support or weapons systems. PremiumSoft specifically disclaims 

any express or implied warranty of fitness for such purposes. 
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d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in 

duration to thirty (30) days from the date of delivery. 

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or 

employees shall create a warranty or in any way increase the scope of ANY warranty PROVIDED 

HEREIN. 

7. LIMITATION OF LIABILITY 

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental, 

punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or 

access data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability 

to use, the Software and based on any theory of liability including breach of contract, breach of warranty, 

tort (including negligence), product liability or otherwise, even if PremiumSoft or its representatives have been 

advised of the possibility of such damages. 

8. Third Party Software 

The Software may contain third party software which requires notices and/or additional terms and conditions. By 

accepting this EULA, you are also accepting the additional terms and conditions of the third party software. 

9. General 

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA. 

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and 

supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that 

any varying or additional terms contained in any purchase order or other written notification or document issued by 

you in relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to 

exercise any of its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those 

rights or of the breach. 

If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision 

will be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full 

force and effect. 

10. Basis of Bargain 

The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of 

the agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an 

economic basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the 

benefit of PremiumSoft's licensors. 

11. Term 

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA. 
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This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to 

comply with any term of this License. 

"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or 

statutory, as to any matter whatsoever. In particular, any and all warranties or merchantability, fitness for a 

particular purpose or non-infringement of third party rights are expressly excluded. 

12. Governing Law 

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive 

jurisdiction and venue sitting in Hong Kong to resolve any disputes arising under this EULA. 

Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If 

you desire to contact the Licensor for any other reason, please contact support@navicat.com. 

PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of 

PremiumSoft CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, 

product names and logos may be the trademarks or registered trademarks of their respective owners. You may not 

remove or alter any trademark, trade names, product names, logo, copyright or other proprietary notices, legends, 

symbols or labels in the Software. This EULA does not authorize you to use PremiumSoft or its licensors names or 

any of their respective trademarks. 
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Chapter 2 – User Interface 

Welcome Window 

When you start Navicat Data Modeler, a Welcome Window will pop up. In this window, you can choose to create a new 

model, open an existing model file, etc. After logged into Navicat Cloud, the Welcome Window divided into two parts: 

Local and Cloud. You can access or save models in the local computer and Navicat Cloud. 

 

Create a new model 

1. Click New Model in the Welcome Window. 

2. Select the model type and other settings. 

Open an existing model 

1. Click Open Model in the Welcome Window. 

2. Choose a model file to open. 

Clear the history of the recent opened models 

1. Choose File -> Recent Models -> Clear History from the main menu. 
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Main Window 

The Main Window consists of a toolbar, several panes and a diagram canvas for you to design your model. A model file 

can have more than one diagram. Each diagram is represented by a tab in the model. To create a new diagram, 

choose File ->  New Diagram from the main menu. 

 

 Toolbar 

The Toolbar is located near the top of the Main Window. The buttons display in the toolbar depend on the model type 

(physical, logical and conceptual). You can use the toolbar to perform some basic tasks, such as adding tables, entities 

or views, applying Auto Layout feature, etc. 

 Explorer Pane 

The Explorer pane has two tabs: Model and Diagram. Model tab holds all tables, views or entities in the model, 

including those used in each individual diagram. You can simply drag an object from the Model tab and drop to the 

active diagram canvas. Diagram tab holds all the objects (tables, views, layers, notes, images, relations, etc) added to 

the active diagram. If the Explorer pane is hidden, choose View -> Show Explorer from the main menu. 

 History Pane 

The History pane shows all the actions that you have taken. Simply click an action to restore that state. If the History 

pane is hidden, choose View -> Show Explorer and Show History from the main menu. 

 Properties Pane 

The Properties pane includes the Model, Diagram and Object tabs for setting default properties for your model. You 

can edit the properties settings of the model, the active diagram and the selected objects quickly. If the Properties pane 

is hidden, choose View -> Show Properties from the main menu. 
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Option Description 

Begin Arrow Style The style of the arrow's back. 

Black and White Check this box to change the diagram color to black and white. 

Bold Check this box or press CTRL+B to bold the table, view, entity, foreign key, relation 

or shape. 

Border Color The color of the shape's border. 

Cap Style The cap style of the line/arrow. 

Case Sensitivity The case sensitivity of the table or view names. Available only for MySQL and 

MariaDB physical models. 

Color The color of the object. 

Dash Style The dash style of the line/arrow. 

Database Type The database type of the model. 

Database Version The database version of the model. 

Diagram Notation The notation of the diagram. The notation options are depended on the model type. 

End Arrow Style The style of the arrow's front. 

Entity Font Name The font name of the entities. 

Entity Font Size The font size of the entities. 

Font Bold Check this box to bold the note/label font. 

Font Color The font color of the note, label or layer. 

Font Italic Check this box to apply an italic style to the note or label font. 

Font Name The font name of the note, label or layer. 

Font Size The font size of the note, label or layer. 

Height The height of the object. 

Height (pages) The height of the diagram (number of papers). 

Join Style The join style of the line/arrow. 

Left The number of pixels from the object to the left side of the canvas. 

Model Type The type of the model. 

Name The name of the object. 

Opacity The transparency of the image/shape. The value for this can be between 0 and 100. 

Use 100 for opacity and 0 for transparent. 

Referenced Cardinality The foreign key/relation cardinality of the referenced (parent) table or entity. 

Referencing Cardinality The foreign key/relation cardinality of the referencing (child) table or entity. 

Schema Name The schema names of the table/view. 

Show Name Check this box to show the name of the foreign key, relation or shape. 

Show Schema Name Check this box to show the schema names of the tables/views in the diagram. 

Show View Relationships Check this box to show the relationship line of the view. 

Table Font Name The font name of the tables. 

Table Font Size The font size of the tables. 

Top The number of pixels from the object to the top of the canvas. 

Visible Check this box to show the foreign key/relation lines. 

Width The width of the object. 
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Width (pages) The width of the diagram (number of papers). 

 

 Overview Pane 

The Overview pane displays the whole active diagram in the canvas. To zoom in or zoom out the selected area of the 

diagram, adjust the slider. If the Overview pane is hidden, choose View -> Show Properties and Show Overview from 

the main menu. Same effect can be achieved with keyboard shortcuts: 

Zoom In: [CTRL++] or [CTRL+Mousewheel Up] 

Zoom out: [CTRL+-] or [CTRL+Mousewheel Down] 

 Diagram Canvas 

You can design your diagram on the Diagram Canvas. 
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Chapter 3 – Navicat Cloud 

About Navicat Cloud 

Navicat Cloud provides a cloud service for synchronizing model files and virtual group information from Navicat Data 

Modeler, other Navicat family members, different machines and different platforms. All the Navicat Cloud objects are 

located under different projects. You can share the project to other Navicat Cloud accounts for collaboration. 

Navicat Cloud could not connect and access your databases. By which it means, it could only store your connection 

settings, queries, model files, and virtual group; your database passwords and data (e.g. tables, views, etc) will not be 

stored to Navicat Cloud. 

Note: PremiumSoft will keep all synchronized files strictly confidential, and all employees are prohibited from 

viewing/accessing content of files you may store in your Navicat Cloud account. 

Create a new account 

1. In the Welcome Window, click Create Navicat ID. Or, in the Main Window, click Sign In and click Create 

Navicat ID. 

2. Enter the required information and click Sign Up button. A verification email will send to your email address. 

3. Click the link in the email to verify the new account. 

Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center. 

Sign in Navicat Cloud 

1. In the Welcome Window, enter your Navicat ID and Password. Or, in the Main Window, click Sign In and 

enter your Navicat ID and Password. 

2. Click Sign In button. 

3. If you enabled two-step verification in Navicat Cloud Portal site, a code will be sent to your phone via your 

mobile app. Enter the received code to sign in. 

Open a model from Navicat Cloud 

1. Choose File -> Open from Navicat Cloud from the main menu. 

2. Select a model file and click Open. 

Save a model to Navicat Cloud 

1. Choose File -> Save to Navicat Cloud from the main menu. 

2. Enter the Model Name. 

https://cloud.navicat.com/
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3. Click Save. 

Save a cloud model to local machine 

1. Choose File -> Save to Local from the main menu. 

2. Enter the file name and choose the saving path. 

3. Click Save. 

Sign out Navicat Cloud 

1. Choose File -> Navicat Cloud from the main menu. 

2. Click your email in the User Info pane and choose Sign Out. 

Manage Navicat Cloud 

After logged into Navicat Cloud, you can open the Navicat Cloud window by choosing File -> Navicat Cloud from the 

main menu. In the Navicat Cloud window, you can view the account details and manage the models and virtual groups 

that stored in Navicat Cloud. 

The left User Info pane shows the account details and the cloud usage. The right Navicat Cloud Activity pane shows 

the project members and activities. If the Navicat Cloud Activity pane is hidden, you can click the  button to show it. 

Note: A model file or a virtual group counts for one unit. 

 

Change your avatar 

1. Click the avatar in the User Info pane. 

file:///D:/manual/Navicat Data Modeler/online_manual/en/navicat_datamodeler/linux_manual/images/navicatCloudWindow.png
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2. Choose an image file. 

Manage your Navicat Cloud account 

1. Click your email in the User Info pane and choose Manage Account. 

2. A browser will open with Navicat Cloud Portal site. 

Upgrade the Navicat Cloud plan 

1. Click Upgrade. 

2. A browser will open with Navicat Cloud Portal site. 

Create a project 

1. Select Navicat Cloud. 

2. Click New Project. 

Add members to a project 

1. Select a project. 

2. Right-click it and choose Collaborate with. 

3. Click Add Members. 

4. Enter the members' Navicat ID. 

5. Select the member role. 

6. Click Add. 

Member 

Roles  

Privileges 

Owner Read Objects, Write Objects, Manage Members and Delete Project 

Admin Read Objects, Write Objects and Manage Members 

Member Read Objects and Write Objects 

Guest Read Objects 

Note: Each time can add up to 10 members. Use comma or enter to separate the members in the edit box. 

Manage members in a project 

1. Select a project. 

2. Right-click it and choose Collaborate with. 

3. Click Apply after changes. 

https://cloud.navicat.com/
https://cloud.navicat.com/
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Note: If you are the Owner or Admin, you can click the x button to remove the member. 

Rename a project 

1. Select a project. 

2. Right-click it and choose Rename. 

3. Enter the project name. 

Quit a project 

1. Select a project. 

2. Right-click it and choose Quit Project. 

Delete a project 

1. Select a project. 

2. Right-click it and choose Delete Project. 

Rename a model 

1. Select a model file. 

2. Right-click it and choose Rename. 

3. Enter the model name. 

Delete a model 

1. Select a model file. 

2. Right-click it and choose Delete Model. 

Create a virtual group 

1. Click New Group. 

2. Enter the group name. 

Move a model to a virtual group 

1. Select a model file. 

2. Right-click it and choose Manage Group -> Move To. 

Move a model to the top-level from a virtual group 

1. Right-click the selected model. 
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2. Choose Manage Group -> Exclude From Group. 

Rename a virtual group 

1. Select a virtual group. 

2. Right-click it and choose Rename Group. 

3. Enter the group name. 

Delete a virtual group 

1. Select a virtual group. 

2. Right-click it and choose Delete Group. 
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Chapter 4 – Physical Models 

Create a Physical Model 

Navicat Data Modeler allows you to create physical models, including tables, fields, views, foreign key constraints and 

other physical properties of the database/schema. 

To create a physical model, select File -> New Model from the main menu. In the New Model window, choose 

Physical as Model Type and select the target Database and Version. 

 

You can also use the following features to create a physical model: 

 Import from Database - reverse engineer from existing databases/schemas. 

 Model Conversion - convert from a logical/conceptual model. 

After creating a physical model, you can compare and synchronize it to an existing database/schema or export it to a 

SQL file. 

Add a Table to a Physical Model 

To add a new table, click the  Table button from the toolbar and click anywhere on the canvas. To add an existing 

table from the Explorer's Model tab, simply drag and drop the selected table from the Model tab to the canvas. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

Note: If you right-click a field, you can choose to add, insert, delete, rename the field and set the field as primary key. 
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The pop-up menu options of the table object in canvas include: 

Option Description 

Design Table Edit the table structure in a Table Designer, e.g. fields, indexes, foreign 

keys, etc. 

Add Related Objects Add all related tables/views to the selected table. 

Add Field Add fields to the existing table. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Tables Select all tables in the diagram. 

Delete Delete a table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

Table Designer 

Table Designer is the basic Navicat Data Modeler tool for working with tables. It allows you to create, edit and drop 

table's fields, indexes, foreign keys, and much more. 

Note: The tabs and options in the designer depend on the diagram database type and version you are chosen. 

In the Fields tab, you can search a field name by pressing CTRL+F. 
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Add Views 

Add a View to a Physical Model 

To add a new view, click the  View button from the toolbar and click anywhere on the canvas. To add an existing 

view from the Explorer's Model tab, simply drag and drop the selected view from the Model tab to the canvas. 

Note: If you right-click the view connector, you can choose to add or delete vertices and change its color, or go to the 

source view or the target table. 

 

The pop-up menu options of the view object in canvas include: 

Option Description 

Design View Edit the view structure in a View Designer. 

Add Related Objects Add all related tables/views to the selected view. 

Cut Remove the view from the diagram and put it on the clipboard. 
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Copy Copy the view from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Views Select all views in the diagram. 

Delete Delete a view from the diagram or from both diagram and model. 

Rename Change the name of the view. 

Color Change the color of the view. 

Size to Fit Resize the view automatically to fit its contents. 

Bring to Front Bring the view to the foreground. 

Send to Back Move the view to the background. 

View Designer 

View Designer is the basic Navicat Data Modeler tool for working with views. In View Designer, you can build the 

views visually using View Builder or edit the view's Definition directly. 

Note: The tabs and options in the designer depend on the diagram database type and version you are chosen. 

 

 

Work with View Builder 

Navicat Data Modeler provides a useful tool called View Builder for building views visually. It allows you to create and 

edit views without knowledge of SQL. The database objects are displayed in left pane. Whereas in the right pane, it is 

divided into two portions: the upper Diagram Design pane, and the lower Syntax pane. 
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Drag a table/view from the left pane to the Diagram Design pane or double-click it to add it to view. To include a field in 

the view, check the left of the field name in the Diagram Design pane. To include all the fields, click at the left of the 

object caption. 

To remove the object from the Diagram Design pane, click the cross button at the object caption. 

To add the table/view alias, simply double-click the table/view name and enter the alias in the Diagram Design pane. 

Hint: You are also allowed to set criteria by right-click any fields from the Diagram Design pane. 

 

Setting Field Association 

To associate database objects by two fields, just drag one field from the object list to another and a line will appear 

between the linked fields. 

Hint: To delete all the links of some object, click button '-' next to the object alias. 

Go to the Syntax pane to change the association between the links, click the operator and choose the properties item 

from the pop-up menu. You can change the association condition by choosing it from the list (=, <>, <, <=, >, >=). Click 

OK to confirm the changes you made. Also you can change the type of Join. 

Setting Output Fields 

The fields you have selected in the Diagram Design pane will be displayed in the Syntax pane which allows you to set 

their displaying order and modify the output fields of the view using Distinct, func and Alias. 

Distinct 

Enable this option if you wish the repeated records are not included into the view result. 
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func 

Set the aggregate functions (SUM, MAN, MIX, AVG, COUNT) for each field. 

Alias 

Change the output field name. 

Setting Criteria 

To add a condition, click the <--> = <--> from the WHERE clause in the Syntax pane. Click <--> to choose the field from 

the list of all the table fields, available in the view. To define your own criteria, type your values directly in the Edit Tab. 

Clicking = to set condition operator. 

Setting Grouping Criteria 

You can set the conditions for grouping view records from the GROUP BY clause in the Syntax pane. They are set in 

the same way as setting criteria. The conditions will be included into the HAVING statement of the current view. 

Setting Sorting Criteria 

In View Builder, you can set the way of sorting view records from the ORDER BY clause in the Syntax pane. To change 

the sorting direction, click on either ASC or DESC. 

Setting Limit Criteria 

LIMIT clause is used to limit your view results to those that fall within a specified range. You can use it to show the first 

X number of results, or to show a range from X - Y results. It is phrased as Limit X, Y and included at the end of your 

view. X is the starting point (remember the first record is 0) and Y is the duration (how many records to display). 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Edit View's Definition 

In Definition tab, you can create and edit the SELECT statement SQL for a view. Navicat Data Modeler provides a 

wide range advanced features for editing the view definition, such as compelling code editing capabilities, smart 

code-completion, sql formatting, and more. 

Hint: SELECT statement will be automatically generated while you build in View Builder. 

Beautify SQL 

To format messy SQL code into a well-structured script, you can click the Beautify SQL button. 

Code-Completion 

Code-completion displays information in drop-down lists as you type your SQL statement in the editor, it assists you 

with statement completion and the available properties of database objects, for example schemas, tables, fields, views 

etc with their appropriate icons. 
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To activate the code-completion, just simply press '.' for the available properties of database object currently in the 

scope. 

 

Hint: You may invoke code-completion by typing two characters or pressing CTRL+SPACE on your keyboard for SQL 

keywords/database objects. 

 

Hint: Smart code-completion will pop up a list of variants for the word completion automatically. 

Brace Highlight 

Navicat Data Modeler supports to highlight the matching brace in the editor, i.e. (), Begin...End . 

Hint: The cursor must be on a brace to show the highlight. 

 

Zoom In/Zoom Out 

Navicat Data Modeler has the ability to zoom in or zoom out the SQL in the editor. 

Zoom In: [CTRL++] or [CTRL+Mousewheel Up] 

Zoom out: [CTRL+-] or [CTRL+Mousewheel Down] 

Reset: [CTRL+0] 
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Add a Foreign Key to a Physical Model 

To add a foreign key, click the  Foreign Key button from the toolbar and drag and drop a field from the child table 

to the parent table. To show/hide the linked name label, simply check/uncheck the Show Name option in Properties 

pane. 

When you move your mouse over a foreign key connecter, the border of the parent and the child tables turn to green 

and blue respectively. Also, the referenced fields and the referencing fields are highlighted. 

 

The pop-up menu options of the foreign key in canvas include: 

Option Description 

Design Relation Edit the foreign key in a Table Designer. 

Cardinality on 

table_name1 

Set the cardinality on table_name1: None, One and Only One, Many, One or 

Many, Zero or One, Zero or Many. 

Cardinality on 

table_name2 

Set the cardinality on table_name2: None, One and Only One, Many, One or 

Many, Zero or One, Zero or Many. 

Add Vertex Add a vertex on a foreign key connecter. 

Delete Vertex Delete a vertex on a foreign key connecter. 

Delete All Vertices Delete all vertices on a foreign key connecter. 

Go to Source Go to and select the source (child) table. 

Go to Target Go to and select the target (parent) table. 

Paste Paste the content from the clipboard into the diagram. 

Select All Relations Select all foreign keys in the diagram. 

Delete from Diagram 

and Model 

Delete a foreign key from both diagram and model. 

Color Change the color of the foreign key. 
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Chapter 5 – Logical Models 

Create a Logical Model 

Navicat Data Modeler allows you to create logical models, including entities, attributes and relations. 

To create a logical model, select File -> New Model from the main menu. In the New Model window, choose Logical 

as Model Type. 

 

You can also use the following features to create a logical model: 

 Import from Database - reverse engineer from existing databases/schemas. 

 Model Conversion - convert from a physical/conceptual model. 

Add an Entity to a Logical Model 

To add a new entity, click the  Entity button from the toolbar and click anywhere on the canvas. To add an existing 

entity from the Explorer's Model tab, simply drag and drop the selected entity from the Model tab to the canvas. 

For Default diagram notation, the  icon means the attribute is a primary key. The  icon indicates that the 

attribute serves as an index. 

Note: If you right-click an attribute, you can choose to add, insert, delete, rename the attribute and set the attribute as 

primary key. 
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The pop-up menu options of the entity object in canvas include: 

Option Description 

Design Entity Edit the entity structure in an Entity Designer, e.g. attributes and 

relations. 

Add Related Objects Add all related entities to the selected entity. 

Add Attribute Add attributes to the existing entity. 

Cut Remove the entity from the diagram and put it on the clipboard. 

Copy Copy the entity from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Entities Select all entities in the diagram. 

Delete Delete an entity from the diagram or from both diagram and model. 

Rename Change the name of the entity. 

Color Change the color of the entity. 

Size to Fit Resize the entity automatically to fit its contents. 

Bring to Front Bring the entity to the foreground. 

Send to Back Move the entity to the background. 

Entity Designer 

Entity Designer is the basic Navicat Data Modeler tool for working with entities. It allows you to create, edit and drop 

entity's attributes, relations, etc. 

In the Attributes tab, you can search an attribute name by pressing CTRL+F. 
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Add a Relation to a Logical Model 

To add a relation, click the  Relation button from the toolbar and drag and drop an attribute from the child entity to 

the parent entity. To show/hide the linked name label, simply check/uncheck the Show Name option in Properties 

pane. 

When you move your mouse over a relation connecter, the border of the parent and the child entities turn to green and 

blue respectively. Also, the referenced attributes and the referencing attributes are highlighted. 
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The pop-up menu options of the relation in canvas include: 

Option Description 

Design Relation Edit the relation in an Entity Designer. 

Cardinality on 

entity_name1 

Set the cardinality on entity_name1: None, One and Only One, Many, One or Many, 

Zero or One, Zero or Many. 

Cardinality on 

entity_name2 

Set the cardinality on entity_name2: None, One and Only One, Many, One or Many, 

Zero or One, Zero or Many. 

Add Vertex Add a vertex on a relation connecter. 

Delete Vertex Delete a vertex on a relation connecter. 

Delete All Vertices Delete all vertices on a relation connecter. 

Go to Source Go to and select the source (child) entity. 

Go to Target Go to and select the target (parent) entity. 

Paste Paste the content from the clipboard into the diagram. 

Select All Relations Select all relations in the diagram. 

Delete from Diagram and 

Model 

Delete a relation from both diagram and model. 

Color Change the color of the relation. 
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Chapter 6 - Conceptual Models 

Create a Conceptual Model 

Navicat Data Modeler allows you to create conceptual models, including entities and relations. 

To create a conceptual model, select File -> New Model from the main menu. In the New Model window, choose 

Conceptual as Model Type. 

 

You can also use the following features to create a conceptual model: 

 Import from Database - reverse engineer from existing databases/schemas. 

 Model Conversion - convert from a physical/logical model. 

Add an Entity to a Conceptual Model 

To add a new entity, click the  Entity button from the toolbar and click anywhere on the canvas. To add an existing 

entity from the Explorer's Model tab, simply drag and drop the selected entity from the Model tab to the canvas. 

 

The pop-up menu options of the entity object in canvas include: 

Option Description 

Add Related Objects Add all related entities to the selected entity. 

Cut Remove the entity from the diagram and put it on the clipboard. 

Copy Copy the entity from the diagram to the clipboard. 
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Paste Paste the content from the clipboard into the diagram. 

Select All Entities Select all entities in the diagram. 

Delete Delete an entity from the diagram or from both diagram and model. 

Rename Change the name of the entity. 

Color Change the color of the entity. 

Size to Fit Resize the entity automatically to fit its contents. 

Bring to Front Bring the entity to the foreground. 

Send to Back Move the entity to the background. 

 

Add a Relation to a Conceptual Model 

To add a relation, click the  Relation button from the toolbar and drag the child entity and drop to the parent entity. 

To show/hide the linked name label, simply check/uncheck the Show Name option in Properties pane. 

When you move your mouse over a relation connecter, the border of the parent and the child entities turn to green and 

blue respectively. 

 

The pop-up menu options of the relation in canvas include: 

Option Description 

Cardinality on 

entity_name1 

Set the cardinality on entity_name1: None, One and Only One, Many, 

One or Many, Zero or One, Zero or Many. 

Cardinality on 

entity_name2 

Set the cardinality on entity_name2: None, One and Only One, Many, 

One or Many, Zero or One, Zero or Many. 

Add Vertex Add a vertex on a relation connecter. 

Delete Vertex Delete a vertex on a relation connecter. 

Delete All Vertices Delete all vertices on a relation connecter. 

Go to Source Go to and select the source (child) entity. 

Go to Target Go to and select the target (parent) entity. 
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Paste Paste the content from the clipboard into the diagram. 

Select All Relations Select all relations in the diagram. 

Delete from Diagram 

and Model 

Delete a relation from both diagram and model. 

Color Change the color of the relation. 
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Chapter 7 – Diagram Layout 

Work with Diagram Canvas 

Show Grid 

To turn the grid on in the diagram canvas, choose View -> Show Grid from the menu. 

Snap to Grid 

To align objects on the canvas with the grid, choose View -> Snap To Grid from the menu. 

Change Diagram Notation 

To change the notation of the diagram, choose Diagram -> Diagram Notation from the menu. 

Note: The options depend on the diagram type you are chosen. 

Option Description 

Default The default notation style used in Navicat Data Modeler. 

Simple A simple notation style. The table, view or entity objects will only show the name. 

IE (Crow's Foot) Crow's Foot notation style. 

IDEF1X The ICAM DEFinition language information modeling method. 

UML Universal Modeling Language style. 

Classic A classic notation style. 

Black and White Change the color of the diagram to black and white. 

Show Schema Name Show the schema names of the tables and views in the diagram. 

 

Change Diagram Dimensions 

To change the number of pages used in the diagram, choose Diagram -> Diagram Dimensions from the menu and 

set the Width and the Height. 

Align Objects 

To align objects on the canvas, select more than one object (tables, entities, views, notes, labels, images or shapes), 

then right-click and choose Alignment -> Align Left, Align Center, Align Right, Align Top, Align Middle or Align 

Bottom. 

Change Objects Distribution 

To distribute objects on the canvas, select more than one object (tables, entities, views, notes, labels, images or 

shapes), then right-click and choose Distribute -> Horizontal or Vertical. 

Change Page Setup 
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To change paper size, orientation and margins, choose File -> Page Setup. 

Add Labels 

Labels are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. To add a new label, click the  Label button from the toolbar and click anywhere on the canvas. 

 

The pop-up menu options of the label object in canvas include: 

Option Description 

Edit Change the content of the label. 

Cut Remove the label from the diagram and put it on the clipboard. 

Copy Copy the label from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Labels Select all labels in the diagram. 

Delete Delete a label from the diagram. 

Size to Fit Resize the label automatically to fit its contents. 

Bring to Front Bring the label to the foreground. 

Send to Back Move the label to the background. 

 

Add Notes 

Notes are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. To add a new note, click the  Note button from the toolbar and click anywhere on the canvas. 
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The pop-up menu options of the note object in canvas include: 

Option Description 

Edit Change the content of the note. 

Cut Remove the note from the diagram and put it on the clipboard. 

Copy Copy the note from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Notes Select all notes in the diagram. 

Delete Delete a note from the diagram. 

Color Change the color of the note. 

Size to Fit Resize the note automatically to fit its contents. 

Bring to Front Bring the note to the foreground. 

Send to Back Move the note to the background. 

 

Add Images 

To add a new image, click the  Image button from the toolbar and click anywhere on the canvas. Then, select an 

image file in the Open dialog box. 

 

The pop-up menu options of the image object in canvas include: 
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Option Description 

Reset Size Reset the size of the image to its original size. 

Reset Aspect Ratio Maintain the image original width to height ratio. 

Cut Remove the image the diagram and put it on the clipboard. 

Copy Copy the image from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Images Select all images in the diagram. 

Delete Delete an image from the diagram. 

Bring to Front Bring the image to the foreground. 

Send to Back Move the image to the background. 

 

Add Shapes 

To add a new shape (line, arrow, rectangle, ellipse, user, database, cloud, trigger, server, desktop or mobile), click the 

 Shape button from the toolbar and choose the type of shape. Then, click anywhere on the canvas. 

 

The pop-up menu options of the shape object in canvas include: 

Option Description 

Reset Aspect Ratio Maintain the shape original width to height ratio. 

Only for rectangle, ellipse, user, database, cloud, trigger, server, 

desktop and mobile. 

Cut Remove the shape from the diagram and put it on the clipboard. 

Copy Copy the shape from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Shapes Select all the shapes in the diagram. 

Delete Delete a shape from the diagram. 

Color Change the color of the shape. 

Border Color Change the color of the shape's border. 

Only for rectangle, ellipse, user, database, cloud, trigger, server, 

desktop and mobile. 
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Begin Arrow Style Change the style of the arrow's back. 

Only for arrow. 

End Arrow Style Change the style of the arrow's front. 

Only for arrow. 

Add Vertex Add a vertex on a line or arrow. 

Only for line and arrow. 

Delete Vertex Delete a vertex on a line or arrow. 

Only for line and arrow. 

Delete All Vertices Delete all vertices on a line or arrow. 

Only for line and arrow. 

Bring to Front Bring the shape to the foreground. 

Send to Back Move the shape to the background. 

 

Add Layers 

Layers are used to help organize objects (e.g. tables, notes, images, etc) on the canvas. You can add all related 

objects to the same layer. For example, you may choose to add all your sales related tables to one layer. To add a new 

layer, click the  Layer button from the toolbar and click anywhere on the canvas. 

 

The pop-up menu options of the layer object in canvas include: 

Option Description 

Cut Remove the layer from the diagram and put it on the clipboard. 

Copy Copy the layer from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Layers Select all layers in the diagram. 

Delete Delete a layer from the diagram. 

Color Change the color of the layer. 
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Size to Fit Resize the layer automatically to fit its contents. 

Bring to Front Bring the layer to the foreground. 

Send to Back Move the layer to the background. 
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Chapter 8 - Reverse Engineering (Available only 

in Full Version) 

Import from Database 

The Import from Database feature allows you to load already existing database structures to create new diagrams. It 

supports to import MySQL, MariaDB, PostgreSQL, Oracle, SQLite tables/views. If the model is logical or conceptual, all 

views will covert to entities after the import process. To start the Import from Database wizard, select Tools -> Import 

from Database from the main menu. 

If it is the first time you open the wizard, you require to establish your server connection before selecting the connection. 

Click the Manage Connection button to create, edit or delete connections. 

Create Connection 

Choose Manage Connections -> New Connection to start the setup. 

 MySQL/MariaDB/PostgreSQL/Oracle/SQLite 

Note: Navicat Data Modeler authorizes you to make connection to remote server running on different platform, i.e. 

Windows, macOS, Linux and UNIX. 

Edit Connection 

To edit a connection information 

 Select an existing connection. 

 Choose Manage Connections -> Edit Connection. 

Delete Connection 

To delete a connection 

 Select an existing connection. 

 Choose Manage Connections -> Delete Connection. 

Import Connection Settings 

To import Navicat (e.g. Navicat Premium) connection settings 

 Choose Manage Connections -> Import Connections from Navicat. 

 Select the connections and click OK. 

https://navicat.com/products/navicat-premium
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Note: Available only when Navicat (e.g. Navicat Premium) is installed in the current machine. If the connection exists, 

the newly created connection will be named as e.g. "connection_name Copy #". 

After selecting the connection, you are allowed to choose databases, schemas, tables or views to import. If your 

diagram is logical and conceptual, views will be imported as entities. Click Start to start the import process. 

Database Connections 

Create a Connection to a Server 

You can create a connection to connect your server: MySQL, MariaDB, PostgreSQL, Oracle, SQLite. 

Note: The tabs in the connection properties window depend on the database type you are chosen. 

 General Settings 

 Advanced Settings 

 SSL Settings 

 SSH Settings 

 HTTP Settings 

General Settings 

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the 

connection properties in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its 

server, Secure Tunneling Protocol (SSH) / HTTP is another solution. Enter a friendly name to best describe your 

connection in Connection Name text box. 

After you logged in Navicat Cloud feature, you can choose to save the connection to My Connections or the projects in 

Navicat Cloud from Add To drop-down list. If you choose My Connections, its connection settings are stored in the 

local machine. When editing a connection in Navicat Cloud, you can choose to synchronize the user name to cloud by 

enabling the Sync User Name with Navicat Cloud option. 

MySQL and MariaDB Connections 

You can connect to your MySQL server remotely however for security reasons native remote direct connections to the 

MySQL server are disabled. Therefore, you cannot use Navicat Data Modeler or other similar MySQL admin 

applications running on your computer to connect to the remote server directly unless the User Privileges has been 

configured. 

By default, MySQL gives "root" as username and leave the password field blank. 

Host Name/IP Address 

A host name where the database is situated or the IP address of the server. 

http://dev.mysql.com/doc/refman/5.7/en/connection-access.html


 44 

 

Port 

A TCP/IP port for connecting to the database server. 

User Name 

User name for connecting to the database server. 

Password 

Password for connecting to the server. 

Oracle Connection 

Navicat Data Modeler supports Basic connection type for Oracle server. In Basic mode, Navicat Data Modeler 

connects to Oracle through the Oracle Call Interface (OCI). OCI is an application programming interface that allows an 

application developer to use a third-generation language's native procedure or function calls to access the Oracle 

database server and control all phases of SQL statement execution. OCI is a library of standard database access and 

retrieval functions in the form of a dynamic-link library. 

By default, Oracle created a number of user accounts upon installation. Administrative accounts: SYS, SYSTEM, 

SYSMAN, and DBSNMP. Sample schema accounts: SCOTT, HR, OE, OC, PM, IX and SH. 

Connection Type 

Connection type for connecting to the server: Basic. 

Host Name/IP Address 

A host name where the database is situated or the IP address of the server. 

Port 

A TCP/IP port for connecting to the database server. 

Service Name/SID 

Set the Service Name/SID which the user connects when making connection. Select the corresponding radio button. 

User Name 

User name for connecting to the database server. 

Password 

Password for connecting to the server. 

See also: 

OCI options 
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PostgreSQL Connection 

For security reasons native remote direct connections to the PostgreSQL server are disabled. Therefore, you may not 

be able to use Navicat Data Modeler or other similar PostgreSQL admin applications running on your computer to 

connect to the remote server. By default, PostgreSQL only allows connections from the local machine using TCP/IP 

connections. Other machines will not be able to connect unless you modify listen_addresses in the postgresql.conf file, 

enable host-based authentication by modifying the $PGDATA/pg_hba.conf file, and restart the server. For more 

information: Client Authentication. 

By default, PostgreSQL gives "postgres" as username and leave the password field blank. 

Host Name/IP Address 

A host name where the database is situated or the IP address of the server. 

Port 

A TCP/IP port for connecting to the database server. 

Initial Database 

The initial database to which user connects when making connection. 

User Name 

User name for connecting to the database server. 

Password 

Password for connecting to the server. 

SQLite Connection 

You can choose the Type of the SQLite database and specify the file path. 

Existing Database File 

Connect an existing database in the Database File. 

New SQLite 3 

Create a new SQLite 3 database in the Database File. 

New SQLite 2 

Create a new SQLite 2 database in the Database File. 

Database File 

http://www.postgresql.org/docs/9.4/interactive/client-authentication.html
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Specify the initial database file. If the HTTP Tunnel is enabled, you need to enter an absolute file path of the database 

file in your web server. 

User Name 

User name for connecting to an existing database file. 

Password 

Password for connecting to an existing database file. 

Advanced Settings 

MySQL and MariaDB Connections 

Encoding 

Choose a codepage to communicate with MySQL Server while MySQL character set not being employed. 

Use Compression 

This option allows you to use compression protocol. It is used if both client and server support zlib compression, and 

the client requests compression. 

Use Named Pipe, Socket 

With this option on, Navicat Data Modeler uses socket file for localhost connection. 

Oracle Connection 

Role 

Indicate that the database user is connecting with either the Default, SYSOPER or SYSDBA system privilege. 

OS Authentication 

With this option on, Oracle Database uses OS user login credentials to authenticate database users. 

SQLite Connection 

Encrypted 

Enable this option and provide Password when connecting to an encrypted SQLite database. 

Attached Databases 

To attach or detach databases in the connection. 
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SSL Settings 

Secure Sockets Layer (SSL) is a protocol for transmitting private documents via the Internet. To get a secure 

connection, the first thing you need to do is to install OpenSSL Library and download Database Source. 

Note: Available only for MySQL, PostgreSQL and MariaDB. Support from PostgreSQL 8.4 or later. 

MySQL and MariaDB Connections 

To provide authentication details, enable Use Authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Certificate 

The SSL certificate file in PEM format to use for establishing a secure connection. 

CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Verify CA Certificate Name 

Check the server's Common Name value in the certificate that the server sends to the client. 

Specified Cipher 

A list of permissible ciphers to use for SSL encryption. 

PostgreSQL Connection 

Choose the SSL Mode: 

require Only try an SSL connection. 

verify-ca Only try an SSL connection, and verify that the server certificate is issued by 

a trusted CA. 

verify-full Only try an SSL connection, verify that the server certificate is issued by a 

trusted CA and that the server hostname matches that in the certificate. 

To provide authentication details, enable Use Authentication and fill in the required information: 

Client Key 

The path of the client private key. 

Client Certificate 

The path of the client certificate. 
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CA Certificate 

The path of the trusted certificate authorities. 

Certificate Revocation List 

The file path of the SSL certificate revocation list (CRL). 

SSH Settings 

Secure SHell (SSH) is a program to log in into another computer over a network, execute commands on a remote 

server, and move files from one machine to another. It provides strong authentication and secure encrypted 

communications between two hosts, known as SSH Port Forwarding (Tunneling), over an insecure network. 

Typically, it is employed as an encrypted version of Telnet. 

In a Telnet session, all communications, including username and password, are transmitted in plain-text, allowing 

anyone to listen-in on your session and steal passwords and other information. Such sessions are also susceptible to 

session hijacking, where a malicious user takes over your session once you have authenticated. SSH serves to prevent 

such vulnerabilities and allows you to access a remote server's shell without compromising security. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 

Please make sure that the parameter - "AllowTcpForwarding" in the Linux server must be set to value "yes", otherwise, 

the SSH port forwarding will be disabled. To look for the path: /etc/ssh/sshd_config. By default, the SSH port forwarding 

should be enabled. Please double check the value settings. 

Even the server support SSH tunnel, however, if the port forwarding being disabled, Navicat Data Modeler cannot 

connect via SSH Port 22. 

Host Name/IP Address 

A host where SSH server is activated. 

Note: The host name in the General tab should be set relatively to the SSH server which provided by your database 

hosting company. 

Port 

A port where SSH server is activated, by default it is 22. 

User Name 

A user on SSH server machine. (It is not a user of database server.) 

Authentication Method 

Password Provide the SSH server user Password. 

Public Key Private Key 
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It is used together with your public key. The private key should be readable 

only by you. 

Passphrase 

A passphrase is exactly like a password, except that it applies to the keys 

you are generating and not an account. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

HTTP Settings 

HTTP Tunneling is a method for connecting to a server that uses the same protocol (http://) and the same port (port 80) 

as a web server does. It is used while your ISPs do not allow direct connections, but allows establishing HTTP 

connections. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Uploading the Tunneling Script 

To use this connection method, first thing you need to do is to upload the tunneling script to the web server where your 

server is located. 

Note: ntunnel_mysql.php (for both MySQL and MariaDB), ntunnel_pgsql.php or ntunnel_sqlite.php is available in 

the Navicat Data Modeler installation folder. 

Setting up HTTP Tunnel 

The following instruction guides you through the process of configuring a HTTP connection. 

1. Select the HTTP tab and enable Use HTTP Tunnel. 

2. Enter URL of the tunneling script, e.g. http://www.navicat.com/ntunnel_mysql.php . 

3. If your server installed a Web Application Firewall, you can check the Encode outgoing query with base64 

option. 

4. If the tunneling script is hosted in a password protected server or you have to access internet over a proxy 

server, you can provide the required authentication details in Authentication or Proxy tab. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 
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Chapter 9 - Forward Engineering (Available only 

in Full Version) 

Forward Engineer Physical Model 

Navicat Data Modeler provides two forward engineering tools for you to generate physical databases or a script file 

from a physical model. 

 Synchronize to Database - compare and synchronize to an actual database. 

 Export SQL - generate a SQL file with customized settings. 

Synchronize to Database 

The Synchronize to Database feature allows you to compare a model with an existing database or schema, states the 

differences between their structures, and offers synchronizing the structures in model to the target connection. To start 

the Synchronize to Database wizard, select Tools -> Synchronize to Database from the main menu. 

Note: This feature is only available for Physical Models. 

Select Synchronization Type 

Sync with selected schemas 

Set the synchronization to work on all objects in the selected schemas. 

Sync with selected objects 

Set the synchronization to work on the selected objects only. 

Select Schemas/Objects and Connection 

In this step, choose one or more schemas or objects in model to compare to the target schemas or objects. If objects in 

model are from existing schemas, you can select the existing schemas. Otherwise, enter a target schema name in 

Objects without schema will synchronize to this schema for the source model objects to compare to. 

Then, choose target connection and database from existing connections. You can click the Manage Connection 

button to view and edit connections in Navicat Data Modeler. See Database Connections for details. 

Select Compare and Advanced Options 

Note: The following options depend on the diagram database type you are chosen. 

Compare Tables 

Check this option if you want to compare tables. 
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Compare Identifier With Case Sensitive 

Check this option if you want to compare table identifier with case sensitive option. 

Compare Primary Keys 

Check this option if you want to compare table primary keys. 

Compare Foreign Keys 

Check this option if you want to compare table foreign keys. 

Compare Indexes 

Check this option if you want to compare indexes. 

Compare Triggers 

Check this option if you want to compare triggers. 

Compare Character Set 

Check this option if you want to compare the character sets of tables. 

Compare Auto Increment Value 

Check this option if you want to compare the auto increment values of tables. 

Compare Uniques 

Check this option if you want to compare uniques. 

Compare Checks 

Check this option if you want to compare checks. 

Compare Excludes 

Check this option if you want to compare excludes. 

Compare Rules 

Check this option if you want to compare rules. 

Compare Collation 

Check this option if you want to compare the collations of tables. 

Compare Views 

Check this option if you want to compare views. 



 52 

 

Compare Definers 

Check this option if you want to compare the definers of views. 

SQL for objects to be created 

Check this option to include all related SQL statements if new database objects will be created in the target. 

SQL for objects to be changed 

Check this option to include all related SQL statements if database objects will be changed in the target. 

SQL for objects to be dropped 

Check this option to include all related SQL statements if database objects will be dropped from the target. 

Continue on error 

Ignore errors that are encountered during the synchronization process. 

View Comparison Result 

The Source Objects and Target Objects views show the differences between model and database/schema objects 

after the comparison of their structures, providing with the detailed SQL statements shown in the Queries for 

Modification list. 

The red item represents the non-existence for the other database/schema. The blue item represents the existence for 

the other database/schema, but different definition detected. 

 

All the scripts are unchecked in the Queries for Modification list by default. Check the scripts you want to apply to the 

target. 

You can highlight multiple lines of scripts, and then right-click to show the pop-up menu. Choose Checked Scripts 

Detail to view the full SQL statements you selected. 
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Click Run Query button to execute the selected query. 

Export SQL 

After finishing your model, you can save table structures and relations from the model into a script file. The Export SQL 

feature generates a SQL file for the script. To start the Export SQL feature, select Tools -> Export SQL from the main 

menu. 

Note: This feature is only available for Physical Models. 

General Properties 

File 

Set the output file name and location. 

Objects 

Choose objects in the model you wish to export. 

Advanced Properties 

Note: The following options depend on the diagram database type you are chosen. 

Server Version 

Select the server version for the SQL file. 

Include Schema 

Include the schema name in file with this option is on. Otherwise, only object names are included in SQL statements. 

Default Schema 

Set the schema name for the objects without schema settings. 

Include Drop SQL 

Include drop object SQL statements in file with this option in on. 

Include Drop With CASCADE 
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Include drop object SQL statements with cascade option in file with this option in on. 

Include Primary Keys 

Include primary keys in file with this option is on. 

Include Foreign Keys 

Include foreign keys in file with this option is on. 

Include Uniques 

Include uniques in file with this option is on. 

Include Indexes 

Include indexes in file with this option is on. 

Include Checks 

Include checks in file with this option is on. 

Include Excludes 

Include excludes in file with this option is on. 

Include Rules 

Include rules in file with this option is on. 

Include Triggers 

Include triggers in file with this option is on. 

Include Character Set 

Include table and field character set in file with this option is on. 

Include auto increment 

Include table auto increment values in file with this option is on. 

Include Collation 

Include table collation in file with this option is on. 
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Chapter 10 – Other Advanced Tools 

Useful Features 

Navicat Data Modeler provides variety of tools that improve user experience when working on models. 

 Model Conversion 

 Auto Layout 

 Preview and Print Model 

 Search Filter 

Model Conversion 

Navicat Data Modeler allows you to convert your models from one database type to another database type and also 

from one model type to another model type, e.g. MariaDB 10.0 physical model to PostgreSQL 9.0 physical model, 

Oracle 10g physical model to a logical model, a conceptual model to MySQL 5.0 physical model. 

During the conversion, all data types are converted automatically. The conversion process does not change the SQL 

syntax of views if converting from one database type to another. If you covert a physical model to logical/conceptual 

model, all views will be converted to entities. If the target database version is MySQL 4.0 or below, all views will be 

removed. 

To convert an opened model file, choose File -> Model Conversion. Then, choose the Model Type and select the 

target Database and Version if necessary. 

Auto Layout (Available only in Full Version) 

To automatically arrange objects on the canvas, click the  Auto Layout button. To change the Auto Layout format 

settings, simply choose Diagram -> Auto Layout with from the menu and set the following options: 

Auto Diagram Dimension 

Choose the suitable diagram dimension automatically. 

Auto Size Tables To Fit 

Resize the table to fit its content automatically. 

Quality 

The quality of the auto layout output. 

Object Distance 
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The distance between the objects in the diagram. 

Preview and Print Model 

To preview the pages before printing, simply click the  Print Preview button. The model can be printed to the 

printer or to various file formats. 

Print to a printer 

Choose File ->  Print to send your diagram directly to the printer. You can set the printer option in the pop-up 

window. 

Print to a file 

Choose File -> Print As and choose the file format to create a PDF, PNG or SVG file of your diagram. 

Search Filter 

Object Filter allows you to filter models in Navicat Cloud Window and tables, entities or views in the canvas that 

names contain the filter string. 

Just specify a filter string in the Search text box. To remove the filter, simply delete the filter string. 

Tree Filter allows you to filter tree structure in Explorer or in View Designer that names contain the filter string. 

Click on the tree to focus and specify a filter string directly. To remove the filter, simply delete the filter string. 
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Chapter 11 – Configurations 

Options Settings 

Navicat Data Modeler provides several options for customizing its user interface and performance. 

To open the Options window, choose Tools -> Options from the main menu. 

General 

Hint: Restart Navicat Data Modeler to take effect. 

Show toolbar caption 

Show text on toolbar buttons in Navicat Data Modeler. Otherwise, only buttons will be presented. 

 

Font 

GUI Font 

Define the font and its size used by Navicat Data Modeler interface. 

Hint: Restart Navicat Data Modeler to take effect. 

Editor Font 

Define the font and its size used by editors. 

Anti Alias 

Check this option to improve the quality of the displaying fonts. 

Model 

Hint: Restart Navicat Data Modeler to take effect. 

Highlight Objects 

With this option is on, when a mouse cursor hovers over an object, Navicat Data Modeler will highlight its border with 

blue color. 

Highlight with Relation 

With this option is on, when a mouse cursor hovers over a table, a entity or a view, Navicat Data Modeler will highlight 

it’s foreign keys, relations or view relations with blue or green color indicating relationships with other objects. 
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Guess Field Type 

With this option is on, Navicat Data Modeler will predict field types when you design fields/attributes in tables or entities. 

Activation & Updater 

Check for updates on startup 

Check this option to allow Navicat Data Modeler checks for new version when it starts. 

Proxy 

Use Proxy 

Check this option to use proxy for the activation process. Choose the Proxy Type and enter Host, Port, User Name 

and Password. 

OCI 

Hint: Restart Navicat Data Modeler to take effect. 

OCI library (oci.dll) 

Choose the Oracle Client / Oracle Instant Client folder that includes the OCI library (oci.dll) for Basic connection. It 

has already included in Navicat Data Modeler installation folder. You can locate it directly. 

Oracle Instant Client is the simplest way to deploy a full Oracle Client application built with OCI, OCCI, JDBC-OCI, or 

ODBC drivers. It provides the necessary Oracle Client libraries in a small set of files. You can also download Oracle 

Client / Oracle Instant Client through - 

Oracle Client 

Oracle Instant Client 

Download the appropriate Instant Client packages for your platform and the CPU. All installations REQUIRE the Basic 

or Basic Lite package. Unzip the packages and set the path points to it. 

  

http://www.oracle.com/technetwork/database/enterprise-edition/downloads/index.html
http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html
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Chapter 12 – Hints and Tips 

Model Hints and Tips 

Navicat Data Modeler provides some useful hints to work on the model more effectively. 

Locate Object in the Diagram Canvas 

Object selected in the Explorer's Diagram tab will be highlighted in the Diagram Canvas. 

Double-click an object in the Explorer's Diagram tab will jump to the corresponding object in the Diagram Canvas. 

Delete Object from Model 

Select an object in the Diagram Canvas and press SHIFT+DELETE. 

Open Table/Entity/View Designer 

Double-click a table/entity/view in the Explorer's Model Tab or the Diagram Canvas. 

Get Table /View Structure (SQL Statement) 

Select and copy a table /view in the Diagram Canvas, and paste it to other text editors. 

Design Field without Table/Entity Designer 

Select and click a table/entity name and press TAB/DOWN ARROW to add/edit fields. Navicat Data Modeler will predict 

field types according to field names you entered. 

Note: Available only for Physical Models and Logical Models. 

INTEGER/int/int4/NUMBER 

 suffix "id", "no" (if it is the first column, it will be predicted as a primary key) 

 suffix "num" 

 "qty", "number" 

 exactly "age", "count" 

DECIMAL(10,2)/decimal(10,2)/NUMBER/REAL/money 

 suffix "price", "cost", "salary" 

FLOAT/double/float8/NUMBER/REAL/float 

 "size", "height", "width", "length", "weight", "speed", "distance" 
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DATE/datetime/date/TEXT/datetime2 

 "date", "time" 

VARCHAR(255)/varchar(255)/VARCHAR2(255)/TEXT 

 other field names 

Enter * before the field name to recognize as primary key. e.g. *itemNo:int. 

Enter : between field name and field type to custom field type, e.g. itemName:varchar(255). 

Reorder Field 

Select a table/entity in Diagram Canvas, then press and hold the SHIFT key. Use  to drag the field to a desired 

location. 

Delete Field 

Select a table/entity in Diagram Canvas, then press and hold the SHIFT key. Use  to drag the desired field out of 

the table/entity. 

Add Vertex to Foreign Key/Relation/Line/Arrow 

Select a foreign key/relation/line/arrow in Diagram Canvas. Press and hold the SHIFT key and click on it to add vertex. 

Delete Vertex on Foreign Key/Relation/Line/Arrow 

Select a foreign key/relation/line/arrow in Diagram Canvas. Press and hold the SHIFT key and click on the vertex. 

Switch to Hand Mode 

Press and hold the SPACE key, then move the diagram. 

Select a Page in Print Preview 

Press and hold the SHIFT key, then point to a page to show the page number. 

Press and hold the SHIFT key, then click a page to jump to the corresponding page in Diagram Canvas. 
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Chapter 13 – Hot Keys 

Model Hot Keys 

Keys Action 

CTRL+N New Model 

CTRL+D New Diagram in Model 

CTRL+S Save Model 

CTRL+Z Undo 

CTRL+Y Redo 

CTRL+X Cut 

CTRL+C Copy 

CTRL+V Paste 

CTRL+P Print 

ESC Select 

H Move Diagram 

T New Table/Entity 

V New View 

R New Foreign Key/Relation 

A New Label 

N New Note 

I New Image 

L New Layer 

CTRL+B Bold Selected Table, Entity, View, Foreign Key, 

Relation or Shape 

CTRL++ or CTRL+Mousewheel Up Zoom In 

CTRL+- or CTRL+Mousewheel Down Zoom Out 

CTRL+0 Reset Zoom 

ALT+RIGHT Next Diagram 

CTRL+TAB Next Window 
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