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Chapter 1 - Introduction

About Navicat

Navicat is a multi-connections Database Administration tool allowing you to connect to MySQL, Oracle, PostgreSQL,
SQLite, SQL Server, MariaDB and/or MongoDB databases, making database administration to multiple kinds of
database so easy. It can also manage cloud databases such as Amazon Redshift, Amazon RDS, Alibaba Cloud.
Features in Navicat are sophisticated enough to provide professional developers for all their specific needs, yet easy to
learn for users who are new to database server. With its well-designed Graphical User Interface(GUI), Navicat lets you

quickly and easily create, organize, access and share information in a secure and easy way.

Navicat is available on three platforms - Microsoft Windows, macOS and Linux. It can connect to local/remote servers,
providing several utility tools such as Navicat Cloud Collaboration, Data Modeling, Data Transfer, Data/Structure

Synchronization, Import/Export, Backup/Restore, Charts and Automation.
For details, visit our website: https://www.navicat.com

System Requirements

Windows

e Microsoft Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10, Server 2008, Server 2012,
Server 2016, Server 2019

macOS

e macOS 10.12 Sierra, macOS 10.13 High Sierra, macOS 10.14 Mojave, macOS 10.15 Catalina, macOS 11 Big
Sur

Linux

e Debian 9 or later, Ubuntu 16.04 or later, CentOS 7 or later, Fedora 26 or later, Linux Mint 18 or later
Supported On-Premises Databases

e MySQL 3.23 or later, Drizzle, OurDelta, Percona Server

e PostgreSQL 7.3 or later

e Oracle 9i or later

e SQLite2and 3

e SQL Server 2000 or later

* MariaDB 5.1 or later

¢ MongoDB 3.0t0 4.4


https://www.navicat.com/

Supported Cloud Databases

Amazon AWS

Amazon Redshift

Amazon Aurora for MySQL

Amazon Aurora for PostgreSQL

Amazon RDS for MySQL

Amazon RDS for PostgreSQL

Amazon RDS for Oracle

Amazon RDS for SQL Server

Amazon RDS for MariaDB

Amazon DocumentDB

Google Cloud

Google Cloud SQL for MySQL

Google Cloud SQL for PostgreSQL

Oracle Cloud

Oracle Database Cloud Service

Oracle MySQL Cloud Service

Microsoft Azure

Microsoft Azure SQL Database

Microsoft Azure Database for MySQL

Microsoft Azure Database for PostgreSQL

Microsoft Azure Database for MariaDB

MongoDB Cloud Services

L]

MongoDB Atlas

Alibaba Cloud

L]

Alibaba Cloud ApsaraDB for RDS (MySQL)
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e Alibaba Cloud ApsaraDB for RDS (PostgreSQL)

e Alibaba Cloud ApsaraDB for RDS (SQL Server)

¢ Alibaba Cloud ApsaraDB for MongoDB
Tencent Cloud

e Tencent Cloud TencentDB for MySQL

¢ Tencent Cloud TencentDB for SQL Server

e Tencent Cloud TencentDB for PostgreSQL

e Tencent Cloud TencentDB for MariaDB

e Tencent Cloud TencentDB for MongoDB
Huawei Cloud

e Huawei Cloud RDS for MySQL

e Huawei Cloud RDS for PostgreSQL

* Huawei Cloud RDS for SQL Server

e Huawei Cloud Document Database Service

Installation

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation.
Installation for Download Version

1. Download Navicat macOS version.

2. Open the .dmg file.

3. Drag Navicat to your Applications folder to install.
Installation for CD Version

1. Load the Navicat CD Installation disk into the CD-ROM drive.

2. Open the .dmg file.

3. Drag Navicat to your Applications folder to install.
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Registration

When the trial period is finished, Navicat requires a license key or a subscription plan to continue using the features.

Note: Perpetual License and Subscription Plan cannot be used at the same Navicat. Before changing the registration

method, you need to deactivate the license key or sign out your Navicat ID.
Perpetual License
If you have purchased a perpetual license, you will receive a license key for activating Navicat.

In the Perpetual License section, paste your license key (16 digits) and click the Activate button. Navicat contacts our

licensing server to activate the license key. If the activation process is successful, the license key details are displayed.
Manual Activation

Manual activation is available when your computer does not have an internet connection. You will need another

computer with an internet connection to complete this activation process.
1. If the online activation is failed, click Manual Activation.
2. Copy the Request Code in the Copy the Request Code Here: box.

3. Open web browser on a computer with an internet connection and then go to

https://customer.navicat.com/manual_activate.php.

4. Paste/Enter the Request Code into the left box.

5. Click Get Activation Code.

6. Copy the generated Activation Code in the right box.

7. Go back to the computer where you are activating Navicat.

8. Paste the Activation Code into the Paste the Activation Code Here: box.
9. Click Activate.
Subscription Plan
If you have subscribed a plan, you can sign in your Navicat ID to use Navicat during the subscription term.
Note: Navicat ID is the Email address that you used to subscribe the plan.

In the Subscription section, provide your Navicat ID and Password. After signed in, the subscription plan details are

displayed.

Navicat contacts our licensing server once per hour to auto reload the plan by default. If you have updated your plan in

the portal site, you can use the Reload Plan button to force reloading the new plan.
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Note: Each Navicat ID can connect to only one Navicat. If you sign in your Navicat ID in another Navicat, you will be

signed out from the current Navicat.

Migration / Upgrade

Migrate Navicat to a new computer
1. In Navicat, choose File -> Export Connections. The exported file (.ncx) contains all your connection settings.
2. Backup the exported file (.ncx).
3. In Navicat, choose Navicat XXX -> Registration.
4. [Perpetual License] Click Deactivate to online deactivate the license key.
5. [Subscription Plan] Click Sign Out to sign out your Navicat ID.
6. Uninstall Navicat from the existing computer.
7. Re-install Navicat in the new computer.

8. Open Navicat and choose File -> Import Connections in the new computer to import the connection settings

(-ncx).

When a new connection is being established, Navicat will create a subfolder under Settings Location. Most files are
stored within this subfolder. To look for the path, control-click the connection and select Edit Connection -> Advanced

-> Settings Location.

Moreover, all your saved profiles are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft

CyberTech/Navicat CC/Navicat Premium/Profiles.
Upgrade Navicat

If you want to upgrade an installed copy of Navicat to the latest release, please choose Navicat XXX -> Check for
Updates to start the Updater. It will automatically check your installed version. If there is a new version, simply follow
the steps in the Updater to upgrade your Navicat. It will replace your previous Navicat and your current settings will

remain unchanged.

Or, you can submit your registered email address on the Customer Center to download the latest version installer.

End-User License Agreement

Note: For the License Agreement of Navicat Cloud service, please click here.

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT
BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN
ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE

13
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INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE
AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE
SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME
BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS,
THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE.
THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD.
HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN.

1. Definitions

"Non-commercial Version" means a version of the Software, so identified, for use by i) the individual who is a
natural person and not a corporation, company, partnership or association or other entity or organization (ii) the
individual who is a student, faculty or staff member at an educational institution, and (iii) staff of a non-profit
organization or charity organization only. For purposes of this definition, "educational institution" means a
public or private school, college, university and other post secondary educational establishment. A non-profit
organization is an organization whose primary objective is to support an issue or matter of private interest or
public concern for non-commercial purposes.

"Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review and
evaluate the Software, only.

"PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any.

"Software" means only the PremiumSoft software program(s) and third party software programs, in each case,
supplied by PremiumSoft herewith, and corresponding documentation, associated media, printed materials,
and online or electronic documentation.

"Unregistered version”, "Trial version" or "Demo version" means an unregistered copy of the SOFTWARE
("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation purposes for a period of
fourteen (14) days following the initial installation of the UNREGISTERED SOFTWARE. At the end of the trial
period ("TRIAL PERIOD"), the USER must either register the SOFTWARE or remove it from his system. The
UNREGISTERED SOFTWARE may be freely copied and distributed to other users for their evaluation.

"Navicat Essentials" means a version of the Software, so identified, to be used for commercial purpose.

2. License Grants

The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA:

a.

Subject to Section 2(b), you may install and use the Software on a single computer; OR install and store the
Software on a storage device, such as a network server, used only to install the Software on your other
computers over an internal network, provided you have a license for each separate computer on which the
Software is installed and run. Except as otherwise provided in Section 2(b), a license for the Software may not
be shared, installed or used concurrently on different computers.

In addition to the single copy of the Software permitted in Section 2(a), the primary user of the computer on
which the Software is installed may make a second copy of the Software and install it on either a portable

computer or a computer located at his or her home for his or her exclusive use, provided that:
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A. the second copy of the Software on the portable or home computer (i) is not used at the same time as
the copy of the Software on the primary computer and (i) is used by the primary user solely as allowed
for such version or edition (such as for educational use only),

B. the second copy of the Software is not installed or used after the time such user is no longer the
primary user of the primary computer on which the Software is installed.

c. Inthe event the Software is distributed along with other PremiumSoft software products as part of a suite of
products (collectively, the "Studio"), the license of the Studio is licensed as a single product and none of the
products in the Studio, including the Software, may be separated for installation or use on more than one
computer.

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You must
reproduce on any such copy all copyright notices and any other proprietary legends on the original copy of the
Software. You may not sell or transfer any copy of the Software made for backup purposes.

e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at any time,
upon reasonable notice. In the event that such audit reveals any use of the Software by you other than in full
compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all reasonable expenses
related to such audit in addition to any other liabilities you may incur as a result of such non-compliance.

f.  Your license rights under this EULA are non-exclusive.

3. License Restrictions

a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or electronically
transfer the Software from one computer to another or over a network.

b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer,
disassemble, or otherwise reduce the Software to a human-perceivable form.

c. Unless otherwise provided herein, you may not rent, lease, or sublicense the Software.

d. Other than with respect to a Trial / Demo Version, Non-commercial Lite Version or a Not For Resale Version of
the Software, you may permanently transfer all of your rights under this EULA only as part of a sale or transfer,
provided you retain no copies, you transfer all of the Software (including all component parts, the media and
printed materials, any upgrades, this EULA, the serial numbers, and, if applicable, all other software products
provided together with the Software), and the recipient agrees to the terms of this EULA. If the Software is an
upgrade, any transfer must include all prior versions of the Software from which you are upgrading. If the copy
of the Software is licensed as part of the whole Studio (as defined above), the Software shall be transferred
only with and as part of the sale or transfer of the whole Studio, and not separately. You may retain no copies
of the Software. You may not sell or transfer any Trial / Demo Version, Non-commercial Lite Version or Not For
Resale Version of the Software.

e. Unless otherwise provided herein, you may not modify the Software or create derivative works based upon the
Software.

f.  Non-commercial Versions of the Software may not be used for, or distributed to any party for, any commercial
purpose.

g. Unless otherwise provided herein, you shall not

A. inthe aggregate, install or use more than one copy of the Trial / Demo Version and Non-commercial

Lite Version of the Software,
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download the Trial / Demo Version and Non-commercial Lite Version of the Software under more than
one username,

alter the contents of a hard drive or computer system to enable the use of the Trial / Demo Version of
the Software for an aggregate period in excess of the trial period for one license to such Trial / Demo
Version,

disclose the results of software performance benchmarks obtained using the Trial / Demo Version or
Non-commercial Lite Version to any third party without PremiumSoft prior written consent, or

use the Trial / Demo Version of the Software for a purpose other than the sole purpose of determining
whether to purchase a license to a commercial or education version of the software; provided, however,
notwithstanding the foregoing, you are strictly prohibited from installing or using the Trial / Demo

Version or Non-commercial Lite Version of the Software for any commercial training purpose.

h. You may only use the Not for Resale Version of the Software to review and evaluate the Software.

i.  You may receive the Software in more than one medium but you shall only install or use one medium.

Regardless of the number of media you receive, you may use only the medium that is appropriate for the

server or computer on which the Software is to be installed.

j- You may receive the Software in more than one platform but you shall only install or use one platform.

k. You shall not use the Software to develop any application having the same primary function as the Software.

I.  Inthe event that you fail to comply with this EULA, PremiumSoft may terminate the license and you must

destroy all copies of the Software (with all other rights of both parties and all other provisions of this EULA

surviving any such termination).

m. This program may include Oracle Instant Client (OCI). You agree that you shall

1.
2.

4. Upgrades

not use of the Oracle Instant Client to the business operations;
not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual or
entity;

a. make the Programs available in any manner to any third party for use in the third party's

business operations; and

b. title to the Programs from passing to the end user or any other party;
not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the
Programs except for a sufficient number of copies of each Program for your licensed use and one copy
of each Program media;
discontinue use and destroy or return to all copies of the Oracle Instant Client and documentation after
termination of the Agreement;
not pubish any results of benchmark tests run on the Programs;
comply fully with all relevant export laws and regulations of the United States and other applicable
export and import laws to assure that neither the Oracle Instant Client, nor any direct product thereof,
are exported, directly or indirectly, in violation of applicable laws;

allow PremiumSoft to audit your use of the Oracle Instant Client;

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license

exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your
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earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person or

entity unless such transfer is pursuant to Section 3.

5. Ownership

The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, title
and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent work and
as an underlying work serving as a basis for any application you may develop), and all copies thereof. All rights not

specifically granted in this EULA, including Federal and International Copyrights, are reserved by PremiumSoft and its

suppliers.

6. LIMITED WARRANTY AND DISCLAIMER

a. Except with respect to Trial / Demo Version, Non-commercial Lite Version and Not For Resale Version of the
Software, PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as evidenced by
a copy of your receipt): the physical media on which the Software is furnished will be free from defects in
materials and workmanship under normal use. The Software is provided "as is". PremiumSoft makes no
warranties, express or implied, arising from course of dealing or usage of trade, or statutory, as to any matter
whatsoever.

b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version,
Non-commercial Lite version and the Not for Resale version of the Software. Trial / Demo version,
Non-commercial Lite version and the Not for Resale version of the Software are provided "as is".

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo version,
Non-commercial Lite version and Not for Resale version, PremiumSoft and its suppliers disclaim all other
warranties and representations, whether express, implied, or otherwise, including the warranties of
merchantability or fithess for a particular purpose. Also, there is no warranty of non-infringement and title or
quiet enjoyment. PremiumSoft does not warrant that the Software is error-free or will operate without
interruption. The Software is not designed, intended or licensed for use in hazardous environments requiring
fail-safe controls, including without limitation, the design, construction, maintenance or operation of nuclear
facilities, aircraft navigation or communication systems, air traffic control, and life support or weapons systems.
PremiumSoft specifically disclaims any express or implied warranty of fithess for such purposes.

d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in duration
to thirty (30) days from the date of delivery.

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or employees

shall create a warranty or in any way increase the scope of ANY warranty PROVIDED HEREIN.

7. LIMITATION OF LIABILITY

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental,
punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or access
data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability to use, the
Software and based on any theory of liability including breach of contract, breach of warranty,

tort (including negligence), product liability or otherwise, even if PremiumSoft or its representatives have been advised

of the possibility of such damages.
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8. Third Party Software

The Software may contain third party software which requires notices and/or additional terms and conditions. By

accepting this EULA, you are also accepting the additional terms and conditions of the third party software.

9. General

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA.

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and
supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that any
varying or additional terms contained in any purchase order or other written notification or document issued by you in
relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to exercise any of
its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those rights or of the

breach.

If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision will
be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full force and

effect.

10. Basis of Bargain

The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of the
agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an economic
basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the benefit of

PremiumSoft's licensors.

11. Term

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA.

This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to

comply with any term of this License.

"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or statutory,
as to any matter whatsoever. In particular, any and all warranties or merchantability, fithess for a particular purpose or

non-infringement of third party rights are expressly excluded.

12. Governing Law

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive jurisdiction

and venue sitting in Hong Kong to resolve any disputes arising under this EULA.

Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If you

desire to contact the Licensor for any other reason, please contact support@navicat.com.
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PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of PremiumSoft
CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, product names and
logos may be the trademarks or registered trademarks of their respective owners. You may not remove or alter any
trademark, trade names, product names, logo, copyright or other proprietary notices, legends, symbols or labels in the
Software. This EULA does not authorize you to use PremiumSoft or its licensors names or any of their respective

trademarks.
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Chapter 2 - User Interface

Main Window

The Main Window consists of several toolbars and panes for you to work on connections, database objects and

advanced tools.

Hint: Navicat has added support for the system-wide dark mode.
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{l:' Main Toolbar

The Main Toolbar allows you to access basic objects and features, such as connections, users, tables, collections,

Index Length
49152

Check Time

backup, automation and more. If the Main Toolbar is hidden, choose View -> Show Toolbar from the menu bar.

@ Navigation Pane

The Navigation Pane is the basic way to navigate with connections, databases and database objects. If the Navigation

Pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane from the menu bar.

@ Tab Bar

The Tab Bar allows you to switch among the tabbed windows on the Object Pane. You can choose to always display
pop-ups on a new tab, or to always display them in a new window. If you have multiple tabs open, you can use
COMMAND-{ or COMMAND-} to easily switch to other tabs. Control-click a tab to add it to favorite list or startup list.

See also Preferences.

@ Object Toolbar
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The Object Toolbar provides other controls that you can use to manipulate the objects.
® Object Pane

The Object Pane displays a list of objects (such as tables, collections, views, queries) and the tabbed window forms.

Use the ¥ List, = Detail and # ER Diagram buttons to change the view of the Objects tab.
(&) Information Pane

The Information Pane shows the detailed object information, project activities, the DDL of database objects, object
dependencies, membership of users/roles and preview. If the Information Pane is hidden, choose View -> Information

Pane -> Show Information Pane from the menu bar.
(7) status Bar

The Status Bar displays the current window's status information. To view or hide the Status Bar, choose View -> Show

Status Bar from the menu bar.

Navigation Pane

The Navigation pane employs tree structure which allows you to take action upon the database and their objects
through their pop-up menus quickly and easily. If the Show objects under schema in navigation pane option is
checked at the Preferences window, all database objects are also displayed in the pane. To connect to a database or

schema, simply double-click it in the pane.

After logged in the Navicat Cloud feature, the Navigation pane will be divided into Navicat Cloud and My Connections

sections.

¥ 4 Navicat Cloud
» €3 Head Office
v €2 Project MH-0015
L E Development Servers
> m Development 03
Development 01
» [ Production Servers
v €2 Project DT-0052
» Og Team A
» [g TeamB
v [@ Production Server
» & HR
o IX
& 5YS
v &% My Connections
m Amazon RDS for MySQL
» 9 MysaL
m Amazon Redshift
» 3 PostgresaL
E Oracle
[ saLite
> SQL Server
» 2 MariaDB

8 Q

You can filter the tree by typing a search string in the Search text box. To show the opened objects only, click the $

button or choose View -> Navigation Pane -> Show Only Active Objects from the menu bar.
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If you want to hide the group structure in the Navigation pane, choose View -> Navigation Pane -> Flatten

Connection.

If the Navigation pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane.

Object Pane

In the Objects tab, you can use the List, Detail and ¥ ER Diagram buttons to change the object view.

If you want to hide the group structure in List view or Details view, choose View -> Flatten Object List from the menu
bar.
List View

By default, Navicat uses the List view. It only shows the names of objects.

Detail View

Detail view shows the name and several properties of objects in columns. To change the display columns of properties,
choose View -> Choose Columns from the menu bar and choose display columns for different objects from the

pop-up window.

ER Diagram View (Available only in Non-Essentials Edition)

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server and MariaDB. Only tables provide ER

Diagram view.

An ER diagram will be generated automatically if the selected database/schema contains tables. ER diagram files are

stored under Settings Location.

Objects
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(1) Diagram Canvas

Display table fields and relationships between tables in a database/schema graphically. You can add, edit or delete

relations between tables, add or delete vertices on a relation line, and also change the color of a table.
Add a Foreigh Key

Click —¢ from the object toolbar. Drag and drop a field from the child table to the parent table.

Edit or Delete a Foreign Key

Control-click a relation line and select Design Relation or Delete Relation from the pop-up menu.
Add or Delete a Vertex

Select a relation line or a vertex. Press and hold the SHIFT key and click on the relation line or the vertex.
Change Table Color

Control-click a table and pick a Color from the pop-up menu.

Apply Auto Layout

Control-click on the canvas and select Auto Layout from the pop-up menu.

Change Page Dimension

Control-click on the canvas and select Page Dimension from the pop-up menu. The corresponding paper dimension

will reflect in the Overview pane.

Note: Double-click a table in the ER Diagram view will open the Table Designer, while double-click a table in the List or

Detail view will open the Table Viewer.
(2) overview

To zoom in or zoom out the selected area of the diagram, adjust the slider of the Overview. Same effect can be

achieved with keyboard shortcuts:

Zoom In: [COMMAND-Mousewheel up]
Zoom Out: [COMMAND-Mousewheel down]
Zoom Reset: [COMMAND-0]

® Object Toolbar

{‘:I\.

Switch to hand mode for moving the diagram. Or, you can press and hold the SPACE key, then move the diagram.
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—E

Add a relation between two table fields. Click this button, and then drag and drop a field from the child table to the

parent table.

Information Pane

The Information Pane shows the detailed object information, project activities, the DDL of database objects, object

dependencies, membership of users/roles and preview. If the Information Pane is hidden, choose View -> Information

Pane -> Show Information Pane from the menu bar.

You can select any connections, objects or projects, and then select the corresponding buttons on the Information

Pane.

Button Description

@ General - Show the general information of the object/project.

L0 Preview - Show the SQL statements in the query.

DDL - Show the DDL statements of the object.

. Using - Show the objects that the selected object depends on.

Objects - Show the objects in the tablespace.
Member Of - Show the roles that the user or the role assigned to.

| Used By - Show the objects that depend on the selected object.
Members - Show the members of the role.

() Code Snippet - Show all built-in and custom code snippets.
(Available only in Non-Essentials Edition)

= & Identifiers - Show all available tables, collections, views or fields in the selected
database or schema.

o Privileges - Show the privileges granted to the user.

@ Project - Show the project members and the project activities done by the
members. Click + to add members to the project.

& Type Color - Set the color of particular types for highlighting cells in Grid View.
(Available only for MongoDB)
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Chapter 3 - Navicat Cloud
About Navicat Cloud

Navicat Cloud provides a cloud service for synchronizing connections, queries, model files and virtual group
information from Navicat, other Navicat family members, different machines and different platforms. All the Navicat
Cloud objects are located under different projects. You can share the project to other Navicat Cloud accounts for

collaboration.

Navicat Cloud could not connect and access your databases. By which it means, it could only store your connection
settings, queries, model files, and virtual group; your database passwords and data (e.g. tables, views, etc) will not be

stored to Navicat Cloud.

Note: PremiumSoft will keep all synchronized files strictly confidential, and all employees are prohibited from

viewing/accessing content of files you may store in your Navicat Cloud account.
Create a new account
1. Inthe main window, click Sign In and click Create Navicat ID.

2. Enter the required information and click the Sign Up button. A verification email will send to your emalil

address.
3. Click the link in the email to verify the new account.
Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center.
Sign in Navicat Cloud
1. Inthe main window, click Sign In and enter your Navicat ID and Password.
2. Click the Sign In button.

3. If you enabled two-step verification in Navicat Cloud Portal site, a code will be sent to your phone via your

mobile app. Enter the received code to sign in.

Sign out Navicat Cloud

1. In the main window, control-click Navicat Cloud and select Close All Connections to close all connections

under Navicat Cloud.
2. Click your avatar on the toolbar.

3. Click your email in the Navicat Cloud window and select Sign Out.
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Manage Navicat Cloud

View the cloud usage

1. Inthe main window, click your avatar on the toolbar.

2. Your cloud usage and current plan will be shown in the Navicat Cloud window.
Note: A connection, a query, a model or a virtual group counts for one unit.
Change your avatar

1. Inthe main window, click your avatar on the toolbar.

2. Click the avatar in the Navicat Cloud window.

3. Choose an image file.

Manage your Navicat Cloud account

1. Inthe main window, click your avatar on the toolbar.

2. Click your email in the Navicat Cloud window and select Manage Account.

3. A browser will open with Navicat Cloud Portal site.

Upgrade the Navicat Cloud plan

1. Inthe main window, click your avatar on the toolbar.

2. Click Upgrade in the Navicat Cloud window.

3. A browser will open with Navicat Cloud Portal site.

Create a project
1. Select Navicat Cloud in the Navigation pane.
2. Control-click it and select New Project.

Add members to a project

1. Select a project in the Navigation pane.

2. Control-click it and select Collaborate with.

3. Click Add Members.

4. Enter the members' Navicat ID.
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5. Select the member role.

6. Click Add.
Member Roles Privileges
Owner Read Obijects, Write Objects, Manage Members and Delete Project
Admin Read Obijects, Write Objects and Manage Members
Member Read Objects and Write Objects
Guest Read Objects

Note: Each time can add up to 10 members. Use comma or enter to separate the members in the edit box.
Manage members in a project
1. Select a project in the Navigation pane.
2. Control-click it and select Collaborate with.
3. Click Apply after changes.
Note: If you are the Owner or Admin, you can click the x button to remove the member.
Rename a project
1. Select a project in the Navigation pane.
2. Control-click it and select Rename.
3. Enter the project name.
Quit a project
1. Select a project in the Navigation pane.
2. Control-click it and select Quit Project.
Delete a project
1. Select a project in the Navigation pane.
2. Control-click it and select Delete Project.
Move/copy a connection to a project
1. Control-click a connection under My Connections and select Move Connection To or Copy Connection To.
2. Select an existing project or create a new project.

3. The connection will move or copy to Navicat Cloud. And, all its query files and virtual groups will store in

Navicat Cloud.
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Move/copy a connection to My Connections

1. Control-click a connection under Navicat Cloud and select Move Connection To or Copy Connection To ->

My Connections.

2. The connection will move or copy to My Connections. And, all its query files and virtual groups will store in the

local machine.
Move/copy a model to Navicat Cloud
1. Select a model file under My Connections.
2. Drag and drop it to a project in Navicat Cloud.
Move/copy a model to My Connections
1. Select a model file in a project under Navicat Cloud.

2. Drag and drop it to My Connections.
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Chapter 4 - Connection

About Connection

To start working with your server in Navicat, you should first establish a connection or several connections using the
Connection window. If you are new to the server or ‘Net in general' and are not quite sure how things work, you may

want to look at:
*  MySQL User Manual
* Oracle Database Documentation
* PostgreSQL User Manual
e SQLite User Manual
e SQL Server MSDN Library
* MariaDB Documentation
* MongoDB Manual

. . 5 . . .
To create a new connection, click #e Connection and select your server type. Then, enter the necessary information
in the Connection window.

Note: Navicat authorizes you to make connection to remote servers running on different platforms (i.e. Windows,

macOS, Linux and UNIX), and supports PAM and GSSAPI authentication.

You can edit the connection properties by control-click the connection and select Edit Connection.

Navicat Cloud

To copy or move a connection between My Connections and Navicat Cloud, control-click the connection and select

Copy Connection To or Move Connection To.

Flush MySQL/MariaDB Connection

To clear or reload various internal caches, flush tables, or acquire locks, control-click your connection in the Navigation
pane and select Flush and choose the flush option. You must have the RELOAD privilege to use this feature.

Manage Azure SQL Database Firewall Rules

You cannot connect to Azure SQL Database until you have granted your client IP access. To access Azure SQL
Database from your computer, ensure that your firewall allows outgoing TCP communication on TCP port 1433. You

must have at least one firewall rule before you can connection to Azure SQL Database.

To manage the Firewall Rule settings, control-click your Azure SQL Database connection in the Navigation pane and

select SQL Azure Firewall Rules. Add a new rule by providing an IP address range.
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Testing Account

Navicat provides evaluated accounts for testing purpose.
MySQL

e Host: serverl.navicat.com

e Port: 4406

* User Name: navicat

* Password: testnavicat
PostgreSQL

* Host: serverl.navicat.com

e Port: 5432

e [nitial Database: HR

* User Name: navicat

¢ Password: testnavicat

General Settings

RDBMS

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database
login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server,

Secure Tunneling Protocol (SSH) / HTTP is another solution.
Note: The following options depend on the connection server type and sort in ascending order.
Add To

After you logged in the Navicat Cloud feature, you can choose to save the connection to My Connections or a project in

Navicat Cloud.

Authentication

SQL Server Use login records to validate the connection. Users must provide their server login: User
Authentication Name and Password.

Windows When a user connects through a Windows user account, SQL Server validates the
Authentication account name and password using the Windows principal token in the operating system.

Connection Name
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Enter a friendly name to best describe your connection.

Connection Type

Basic In Basic mode, it connects to Oracle through the Oracle Call Interface (OCI). Enter the
Host and Port. Set the Service Name/SID which the user connects when making

connection. Select the corresponding radio button.

TNS In TNS mode, it connects to Oracle server using an alias entry from a tnsnames.ora file

through the Oracle Call Interface (OCI). User needs to provide the Net Service Name.

OCl is an application programming interface that allows an application developer to use a third-generation language's
native procedure or function calls to access the Oracle database server and control all phases of SQL statement
execution. OCl is a library of standard database access and retrieval functions in the form of a dynamic-link library. See

also: Environments

Database File

Specify the initial database file. If the HTTP Tunnel is enabled, you need to enter an absolute file path of the database

file in your web server.

Endpoint

The Endpoint for connecting to the Amazon Web Services instance.

Host

A host name where the database is situated or the IP address of the server.

Initial Database

Set the initial database which user connects when making connection.

OS authentication

Use OS user login credentials to authenticate database users.

Password

Password for connecting to the database server.

Port

A TCP/IP port for connecting to the database server.

Role

Indicate that the database user is connecting with either the Default, SYSOPER or SYSDBA system privilege.

Sync User Name with Navicat Cloud
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When editing a connection in Navicat Cloud, you can choose to synchronize the user name.

Type
Existing Database File Connect to an existing database in the Database File.
New SQLite 3 Create a new SQLite 3 database in the Database File.
New SQLite 2 Create a new SQLite 2 database in the Database File.
User Name

User name for connecting to the database server.

MongoDB

To successfully establish a new connection to local/remote server - no matter via SSL or SSH, set the database login
information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server,

Secure Tunneling Protocol (SSH) is another solution.
Connection Name

Enter a friendly name to best describe your connection.
Add To

After you logged in the Navicat Cloud feature, you can choose to save the connection to My Connections or a project in

Navicat Cloud.

Connection

The type of your MongoDB server: Standalone, Shard Cluster or Replica Set.
SRV record

Check this option to connect the server using an SRV Record.

Host

A host name, IP address, or UNIX domain socket of the server.

Port

A TCP/IP port for connecting to the server.

Member

Add or remove the members of replica set or the instances of sharded cluster to the connection.
Read Preference

Choose the replica set read preference for this connection.
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Replica Set

The name of the replica set.

Authentication

Choose the authentication mechanism that MongoDB will use to authenticate the connection.

None No authentication.

Password Specify the Authentication Database name associated with the User Name
and Password.

LDAP Specify the User Name and Password.

Kerberos Set the Kerberos Service Name and the user Principal. Enable Use
canonicalized host name if you want the Kerberos service canonicalizes host

name.

X.509 x.509 certificate authentication.

Use MongoDB URI

You can also use a MongoDB URI to connect your MongoDB server. Simply click the URI button and paste the URI.

Navicat will automatically fill out the options in the General, SSL and SSH tabs.

SSL Settings

Secure Sockets Layer(SSL) is a protocol for transmitting private documents via the Internet. To get a secure

connection, the first thing you need to do is to install OpenSSL Library and download Database Source.
Note: Available only for MySQL, PostgreSQL, MariaDB and MongoDB. Support from PostgreSQL 8.4 or later.
MySQL and MariaDB Connections

To provide authentication details, enable Use authentication and fill in the required information:

Client Key

The SSL key file in PEM format to use for establishing a secure connection.

Client Certificate

The SSL certificate file in PEM format to use for establishing a secure connection.

CA Certificate

The path to a file in PEM format that contains a list of trusted SSL certificate authorities.

Verify server certificate against CA

Check the server's Common Name value in the certificate that the server sends to the client.
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Specified Cipher

A list of permissible ciphers to use for SSL encryption.

PostgreSQL Connection

Choose the SSL Mode:

allow First try a non-SSL connection; if that fails, try an SSL connection.

prefer First try an SSL connection; if that fails, try a non-SSL connection.

require Only try an SSL connection.

verify-ca Only try an SSL connection, and verify that the server certificate is issued by a
trusted CA.

verify-full Only try an SSL connection, verify that the server certificate is issued by a
trusted CA and that the server hostname matches that in the certificate.

To provide authentication details, enable Use authentication and fill in the required information:

Client Key

The path of the client private key.

Client Certificate

The path of the client certificate.

Root Certificate

The path of the trusted certificate authorities.

Certificate Revocation List

The file path of the SSL certificate revocation list (CRL).

MongoDB Connection

To provide authentication details, enable Use authentication and fill in the required information:

Client Key

The SSL key file in PEM format to use for establishing a secure connection.

Client Key Password

The password of the key file.

Weak certificate validation

Check this option if your MongoDB server allows weak certificate validation.
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CA Certificate

The path to a file in PEM format that contains a list of trusted SSL certificate authorities.
Certificate Revocation List

The file path of the SSL certificate revocation list (CRL).

Allow invalid host names

Check this option to allow invalid hostnames in SSL certificates.

SSH Settings

Secure SHell (SSH) is a program to log in into another computer over a network, execute commands on a remote
server, and move files from one machine to another. It provides strong authentication and secure encrypted
communications between two hosts, known as SSH Port Forwarding (Tunneling), over an insecure network.

Typically, it is employed as an encrypted version of Telnet.

In a Telnet session, all communications, including username and password, are transmitted in plain-text, allowing
anyone to listen-in on your session and steal passwords and other information. Such sessions are also susceptible to
session hijacking, where a malicious user takes over your session once you have authenticated. SSH serves to prevent

such vulnerabilities and allows you to access a remote server's shell without compromising security.
Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server, MariaDB and MongoDB.

Please make sure that the parameter - "AllowTcpForwarding" in the Linux server must be set to value "yes", otherwise,
the SSH port forwarding will be disabled. To look for the path: /etc/ssh/sshd_config. By default, the SSH port forwarding

should be enabled. Please double check the value settings.

Even the server support SSH tunnel, however, if the port forwarding being disabled, Navicat cannot connect via SSH
Port 22.

Host
A host where SSH server is activated.

Note: The host name in the General tab should be set relatively to the SSH server which provided by your database

hosting company.

Port

A port where SSH server is activated, by default it is 22.
User Name

A user on SSH server machine. (It is not a user of database server.)
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Sync User Name with Navicat Cloud

When editing a connection in Navicat Cloud, you can choose to synchronize the user name.

Authentication Method

Password Provide the SSH server user Password.

Public Key Private Key
It is used together with your public key. The private key should be readable only by you.
Passphrase

A passphrase is exactly like a password, except that it applies to the keys you are

generating and not an account.

Use compression

Request compression of all data (including stdin, stdout, stderr, and data for forwarded X11 and TCP connections). The
compression algorithm is the same used by gzip(1), and the "level" can be controlled by the CompressionLevel option

for protocol version 1.

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select

the HTTP Tunnel and vice versa.

HTTP Settings

HTTP Tunneling is a method for connecting to a server that uses the same protocol (http://) and the same port (port 80)
as a web server does. It is used while your ISPs do not allow direct connections, but allows establishing HTTP

connections.
Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB.

Uploading the Tunneling Script

To use this connection method, first thing you need to do is to upload the tunneling script to the web server where your

server is located.

Note: Click the Export Tunnel Script button to extract the script file, ntunnel_mysql.php (for both MySQL and
MariaDB), ntunnel_pgsql.php or ntunnel_sqlite.php.

Setting up HTTP Tunnel
The following instruction guides you through the process of configuring a HTTP connection.
1. Selectthe HTTP tab and enable Use HTTP tunnel.

2. Enter URL of the tunneling script.

e.g. http://www.navicat.com/ntunnel_mysqgl.php
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3. If the tunneling script is hosted in a password protected server, you can provide the required authentication

details.

4. If your server installed a Web Application Firewall, you can check the Encode outgoing query with base64

option.
5. If you have to access internet over a proxy server, click the Proxy Settings button and provide the details.

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select

the HTTP Tunnel and vice versa.

Advanced Settings

Note: The following options depend on the connection server type and sort in ascending order.
Auto connect

Open the connection at application startup automatically.

Client Character Set

Choose the session client character set used in Navicat.

Encoding

Choose a codepage for converting data to display in Navicat Ul.

Encrypt

Enable this option and provide Password when connecting to an encrypted SQLite database.
Keepalive interval (sec)

Keep the connection with the server alive by pinging it. You can set the period between pings in the edit box.
Limit connection sessions

Specify the maximum number of concurrent connections that the server allows.

Settings Location

When a new connection is being established, Navicat will create a subfolder under the Settings Location. Most files are

stored within this subfolder:

File in Settings Location Server Type File Extension
Backup MySQL, PostgreSQL, SQLite and .nb3

MariaDB
Backup Profile MySQL .nbakmysq|
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PostgreSQL .nbakpgsq|
SQLite .nbaksqlite
SQL Server .nbakmssq|l
MariaDB .nbakmariadb
Data Pump Export Profile Oracle .nbakora
ER Diagram File MySQL, Oracle, PostgreSQL, .ned
SQLite, SQL Server and MariaDB
Export Materialized View Oracle .nexpmora
Profile PostgreSQL .nexpmpgsql
Export Query Result Profile | MySQL .nexpgmysq|
Oracle .nexpqgora
PostgreSQL .nexpgpgsql
SQLite .nexpgsqlite
SQL Server .nexpgmssq|
MariaDB .nexpgmariadb
MongoDB .nexpgmongodb
Export Table/Collection MySQL .nexptmysq|l
Profile Oracle .nexptora
PostgreSQL .nexptpgsql
SQLite .nexptsqlite
SQL Server .nexptmssql
MariaDB .nexptmariadb
MongoDB .nexptmongodb
Export View Result Profile MySQL .nexpvmysq|
Oracle .nexpvora
PostgreSQL .nexpvpgsql
SQLite .nexpvsqlite
SQL Server .nexpvmssq|
MariaDB .nexpvmariadb
MongoDB .nexpvmongodb
Import Table/Collection MySQL .nimpmysq|l
Profile Oracle .nimpora
PostgreSQL .nimppgsq|
SQLite .nimpsqlite
SQL Server .nimpmssq|!
MariaDB .nimpmariadb
MongoDB .nimpmongodb
MapReduce MongoDB .mapreduce
Query MySQL, Oracle, PostgreSQL, .sql
SQLite, SQL Server and MariaDB
MongoDB Js

38




Schema Analysis MongoDB .nsatmongodb

TDS Version
Choose the TDS protocol version supported by your server if the connection runs into an incompatibility.
Use compression

Use compression protocol. It is used if both client and server support zlib compression, and the client requests

compression.
Use socket file

Use socket file for localhost connection.

Databases Settings

MySQL, Oracle, PostgreSQL, SQL Server, MariaDB, MongoDB

In the Databases tab, you can set which databases will be shown in the Navigation pane when connecting to your
server. It is not obligatory. To start working with custom database settings, check Use custom database list. Then,
check the preferable databases in the Name column. If you want Navicat automatically open the databases at

connection, check the Auto Open box.
Add a hidden database to the list
1. Click the + button.
2. Enter the database name.
3. Check the newly added database in the database list.
Remove a database from the list
1. Select the database in the database list.
2. Click the - button.
Note: The database will be just removed from the database list box, it will still exist in the server.

SQLite

In the Databases tab, you can attach SQLite database files to the connection. Click the + button and enter the

information:
Option Description
Database Name Enter the database name which displays in Navicat.
Database File Choose the file path of a database file.
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Encrypt

Check this option and provide the Password if the database file is encrypted.

To detach a database, select it from the list and click the - button.
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Chapter 5 - Server Objects
About Server Objects

Navicat provides powerful tools to manage server objects, such as databases, tables, views, functions, etc.

Some server objects may have been hidden by Navicat. These objects include system databases, system tables and

so on. To show the hidden items, choose View -> Show Hidden Items from the menu bar.
Note: Before working with the server objects in Navicat, you should establish the connection first.

In object designers, you can preview the necessary SQL statements or scripts for creating or editing the object on the
SQL Preview or Script Preview tab. For some database or schema objects, you can use the bottom drop-down menu

to show the SQL or scripts which will be run when choosing Save or Save As from the File menu.

MySQL / MariaDB

Databases

To start working with the server objects, you should create and open a connection. If the server is empty, you need to

create a new database.
Create a new database
1. Inthe Navigation pane, control-click your connection and select New Database.
2. Enter the database properties in the pop-up window.
Edit an existing database
1. Inthe Navigation pane, control-click a database and select Edit Database.
2. Edit the database properties in the pop-up window.

Note: MySQL does not support renaming database through its interface at this moment. Access the directory in which
databases being stored. By default, all databases store within a directory called data under MySQL Installation folder.

For example: /usr/local/mysql5/data. You must stop MySQL before you can rename the database.

Tables

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their

intersections are fields. In the main window, click ™ Table to open the table object list.

There are two ways to open a table with graphical fields, control-click a table and select:

Option Description

Open Table Navicat loads all your BLOB fields (images) while opening the table.
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Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will
not be loaded until you click on the cell. (It is invisible by default until you hold

down the OPTION key when choosing the pop-up menu.)

You can create a table shortcut by dragging the table out. It provides a convenient way for you to open your table for

entering data directly without activating the Navicat main window.

To empty a table, control-click the selected table and select Empty Table from the pop-up menu. This option is only
applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the
auto-increment value while emptying your table, use Truncate Table.

Table Designer

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields,

indexes, foreign keys, and much more.

In the Fields tab, you can search a field name by choosing Edit -> Find -> Find or pressing COMMAND-F. You can

change the order of a field, simply drag and drop it to the desired location.

Note: The tabs and options in the designer depend on the server type and version.

Table Viewer

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and

Form View. See Data Viewer for details.

Note: Transaction is only available for INNODB tables.

Views

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the

main window, click o View to open the view object list.

You can create a view shortcut by dragging the view out. It provides a convenient way for you to open your view without

activating the Navicat main window.

View Designer

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement
(SELECT statement it implements) in the SQL Editor tab. To customize the view of the editor and find out more
features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you

can choose File -> Import SQL.

Button Description

s Preview the data of the view.

e Show the Query Plan of the view.
[ | Stop the preview process.
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Em Build the view visually. It allows you to create and edit views without knowledge of SQL.

See SQL Builder for details.

AN Format the codes with the Beautify SQL settings in Editor.

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Results ->
Show Below Editor or Show in New Page.
View Viewer

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form

View. See Data Viewer for details.
Note: Transaction is only available for updatable views.

Procedures / Functions

Procedures and functions (stored routines) are supported in MySQL 5.0. A stored routine is a set of SQL statements

that can be stored in the server. In the main window, click J= Function to open the function object list.

Function Wizard

Click s from the object toolbar. Function Wizard will pop up and it allows you to create a function easily.

=

Select the type of the routine: Procedure or Function.

2. Define the parameters. Set the Mode, Name and Type under the corresponding columns.

w

If you create a function, select the Return Type.
4. Select the additional function options.

Hint: Once click the Skip button, you can go to Preferences to enable the function wizard.

Function Designer

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL
statement in the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound
statement written using BEGIN and END. Compound statements can contain declarations, loops, and other control
structure statements. To customize the view of the editor and find out more features for SQL editing, see SQL Editor for

details.

Results

To execute the procedure/function, click P on the toolbar. If the SQL statement is correct, the statement will be
executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error
occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the
procedure/function requires input parameters, the Input Parameters dialog will pop up. Check the Raw Mode option to

pass the inputted values to the procedure/function without quotation marks.
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Note: Navicat supports to return 20 result sets.

Tablespaces

An InnoDB general tablespace is a shared tablespace which can hold multiple tables, and supports all table row
formats. An InnoDB undo tablespace contains undo logs. In MySQL NDB Cluster, tablespace can contain one or more

data files, providing storage space for NDB Cluster Disk Data table. In the main window, click & Others > &

Tablespace to open the tablespace object list.

Tablespace Designer
Tablespace Designer is the basic Navicat tool for working with tablespaces. It allows you to set the table engine,

specify the data file, etc.

Events

An event is a task that run according to a schedule. In the main window, click & Others > @ Event to open the

event object list.

Event Designer

Event Designer is the basic Navicat tool for working with events. You can enter a valid SQL procedure statement in
the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound statement
written using BEGIN and END. Compound statements can contain declarations, loops, and other control structure

statements. To customize the view of the editor and find out more features for SQL editing, see SQL Editor for details.
Maintain Objects
Navicat provides a complete solution for maintaining MySQL / MariaDB objects.

1. Inthe main window, select objects in the Navigation pane or the Objects tab.

2. Control-click the selected objects.

3. Choose Maintain, and then choose a maintain option the from the pop-up menu.

4. Results show in a pop-up window.

Table
Option Description
Analyze Table Analyze and store the key distribution for the table.
Check Table Check the table for errors.
Optimize Table Optimize the table to reduce storage space and improve I/O efficiency.
Repair Table Repair the possibly corrupted table.
Get Rows Count Count the number of rows in the table.
Tablespace
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Option Description

Set Active Mark an InnoDB undo tablespace as active.
Set Inactive Mark an InnoDB undo tablespace as inactive.
Oracle
Schemas

To start working with the server objects, you should create and open a connection. When you create a user account,
you are also implicitly creating a schema for that user. A schema is a logical container for the database objects (such
as tables, views, triggers, and so on) that the user creates. The schema name is the same as the user name, and can

be used to unambiguously refer to objects owned by the user.

Hint: Oracle interprets non-quoted object identifiers as uppercase. In Navicat, all object identifiers will be quoted. That

is, Navicat saves exactly what you have inputted.

Tables

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their

intersections are fields. In the main window, click = Table to open the table object list.

You can create Normal / External / Index Organized tables. To create a new normal table, simply click £ from the

object toolbar. Or, you can click and hold the Es button and choose the table type.

There are two ways to open a table with graphical fields, control-click a table and select:

Option Description

Open Table Navicat loads all your BLOB fields (images) while opening the table.

Open Table (Quick) | Faster performance for opening the graphical table, as BLOB fields (images) will not be
loaded until you click on the cell. (It is invisible by default until you hold down the

OPTION key when choosing the pop-up menu.)

You can create a table shortcut by dragging the table out. It provides a convenient way for you to open your table for

entering data directly without activating the Navicat main window.

To empty a table, control-click the selected table and select Empty Table from the pop-up menu. This option is only
applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the
auto-increment value while emptying your table, use Truncate Table.

Table Designer

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields,

indexes, foreign keys, and much more.

In the Fields tab, you can search a field name by choosing Edit -> Find -> Find or pressing COMMAND-F. You can

change the order of a field when creating new tables, simply drag and drop it to the desired location.
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Note: The tabs and options in the designer depend on the server version and the table type.

Table Viewer

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and

Form View. See Data Viewer for details.

Views

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the

main window, click %o View to open the view object list.

You can create a view shortcut by dragging the view out. It provides a convenient way for you to open your view without

activating the Navicat main window.

View Designer

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement
(SELECT statement it implements) in the SQL Editor tab. To customize the view of the editor and find out more
features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you

can choose File -> Import SQL.

Button Description

3 Preview the data of the view.

s Show the Query Plan of the view.

[ | Stop the preview process.

Eg Build the view visually. It allows you to create and edit views without knowledge of SQL.
See SQL Builder for details.

AN Format the codes with the Beautify SQL settings in Editor.

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Results ->

Show Below Editor or Show in New Page.
View Viewer
When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form

View. See Data Viewer for details.

Materialized Views

Materialized Views are schema objects that used to summarize, compute, replicate, and distribute data. In the main

window, click e Materialized View to open the materialized view object list.

You can create a materialized view shortcut by dragging the materialized view out. It provides a convenient way for you

to open your materialized view without activating the Navicat main window.

To refresh a materialized view, control-click it in the Objects tab and select Refresh Materialized View from the pop-up
menu.
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Materialized View Designer

Materialized View Designer is the basic Navicat tool for working with materialized views. You can edit the view
definition as SQL statement (SELECT statement it implements) in the SQL Editor tab. To customize the view of the
editor and find out more features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a

SQL file to the editor, you can choose File -> Import SQL.

Button Description

iz} Preview the data of the materialized view.

s Show the Query Plan of the materialized view.

[ | Stop the preview process.

Eg Build the materialized view visually. It allows you to create and edit materialized views
without knowledge of SQL. See SQL Builder for details.

AN Format the codes with the Beautify SQL settings in Editor.

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Results ->

Show Below Editor or Show in New Page.

Materialized View Viewer

When you open a materialized view, Materialized View Viewer displays data as a grid. Data can be displayed in two

modes: Grid View and Form View. See Data Viewer for details.

Procedures / Functions

Procedures and functions are schema objects that consist a set of SQL statements and stored in the server. In the

main window, click Jo Function to open the function object list.

Function Wizard
Click T from the object toolbar. Function Wizard will pop up and it allows you to create a function easily.
1. Select the type of the routine: Procedure or Function.
2. Define the parameters. Set the Mode, Name, Type Schema and Type under the corresponding columns.
3. If you create a function, select the Return Type.
4. Select the additional function options.
Hint: Once click the Skip button, you can go to Preferences to enable the function wizard.

Function Designer

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL
statement in the Definition tab. To customize the view of the editor and find out more features for SQL editing, see

SQL Editor for details.
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The Code Outline pane displays information about the procedure/function including parameters, code body, etc. If the

Code Outline pane is hidden, choose View -> Code Outline.

Note: Available only in Non-Essentials Edition.

Button Description

C Refresh the code outline.

& Turn mouse over highlight on or off.

= Show the detail view of the code outline.

= Toggle sorting by position.

E= Expand the selected item.

I Collapse the selected item.

Results

To execute the procedure/function, click P on the toolbar. If the SQL statement is correct, the statement will be
executed and, if the statement is supposed to return data, the DBMS Output tab opens with the data returned. If an

error occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the
procedure/function requires input parameters, the Input Parameters dialog will pop up. Check the Raw Mode option to

pass the inputted values to the procedure/function without quotation marks.

Note: Navicat supports to return 20 result sets.

Debug (Available only in Non-Essentials Edition)

You can add/remove breakpoints for debugging by clicking ® inthe grey area beside each statement.

click T on the toolbar to launch the Oracle Debugger. Enter the input parameters if necessary.

Packages

Packages are encapsulated collections of related procedures, stored functions, and other program objects stored
together in the database. An package consists of two parts: a specification and a body. In the main window, click &

Others -> & Package to open the package object list.

Package Designer & Package Body Designer

Package Designer and Package Body Designer are the basic Navicat tools for working with packages. After saving

the package in Package Designer, you can edit its package body by clicking 3

Likewise, you can edit its package specification by clicking & in Package Body Designer.

You can enter a valid SQL statement in the Definition tab. To customize the view of the editor and find out more

features for SQL editing, see SQL Editor for details.

The Code Outline pane displays information about the package/package body including function, procedure,

parameter, code body, etc. If the Code Outline pane is hidden, choose View -> Code Outline.

48



Note: Available only in Non-Essentials Edition.

Button Description

C Refresh the code outline.

& Turn mouse over highlight on or off.

= Show the detail view of the code outline.
1= Toggle sorting by position.

Es Expand the selected item.

=1 Collapse the selected item.

Results

To execute the package, click P on the toolbar. If the SQL statement is correct, the statement will be executed and, if
the statement is supposed to return data, the DBMS Output tab opens with the data returned. If an error occurs while

executing the package, execution stops, the appropriate error message is displayed. If the package requires input

parameters, the Input Parameters dialog will pop up.

Debug (Available only in Non-Essentials Edition)

You can add/remove breakpoints for debugging by clicking ® inthe grey area beside each statement.
click T on the toolbar to launch the Oracle Debugger. Enter the input parameters if necessary.

Recycle Bin

Recycle bin contains dropped tables and any associated objects such as indexes, constraints, nested tables. In the

main window, click Z Others > @ Recycle Bin to open the recycle bin object list.
Restore a table

1. Select atable in the Objects tab.

2. Click T3,
Remove an object

1. Select an object for purging in the Objects tab.

2. Click
3. Confirm deleting in the dialog window.
Remove all objects
1. Control-click anywhere in the Objects tab and select Purge Recycle Bin from the pop-up menu.
2. Confirm deleting in the dialog window.

Remove all objects of any users
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1. Log in a user with SYSDBA privilege.
2. Control-click anywhere in the Objects tab and select Purge DBA Recycle Bin from the pop-up menu.
3. Confirm deleting in the dialog window.

Other Objects

Navicat also allows you to manage other Oracle objects: Database Link, Index, Java, Materialized View Log, Sequence,
Synonym, Trigger, Type, XML Schema, Directory, Public Database Link, Public Synonym and Tablespace. In the main

window, click &L Others and select an object to open the object list.
Maintain Objects
Navicat provides a complete solution for maintaining Oracle objects.
1. Inthe main window, select objects in the Navigation pane or the Objects tab.
2. Control-click the selected objects.
3. Choose Maintain, and then choose a maintain option the from the pop-up menu.

4. Results show in a pop-up window.

Table
Option Description
Enable Table Lock Allow DDL operations on the table.
Disable Table Lock Prevent DDL operations on the table.
Enable Row Movement Allow the database to move a row, thus changing the rowid.
Disable Row Movement Prevent the database from moving a row, thus preventing a change of
rowid.
Shrink Space Shrink space in the table.
Move Relocate data of the table.
Validate Table Structure Verify the integrity of the structure of the table.
Collect Table Statistics Analyze the contents of the table.
View
Option Description
Compile Recompile the view specification or body.
Procedure / Function
Option Description
Compile Recompile the specification or body.
Compile for Debug Recompile the specification or body. Instruct the PL/SQL compiler to
generate and store the code for use by the debugger.
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Index

Option

Description

Rebuild Index

Re-create the index or one of its partitions or subpartitions.

Make Index Unusable

Make the index unusable.

Coalesce Index

Merge the contents of index blocks where possible to free blocks for reuse.

Compute Index Statistics

Compute the statistics of the index.

Java

Option

Description

Compile or Resolve

Resolve the primary Java class schema object.

Set AuthID Current User

Set the invoker rights to AUTHID CURRENT_USER.

Set AuthIlD Definer

Set the invoker rights to AUTHID DEFINER.

Materialized View

Option

Description

Enable Row Movement

Allow the database to move a row, thus changing the rowid.

Disable Row Movement

Prevent the database from moving a row, thus preventing a change of

rowid.
Shrink Space Compact the materialized view segment.
Compile Revalidate the materialized view.

Force Refresh

Refresh the materialized view.

Materialized View Log

Option

Description

Enable Row Movement

Allow the database to move a row, thus changing the rowid.

Disable Row Movement

Prevent the database from moving a row, thus preventing a change of

rowid.

Shrink Space

Compact the materialized view log segments.

Package
Option Description
Compile Recompile the package specification and body.

Compile for Debug

Recompile the package specification and body. Instruct the PL/SQL

compiler to generate and store the code for use by the debugger.

Trigger
Option Description
Compile Recompile the trigger.

Compile for Debug

Recompile the trigger. Instruct the PL/SQL compiler to generate and store

the code for use by the debugger.

Enable Trigger

Enable the trigger.
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Disable Trigger Disable the trigger.
Type
Option Description
Compile Recompile the type specification and body.

Compile for Debug

Recompile the type specification and body. Instruct the PL/SQL compiler

to generate and store the code for use by the debugger.

XML Schema
Option Description
Compile Recompile the already registered XML schema.

Purge XML Schema

Removes the XML schema completely from Oracle XML DB.

Tablespace
Option Description
Read Only Place the tablespace in transition read-only mode.
Read Write Allow write operations on a previously read-only tablespace.
Online Take the tablespace online.
Offline Take the tablespace offline.
Coalesce Combine all contiguous free extents into larger contiguous extents for each
datafile in the tablespace.
Shrink Space Reduce the amount of space the tablespace is taking.

PostgreSQL

Databases & Schemas

To start working with the server objects, you should create and open a connection. If the server is empty, you need to

create a new database and/or a new schema.

Create a new database

1. Inthe Navigation pane, control-click a connection and select New Database.

2. Enter the database properties in the pop-up window.

Edit an existing database

1. Inthe Navigation pane, control-click a database and select Edit Database.

2. Edit the database properties in the pop-up window.

Create a new schema

1. Inthe Navigation pane, control-click a database and select New Schema.
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2. Enter the schema properties in the pop-up window.

Edit an existing schema
1. Inthe Navigation pane, control-click a schema and select Edit Schema.
2. Edit the schema properties in the pop-up window.

Tables

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their

intersections are fields. In the main window, click B Table to open the table object list.

You can create Normal / Foreign / Partitioned tables. To create a new normal table, simply click i) from the object

toolbar. Or, you can click and hold the i) button and choose the table type.

There are two ways to open a table with graphical fields, control-click a table and select:

Option Description

Open Table Navicat loads all your BLOB fields (images) while opening the table.

Open Table (Quick) | Faster performance for opening the graphical table, as BLOB fields (images) will not be
loaded until you click on the cell. (It is invisible by default until you hold down the

OPTION key when choosing the pop-up menu.)

You can create a table shortcut by dragging the table out. It provides a convenient way for you to open your table for

entering data directly without activating the Navicat main window.

To empty a table, control-click the selected table and select Empty Table from the pop-up menu. This option is only
applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the
auto-increment value while emptying your table, use Truncate Table.

Table Designer

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields,

indexes, foreign keys, and much more.
In the Fields tab, you can search a field name by choosing Edit -> Find -> Find or pressing COMMAND-F.
Note: The tabs and options in the designer depend on the server version and the table type.

Table Viewer

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and

Form View. See Data Viewer for details.

Views

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the

main window, click %o View to open the view object list.



You can create a view shortcut by dragging the view out. It provides a convenient way for you to open your view without

activating the Navicat main window.

View Designer

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement
(SELECT statement it implements) in the SQL Editor tab. To customize the view of the editor and find out more
features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you

can choose File -> Import SQL.

Button Description

iz} Preview the data of the view.

s Show the Query Plan of the view.

[ | Stop the preview process.

Eg Build the view visually. It allows you to create and edit views without knowledge
of SQL. See SQL Builder for details.

AN Format the codes with the Beautify SQL settings in Editor.

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Results ->

Show Below Editor or Show in New Page.
View Viewer

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form

View. See Data Viewer for details.

Materialized Views

Materialized Views are schema objects that used to summarize, compute, replicate, and distribute data. In the main

window, click 50 Materialized View to open the materialized view object list.

You can create a materialized view shortcut by dragging the materialized view out. It provides a convenient way for you

to open your materialized view without activating the Navicat main window.

To refresh and completely replace the contents of a materialized view, control-click it in the Objects tab and select

Refresh Materialized View With -> Data or No Data from the pop-up menu.

Materialized View Designer

Materialized View Designer is the basic Navicat tool for working with materialized views. You can edit the view
definition as SQL statement (SELECT statement it implements) in the SQL Editor tab. To customize the view of the
editor and find out more features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a

SQL file to the editor, you can choose File -> Import SQL.

Button Description
s Preview the data of the materialized view.
- Show the Query Plan of the materialized view.
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Stop the preview process.

= |l

Build the materialized view visually. It allows you to create and edit materialized

views without knowledge of SQL. See SQL Builder for details.

i
#

Format the codes with the Beautify SQL settings in Editor.

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Results ->

Show Below Editor or Show in New Page.
Materialized View Viewer

When you open a materialized view, Materialized View Viewer displays data as a grid. Data can be displayed in two

modes: Grid View and Form View. See Data Viewer for details.

Procedures / Functions

Procedures and functions are schema objects that consist a set of SQL statements and stored in the server.

Procedures are supported in PostgreSQL 11. In the main window, click J Function to open the function object list.

Function Wizard
Click Jo from the object toolbar. Function Wizard will pop up and it allows you to create a function easily.

1. Select the type of the routine: Procedure or Function.

2. Define the parameters. Set the Mode, Name, Type Schema, Type and Default Value under the

corresponding columns.

3. If you create a function, select the Return Type.

»

Select the additional function options.

Hint: Once click the Skip button, you can go to Preferences to enable the function wizard.

Function Designer

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL
statement in the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound
statement written using BEGIN and END. To customize the view of the editor and find out more features for SQL

editing, see SQL Editor for details.

Results

To execute the procedure/function, click P on the toolbar. If the SQL statement is correct, the statement will be

executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error
occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the
procedure/function requires input parameters, the Input Parameters dialog will pop up. Check the Raw Mode option to

pass the inputted values to the procedure/function without quotation marks.
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Note: Navicat supports to return 20 result sets.

Debug (Available only in Non-Essentials Edition)

Before debugging PL/pgSQL procedures/functions, you need to install the pldbgapi extension or enable the debugger

plugin manually in the server.

Then, open a PL/pgSQL procedure/function. You can add/remove breakpoints for debugging by clicking ® in the
grey area beside each statement.

click 5 on the toolbar to launch the PostgreSQL Debugger. Enter the input parameters if necessary.

Types

Types register new data types for use in the current database. In the main window, click & others > ¢ Type to
open the type object list.

You can create Base / Composite / Enum / Range types. To create a new base type, simply click “o from the object

toolbar. Or, you can click and hold the & button and choose the type.

Type Designer

Type Designer is the basic Navicat tool for working with types. It allows you to create or edit a type.

Note: The tabs and options in the designer depend on the server version and the type you are chosen.

Foreign Servers

A foreign server typically encapsulates connection information that a foreign-data wrapper uses to access an external

data resource. In the main window, click & others > B Foreign Server to open the foreign server object list.

To install the postgres_fdw extension for accessing data stored in external PostgreSQL servers, you can control-click
anywhere in the foreign server object list and select Install postgres_fdw Extension.
Foreign Server Designer

Foreign Server Designer is the basic Navicat tool for working with foreign servers. It allows you to create or edit a

foreign server.

Other Objects

Navicat also allows you to manage other PostgreSQL objects: Aggregate, Conversion, Domain, Index, Operator,

Operator Class, Sequence, Trigger, Tablespace, Cast and Language. In the main window, click & Others and select

an object to open the object list.

Maintain Objects

Navicat provides a complete solution for maintaining PostgreSQL objects.
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1. Inthe main window, select objects in the Navigation pane or the Objects tab.

2. Control-click the selected objects.

3. Choose Maintain, and then choose a maintain option the from the pop-up menu.

4. Results show in a pop-up window.

Database
Option Description
Allow Users can connect to the database.
Disallow No users can connect to the database.
Analyze Database Collect statistics about the database.
Vacuum Database Garbage-collect and optionally analyze the database.
Reindex Database Recreate all indexes within the database.
Table
Option Description
Analyze Table Collect statistics about the contents of the table.
Vacuum Table Garbage-collect and optionally analyze the table.
Reindex Table Recreate all indexes of the table.

SQL Server

Databases & Schemas

To start working with the server objects, you should create and open a connection. If the server is empty, you need to

create a new database and/or a new schema.

Create a new database
1. Inthe Navigation pane, control-click a connection and select New Database.
2. Enter the database properties in the pop-up window.

Edit an existing database
1. Inthe Navigation pane, control-click a database and select Edit Database.
2. Edit the database properties in the pop-up window.

Create a new schema
1. Inthe Navigation pane, control-click a database and select New Schema.
2. Enter the schema properties in the pop-up window.
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Edit an existing schema
1. Inthe Navigation pane, control-click a schema and select Edit Schema.
2. Edit the schema properties in the pop-up window.

Tables

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their

intersections are fields. In the main window, click B Table to open the table object list.

There are two ways to open a table with graphical fields, control-click a table and select:

Option Description

Open Table Navicat loads all your BLOB fields (images) while opening the table.

Open Table (Quick) | Faster performance for opening the graphical table, as BLOB fields (images) will not

be loaded until you click on the cell. (It is invisible by default until you hold down the

OPTION key when choosing the pop-up menu.)

You can create a table shortcut by dragging the table out. It provides a convenient way for you to open your table for

entering data directly without activating the Navicat main window.

To empty a table, control-click the selected table and select Empty Table from the pop-up menu. This option is only
applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the
auto-increment value while emptying your table, use Truncate Table.

Table Designer

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields,

indexes, foreign keys, and much more.
In the Fields tab, you can search a field name by choosing Edit -> Find -> Find or pressing COMMAND-F.

Note: The tabs and options in the designer depend on the server version.

Table Viewer
When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and

Form View. See Data Viewer for details.

Views

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the

main window, click %o View to open the view object list.

You can create a view shortcut by dragging the view out. It provides a convenient way for you to open your view without

activating the Navicat main window.
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View Designer

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement
(SELECT statement it implements) in the SQL Editor tab. To customize the view of the editor and find out more
features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you

can choose File -> Import SQL.

Button Description

iz} Preview the data of the view.

s Show the Query Plan of the view.

[ | Stop the preview process.

Eg Build the view visually. It allows you to create and edit views without knowledge of
SQL. See SQL Builder for details.

AN Format the codes with the Beautify SQL settings in Editor.

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Results ->

Show Below Editor or Show in New Page.
View Viewer

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form

View. See Data Viewer for details.

Procedures / Functions

Procedures and functions are schema objects that consist a set of SQL statements and stored in the server. In the

main window, click Jw Function to open the function object list.

Function Wizard
Click % from the object toolbar. Function Wizard will pop up and it allows you to create a function easily.

1. Select the type of the routine: Procedure or Function.

2. Define the parameters. Set the Name, Type Schema, Type, Default Value, Output and Read Only under the

corresponding columns.
3. Ifyou create a function, select the Return Type.
4. Select the additional function options.
Hint: Once click the Skip button, you can go to Preferences to enable the function wizard.

Function Designer

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL
statement in the Definition tab. To customize the view of the editor and find out more features for SQL editing, see
SQL Editor for details.
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The Code Outline pane displays information about the procedure/function including parameters, code body, etc. If the

Code Outline pane is hidden, choose View -> Code Outline.

Note: Available only in Non-Essentials Edition.

Button Description

C Refresh the code outline.

& Turn mouse over highlight on or off.

= Show the detail view of the code outline.

= Toggle sorting by position.

Esx Expand the selected item.

z Collapse the selected item.

Results

To execute the procedure/function, click P on the toolbar. If the SQL statement is correct, the statement will be
executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error

occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the
procedure/function requires input parameters, the Input Parameters dialog will pop up. Check the Raw Mode option to

pass the inputted values to the procedure/function without quotation marks.
Note: Navicat supports to return 20 result sets.

Other Objects

Navicat also allows you to manage other SQL Server objects: Index, Synonym, Trigger, Backup Device, Linked Server,
Server Trigger, Assembly, Database Trigger, Partition Function and Partition Scheme. In the main window, click i

Others and select an object to open the object list.
Maintain Objects
Navicat provides a complete solution for maintaining SQL Server objects.
1. Inthe main window, select objects in the Navigation pane or the Objects tab.
2. Control-click the selected objects.
3. Choose Maintain, and then choose a maintain option the from the pop-up menu.

4. Results show in a pop-up window.

Database
Option Description
Read Write Set the database to Read and Write mode.
Read Only Set the database to Read Only mode.
Online Bring the database online.
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Offline Take the database offline.
Emergency Set the database to the Emergency state.
Multi User Set the database to Multi User mode.
Single User Set the database to Single User mode.
Restricted User Set the database to Restricted User mode.
Assembly
Option Description
Set Invisible Set the assembly to not visible.
Set Visible Set the assembly to visible.
Index
Option Description
Rebuild Index Rebuild and enable the index.
Reorganize Index Reorganize the enabled index.
Disable Index Disable the index.

Trigger / Database Trigger / Server Trigger

Option Description
Enable Trigger Enable the trigger.
Disable Trigger Disable the trigger.
SQLite
Databases

To start working with the server objects, you should create and open a connection. The database file set in the General

tab of the Connection window is named as the main database.

Attach a database file

1. Inthe Navigation pane, control-click a connection and select Attach Database.

2. Enter the database properties in the pop-up window.

Detach a database

1. Inthe Navigation pane, control-click an attached database and select Detach Database.

Encrypt main database

1. Inthe Navigation pane, control-click the main database and select Encrypt Database.

2. Enter the password in the pop-up window.
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Decrypt main database
1. Inthe Navigation pane, control-click the main database and select Decrypt Database.
2. Confirm decrypting in the dialog window.
View the sqlite_master table
1. Inthe Navigation pane, control-click a database and select View Master Table.
2. The sqglite_master table opens in Table Viewer.

Tables

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their

intersections are fields. In the main window, click B Table to open the table object list.

You can create a table shortcut by dragging the table out. It provides a convenient way for you to open your table for

entering data directly without activating the Navicat main window.

To empty a table, control-click the selected table and select Empty Table from the pop-up menu.

Table Designer

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields,

indexes, foreign keys, and much more.
In the Fields tab, you can search a field name by choosing Edit -> Find -> Find or pressing COMMAND-F.

Note: The tabs and options in the designer depend on the server version.

Table Viewer

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and

Form View. See Data Viewer for details.

Views

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the

main window, click o View to open the view object list.

You can create a view shortcut by dragging the view out. It provides a convenient way for you to open your view without

activating the Navicat main window.

View Designer

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement

(SELECT statement it implements) in the SQL Editor tab. To customize the view of the editor and find out more
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features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you

can choose File -> Import SQL.

Button Description

8 Preview the data of the view.

Fe Show the Query Plan of the view.

[ | Stop the preview process.

/g Build the view visually. It allows you to create and edit views without knowledge
of SQL. See SQL Builder for details.

=N Format the codes with the Beautify SQL settings in Editor.

Hint: You can choose to show the preview results below the editor or in a new tab by choosing View -> Results ->

Show Below Editor or Show in New Page.
View Viewer

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form

View. See Data Viewer for details.

Other Objects

Navicat also allows you to manage other SQLite objects: Index and Trigger. In the main window, click & Others and
select an object to open the object list.

Maintain Objects
Navicat provides a complete solution for maintaining SQLite objects.
1. Inthe main window, select objects in the Navigation pane or the Objects tab.
2. Control-click the selected objects.
3. Choose Maintain, and then choose a maintain option the from the pop-up menu.

4. Results show in a pop-up window.

Database
Option Description
Analyze Database Collect statistics about the database.
Vacuum Database Rebuild the database file. It only works on the main database.
Reindex Database Delete and recreate all indexes within the database.
Table
Option Description
Analyze Table Collect statistics about the contents of the table.
Reindex Table Delete and recreate all indexes of the table.
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Get Rows Count Count the number of rows in the table.

Index

Option Description

Reindex Delete and recreate the index.

MongoDB

Databases

To start working with the server objects, you should create and open a connection. If the server is empty, you need to

create a new database.
Create a new database
1. Inthe Navigation pane, control-click your connection and select New Database.

2. Enter the database properties in the pop-up window.

Collections

Collections are analogous to relational database tables for storing documents. In the main window, click =
Collection to open the collection object list.

You can create a collection shortcut by dragging the collection out. It provides a convenient way for you to open your

collection for entering data directly without activating the Navicat main window.
To empty a collection, control-click the selected collection and select Empty Collection from the pop-up menu.

Collection Designer

Collection Designer is the basic Navicat tool for working with collections. It allows you to set the collection properties,

indexes, validation, storage engine, and much more.
Note: The tabs and options in the designer depend on the server version.

Collection Viewer

When you open a collection, Collection Viewer displays data as a grid. Data can be displayed in three modes: Grid

View, Tree View and JSON View. See Data Viewer for details.

Views

A view is the result of the applying the specified aggregation pipeline to the source collection or view. In the main

window, click e View to open the view object list.
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You can create a view shortcut by dragging the view out. It provides a convenient way for you to open your view without

activating the Navicat main window.

View Designer

View Designer is the basic Navicat tool for working with views.

Button Description
8 Preview the data of the view.
s Show the Query Plan of the view.

In the Pipeline tab, you can add, insert or delete aggregation pipeline stages. In the Operator column, select an
expression operator. An expression template will be generated in the Expression column, you can modify the
template.

View Viewer

When you open a view, View Viewer displays data as a grid. Data can be displayed in three modes: Grid View, Tree
View and JSON View. See Data Viewer for details.

Functions

You can store JavaScript functions for reuse. In the main window, click f» Function to open the function object list.

Function Designer

Function Designer is the basic Navicat tool for working with functions. You can enter the function definition in the
Definition tab. To customize the view of the editor and find out more features for script editing, see Query Editor for

details.

Results

To execute the function, click P on the toolbar. If the script is correct, a dialog will pop up. Enter input parameters if
necessary and click OK. If the function is supposed to return data, the Result tab opens with the data returned. If an

error occurs while executing the function, execution stops, the appropriate error message is displayed.

Indexes

Navicat allows you to manage MongoDB indexes. In the main window, click ** Index to open the index object list.

MapReduce

Map-Reduce is a data processing paradigm for condensing large volumes of data into useful aggregated results. In the

main window, click == MapReduce to open the map-reduce object list.

You can set automation tasks to schedule Map-Reduce jobs.

Map-Reduce Designer
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Map-Reduce Designer is the basic Navicat tool for working with Map-Reduce jobs.

Button Description

> Run the Map-Reduce job.

[ | Stop the running Map-Reduce job.

@ Preview the documents by applying Input, Mapper, Reducer or Finalizer.
I, Import an existing function to Mapper, Reducer or Finalizer.

Results

To run the Map-Reduce job, click P on the toolbar. If you set to output the results inline, the Result tab opens with
the documents returned, the number of documents and the timing information. If you set to write the results to a

collection, the results return a document to the specified output collection.

GridFS

GridFS is a specification for storing and retrieving files. In the main window, click @ GridFs to open the GridFS
object list.

You can create multiple buckets in a database for storing files. Click £} and enter the name of the bucket.
To open the selected bucket, click &

Bucket Viewer

Bucket Viewer is the basic Navicat tool for working with GridFS buckets. You can upload, download and view GridFS

files that are inside the bucket.

Button Description
= Open the selected GridFS file.
Delete the selected GridFS files.

Upload files into the bucket.

Download the selected GridFS files.

Filter the GridFS file table by creating and applying filter criteria.

Preview an image file that is less than 1 MB.

M e |-d|’57 e’

Check the status of file uploads and downloads.

File Table

The File table displays all the files that are uploaded to the bucket.

You can edit the GridFS file's name, content type, alias or metadata. In the table, control-click the name of the file and
select Modify File Name, Modify Content Type, Modify Alias or Modify Metadata. Then, enter the information in the
pop-up window.

Filter Pane
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If you have many files uploaded to the bucket, you can find matching files using a filter. To toggle the Filter pane, click

T .

Progress Pane

The Progress pane displays the status of all file uploads and downloads in the current window. Parallel downloads and

uploads are supported. If the window is closed, the list will be cleared.

When a file is starting to upload or download, click the corresponding buttons next to the progress bar to pause, resume
and stop the process. After the process is finished, you can click Q 1o open the folder that contains the file, or hover

over an item and click #¢ to remove it from the list.

If you want to pause, resume and stop all items that are in progress, control-click the list and select the appropriate

options.
To clear the finished items, control-click the list and select Clear All Finished.
Maintain Objects
Navicat provides a complete solution for maintaining MongoDB objects.
1. Inthe main window, select objects in the Navigation pane or the Objects tab.
2. Control-click the selected objects.
3. Choose Maintain, and then choose a maintain option the from the pop-up menu.

4. Results show in a pop-up window.

Database

Option Description

Repair Database Rebuild the database and indexes by discarding invalid or corrupt data.
Collection

Option Description

Compact Collection Rewrite and defragment all data and indexes in the collection.

Validate Collection Check the structures within a namespace for correctness by scanning

the collection’s data and indexes.
Reindex Collection Drop and recreate all indexes on the collection.
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Chapter 6 - Data Viewer

About Data Viewer

Navicat includes a data viewer that allows you to view, update, or delete data. The viewer also includes advanced
features and editors that can help you understand the data as you manipulate it. You can use common keyboard

navigation to browse your data.

RDBMS

RDBMS Data Viewer

RDBMS Data Viewer displays the data as a grid or a form. To switch the view, click B or at the bottom.
Note: Form View is available only in Non-Essentials Edition.

The toolbar of the data viewer provides the following functions for managing data:

Button Description

E;:.s Start a transaction. If Auto begin transaction is enabled in Preferences, transaction

will be started automatically when opening the data viewer.

= Make permanent all changes performed in the current transaction.

o Undo work done in the current transaction.

Activate the assistant editors for viewing and editing data.

Y Filter records by creating and applying filter criteria for the data grid.
= Sort records by custom order.

= Import data from files.

5z Export data to files.

Use Navigation Bar

Data Viewer provides a convenient way to navigate among the records/pages using the Navigation Bar buttons.

+ - c SELECT * FROM “sakila®. payment” LIMIT Q,... =+ 1 + o o [
Record 11 of 1000 in page 1
Button Description
+ Add Record - enter a new record. At any point when you are working in the data
viewer, click on this button to get a blank display for a record.
- Delete Records - delete an existing record.
v Apply Changes - apply the changes.
b 4 Discard Changes - remove all edits made to the current record.
Cc Refresh - refresh the data.
| Stop - stop when loading enormous data from server.
[ First Page - move to the first page.
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Previous Page - move to the previous page.

Next Page - move to the next page.

Last Page - move to the last page.

First Record - move to the first record.

Previous Record - move one record back (if there is one) from the current record.

Next Record - move one record ahead.

Last Record - move to the last record.

Setting - set number of records showing on each page.

Grid View - switch to Grid View.

|| % | me ||+ ||+ |T

Form View - switch to Form View.

Use the Setting 2 putton to enter to the edit mode.

Limit [ ] records per page

Check this option if you want to limit the number of records showed on each page. Otherwise, all records will be
displayed in one single page. And, set the value in the edit box. The number representing the number of records

showed per page.

Note: This setting mode will take effect on current object only. To adjust the global settings, see Preferences.

+ - c SELECT * FROM “sakila™. payment” LIMIT Q,... Limit 1000  records per page & [

Recerd 11 of 1000 in page 1

Record a of bin page c

Display the numbers representing the selected record and page.
a - the selected record.

b - number of records in the current page.

c - the current page.

Edit Records

Grid View

Grid View is a spreadsheet-like view showing records and fields as rows and columns. The navigation bar allows you to

switch the records quickly, insert or delete records.
To add arecord

1. Make sure that your cursor is situated in the first blank cell on the table, then enter the desired data. If you are

adding the new record into an existing table, just simply click on an existing record and click + from the

navigation bar or press COMMAND-+ to get a blank display for a record.
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2. Watch the graphics symbol in the record selectors box just to the left of your record. It will change from *,

which indicates that it is the current record, to I , Which indicates that you are editing this record.
3. Just simply move to another record to save the record or click ¥ from the navigation bar.
To edit arecord
1. Select the record that you wish to edit by clicking in the specific field you want to change.
2. Type in the new data for that field.

3. Just simply move to another record, the new data will overwrite the previous data or click ¥ from the

navigation bar.

Note: Close the table is another way to save the records.
To edit multiple cells with same data
1. Select a block of cells in the data grid.
2. Type in the new data.
Note: Changes will apply to multiple fields with compatible data type.
To delete arecord
1. Select the record that you wish to delete.

2. Just simply control-click and select Delete Record or click from the navigation bar.

Form View

Form View displays a single record at a time from a table. The navigation bar allows you to switch the records quickly,

insert or delete records.
To add arecord
1. Click ¥ from the navigation bar or press COMMAND-+ to get a blank display for a record.
2. Enter the desired data.
3. Click ¥ fromthe navigation bar to save the record.
To edit arecord
1. Go to the record that you wish to edit.
2. Type in the new data for the specific field you want to change.

3. Click ¥ fromthe navigation bar. The new data will overwrite the previous data.
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Note: Close the table is another way to save the records.
To delete arecord

1. Go to the record that you wish to delete.

2. Just simply control-click and select Delete Record or click from the navigation bar.

Edit Records with Special Handling

To set the cell value to an empty string or NULL, click on a cell to enter edit mode, and then control-click the cell and
select Set to Empty String or Set to NULL.

To view images in the grid, just simply choose View -> Display -> Show Image in Grid.
Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server and MariaDB.
id image
1 3]
2 —
TS

3

Hint: To view/edit images in an ease way, see Image Editor.

To edit a Date/Time record, just simply click J to open the editor for editing. Choose/enter the desired data. The
editor used in cell is determined by the field type assigned to the column.

Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server and MariaDB.

Date Time DateTime/Timestamp

May 2017 49 May 2017 48

P 12 N

T ¥ 3 4 5 6

10\% T
10 2
78 810 11213 o 8 78 810 1 1213
9 3
14 15 16 17 18 19 20 8 4 14 15 16 17 18 19 20
218 23 24 25 26 27 7 g 5 218 23 24 25 26 27 = . 54

1T 2 3 4 5 6

28 79 30 3 28 29 30 A
12:54:09 PM 2

-

22/ 5/ 2017 I cancel | (LN 22/ 5/ 2017, 4:42:30PM I

cancel | (LS cance! | (ZED

To edit an Enum record, just simply choose the record from the drop-down menu.

Note: Available only for MySQL, PostgreSQL and MariaDB.

id course
1 Maths

Chinese
English
Maths
Music
Sports



To edit a Set record, just simply click J to open the editor for editing. Select the records from the list. To remove the

records, uncheck them in the same way.Check Null or Empty String to set the value as Null or Empty String.

Note: Available only for MySQL and MariaDB.

id course
1 English,Maths Music,Sports
r 2 Apply Maths,Sports |_|
Set List Objects

Chinese
English
| Maths
Music

Apply Maths
Sports

Select All Deselect All | || Null || Empty String | Cancel m

To view BFile content, just simply choose View -> Display -> Preview BFile.
Note: Available only for Oracle.
To generate UUID/GUID, control-click the selected cell and select Generate UUID.

Note: Available only for PostgreSQL and SQL Server.

Edit Records with Foreign Key (Foreign Key Data Selection - Available only in Non-Essentials Edition)

Foreign Key Data Selection is a useful tool for letting you to get the available value from the reference table in an

easy way. It allows you to show additional records from the reference table and search for particular records.

To include data to the record, just simply click J to open the editor for editing.

3 _| 2 _| 1422 _| 0.99 2005-06-15 _| 201

@ @ fk_payment_customer: (customer_id) - sakila.customer(customer_id)
i c s |
L 1]

customer_id

= I I = T I

Just simply double-click to select the desired data.

Hint: By default, the number of records showed is 1000. To show all records, click %25 To refresh the records, click
c
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click B to open a pane on the left for showing a list of column names. Just simply click to show the additional column.
To remove the columns, uncheck them in the same way.

[ ) @ fk_payment_customer: (customer_id) - sakila.customer(customer_id)

3 &) C &
customer_id customer_id first_name  last_name
store_id I MARY SMITH

first_name 2 PATRICIA JOHNSON
3 LINDA WILLIAMS
| email 4 BARBARA JONES

| address_id 5 ELIZABETH BROWM

| active B JENNIFER DAVIS

| create_date 7 MARIA MILLER

—| last_update il SUSAN WILSON

Cancel ﬁ

Hint: To set column in ascending or descending mode, click the right side of the column and select Sort Asc / Sort

Desc.

Enter a search string into the Filter edit box and press ENTER to filter for the particular records.

L] @ fk_payment_customer: (customer_id) - sakila.customer{customer_id)

m c# [
customer_id customer_id first_name last_name
| store_id 1 MARY SMITH
first_name 7 MARIA MILLER
B last_name 9 MARGARET MOORE
| email 16 SANDRA MARTIN
~| address_id 19 RUTH MARTINEZ
| active 38 MARTHA GONZALEZ

create_date A4 MARIE TURNER
~| last_update 80 MARILYN ROSS

Hint: To remove the filter results, simply remove the search string and press ENTER.

Copy Data from Grid View

Data that being copied from Navicat goes into the clipboard with the fields delimited by tabs and the records delimited
by carriage returns. It allows you to easily paste the clipboard contents into any application you want. Spreadsheet
applications in general will notice the tab character between the fields and will neatly separate the clipboard data into

rows and columns.

To select data using keyboard shortcuts

COMMAND-A Toggle the selection of all rows and columns in the data grid.
SHIFT-UP ARROW Toggle the selection of rows as you move up in the data grid.
SHIFT-DOWN ARROW Toggle the selection of rows in the data grid as you move down.

To select data using mouse actions
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e Select the desired records by holding down the COMMAND key while clicking on each row.

e Select range of records by clicking the first row you want to select and holding down the SHIFT key together

with moving your cursor to the last row you wish to select.

* Select a block of cells.
Note: After you have selected the desired records, just simply press COMMAND-C or choose Edit -> Copy.
Paste Data into Grid View
Data are copied into the clipboard will be arranged as below format:

e Data are arranged into rows and column.

* Rows and columns are delimited by carriage returns/tab respectively.

e Columns in the clipboard have the same sequence as the columns in the data grid you have selected.

When pasting data into Navicat, you can replace the contents of current records and append the clipboard data into the
table. To replace the contents of current records in a table, you must select the rows in the data grid whose contents
must be replaced by the data in the clipboard. Just simply press COMMAND-V or choose Edit -> Paste. Navicat will
paste all the content in the clipboard into the selected rows. The paste action cannot be undone if you do not enable
transaction.

Copy Records as Insert/Update Statements

To copy records as Insert/Update statement, control-click the selected records and select Copy As -> Insert
Statement or Update Statement. Then, you can paste the statements in any editors.

Copy Field Name

To copy field names as tab separated values, control-click the selected columns/records and select Copy As -> Tab
Separated Values (Field Name only). If you want to copy data only or both field names and data, you can choose Tab

Separated Values (Data only) or Tab Separated Values (Field Name and Data) respectively.
Sort / Find / Replace Records

Sort Records

Server stores records in the order they were added to the table. Sorting in Navicat is used to temporarily rearrange

records, so that you can view or update them in a different sequence.

Move over the column caption whose contents you want to sort by, click the right side of the column and select Sort

Asc, Sort Desc or Remove Sort.
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payment_id customer_id ~  staff_id rental_id amount

1 1 1% Sort Asc 2
2 3 Sort D 0.99
3 3 5.99
12 Remove Sort
4 3 — e 0.99
B 1 2 1476 9.99
5] 1 1 1725 4.99
To sort by custom order of multiple columns, click 1= from the toolbar.
[ JoN |
f payment@sakila (MySQL 5.7)
B, Y IE R E
amount ASC
customer_id ASC
+ 4+ v
payment_id customer_id~  staff_id rental_id amount~  payment_date last_update
417 15 2 13968 0.00 2006-02-14 15:16:03 2006-02-15 22:12:32
178 42 1 15407 0.00 2006-02-14 15:16:03 2006-02-15 22:12:39
1202 43 1 15745 0.00 2006-02-14 15:16:03 2006-02-15 22:12:39
1483 53 1 14137 0.00 2008-02-14 15:16:03 2006-02-15 22:12:42
1671 60 2 14741 0.00 2008-02-14 15:16:03 2006-02-15 22:12:45
2080 75 1 14488 0.00 2006-02-14 15:16:03 2006-02-15 22:12:50
2081 75 2 15191 0.00 2008-02-14 15:16:03 2006-02-15 22:12:50
2902 107 1 154587 0.00 2006-02-14 15:16:03 2006-02-15 22:13:03
4235 155 1 123562 0.00 2006-02-14 15:16:03 2006-02-15 22:13:33
4450 163 1 15282 0.00 2006-02-14 15:16:03 2006-02-15 22:13:38
4762 175 2 13181 0.00 2008-02-14 15:16:03 2006-02-15 22:13:48
5655 208 1 15717 0.00 2006-02-14 15:16:03 2006-02-15 22:14:10
5BBO 216 1 11676 0.00 2008-02-14 15:16:03 2006-02-15 22:14:17
6160 228 1 15234 0.00 2008-02-14 15:16:03 2006-02-15 22:14:28
+ - c SELECT * FROM “saki... W 1 + & M

100 records in page 1
Find and Replace
Find Records

The Find bar is provided for quick searching for the text in the viewer. Just simply choose Edit-> Find -> Find or press

COMMAND-F. Then, click ©* and choose Find Data and enter a search string. The search starts at the cursor's
current position to the end of the file.
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[ JoN )
] customer@sakila (MySQL)

B, ¥ 1=
stomer_id store_id first_name
MARY
PATRICIA
LINDA
BARBARA
ELIZABETH
JEMNIFER
MARIA
SUSAN
MARGARET
DORCTHY
LISA
MNANCY
KAREM
BETTY
HELEN
SANDRA
DONNA
CAROL
RUTH
SHAROM

[ S T R I L R T S I S T R

M R

last_name

| SMITH

JOHNSON
WILLIAMS
JOMES
BROWN
DAVIS

| MILLER

WILSON

| MOCRE

TAYLOR
ANDERSON
THOMAS
JACKSON
WHITE
HARRIS
MARTIN
THOMPSON
GARCIA
MARTINEZ
ROBINSON

email

:MARY_S MITH®@sakilacustoMer.org
PATRICIA.JOHNSON@sakilacustobMer.org
LINDAWILLIAMS @sakilacustoMer.org
BARBARA.JONES@sakilacustoMer.org
ELIZABETH.BROWN®EsakilacustoMer.org
JENNIFER.DAVIS@sakilacustoMer.org
:M.hRI A.MILLER®@sakilacustoMer.org
SUSANWILSON®@sakilacustoMer.org
:M.ARGAR ET.MOORE@sakilacustoMer.org
DORCTHY.TAYLOR@sakilacustoMer.org
LISA. ANDERSON®@sakilacustoMer.org

| NANCY.THOMAS@sakilacustoMer.org

KAREN.JACKSON@sakilacustoMer.org
BETTY.WHITE®@sakilacustoMer.org
HELEM.HARRIS@sakilacustoMer.arg

| SANDRA.MARTIN@sakilacustoMer.org

DOMNNATHOMPS ON@sakilacustoMer.org
CAROL.GARClA@sakilacustoMer.org

| RUTH.MARTINEZ@sakilacustoMer.org

SHAROMN.ROBINSON@sakilacusteMer.org

Find | Q-MA

@/ 182 matehes ¢ >

+ - c

SELECT * FROM “sakila"....

H 1

599 recerds in page 1

To find for the next text, just simply click > or press COMMAND-G.

Replace Records

Done

+ o HE

In the Find bar, choose Replace or press OPTION-COMMAND-F and enter the text you want to search and replace.

Click Replace or Replace All to replace the first occurrence or all occurrences automatically. If you clicked Replace

All, you can click v to apply the changes or X to cancel the changes.

Replace O, MAR

TA

Find Columns

@ 62 matches ¢ >

Replace

Done

Replace All

To search a column, just simply choose Edit -> Find -> Find or press COMMAND-F. Then, click ©* and choose Find

Column and enter a search string.
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FH customer@sakila (MySQL)

: MARY.SMITH@sakilacustoMer.org

: PATRICIA.JOHNSON@sakilacustoMer.org
: LINDAWILLIAMS @sakilacustoMer.org

: BARBARA.JOMES@sakilacustoMer.org

: ELIZABETH.BROWM@EsakilacustoMer.org
: JEMNIFER.DAVIS@sakilacustoher.org

: MARIA.MILLER@sakilacustoMer.org

: SUSAN.WILSON®@sakilacustoMer.org

: MARGARET.MOORE®@sakilacustoMer.org
: DOROTHY.TAYLOR@sakilacustoMer.org

: LISA.ANDERSON@sakilacustoMer.org

: NANCY.THOMAS®@sakilacustoMer.org

: KAREN.JACKSON@sakilacustoMer.org

: BETTY.WHITE@sakilacustoMer.org

: HELEN.HARRIS@sakilacustoMer.org

: SAMDRA.MARTIN@sakilacustoMer.org

: DONNATHOMPSON@sakilacustoMer.org
: CAROL.GARCIA®sakilacustoMer.org

: RUTH.MARTINEZ@sakilacustoMer.org

: SHARCM.ROBINSON@sakilacustoMer.org

0| 2 matches < »

B, Y IE R B

stomer_id stare_id first_name last_name email

1 MARY | SMITH

1 PATRICIA | UOHNSON

1 LINDA | WILLIAMS

2 BARBARA | UONES

1 ELIZABETH | BROWN

2 JENNIFER | DAVIS

1 MARIA | MILLER

2 SUSAN | WILSON

2 MARGARET | MOORE

1 DOROTHY | TAYLOR

2 LISA | ANDERSON

1 NANCY | THOMAS

2 KAREN | UACKSON

2 BETTY | WHITE

1 HELEN | HARRIS

2 SANDRA | MARTIN

1 DONNA | THOMPSON

2 CAROL | eARCIA

1 RUTH | MARTINEZ
| 2 SHARON | ROBINSON

Find | C~name
Find Data b

+ - | ¢ Find Column ila ..

W« 1 + 5 O

Done

H B

rds in page 1
¥ Highlight Matched Cells
Match Case
¥ Imcremental Search

There are some additional options for Find and Replace, click

Q.

Option

Description

Highlight Matched Cells

Highlight all matches in the viewer.

Incremental Search

Find matched text for the search string as each character is typed.

Match Case

Enable case sensitive search.

Filter Records

Use either of the following methods to filter the data in the grid:

e Click on a cell to enter edit mode. Control-click the cell and select Filter -> Field xxx Value from the pop-up

menu to filter records by the current value in the cell.

* You can also customize your filter in a more complicated way by clicking Y from the toolbar. The Filter

Wizard becomes visible at the top of the grid, where you can see the active filtering condition and easily enable

or disable it by clicking a check box at the left.

Manipulate Raw Data

Navicat normally recognize what user has input in a table as normal string, any special characters or functions would

be processed as plain text (that is, its functionality would be skipped).

Editing data in Raw Mode provides an ease and direct method to apply server built-in functions. To access Raw Mode,

just simply choose View -> Display -> Raw Mode.




Note: Available only for MySQL, PostgreSQL, SQLite, SQL Server and MariaDB.

CustMNo Company Addrl
1 EES coNcAT'Sight Diverod', X'
1380 ‘Blue Jack Agua Center’ '23-73B Paddingten
1384 '"WIP Divers Club’ '32 Main 5t
1510 'Ocean Paradise’ 'POC Box 8745'
1513 'Fantastique Aquatica’ 'Z32 999 #12A-77 AAS

Format Data View

Use the following methods to format the table:

Hint: Form View only supports Show/Hide Columns.

Move Columns
1. Click on the column header and hold down the left mouse button.
2. Move the pointer to the desired location.

3. Release the mouse and the column will move.

payment_id staff_ideustomer_id rental_id
1 1 1 78

2 1 3 573

3 1 3 1185

4 2 3 1422

& 2 1 1476

5] 1 1 1725

Set Column Width
e Click right border at top of column and drag either left or right.
e Double-click right border at top of column to obtain the best fit for the column.

e Control-click the column you want to set the column width with and select Set Column Width or select from
the View menu. Specify width in the Set All Columns Width dialog.

Hint: The result applies on all columns.

Set Row Height

Control-click anywhere on the table grid and select Set Row Height or select from the View menu. Specify row height
in the Set Row Height dialog.

Hint: This action applies on the current table grid only.

Show/Hide Columns

If there are many columns in the table and you want to hide some of them from the grid/form, just simply control-click

anywhere on the grid/form and select Show/Hide Columns or select from the View menu. Select the columns that you
would like to hide.
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The hidden columns will disappear from the grid/form.

To unhide the columns, just simply control-click anywhere on the grid/form and select Show/Hide Columns or select

from the View menu. Select the columns that you would like to redisplay.

payment_id payment_id customer_id rental_id payment_date
customer_id 2 3 573 2005-05-28
| staff_id
staff_id 3 3 1185 2005-06-15
tal_id
rental_ig A 3 1422 2005-06-15
- t
amoun 5 1 .| 1476 .| 2005-06-15 |
payment_date
6 1 1725 2005-06-16
~| last_updat
ast_update 7 1 2308 2005-06-18

Show/Hide ROWID

If you want to display or hide the rowid (address) of every row, control-click anywhere on the table grid and select

Show/Hide ROWID or select from the View menu.
The ROWID column will be showed in the last column.

Note: Available only for Oracle and SQLite.

MongoDB

MongoDB Data Viewer

MongoDB Data Viewer displays the data as a grid or a tree, or in JSON format. To switch the view, click ﬁ, or
at the bottom.

The toolbar of the data viewer provides the following functions for managing data:

Button Description

E;:.s Start a transaction. If Auto begin transaction is enabled in Preferences, transaction

will be started automatically when opening the data viewer.

= Make permanent all changes performed in the current transaction.
=) Undo work done in the current transaction.
Activate the assistant editors for viewing and editing data.

Available only for Grid View and Tree View.

Y Filter records by creating and applying filter criteria for the data grid.

= Sort records by custom order.

< [Tree View] Expand all embedded documents and arrays.

< [Grid View] Collapse all embedded documents.

[Tree View] Collapse all embedded documents and arrays.

[Grid View] Use the specified type color set on the Type Color pane to highlight cells.

Import data from files.

Export data to files.

Analyze the collection.

=3 a0
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Use Navigation Bar

Data Viewer provides a convenient way to navigate among the documents/pages using the Navigation Bar buttons.

+ - c db.getCollection("departments") find().li... M=+ 1 =+ = & [H

Document 13 of 27 in page 1

Button Description

+ Add Document - enter a new document. At any point when you are working in

the data viewer, click on this button to get a blank display for a document.

- Delete Documents - delete an existing document.

Apply Changes - apply the changes.

Discard Changes - remove all edits made to the current document.

Refresh - refresh the data.

Stop - stop when loading enormous data from server.

First Page - move to the first page.

Previous Page - move to the previous page.

Next Page - move to the next page.

Last Page - move to the last page.

First Document - move to the first document.

+ H |+ | T F\m| Qx|

Previous Document - move one document back (if there is one) from the current

document.

Next Document - move one document ahead.

Last Document - move to the last document.

Setting - set number of documents showing on each page.

Grid View - switch to Grid View.

Tree View - switch to Tree View.

JSON View - switch to JISON View.

=] | [l |BH | & | W= | *

Use the Setting £ putton to enter to the edit mode.
Limit [ ] documents per page

Check this option if you want to limit the number of documents showed on each page. Otherwise, all documents will be
displayed in one single page. And, set the value in the edit box. The number representing the number of documents

showed per page.
Note: This setting mode will take effect on current object only. To adjust the global settings, see Preferences.

+ - ¢ db.getCollection("departments”).find.. & Limit 1000 documentsper page & [j

Document 13 of 27 in page 1

Document a of b in page c

Display the numbers representing the selected document and page.
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a - the selected document.
b - number of documents in the current page.
c - the current page.

Grid View

Grid View is a spreadsheet-like view showing documents and fields as rows and columns. The navigation bar allows

you to switch the documents quickly, insert or delete documents.
To add a document using the grid

1. Click on an existing document and click + from the navigation bar or press COMMAND-+ to get a blank
display for a document.

2. Enter the desired data.

3. Watch the graphics symbol in the document selectors box just to the left of your document. It will change from

*  which indicates that it is the current document, to I , which indicates that you are editing this document.

4. Just simply move to another document to save the document or click v from the navigation bar.
Note: If your collection is empty, a window will pop up for you to add documents.
To add a document using the pop-up window

1. Control-click the grid and select Add Document.

2.  Write the document in the pop-up window.

3. Click Validate to ensure the document is correct.

4. Click Save.
To edit a document using the grid

1. Select the document that you wish to edit by clicking in the specific cell you want to change.

2. Type in the new data for that cell.

3. Just simply move to another document or click ¥ from the navigation bar, the new data will overwrite the

previous data.
To edit a document using the pop-up window
1. Control-click the document that you wish to edit and select Edit Document.

2. Edit the document in the pop-up window.
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3. Click Validate to ensure the document is correct.
4. Click Save.
Note: Close the collection is another way to save the documents.
To edit multiple cells with same data
1. Select a block of cells in the data grid.
2. Type in the new data.
Note: Changes will apply to multiple fields with compatible data type.
To delete a document
1. Select the document that you wish to delete.

2. Just simply control-click and select Delete Document or click from the navigation bar.

Edit Documents with Special Handling

To set the cell value to an empty string or NULL, click on a cell to enter edit mode, and then control-click the cell and

select Set to Empty String or Set to NULL.

To edit a DateTime data, just simply click J to open the editor for editing. Choose/enter the desired data.

Jul 2018 48 r
12 N
S 1
12 3 4 5 68 7 10 2
g ol 11 1z 13 14
9 3
15 16 17 18 19 20 21
22 23 24 25 26 27 2B
29 30 3 7 g
10/ 7/ 2018, 12:19:40 PM |2

To change the type of a cell value, click on a cell to enter edit mode, and then control-click the cell and select Value

Type. Then, select the desired type.

Copy Data from Navicat

Data that being copied from Navicat goes into the clipboard with the fields delimited by tabs and the documents
delimited by carriage returns. It allows you to easily paste the clipboard contents into any application you want.
Spreadsheet applications in general will notice the tab character between the fields and will neatly separate the

clipboard data into rows and columns.

To select data using keyboard shortcuts
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COMMAND-A Toggle the selection of all rows and columns in the data grid.

SHIFT-UP ARROW Toggle the selection of rows as you move up in the data grid.

SHIFT-DOWN ARROW Toggle the selection of rows in the data grid as you move down.

To select data using mouse actions
* Select the desired documents by holding down the COMMAND key while clicking on each row.

e Select range of documents by clicking the first row you want to select and holding down the SHIFT key together

with moving your cursor to the last row you wish to select.

* Select a block of cells.
Note: After you have selected the desired documents, just simply press COMMAND-C or choose Edit -> Copy.
Paste Data into Navicat
Data are copied into the clipboard will be arranged as below format:

e Data are arranged into rows and column.

* Rows and columns are delimited by carriage returns/tab respectively.

e Columns in the clipboard have the same sequence as the columns in the data grid you have selected.

When pasting data into Navicat, you can replace the contents of current documents and append the clipboard data into
the collection. To replace the contents of current documents in a collection, you must select the rows in the data grid
whose contents must be replaced by the data in the clipboard. Just simply press COMMAND-V or choose Edit ->
Paste. Navicat will paste all the content in the clipboard into the selected rows. The paste action cannot be undone if

you do not enable transaction.

Copy Field Name

To copy field names as tab separated values, control-click the selected fields/documents and select Copy As -> Tab
Separated Values (Field Name only). If you want to copy data only or both field names and data, you can choose Tab
Separated Values (Data only) or Tab Separated Values (Field Name and Data) respectively.

Filter Documents

Use either of the following methods to filter the data in the grid:

e Click on a cell to enter edit mode. Control-click the cell and select Filter -> Field xxx Value from the pop-up

menu to filter documents by the current value of the selected field.

* You can also customize your filter in a more complicated way by clicking Y from the toolbar. The Filter

Wizard becomes visible at the top of the grid, where you can see the active filtering condition and easily enable

or disable it by clicking a check box at the left.
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Format Grid View

Use the following methods to format the collection grid:
Highlight Cells based on Types

Grid View allows highlighting cells based on data types to make particular cells easy to identify. The Type Color pane is

on the right side of the grid. If the grid window is docked to the Navicat main window, you can click the & icon in the
Information pane to set the color.

To apply the color, click the &% button on the toolbar or check the Enable Coloring option on the Type Color pane.

ece
] departments@hr (MongoDB) ® &
D' Y = e @ R B ik Enable Coloring

id DEPARTMEMNT_ID DEPARTMENT_MAME MAMNAGER_ID LOCATION_ID
5b3c34124348020a10003a8: 10 Administration 200 1700 |:| Int32 a
5b3c34124348b20a10003a8f 20 Marketing 201 1800 Null a
5b3c34124348b20a10003a20 30 Purchasing 114 1700
5b3c34124348b20a10003a81 40 Human Resources 203 2400 String a
5b3c34124348b20a10003a%2 5O Shipping 121 1500
5b3c34124348020a10003a83 60 I 103 1400 Dauble a
5b3c34124348b20a10003a84 70 Public Relations 204 2700
5b3c34124348b20a10003a85 80 Sales 145 2500 a
5b3c34124348b20a10003a%6 90 (Document) Z Fields 100 1700 a
5b3c34124348b20a10003a87 100 Finance 108 1700
5b3c34124348020a10003a28 110 Accounting 205 1700
5b3c34124348b20a10003a88 120 Treasury 1700
Eb3c34124348b20a10003a% 130 Corporate Tax 1700
5b3c34124348b20a10003a%0 140 Control And Credit 1700
5b3c34124348b20a10003a%¢ 150 (Document) 2 Fields (Array) 3 Elements 1700
5b3c34124348b20a10003a%d 160 Benefits 1700
5b3c34124348b20a10003a% 170 Manufacturing 1700
5b3c34124348b20a10003a8f 180 Construction 1700
5b3c34124348b20a10003aa0 190 Contracting 1700
5b3c34124348b20a10003aa1 200 Operations 1700

» 5b3c3412434Bb20a10003aa2 210 IT Support 1700
5b3c34124348b20a10003aa3 220 NOC 1700
5b3c34124348020a10003aa4 230 IT Helpdesk 1700
5b3c3412434B8b20a10003aa5 240 Government Sales 1700
5b3c34124348020a10003aa6 250 Retail Sales 1700

+ - c db.getCollection({"depart... W=+ 1 + o H

Document 21 of 27 in page 1
Expand/Collapse Embedded Documents

Grid View allows embedded documents to be expanded alongside other columns for easier data analysis. To expand

or collapse an embedded document, just simply click on the cell with embedded document and click E or II or

control-click the cell and select Expand, Collapse or Collapse All Embedded Documents.

&0 IT 103
70 Public Relations 204
a0 Sales 145
100 Finance 108
10 Accounting 205
120 Treasury

Expand Arrays

Grid View allows showing all elements in an array. To expand array elements, just simply click on the cell with array

elements and click E or control-click the cell with array elements and select Expand.
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1700
1700
1700

> l (Array) 3 Elements B9 PRSI

1700
1700
1700

All array elements display on a new grid. You can view, add or delete the elements here. Click the collection name to

jump back to the collection grid.

departments MAMNAGER_ID

MANAGER_ID

101
103
108

Move Columns
¢ Click on the column header and hold down the left mouse button.
* Move the pointer to the desired location.

¢ Release the mouse and the column will move.

DEPARTMENT_MAME DEPARTMEMNT_ID MANAGER_ID LOCATION_ID
Administration 10 200 1700
Marketing 20 2Mm 1800
Purchasing 30 114 1700
Human Resources 40 203 2400
Shipping 50 121 1500
IT 60 103 1400
Public Relations 70 204 2700
Sales 80 145 2500
(Document) 2 Fields S50 100 1700

Set Column Width
e Click right border at top of column and drag either left or right.
e Double-click right border at top of column to obtain the best fit for the column.

e Control-click the grid and select Set Column Width or select from the View menu. Specify width in the Set All

Column Width dialog.
Hint: The result applies on all columns.
Set Row Height

Control-click anywhere on the collection grid and select Set Row Height or select from the View menu. Specify row

height in the Set Row Height dialog.

Hint: This action applies on the current collection grid only.
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Show/Hide Columns

If there are many columns in the collection and you want to hide some of them from the collection grid, just simply

control-click anywhere on the collection grid and select Show/Hide Columns or select from the View menu. Select the

columns that you would like to hide.

The hidden columns will disappear from the collection grid.

To unhide the columns, just simply control-click anywhere on the collection grid and select Show/Hide Columns or

select from the View menu. Select the columns that you would like to redisplay.

| d DEPARTMENT_ID MANAGER_ID
DEPARTMENT_ID 10 200
—| DEPARTMENT.N
MANAGER_ID 30 14
LOCATION_ID 40 203

50 121

60 103

70 204

80 145

Tree View

Tree View displays documents in a hierarchical view. The navigation bar allows you to switch the documents quickly,

insert or delete documents.

To add a document

1. Click * from the navigation bar or press COMMAND-+ to get a blank display for a document.

2. Enter the desired data.
3. Click ¥ from the navigation bar to save the document .

Note: If your collection is empty, you need to click "™ to add a new field.

To edit adocument

1. Go to the document that you wish to edit.

2. Click on a field name, a value or a type to modify.

3. Click ¥ fromthe navigation bar to apply the changes.
To add a field or an item

1. Go to the document that you wish to edit.

2. Click ™ to add a new field/item.

3. Enter the desired data.
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To delete afield or an item

1. Go to the document that you wish to edit.

2. Control-click the field/item you want to delete and select Delete Value.
Note: Close the collection is another way to save the documents.

To delete a document

1. Go to the document that you wish to delete.

2. Just simply click from the navigation bar.

Edit Documents with Special Handling

To set the value to NULL, control-click the selected item and select Value Type -> NULL.

To edit a DateTime data, just simply click J to open the editor for editing. Choose/enter the desired data.

Jul 2018 a8 »

777 12 1N
123 456 7 10 2
g offf] 1 1z 13 14 o 3
16 16 17 18 18 20 21
?ﬁ 5

22 23 24 25 26 27 28
28 30 &1

-

10/ 7/ 2018, 12:19:40 PM  C

Format Tree View

Expand/Collapse Embedded Documents & Arrays

All embedded Documents and arrays are represented as nodes. The nodes can be expanded or collapsed by clicking

the node icon.

_id : 5b3c34124348b20a10003a8¢c ObjectiD2
DEPARTMENT_ID : 150 Double &
¥ DEPARTMENT_NAME : (Document) 2 Fields Document <
NAME1 : C5 String &
MAME2 : IT Support String &

+
¥ MANAGER_ID : (Amay) 3 Elements Array &
0 : 101 Double &
1: 103 Double 2
2 : 105 Double &

+

LOCATION_ID : 1700
+

Double &
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JSON View

JSON View displays documents in JSON format. The navigation bar allows you to switch the documents quickly, insert

or delete documents.
To add a document
1. Click * from the navigation bar or press COMMAND-+.
2.  Write the document in the pop-up window.
3. Click Validate to ensure the document is correct.
4. Click Save.
To edit a document
1. Control-click the document that you wish to edit and select Edit Document.
2. Edit the document in the pop-up window.
3. Click Validate to ensure the document is correct.
4. Click Save.
To delete a document
1. Click on the document that you wish to delete.

2. Just simply click from the navigation bar.

Sort / Find / Replace Documents

Sort Documents

Server stores documents in the order they were added to the collection. Sorting in Navicat is used to temporarily

rearrange documents, so that you can view or update them in a different sequence.

Move over the field caption whose contents you want to sort by, click the right side of the field and select Sort Asc,

Sort Desc or Remove Sort.

id EMPLOYEEID ~ FIRST_NAME LAST_NAME
503c34184348020a1000479e 100 1% Sort Asc ng
5b3c34184348020a1000479F 101 12 Sort Desc ichhar
5b3c34184348b20a100047a0 102 1® Remove Sort  1Haan
5b3c34184348020a100047a1 103 e ranold
5b3c34184348b20a100047a2 104 Bruce Ernst
5b3c34184348b20a100047a3 105 David Austin
5b3c34184348b20a100047a4 106 Valli Pataballa

To sort by custom order of multiple fields, click 1= from the toolbar.
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[ JoN ]
| employees@hr (MongoDB)

B. YIE <& BRE b

FIRST_NAME ASC
EMPLOYEE_ID ASC

+ 4+ v
id EMPLOYEE_ID ~ FIRST_MAME ~ LAST_NAME EMAIL PHOME_MUMEBER

5b3c34184348b20a1000473 121 Adam Fripp AFRIPP 650.123.2234
Eb3c34184348b20a100047fe 196 Alana Walsh AWALSH B50.507.9811
5b3c34184348b20a100047cd 147 Alberto Errazuriz AERRAZUR 011.44.1344.429278
5b3c34184348b20a100047a1 103 Alexander Hunaold AHUNOLD 590.423.4567
5b3c34184348b20a100047ad 115 Alexander Khoo AKHOO 515.127.4582
5b3c34184348b20a100047f3 185 Alexis Bull ABULL 650.509.2876
5b3c34184348b20a100047d8 158 Allan McEwen AMCEWEN 011.44.1345.829268
5b3c34184348b20a100047e8 175 Alyssa Hutten AHUTTON 011.44.1644.429266
Eb3c34184348b20a100047e1 167 Amit Banda ABANDA 011.44.1348.729268
5b3c34184348b20a100047f5 187 Anthony Cabrio ACABRIO B650.509.4876
5b3c34184348b20a100047fl2 193 Britney Everett BEVERETT 650.501.28786
5b3c34184348b20a100047a2 104 Bruce Ernst BERNST 590.423.4568
5b3c34184348b20a100047ed 179 Charles Johnson CJOHNSCN 011.44.1644.429262
Eb3c34184348b20a100047d3 153 Christopher Dlsen COLSEN 011.441344.498718
5b3c34184348b20a100047de 162 Clara Wishney CVISHNEY 011.44.1346.129268
5b3c34184348b20a100047c8 142 Curtis Davies CDAVIES 650.121.2994

+ = c db.getCollection("employees... W 1 + = & H

107 documents in page 1

Find and Replace

Find Documents

The Find bar is provided for quick searching for the text in the viewer. Just simply choose Edit-> Find -> Find or press

COMMAND-F. Then, enter a search string. The search starts at the cursor's current position to the end of the file.

For Grid View or Tree View, you need to click @~ and choose Find Data.

[ JoN |
§ employees@hr (MongoDB)

B. Y IE 2k & R R Ih

id EMPLOYEEID ~ FIRST.NAME ~ LASTNAME  EMAIL PHONE_NUMBER
5b3c34184348020a100047% 100 Steven King SKING 515.123.4567
5b3c34184348020a1000479f 101 Neena Kochhar NKOCHHAR 5151234568
5b3c34184348020a100047a0 102 Lex De Haan LDEHAAN 515.123.4569
5b3c34184348020a100047a1 103 Alexander Hunold AHUNOLD  590.423.4567
5b3c341843480202100047a2 104 Bruce Ermst BERNST 580.423.4568
5b3c34184348020a100047a3 105 David | Austin DAUSTIN | 590.423.4568
5b3c34184348020a100047a4 106 Valii Pataballa VPATABAL  590.423.4560
5b3c34184348020a100047a5 107 Diana Lorentz DLORENTZ  590.423.5567
5b3c34184348020a100047a6 108 Nancy Greenberg NGREENBE  515.124.4569
5b3c341843480202100047a7 109 Daniel | Faviet DFAVIET 515.124.4169
5b3c34184348b20a100047a8 110 John Chen JCHEN 515.124.4269
5b3c34184348b20a100047a8 111 lsmael Sciarra ISCIARRA 515.124.4369
5b3c34184348020a100047aa 112 Jose Manuel  Urman JMURMAN  515.124.4469
5b3c34184348b20a100047ab 113 Luis Popp LPOPP 515.124.4567
5b3c34184348b20a100047ac 114 Den Raphaely DRAPHEAL  515.127.4561
5b3c34184348b20a100047ad 115 Alexander Khoo AKHOO 515.127.4562
5b3c34184348020a1000472e 116 Sheli Baida | SBAIDA | 515.127.4563
5b3c34184348020a100047aF 117 Sigal Toblas STOBIAS 515.127.4564
5b3c34184348020a10004760 118 Guy Himuro GHIMURO  515127.4565
Find | C~Da 0| < » Done
= = c db.getCollection("employees... M+ 1 + & H

107 documents in page 1

To find for the next text, just simply click > or press COMMAND-G.
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Replace Documents

In the Find bar, choose Replace or press OPTION-COMMAND-F and enter the text you want to search and replace.

Click Replace or Replace All to replace the first occurrence or all occurrences automatically. If you clicked Replace

All, you can click ¥ to apply the changes or * to cancel the changes.

Replace 1 Da [x] < > Done

Ta Replace Replace All

Find Fields

In Grid View or Tree View, you can search for fields in the collection. Just simply choose Edit -> Find -> Find or press

COMMAND-F. Click “" and choose Find Column. Then, enter a search string.

[ JoN |
§ employees@hr (MongoDB)

B. Y IE 2k & R R Ih

id EMPLOYEEID ~ FIRST.NAME ~ LAST.NAME  EMAI PHONE_NUMBER
5b3c34184348020a100047% 100 Steven | King | SKING 515.123.4567
5b3c34184348020a1000478f 101 Neena | Kochhar | NKOCHHAR  515.123.4568
5b3c34184348020a100047a0 102 Lex | De Haan | LDEHAAN 515.123.4569
5b3c34184348020a100047a1 103 Alexander | Hunold | AHUNOLD  530.423.4567
5b3c34184348020a100047a2 104 Bruce | Emst | BERNST 590.423.4568
5b3c34184348020a100047a3 105 David | Austin | DAUSTIN 530.423.4560
5b3c34184348b20a10004724 106 valli  Pataballa | VPATABAL  590.423.4560
5b3c34184348020a100047a5 107 Diana | Lorentz | DLORENTZ ~ 530.423.5567
5b3c34184348020a100047a6 108 Nancy | Greenberg | NGREENBE  515.124.4568
5b3c34184348020a100047a7 109 Dariel | Faviet | DFAVIET 515.124.4169
5b3c34184348020a100047a8 110 John | Chen | JCHEN 515.124.4269
5b3c34184348520a10004728 1M1 Ismael | Sciarra | ISCIARRA 515.124.4369
5b3c34184348020a100047aa 112 Jose Manuel | Urman | JMURMAN  515.124.4469
5b3c341843480b20a100047ab 113 Luis " Popp | LPOPP 516.124.4567
5b3c34184348020a100047ac 114 Den | Raphaely | DRAPHEAL  515.127.4561
5b3c34184348b20a100047ad 115 Alexander | Khoo | AKHOO 515.127.4562
5b3c34184348020a100047a 116 Shelli | Baida | SBAIDA 515.127.4563
5b3c34184348020a100047af 117 Sigal | Tobias | STOBIAS 515.127.4564
5b3c34184348020a10004760 118 Guy | Himuro | GHIMURO 515.127.4565
Find [ ONAME 0| <[> Dene
= = c db.getCollection("employees... M+ 1 + & H

107 documents in page 1

There are some additional options for Find and Replace, click

Option Description

Highlight Matched Cells Highlight all matches in the viewer.

Incremental Search Find matched text for the search string as each character is typed.
Match Case Enable case sensitive search.

Regular Expression Search regular expressions.

Whole Word Return the objects that match the entire word of the search string.

Assistant Editors

Navicat provides powerful assistant editors to view and edit TEXT, BLOB and BFile fields content. The editor allows

you to view, update, insert, or delete data in a table or a collection. Click B Text, Hex, [adl Image and ® web
from the toolbar to activate the appropriate viewer/editor.
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Note: Oracle BFile fields cannot be edited. MongoDB JSON View does not support assistant editors.

The Text pane allows you to edit data as a simple text. To change the syntax highlight, simply control-click the empty

space and select Language. Use the ¥ putton on the navigation bar to update the changed records or documents.

The Hex pane allows you to edit data in hexadecimal mode. Use the ¥ button on the navigation bar to update the
changed records or documents.

The Image pane allows you to show data as image. Use the ™ Load, Save to disk and ] Clear buttons to
load/remove the image from a file, and save the image to a file.

The Web pane allows you to show data with HTML codes as in a web browser.

Filter Wizard

Filter Wizard allows you to facilitate creating and applying filter criteria that you specify for the data grid. Moreover, it

allows you to save filter criteria as a profile for future use. Click ¥ from the toolbar to activate the filter.

[ JoN |
FH customer@sakila (MySQL)

B, Y I R E
@ (

customer_id > 100 and
store_id = 2

) or
(
active = 0 and
store_id = 1
)
+t ¥+ v
customer_id store_id first_name last_name email address_id active
1089 2 EDNA WEST EDMAWEST @sakilacustoMer.org 13 1
10 2 TIFFANY JORDAN TIFFANY.JORDAN@sakilacustoMer.org 14 1
112 2 ROSA REYNOLDS ROSA.REYNOLDS®@sakilacustoMer.org 16 1
113 2 CINDY FISHER CINDY.FISHER@sakilacustoMer.org M7 1
114 2 GRACE ELLIS GRACE.ELLIS@sakilacustoMer.org 18 1
120 2 SYLVIA ORTIZ SYLVIA.ORTIZ@sakilacustoMer.org 124 1
123 2 SHANNON FREEMAN SHANNON.FREEMAN@sakilacustoMer.org 127 1
124 1 SHEILA WELLS SHEILAWELLS®@sakilacustoMer.org 128 0
127 2 ELAINE STEVENS ELAINE.STEVENS@sakilacustoMer.org 131 1
131 2 MONICA HICKS MONICA.HICKS@sakilacustoMer.org 135 1
132 2 ESTHER CRAWFORD ESTHER.CRAWFORD@sakilacustoMer.org 136 1
135 2 JUANITA MASON JUANITA.MASON@sakilacustoMer.org 138 1
136 2 ANITA MORALES ANITAMORALES®@sakilacustoMer.org 140 1
+ - c SELECT * FROM “sakila*. customer’ WHERE (c... K+ 1 + o [H
233 records in page 1
Create Filter
1. To add a new condition to the criteria, just simply click . If you need to add conditions in parentheses, click

Hint: To add parentheses to existing conditions, simply control-click on the selected conditions and select
Group with Bracket. To remove the parentheses, control-click a bracket and select Delete Bracket or Delete

Bracket and Conditions.

2. Click on the field name (next to the checkbox) and choose a field from the list.
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3. Click on the operator (next to the field name) and choose a filter operator. You can choose [Custom] from the

list to enter the condition manually.

Filter Operator

Operator Description

The field is equal to 'value'.

The field is not equal to 'value'.

< The field is less than 'value'.

<= The field is less than or equal to 'value'.

> The field is greater than 'value'.

>= The field is greater than or equal to 'value'.
contains The field contains ‘'value'.

contains (case

insensitive)

The field contains 'value' (case insensitive).

Available only for PostgreSQL.

does not contain

The field does not contain 'value'.

does not contain (case

insensitive)

The field does not contain 'value' (case insensitive).

Available only for PostgreSQL.

begin with

The field starts with 'value'.

does not begin with

The field does not start with 'value'.

end with

The field ends with 'value'.

does not end with

The field does not end with 'value'.

is null The field is NULL.

is not null The field is NOT NULL.

is empty The field is empty.

is not empty The field is not empty.

is between The field is between 'valuel' and 'value2'.

is not between

The field is not between 'valuel' and 'value2'.

is in list The field is in the list of (‘'valuel','value2',...).
is not in list The field is not in the list of ('valuel','value2',...).
exists The field exists.

Available only for MongoDB.

does not exist

The field does not exist.

Available only for MongoDB.

is field type

The field type is 'value'.
Available only for MongoDB.

is not field type

The field type is not 'value'.

Available only for MongoDB.

4. Click on ? to activate the appropriate editor and enter the criteria values. The editor used in the criteria values

box is determined by the data type assigned to the corresponding field.

Hint: For MongoDB, you can change the editor type in the criteria values box.

5. Click on the logical operator (next to the criteria values) to choose and or or.
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6. Repeat step 1-5 to add another new condition.

7. Click ¥ 'to see the result of the filtering you made.

Hint: If you want to reverse the conditions, control-click the selected conditions and select Toggle Negator. (Available

only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server and MariaDB)

Save Profile

You are allowed to save filter criteria to profiles for future use. Just simply control-click on the Filter Wizard and select

Load Profile, Delete Profile, Save Profile or Save Profile As.
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Chapter 7 - Query
About Query

A query is used to extract data from the database in a readable format according to the user's request. Navicat provides
powerful tools for working with queries: Query Editor for editing the query text directly, and Query Builder, Find Builder
or Aggregate Builder for building queries visually. You can save your queries for setting automation tasks. In the main

window, click & Query to open the query object list. You can also click o New Query in the main toolbar to create
a new query without opening any connections.

To open a query using an external editor, control-click it and select Open with External Editor. You can set the file

path of an external editor in Preferences.

Hint: Queries (.sql or .js) are stored under the Settings Location. To open the folder, control-click a query and select

Show in Finder. If the connection is synchronized to Navicat Cloud, its queries are stored in the Cloud.

Query Designer

Query Designer is the basic Navicat tool for working with queries.

Button Description

MySQL, Oracle, PostgreSQL, SQLite, SQL Server and MariaDB

Enm Open the SQL Builder for building queries visually.

AN Format the codes with the Beautify SQL settings in Editor.

MongoDB

3 Open the Find Builder for building queries visually.

5 Open the Aggregate Builder for building queries visually.

=N Format the codes in Editor.

o [Grid View] Use the specified type color set on the Type Color pane to
highlight cells.

Common

() Show the Code Snippet pane.

Activate the assistant editors for viewing and editing data.

= Export the result of the query.

> Execute the query: Run, Run Current Statement, or Run Selected
(when highlighted code).
MongoDB does not support Run Current Statement.

[ | Stop the executing query.

e Show the Query Plan of the query: Explain or Explain Selected (when
highlighted code).

Open an external file in Navicat

1. Control-click anywhere in the Objects tab and select Open External Query. from the pop-up menu.
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2. Select the file.
3. Click Open.
Save an opened external file as a Navicat query
1. In Query Designer, choose File -> Save to Navicat.
2. Enter the query name and choose the save location.
3. Click OK.
Save a Navicat query as an external file
1. In Query Designer, choose File -> Save As External File.
2. Choose the save path and enter the file name.

3. Click Save.

RDBMS

SQL Editor

SQL Editor allows you to create and edit SQL text, prepare and execute selected queries. You can define multiple SQL
statements in one query window. Drag-and-drop or double-click an identifier in the right Identifiers pane to add it to the

editor.
Hint: SELECT statement will be automatically generated in SQL Editor while you build in SQL Builder.

Navicat provides a wide range advanced features, such as compelling code editing capabilities, smart code-completion,

SQL formatting, and more.

SQL Formatting

To change the SQL statement format, simply choose from the Format menu -
Indent

Increase/decrease indent for the selected lines of codes.

Comment

Comment/uncomment the selected lines of codes.

Convert Case

Format the selected codes into upper/lower case.

Beautify SQL (Available only in Non-Essentials Edition)
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Format the selected codes with the Beautify SQL settings.

Beautify SQL With (Available only in Non-Essentials Edition)

Change the SQL beautifier options.

Option / Button Description

Short Brace Length Set the length of the short brace.

Upper case keywords Format all the SQL keywords to upper case.
Beautify Save and apply the SQL beautifier options.

Minify SQL (Available only in Non-Essentials Edition)

Minify the format of the SQL in the SQL Editor.

Code Completion (Available only in Non-Essentials Edition)

Code completion feature in Navicat pops up a list of suggestions as you type your SQL statement in the editor. It
assists you with statement completion and the available properties of database objects, for example databases, tables,
fields, views etc with their appropriate icons and information. You can update the code suggestions with latest

database information by choosing Edit -> Code Completion -> Update Code Completion Info.

To invoke code completion, just simply press "' for the available properties of database object currently in the scope.

When the suggestion list appears, press TAB to insert the first item. You can also select the needed item using UPPER
ARROW or DOWN ARROW and then press TAB or ENTER.

1 SELECT
& sakila.customer.customer_id,
3 sakila.customer.store_id,
4 sakila.customer.first_name,
5 sakila.customer. Last_name,
6 sakila.customer.email,
T sakila.customer.
8 FROM B store_id tinyint(3) unsigned .customer
4 sakila. custolm a5t update sakila.customer
[E] last_name sakila.customer
[E] first_name sakila.customer
[E] email sakila.customer
[E] customer_id sakila.customer
[E] create_date sakila.customer
[E] address_id sakila.customer
[E] active sakila.customer
SelectAll
CreateFunction

In addition, code completion can be invoked by typing a character or pressing ESC on your keyboard for SQL

keywords/database objects.

If you select a snippet name from the list, the saved code will be inserted to the editor.
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SELECT
sakila.customer.customer_id,
sakila.customer.store_id,

sakila. customer. last_name,
sakila.customer.email

sel

1
2
i
4 sakila.customer.first_name,
5
[
T/

{5 sales_by_film_category sakila
F‘% customer_list sakila
Fo% nicer_but_slower_film_list sakila
@ special_features sakila.film
f.r get_customer_balance(int p_customer_id, sakila
SelectaAll
7 session_variables performance_schema
{5, SESSION_VARIABLES information_schema
{5 session_ssl_status 5YyS
F‘% SCHEMA_PRIVILEGES information_schema

Hint: Resize the suggestion list by dragging the lower right corner.

You can enable or disable the code completion feature in Preferences.

Clipboard Stack

When you copy or cut some codes as usual in the editor, the copied content will also be added to Clipboard Stack.
Clipboard Stack can store up to 10 items and use the last-in-first-out logic. To paste an item from Clipboard Stack, you
can press COMMAND-SHIFT-V. Press COMMAND-SHIFT-V multiple times to cycle through Clipboard Stack.

Code Folding

Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in SQL
Editor.

A block of code that can be folded is indicated by an icon I to the left of the first line of the block. A vertical line
extends from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon

to left of the code block. You can fold the block by clicking =l or expand it by clicking [,

30 [ IFNULL(

31 [ SuM(

32 | IF

33 (

34 (L]

37 [ (

38 {

EL] TO_DAYS( rental.return_date ) - TO_DAYS( rental.rental_date )
49 ) — film.rental_duration
41 ¥,

42 a

43 )

44 ¥,

45 o

46 ) INTO v_overfees

Brace Highlight

Navicat supports to highlight the matching brace in the editor, i.e. () .

Note: The cursor must be on a brace to show the highlight.



30 [ TFNULL(

31 [ SUM(

32 | IF

34 [— (
35 TO_DAYS( rental.return_date )} — TO_DAYS{ rental.rental_date }
36
37
38 i

39 TO_DAYS( rental.return_date ) - TO_DAYS( rental.rental_date )
49 ) — film.rental_duration

41
42 a
43
44 ¥,

} = film.rental_duration,

(

{THT

T
—

Find and Replace
Find

The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find -> Find from the

menu or press COMMAND-F, and then enter a search string.

Incremental searching is used here. As you type, the matched text is found and highlighted instantly. This saves your

time from typing the entire text.

Find B [Q«id 0] 4 » Done
SELECT

sakila.customer.customer_id,
sakila.customer.store_id,
sakila.customer.first_name,

sakila.customer.email
FROM

1
&
3
4
5 sakila.customer. Last_name,
[
T
8 sakila.customer

9

The search starts at the cursor's current position to the end of the file.
To find the previous or next occurrence, just simply click 4 or >
Replace

To open the Replace bar, simply choose Edit -> Find -> Find and Replace from the menu bar or press
OPTION-COMMAND-F. Then, enter the text you want to search and replace.

Click the Replace button to replace the first occurrence.

Click the Replace All button to replace all occurrences automatically.

Replace B [Q«id| 0] 4 > Done
ID Replace All  Replace
There are some additional options for Find and Replace, click Q.
Option Description
Regular Expression Search regular expressions.
Match Case Enable case sensitive search.
Whole Words Return the objects that match the entire word of the search string.
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Copy with Quotes

To copy the SQL statement with quotes, just simply control-click the highlighted SQL. Then, select Copy with Quotes

and choose the format.

Word Wrap

In the Word Wrap mode, the horizontal scrollbar is removed. SQL statement that exceed the width of the editor window

size wraps to the next line. To enable Word Wrap, choose View -> Word Wrap.

Zoom In/Zoom Out

Navicat has the ability to zoom in or zoom out the SQL in the editor. The zooming options are available from the View

menu. The same effect can be achieved with keyboard shortcuts.

Zoom In: [COMMAND-+]

Zoom Out: [COMMAND--]

Reset: [COMMAND-0]

Note: Editors that are opened in different tabs or windows will not be effected by the zoom.

SQL Builder (Available only in Non-Essentials Edition)

Navicat provides a useful tool called SQL Builder for building queries, views and materialized views visually. It allows
you to create and edit queries without knowledge of SQL. Even if you are familiar with SQL, the convenient and fluent

graphical interface makes it easier to create relations and visualize the query.

F
In Query Designer, click the 1 button to open the visual SQL Builder.

All database objects are displayed on the left Object pane. Whereas on the middle pane, it is divided into two portions:
the upper Diagram pane, and the lower Criteria pane. When building the query, you can view the auto-generated

query on the right SQL pane.

Note: SQL Builder supports SELECT statement only. Use SQL Editor for creating other complex queries (e.g. INSERT,
UPDATE, DELETE).
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[ ] [ ] staff_list@sakila (Default) - Query Builder

» = Default ") Table Relation @ Field Relation SELECT
vE sadla s.staff_id AS ID,
5 CONCAT(s.first_name, _utfB' ', s.last_n
actor a.address AS address,
FF address 0- 0- a.postal_code AS ‘zip code’,
R category . a.phone AS phone,
B city ] staff_id [ address_id city.city AS city,
T countr [] first_name V] address country.country AS country,
4 [] 1ast_name [[] address2 s.store_id AS SID
[ customer [] address_id [] district FROM
& fim [ picture [ cityid staff AS s
3 fim_actor [ aman ) |_[F]_nnctal anda ) JOIN
1 fim_category address AS a
oN
= fim_text s.address_id = a.address_id
[T inventory J0IN
7 1anguage city
oN
ayment
g :]E:‘m CENd9l FROM  WHERE GROUPBY  HAVING ORDERBY  LIMIT a.city_id = city.city_id
R staff s.staffid (ID) JOIN
% store Expression: CONCAT(s.first_name, _utf8' ' s.last_name) (name} ;;umw
= a.address (address) N . _d . . "
i city. country_id = country.country_ir
G0 actor_info a.postal_code (zip code) v - v -
ﬁ, customer_list a.phone (phone)
o film_i sakila.city.city (city,
R film_list kila.city.city (cit
{5 nicer_but_slower_film_list sakila.country.country (country)
{5 sales_by.film_category s.storeid (SID)
[55 sales_by store
55 staff_list
+ 4+ | DISTINCT
[ Cancel Build and Run Build

Add Objects to Query

The first step is to decide which tables and views you need to add to the query.
To add tables and views to the query, use one of the following methods:

* Drag them from the Object pane to the Diagram pane.

*  Double-click them on the Object pane.

You can set aliases for tables, views and subqueries by double-clicking the object title on the Diagram pane and

entering the name to use as an alias for the object name.
After you have added objects to the diagram, you can use the FROM tab to adjust the query to your needs.
* To change the object, click the object and select an identifier.

¢ To add the table alias, click <Alias>.

SELECT QYN WHERE GROUP BY HAVING ORDER BY  LIMIT

sakila.staff (s)
JOIN [s.address_id = a.address_id]

d |

JOIN [eity.countr, .J = country.country_id]
sakila.country

You can control-click an object on the Diagram pane and select Remove, or simply press DELETE key to remove the

selected object from the query.

When you remove an object, Query Builder automatically removes joins that involve that object.

Choose Output Fields

To include fields in the query, use one of the following methods:
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¢ Check the left checkbox of a field name you want to add to the query on the Diagram pane.
e Toinclude all the fields for an object, check the * checkbox on the Diagram pane.
e To add all fields for all objects, click ™ on the SELECT tab and select All fields(*).
The selected fields display on the SELECT tab. You can specify additional output field options.
e Check the DISTINCT checkbox to force the query to return distinct results.
e To add the field alias, click <Alias> and enter the name.
e Click the identifier and select the Aggregate function.
e Use the up arrow and down arrow buttons to change the order of fields.

Set Field Association

Query Builder will automatically join the tables as per the foreign key relations. If you want to associate database
objects manually, just select a field from an object and drag it to a field in another object. A connector line appears

between the two objects to visually represent the relationship and the join type.

There are two views to show the connector lines: Table Relation and Field Relation. The Field Relation view allows
you to identify matching fields in two tables, while the Table Relation view displays the join relationship between the

two tables.

All'joins is initially created as INNER JOIN by default. To change the association, click or double-click the connector line
on the Diagram pane or click the JOIN keyword on the FROM tab, and then select a join type. If a join type is not listed,

you can enter a customized one in the Custom textbox.

0- O-
[ city_id [ country_id
[v] city [wf] country

sakila.city “v sakila.country

city.cot
INNER JOIN

Select all records from Table L and Table R, where
the join condition is met.

LEFT JOIN
() Select all records from Table L, aleng with records
from Table R for which the join condition is met (i

fatall).

RIGHT JOIN | &

Select all records from Table R, along with record
s from Table L for which the join condition is met (
if at all).

CROSS JOIN

Select every record from Table L crossing with all
the records from Table R.

FULL OUTER JOIN
"’ Select all records from Table L and Table R, regar

To remove a join, control-click the connector line and select Remove.

To modify the join condition, control-click a connector line and select Edit Join, or click the condition on the FROM tab.
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sakila.staff (s)

SELECT @zl WHERE GROUP BY HAVING ORDER BY  LIMIT

LEFT JOIN [s.address_id = a.address_id]

sakila.address (a)

JOIM Ta.citv id = citv.citv i

sakila.city

Insert
Insert Bracket

JOIN [city.country_id = c.c|

sakila.country (c)

| Remove

Clear And Convert To USING Clause

The pop-up menu options of the FROM tab:

Option

Description

Insert

Add an identifier, an expression or a subquery.

Insert Bracket

Add a pair of parentheses.

Remove

Remove the identifier, expression or subquery.

Clear and Convert to
USING Clause

Remove the ON condition and convert it to USING clause.

Clear and Convert to ON

Clause

Remove the USING condition and convert it to ON clause.

Group with Bracket

Add parentheses to group the selected conditions.

Ungroup

Remove the parentheses.

Set Filter Criteria

When retrieving data, you may want to set up a filtering expression. To filter data returned by the query, control-click a

field on the Diagram pane and select WHERE and an operator.

The condition is added to the WHERE tab. You can edit the value there by clicking <Value>. If you want to add a

condition with parentheses, click

. You can change a logical operator (and/or) by clicking it. Use the up arrow and

down arrow buttons to change the order of conditions.

SELECT FROM QUGG GROUPBY  HAVING  ORDERBY  LIMIT

s.staff_id < 10 OR

(

s.store id = 2 AND Toggle Negator
s.active <> 1

Insert

Insert Custom
Insert Bracket
Remoaove

Group with Bracket

The pop-up menu options of the WHERE tab:

Option

Description

Toggle Negator

Reverse the meaning of the condition.

Insert

Add a condition.
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Insert Custom Add a custom condition.

Insert Bracket Add a pair of parentheses.

Remove Remove the condition.

Group with Bracket Add parentheses to group the selected conditions.
Ungroup Remove the parentheses.

Group Resulting Data

You can set the conditions for grouping query records by control-clicking a field in the Diagram pane and selecting
GROUP BY -> Add Fields.

The condition is added to the GROUP BY tab. Use the up arrow and down arrow buttons to change the order of fields.

On the HAVING tab, you can filter summarized data or grouped data. Select the identifiers, operators, aggregate or
enter expressions to include in the condition. Use the up arrow and down arrow buttons to change the order of

conditions.

The pop-up menu options of the HAVING tab:

Option Description

Toggle Negator Reverse the meaning of the condition.

Insert Add a condition.

Insert Custom Add a custom condition.

Insert Bracket Add a pair of parentheses.

Remove Remove the condition.

Group with Bracket Add parentheses to group the selected conditions.
ungroup Remove the parentheses.

Sort Resulting Data

You can set the way of sorting query records by control-clicking a field on the Diagram pane and selecting ORDER BY
-> ASC or DESC. The condition will be added to the ORDER BY tab.

Limit Resulting Data

On the LIMIT tab, you can limit your query results to those that fall within a specified range.

Offset

Specify the number of records to be skipped. It is optional.

Limit

Specify the number of records to be displayed.

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB.
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Add Expressions/Subqueries

You can add an expression or a subquery to further limit the query results. On the FROM tab, click “* and select the
Expression/Subquery tab.

After entered an expression or a subquery, confirm editing by pressing the ENTER key. It will be added to the Diagram

pane indicates that the statement contains an expression or a subquery and identifies the columns it is on.

D N SELECT *, sakila.city.city id, sakila_city.city, sakila.city.country_id FROM

E‘ country. id sakila.city X
[ country D . !
[] tast_update [ city_id

] eity

I:‘ country_id

|:| last_update

By clicking the r button, you will be switched to a subquery layer where you can build it visually in the same way as
the main query.

You can always go back to the main query by clicking (Main Query).

View Generated SQL

The SQL pane presents a read-only, formatted representation of the SQL generated by Query Builder. You can copy
the SQL that appears in the SQL pane for use in other tools. In a subquery layer, you can enable Show Current Layer

Only to show the subquery SQL.

Query Parameters

Query supports using of parameters inside the query text. You can set query parameters to add variable values to a
guery each time you run it. The parameter should appear as an identifier with $ at its beginning, quote with [ ], e.g.

[$any_name].

Execute the query and the Input Parameters dialog is provided for you to enter the desired data you wish to search.

Check the Raw Mode option to pass the inputted values to the query without quotation marks.

Debug Oracle Query (Available only in Non-Essentials Edition)

To debug an Oracle query, click & on the toolbar to launch the Oracle Debugger.

Enter the parameters if the query has input parameters.

Query Results

You can run the query in any servers. Select the target connection, database and/or schema from the drop-down menu

on the toolbar, and then click > if the query statement is correct, the query executes and, if the query statement is
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supposed to return data, the Result tab opens with the data returned by the query. If an error occurs while executing

the query, execution stops, the appropriate error message is displayed.

The Result tab displays the result data, returned by the query, as a grid. Data can be displayed in two modes: Grid

View and Form View. See Data Viewer for details.
Note: Navicat supports to return 20 result sets.

You can choose to show results below the editor or in a new tab by choosing View -> Results -> Show Below Editor

or Show in New Page.

You are allowed to run selected portion of query, just simply highlight SQL in SQL Editor and click P . To run the
current statement your cursor is on (position the cursor within the desired statement), just simply click and hold the >
button and select Run Current Statement.

Custom Tab Name

To customize the names of the result tabs, simply add -- NAME:tab_name or /*NAME:tab_name*/ before each
SELECT statement in the SQL Editor.

SQL Editor Message actor  payment  Profile  Status
I

SELECT * FROM actor;

M : pay
SELECT # FROM payment;

Show Profile and Status (Available only for MySQL and MariaDB)

To show the profile and status when running the query, simply choose View -> Show Profile and Status and click >
on the toolbar.

The Profile tab displays the query profile: Table lock, System lock, Statistic, etc.
Note: For MySQL 5.0, supported from 5.0.37. For MySQL 5.1, supported from 5.1.24.

The Status tab displays the query status: Bytes received, Bytes sent, etc.

MongoDB

Script Editor

Script Editor allows you to create and edit a script, prepare and execute selected script. Drag-and-drop or double-click

an identifier in the right Identifiers pane to add it to the editor.
Hint: Script will be automatically generated in Script Editor while you build in Find Builder or Aggregate Builder.

Navicat provides a wide range advanced features, such as compelling code editing capabilities, smart code-completion,

script formatting, and more.
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Script Formatting

To change the script format, simply choose from the Format menu -

Indent

Increase/decrease indent for the selected lines of codes.

Comment

Comment/uncomment the selected lines of codes.

Beautify Script (Available only in Non-Essentials Edition)

Format the selected codes.

Code Completion (Available only in Non-Essentials Edition)

Code completion feature in Navicat pops up a list of suggestions as you type your script in the editor. It assists you with

database names, collection names, view names, document field names and shell methods with their appropriate icons

and information. You can update the code suggestions with latest database information by choosing Edit -> Code

Completion -> Update Code Completion Info.

Code completion can be invoked by typing a dot (.), a character or pressing ESC.

1
2
3
4
5
3
7
8
]

1@

Edh.get(oltec‘tioni't—'1pL3'ye-:-:-"
E] “EMPLOYEE_ID": {
ggt: 185

- }
hA

_id: @,

BIRTHDATE: @
H.sort({

DE

- departments

@ duty_time
delete
debugger

&= demo
UPDATE Syntax
db.collection.find()
db.collection.insert()

db.collection.update()
do...while...
fx Code

). find({

hr

hr

demo

When the suggestion list appears, press TAB to insert the first item. You can also select the needed item using UPPER

ARROW or DOWN ARROW and then press TAB or ENTER.

If you select a snippet name from the list, the saved code will be inserted to the editor.
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1
2
|
4
5
[
T/
8
]

1@

E]dh.get(ollectioni“empLoyeeﬂ”}.findi{
E “EMPLOYEE_ID": {

3gt: 185
- }
oA
_id: @,
BEIRTHDATE: @
}.sert({

o
y @ countries hr
@ locations hr
const

continue

COMMENTS Code Snippet = MongoDB
constructor

&= config config
S COoWCOW COWCOW
Jx Code
f} Code (code, scope

db.collection. find() Code Snippet MongoDB

Hint: Resize the suggestion list by dragging the lower right corner.

You can enable or disable the code completion feature in Preferences.

Clipboard Stack

When you copy or cut some codes as usual in the editor, the copied content will also be added to Clipboard Stack.
Clipboard Stack can store up to 10 items and use the last-in-first-out logic. To paste an item from Clipboard Stack, you
can press COMMAND-SHIFT-V. Press COMMAND-SHIFT-V multiple times to cycle through Clipboard Stack.

Code Folding

Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in Script

Editor.

A block of code that can be folded is indicated by an icon | to the left of the first line of the block. A vertical line

extends from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon

to left of the code block. You can fold the block by clicking = or expand it by clicking [,

Brace Highlight

1 []db.getCollection("employees" ). find({

23 “EMpLOYEE_ID": { [.]
5 |} 4

6 _id: @,

T BIRTHDATE: @

8 | V.sort{{

9 "DEPARTMENT_ID": q

1 =1

Navicat supports to highlight the matching brace in the editor, i.e. () .

Note: The cursor must be on a brace to show the highlight.
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1 Hdb.getCollection("employees"}. find({
2 E] “EMPLOYEE_ID": {

3 $gt: 1as

4 - }-

5 h A

g _id: @,

7 BIRTHDATE: @

8 | }.sorti{{

9 “DEPARTMENT_ID": 1

1 -3}

Find and Replace
Find

The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find -> Find from the

menu or press COMMAND-F, and then enter a search string.

Incremental searching is used here. As you type, the matched text is found and highlighted instantly. This saves your

time from typing the entire text.

Find B | oig ol <« » Done
1 Edh.get(ouection(' employees"}.find({
2 “EMPLOYEE_ID": {

3 ggt: 185

4 + }

5 |4

6 _id: @,

7 BEIRTHDATE: @

8 | }).sort({

9 “DEPARTMENT_ID": 1
1 -4

The search starts at the cursor's current position to the end of the file.
To find the previous or next occurrence, just simply click 4 or >
Replace

To open the Replace bar, simply choose Edit -> Find -> Find and Replace from the menu bar or press
OPTION-COMMAND-F. Then, enter the text you want to search and replace.

Click the Replace button to replace the first occurrence.

Click the Replace All button to replace all occurrences automatically.

Replace B QD e 4 »r Done
NUM| Replace All  Replace
There are some additional options for Find and Replace, click Q.
Option Description
Regular Expression Search regular expressions.
Match Case Enable case sensitive search.
Whole Words Return the objects that match the entire word of the search string.
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Copy with Quotes

To copy the script with quotes, just simply control-click the highlighted script. Then, select Copy with quotes and
choose the format.

Word Wrap

In the Word Wrap mode, the horizontal scrollbar is removed. Script that exceed the width of the editor window size
wraps to the next line. To enable Word Wrap, choose View -> Word Wrap.

Zoom In/Zoom Out

Navicat has the ability to zoom in or zoom out the script in the editor. The zooming options are available from the View

menu. The same effect can be achieved with keyboard shortcuts.
Zoom In: [COMMAND-+]

Zoom Out: [COMMAND--]

Reset: [COMMAND-0]

Note: Editors that are opened in different tabs or windows will not be effected by the zoom.

Find Builder (Available only in Non-Essentials Edition)

Navicat provides Find Builder for building queries visually to select documents in a collection or view. It allows you to

create and edit queries without knowledge of the find command.
In Query Designer, click the E% button to open the visual Find Builder.

ece Find Builder
Collection/View: employees

m Projection Sort  Limit Script Preview

EMPLOYEE_ID » 200 Mumber and
(
JOB_ID contains IT or
MANAGER_ID = 101 Number
) and
{
SALARY < 11000 Number
)

Cancel

Select the name of the collection or view to query from the Collection/View drop-down menu.
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Filter

In this tab, you can specify selection filters for the query. Documents that meet the conditions will be returned. If you not
specify the filter, all documents will be returned. See Filter Wizard for details.

Projection

In this tab, you can choose which fields to include or exclude in the returned documents. If you not specify the
projection, all fields will be returned.

Sort

In this tab, you can sort the returned documents by fields in ascending or descending order.
Limit

In this tab, you can limit the maximum number of documents to return and set the number of documents to skip.

Aggregate Builder (Available only in Non-Essentials Edition)

Navicat provides Aggregate Builder for building queries visually to return computed results. It allows you to create and

edit queries without knowledge of the aggregate command.
In Query Designer, click the £25 button to open the visual Aggregate Builder.

[ JoN ] Aggregate Builder

Collection/View: employees

Script Preview

Operator Expression

$match L

$sort
$limit

Expression

2 | _id: “EMPLOYEE_ID",
Ef | field: {

4 | $sum: “SALARY"

Cancel

Select the name of the collection or view to query from the Collection/View drop-down menu

Pipeline
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In this tab, you can add aggregation pipeline stages. In the Operator column, select an expression operator. An

expression template will be generated in the Expression column, you can modify the template.

Query Results

You can run the query in any servers. Select the target connection and database from the drop-down menu on the

toolbar, and then click P If the query script is correct, the query executes and, if the query script is supposed to return
data, the Result tab opens with the data returned by the query. If an error occurs while executing the query, execution

stops, the appropriate error message is displayed.

The Result tab displays the result data, returned by the query, as a grid. Data can be displayed in three modes: Grid

View, Tree View and JSON View. See Data Viewer for details.
Note: Navicat only returns the last result data.

You can choose to show results below the editor or in a new tab by choosing View -> Results -> Show Below Editor

or Show in New Page.

You are allowed to run selected portion of query, just simply highlight script in the editor and click >

Code Snippets (Available only in Non-Essentials Edition)

Code Snippets provide a easy way for you to insert reusable code into editor when writing statements or scripts. The

Code Snippet pane is on the right side of the editor. If the editor window is docked to the Navicat main window, you can

click the () icon in the Information pane to open the library.

The library includes built-in and user-defined snippets. Choose a label from the drop-down menu or enter a search
string in the Search box to filter the list. If you want to show the available snippets according to your database type, you

can control-click anywhere on the library and disable Hide Snippets For Other Database Type.
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(O - NON: |

[ All Labels ¢] (&

2
B!

Batchlnsert Cenera
Batch Insert Statements

CreateFunction DDL
Create Function Template

DropTable DDL
Drop Table Statement

INSERT Syntax DML
Insert new rows into an existing
table

InsertUser DL
Insert Records in User Table

SELECT Syntax DN
Retrieve rows selected from one
or more tables

SelectAll Cenerz
Select All From a Table

UpdateUser DL
Update User Table Records

o]

Built-in snippets are non-editable. A user-defined snippet can be edited by double-clicking it in the library and clicking

Edit. If you want to hide the built-in snippets, you can control-click anywhere on the library and disable Show Preset

Snippets.

Use Code Snippets

There are two ways to insert a snippet into the editor.

* You can start typing the name of a snippet in the editor. Smart code completion will pop up a list of suggestions

for the word completion automatically. Select a snippet name from the list, the saved code will be inserted to the

editor.

=

2
223
i
[
Jx

customer_list

sales_by_film_category

nicer_but_slower_film_list
special_features
get_customer_balance(int p_customer_id,

sakila
sakila
sakila
saki...film

sakila

SelectAll Snippet - General

SELECT Syntax
SERIALIZABLE

SQL_BIG_RESULT

* You can simply drag and drop a snippet from the library into the editor.

After inserting the snippet with placeholders to the editor, you can easily navigate to them by clicking on one of the

placeholders, and then using the TAB key and entering the information.
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Create Code Snippets

SELECT
[field_namel],
[field_name2],
[field_name3]

FROM
[tablel]

INNER JOIN
[table2] oON [conditionl]

(=T (Y T S PYR

You can create your own code snippets and add them to the library. To create a code snippet, select your desired code

in the editor, then control-click and select Create Snippet, or simply drag and drop the selected code to the Code

Snippet pane.

Alternatively, click (3 inthe Code Snippet pane. If you use this method, you must manually enter the code in the New

Snippet window; code selected in the editor is not automatically added to the Code box.

Hint: Code snippets (.nsnippet) are stored under the default path, e.g. ~/Library/Application Support/PremiumSoft

CyberTech/Navicat CC/Common/Snippet.

Option / Button

Description

Untitled text box

Enter the name of the snippet that displays in the library and the code completion list.

Database Type

Choose the database server type of the snippet.

Label Choose an existing label or enter a new label name for the snippet.

Remarks Enter a description for the snippet that displays in the library.

Code Enter the code.

= Add a placeholder by highlighting any words in the code and click this button. The
placeholder will be highlighted in light green.

= Remove a placeholder by highlighting it in the code and click this button.
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Chapter 8 - Model (Available only in Navicat

Premium and Enterprise Edition)
About Model

Model is a powerful tool for creating and manipulating database models. In the main window, click Model to open
the model object list.

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server and MariaDB.
Some of key features are listed here:
* Create and manipulate conceptual/logical/physical models.
Note: Only Navicat Premium supports conceptual and logical models.
* Reverse engineer a database/schema, tables or views to a physical model.
* Forward engineer a physical model to a sql file or database/schema.
* Create and edit table structures directly.

To create a model, click % from the object toolbar. The New Model window will pop up for you to select the Database,
Version and/or Edition.

Hint: Model files (.ndm2/.ndml2/.ndmc2) are saved under the default path, e.g. ~/Library/Application
Support/PremiumSoft CyberTech/Navicat CC/Navicat Premium/Profiles. To open the folder, control-click a model file

and select Show in Finder. If the model is synchronized to Navicat Cloud, it is stored in the Cloud.
Open an external model file
1. Control-click anywhere in the Objects tab and select Open External Model from the pop-up menu.
2. Browse the file and click Open in the dialog window.
Save an opened external file as a Navicat model
1. In Model Designer, choose File -> Save to Navicat.
2. Enter the model name and choose the save location.
3. Click OK.
Save a Navicat model as an external file
1. In Model Designer, choose File -> Save As External File.

2. Choose the save path and enter the file name.



3. Click Save.

Model Window

The Model Window consists of a toolbar, several panes and a diagram canvas for you to design your model. A model
file can have more than one diagram. Each diagram is represented by a tab in the model. To create a new diagram,
choose Diagram -> New Diagram from the menu bar.

ece SQL 3schemas
[ saQL_3schemas

O B ~«~TEeeE = (1)

HR ¢ a in[u) ®
Active Diagram ® Table @
» EE Tables @
5 views Name | Employechddress
» — Foreign Keys Schema | HumanResources
v T Lapels B B
T FK_EmployeeAddress_Empioyee.... Position | 1576 8 340 <
T FK_VendorAddress_Address Add... /7 DepartmentiD: smallint ) X . ¥ :
Name: [dbo].[Name] Size | 300 ) 120 <)
T FK_VendorContact_Contact_Cont... e Width Heigit -
T FK_vendorGentact_Vendor Vend... 2 more columns
= otes coor ||
[ad) iImages "1 Bold
[ shapes FK_E _Employee_E! D J° EmployeelD: int
v 1 Leyers o 3 more columns.
T4 vendor $
Person.Contact Person.ContactType
Names of each employee, ... Lookup table containing. .. @
Histary /7 ContaetiD: int 3 more columns..
Create Model —H NameStyle: [dbo] [NameSt.
Show Table Comment of Diagram "HR" Title: nvarchar(8) :F — :
FirstName: [dbo] [Name] L] . E‘:
MiddleName: [dbol [Name]
LastName [dbo] [Mame] [ | . I =
Suffix: nvarchar(10) - [ |
EmailAddress: nvarchar(50)
EmailPromotion: int
6 more columns.
FK_VendorContact_Vendor_Vi
s ]

00% S

Table "EmployecAddress" is selected.

@ Toolbar

The Toolbar is located near the top of the Model Window. The buttons display in the toolbar depend on the model type
(physical, logical and conceptual). You can use the toolbar to perform some basic tasks, such as adding tables, entities

or views, applying Auto Layout feature, etc.
@ Explorer Pane

The Explorer pane has two tabs: Model and Active Diagram. The Model tab holds all tables or views in the
model, including those used in each individual diagram.The Model tab holds all schemas, tables, views, entities in the
model, including those used in each individual diagram. You can simply drag an object from the Model tab and drop to
the active diagram canvas. The Active Diagram tab holds all the objects (tables, views, foreign keys, layers, notes,
images, etc) added to the active diagram. If the Explorer pane is hidden, choose View -> Show Explorer from the

menu bar.

@ History Pane

The History pane shows all the actions that you have taken. Simply click an action to restore that state. If the History

pane is hidden, choose View -> Show Explorer and Show History from the menu bar.

@ Properties Pane
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The Properties pane includes the Model, Diagram and 5] Object tabs for setting default properties for your
model. You can edit the properties settings of the model, the active diagram and the selected objects quickly. If the

Properties pane is hidden, choose View -> Show Properties from the menu bar.

Option

Description

Begin Style

The style of the arrow's back.

Black and white

Check this box to change the diagram color to black and white.

Bold

Check this box or press COMMAND-B to bold the table, view, entity,

foreign key, relation or shape.

Border Color

The color of the shape's border.

Cap Style

The cap style of the line/arrow.

Cardinality

The foreign key/relation cardinality of the table/entity.

Case Sensitive

The case sensitivity of the table or view names. Available only for MySQL

and MariaDB models.

Color The color of the object.
Dash Style The dash style of the line/arrow.
Database The database server type of the model.

Database Version

The database version of the model.

Default Database

The default database of the model.

Default Schema

The default schema of the model.

End Style The style of the arrow's front.

Entity Font The font and font size of tables/entities.

Font The font and font size of notes, labels or layers.
Font Color The font color of notes, labels or layers.

Join Style The join style of the line/arrow.

Model Type The type of the model.

Model Version

The version of the model.

Name The name of the object.

Notation The notation of the diagram. The notation options are depended on the
model type.

Note Style The style of the note. The value for this can be Note or Label.

Opacity The transparency of the image/shape.

Pages The width and height of the diagram (number of papers).

Position The number of pixels from the object to the left side (X) and the top () of
the canvas.

Referenced The referenced (parent) table, view or entity.

Referencing

The referencing (child) table, view or entity.

Schema

The database/schema name of the table/view.

Show entity comments

Check this box to show the entity comments in the diagram.

Show field comments

Check this box to show the field comments in the diagram.

Show name

Check this box to show the name of the foreign key, relation or shape.

Show schema name

Check this box to show the database/schema names of the tables/views in
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the diagram.

Show table comments Check this box to show the table comments in the diagram.

Show view relationships Check this box to show the relationship line of the view.

Size The width and height of the object.

Visible Check this box to show the foreign key or relation lines.

L2} Overview Pane

The Overview pane displays the whole active diagram in the canvas. To zoom in or zoom out the selected area of the

diagram, adjust the slider. Same effect can be achieved with keyboard shortcuts:

Zoom In: [COMMAND-Mousewheel Up]

Zoom out: [COMMAND-Mousewheel Down]

If the Overview pane is hidden, choose View -> Show Properties and Show Overview from the menu bar.
® Diagram Canvas

You can design your diagram on the Diagram Canvas. All added objects can be moved (by dragging them with mouse

or by keyboard), resized, aligned to the grid, etc.

Physical Models

Create Physical Models

Navicat allows you to create physical models, including tables, fields, views, foreign key constraints and other physical

properties of the database/schema.
In the New Model window, choose the Model Type and select the target Database and Version if necessary.

After creating a physical model, you can compare and synchronize it to an existing database/schema or export it to a
SQL file.

Add Databases / Schemas

When creating a new model, a database/schema (named Default) is automatically created and it is the default

database/schema. All newly added objects (tables and views) are belonged to the default database/schema.
You can view all databases/schemas with their objects as tree structure on the Explorer's Model tab.

The pop-up menu options of a database/schema in the Explorer's Model tab include:

Option Description
New Database / New Create a database/schema.
Schema

Delete Database / Delete | Delete the selected database/schema including its objects from the model.

Schema The default database/schema cannot be deleted.
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Rename Change the name of the database/schema.

Set As Default Database / | Set the selected database/schema as the default database/schema.

Set As Default Schema

Add Tables

To add a new table, click the & button from the toolbar and click anywhere on the canvas. To add an existing table
from the Explorer's Model tab, simply drag and drop the selected table from the Model tab to the canvas.

For Default diagram notation, the ¢ icon means the field is a primary key. The icon indicates that the field serves
as an index.

Note: If you control-click a field, you can choose to add, insert, delete, rename the field and set the field as primary key.

The pop-up menu options of the table object in the canvas include:

Option Description

Design Table Edit the table structure in a table designer, e.qg. fields, indexes, foreign
keys, etc. The tabs and options in the designer depend on the diagram
database type you are chosen.

Add Related Objects Add all related tables/views to the selected table.

Add Field Add fields to the existing table.

Cut Remove the table from the diagram and put it on the clipboard.

Copy Copy the table from the diagram to the clipboard.

Paste Paste the content from the clipboard into the diagram.

Select All Tables Select all tables in the diagram.

Delete Delete a table from the diagram or from both diagram and model.

Rename Change the name of the table.

Color Change the color of the table.

Size to Fit Resize the table automatically to fit its contents.

Bring to Front Bring the table to the foreground.

Send to Back Move the table to the background.

Add Views

To add a new view, click the T button from the toolbar and click anywhere on the canvas. To add an existing view

from the Explorer's Model tab, simply drag and drop the selected view from the Model tab to the canvas.

Note: If you control-click the view connector, you can choose to add or delete vertices and change its color, or go to the

source view or the target table.

The pop-up menu options of the view object in canvas include:

Option Description
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Design View

Edit the view structure in a view designer. The tabs and options in the

designer depend on the diagram database type you are chosen.

Add Related Objects

Add all related tables/views to the selected view.

Cut Remove the view from the diagram and put it on the clipboard.
Copy Copy the view from the diagram to the clipboard.
Paste Paste the content from the clipboard into the diagram.

Select All Views

Select all views in the diagram.

Delete Delete a view from the diagram or from both diagram and model.
Rename Change the name of the view.

Color Change the color of the view.

Size to Fit Resize the view automatically to fit its contents.

Bring to Front

Bring the view to the foreground.

Send to Back

Move the view to the background.

Add Foreign Keys

To add a foreign key, click the — button from the toolbar and drag and drop a field from the child table to the parent
table. To show/hide the linked name label, simply check/uncheck the Show name option in the Properties pane.

When you move your mouse over a foreign key connector, the border of the parent and the child tables turn to green

and blue respectively. Also, the referenced fields and the referencing fields are highlighted.

The pop-up menu options of the foreign key in canvas include:

Option

Description

Design Relation

Edit the foreign key in a table designer. The options in the designer depend

on the diagram database type you are chosen.

Cardinality on table_namel

Set the cardinality on table_namel: None, One and Only One, Many, One

or Many, Zero or One, Zero or Many.

Cardinality on table_name2

Set the cardinality on table_name2: None, One and Only One, Many, One

or Many, Zero or One, Zero or Many.

Add Vertex

Add a vertex on a foreign key connector.

Delete Vertex

Delete a vertex on a foreign key connector.

Delete All Vertices

Delete all vertices on a foreign key connector.

Paste

Paste the content from the clipboard into the diagram.

Select All Relations

Select all foreign keys in the diagram.

Delete

Delete a foreign key from both diagram and model.

Color

Change the color of the foreign key.
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Logical Models

Create Logical Models

Navicat Premium allows you to create logical models, including entities, attributes and relations.

In the New Model window, choose Logical as Model Type.

Add Entities

To add a new entity, click the = button from the toolbar and click anywhere on the canvas. To add an existing entity

from the Explorer's Model tab, simply drag and drop the selected entity from the Model tab to the canvas.

For Default diagram notation, the # icon means the attribute is a primary key. The icon indicates that the

attribute serves as an index.

Note: If you control-click an attribute, you can choose to add, insert, delete, rename the attribute and set the attribute

as primary key.

The pop-up menu options of the entity object in the canvas include:

Option

Description

Design Entity

Edit the entity structure in an Entity Designer, e.g. attributes and relations.

Add Related Objects

Add all related objects to the selected entity.

Add Attribute Add attributes to the existing entity.

Cut Remove the entity from the diagram and put it on the clipboard.
Copy Copy the entity from the diagram to the clipboard.

Paste Paste the content from the clipboard into the diagram.

Select All Entities

Select all entities in the diagram.

Delete Delete an entity from the diagram or from both diagram and model.
Rename Change the name of the entity.

Color Change the color of the entity.

Size to Fit Resize the entity automatically to fit its contents.

Bring to Front

Bring the entity to the foreground.

Send to Back

Move the entity to the background.

Add Relations

To add a relation, click the — button from the toolbar and drag and drop an attribute from the child entity to the parent

entity. To show/hide the linked name label, simply check/uncheck the Show name option in the Properties pane.

When you move your mouse over a relation connector, the border of the parent and the child entities turn to green and

blue respectively. Also, the referenced attributes and the referencing attributes are highlighted.

The pop-up menu options of the relation in the canvas include:
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Option Description

Design Relation Edit the relation in an Entity Designer.

Cardinality on Set the cardinality on entity_namel: None, One and Only One, Many, One
entity_namel or Many, Zero or One, Zero or Many.

Cardinality on Set the cardinality on entity_name2: None, One and Only One, Many, One
entity_name2 or Many, Zero or One, Zero or Many.

Add Vertex Add a vertex on a relation connector.

Delete Vertex Delete a vertex on a relation connector.

Delete All Vertices Delete all vertices on a relation connector.

Paste Paste the content from the clipboard into the diagram.

Select All Relations Select all relations in the diagram.

Delete Delete a relation from both diagram and model.

Color Change the color of the relation.

Conceptual Models

Create Conceptual Models

Navicat Premium allows you to create conceptual models, including entities and relations.

In the New Model window, choose Conceptual as Model Type.

Add Entities

To add a new entity, click the ™ button from the toolbar and click anywhere on the canvas. To add an existing entity
from the Explorer's Model tab, simply drag and drop the selected entity from the Model tab to the canvas.

The pop-up menu options of the entity object in the canvas include:

Option Description

Add Related Objects Add all related objects to the selected entity.

Cut Remove the entity from the diagram and put it on the clipboard.
Copy Copy the entity from the diagram to the clipboard.

Paste Paste the content from the clipboard into the diagram.

Select All Entities Select all entities in the diagram.

Delete Delete an entity from the diagram or from both diagram and model.
Rename Change the name of the entity.

Color Change the color of the entity.

Size to Fit Resize the entity automatically to fit its contents.

Bring to Front Bring the entity to the foreground.

Send to Back Move the entity to the background.
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Add Relations

To add a relation, click the — button from the toolbar and drag the child entity and drop to the parent entity. To

show/hide the linked name label, simply check/uncheck the Show name option in the Properties pane.

When you move your mouse over a relation connector, the border of the parent and the child entities turn to green and

blue respectively.

The pop-up menu options of the relation in the canvas include:

Option

Description

Cardinality on

entity_namel

Set the cardinality on entity_namel: None, One and Only One, Many, One

or Many, Zero or One, Zero or Many.

Cardinality on

entity_name2

Set the cardinality on entity_name2: None, One and Only One, Many, One

or Many, Zero or One, Zero or Many.

Add Vertex

Add a vertex on a relation connector.

Delete Vertex

Delete a vertex on a relation connector.

Delete All Vertices

Delete all vertices on a relation connector.

Paste

Paste the content from the clipboard into the diagram.

Select All Relations

Select all relations in the diagram.

Delete

Delete a relation from both diagram and model.

Color

Change the color of the relation.

Diagram Layout

Work with Diagram Canvas

Show Grid Lines

To turn the grid on in the diagram canvas, choose Diagram -> Show Grid Lines from the menu bar.

Snap to Grid

To align objects on the canvas with the grid, choose Diagram -> Snap to Grid from the menu bar.

Change Diagram Notation

To change the notation of the diagram, choose Diagram -> Diagram Notation from the menu bar.

Note: The options depend on the diagram type you are chosen.

Option Description

Default The default notation style used in Navicat.

Simple A simple notation style. The table or view will only show the name.
IDEF1X The ICAM DEFinition language information modeling method.
UML Universal Modeling Language style.
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IE (Crow's Foot) Crow's Foot notation style.

Black and White Change the color of the diagram to black and white.

Show Schema Name Show the schema names of the tables and views in the diagram.

Show View Relationships | Show the relationship lines of views in the diagram.

Show Entity Comments Show the entity comments in the diagram.
Show Table Comments Show the table comments in the diagram.
Show Field Comments Show the field comments in the diagram.

Change Diagram Dimensions

To change the number of pages used in the diagram, choose Diagram -> Diagram Dimensions from the menu bar
and set the Width and the Height.

Align Objects

To align objects on the canvas, select more than one object (tables, entities, views, notes, labels, images or shapes),
then control-click and select Alignment -> Align Left, Align Center, Align Right, Align Top, Align Middle or Align

Bottom.
Change Objects Distribution

To distribute objects on the canvas, select more than one object (tables, entities, views, notes, labels, images or

shapes), then control-click and select Distribute -> Horizontal or Vertical.
Change Page Setup

To change paper size, orientation and margins, choose File -> Page Setup.
Apply Auto Layout

To automatically arrange objects on the canvas, click the 5% putton. To change the Auto Layout format settings,
simply choose Diagram -> Auto Layout With from the menu bar and set the following options:

Option Description
Space Between Objects The distance between the objects in the diagram.
Number of Trials The quality of the auto layout output.
Auto Dimension Choose the suitable diagram dimension automatically.
Tables resize to fit Resize the table to fit its content automatically.

Add Labels

Labels are typically used to help document the diagram design process. For example, to explain a grouping table

objects. To add a new label, click the T button from the toolbar and click anywhere on the canvas.

The pop-up menu options of the label object in canvas include:

Option Description
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Edit Change the content of the label.

Cut Remove the label from the diagram and put it on the clipboard.
Copy Copy the label from the diagram to the clipboard.
Paste Paste the content from the clipboard into the diagram.

Select All Labels Select all labels in the diagram.

Delete Delete a label from the diagram.

Size to Fit Resize the label automatically to fit its contents.

Bring to Front Bring the label to the foreground.

Send to Back Move the label to the background.

Add Notes

Notes are typically used to help document the diagram design process. For example, to explain a grouping table

objects. To add a new note, click the (=) button from the toolbar and click anywhere on the canvas.

The pop-up menu options of the note object in canvas include:

Option Description

Edit Change the content of the note.

Style Change the style of the note: Note or Label.

Cut Remove the note from the diagram and put it on the clipboard.
Copy Copy the note from the diagram to the clipboard.

Paste Paste the content from the clipboard into the diagram.

Select All Notes

Select all notes in the diagram.

Delete Delete a note from the diagram.
Color Change the color of the note.
Size to Fit Resize the note automatically to fit its contents.

Bring to Front

Bring the note to the foreground.

Send to Back

Move the note to the background.

Add Images

You can insert images (BMP, JPG, JPEG or PNG files) to your model for design or identification purposes. To add a

new image, click the @l putton from the toolbar and click anywhere on the canvas. Then, select an image file in the
Open dialog box.

The pop-up menu options of the image object in canvas include:

Option Description

Reset Size Reset the size of the image to its original size.

Reset Aspect Ratio Maintain the image original width to height ratio.

Cut Remove the image the diagram and put it on the clipboard.

Copy Copy the image from the diagram to the clipboard.
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Paste Paste the content from the clipboard into the diagram.
Select All Images Select all images in the diagram.
Delete Delete an image from the diagram.
Bring to Front Bring the image to the foreground.
Send to Back Move the image to the background.
Add Shapes

Navicat includes some pre-defined shapes for creating database model diagrams: line, arrow, rectangle, ellipse, user,

database, cloud, trigger, server, desktop or mobile. To add a new shape, click the B button from the toolbar and
choose the type of shape. Then, click anywhere on the canvas. To show/hide the linked name label, simply

check/uncheck the Show name option in the Properties pane.

The pop-up menu options of the shape object in canvas include:

Option Description

Reset Aspect Ratio Maintain the shape original width to height ratio.
Only for rectangle, ellipse, user, database, cloud, trigger, server, desktop

and mobile.

Add Vertex Add a vertex on a line or arrow.

Only for line and arrow.

Delete Vertex Delete a vertex on a line or arrow.

Only for line and arrow.

Delete All Vertices Delete all vertices on a line or arrow.

Only for line and arrow.

Cut Remove the shape from the diagram and put it on the clipboard.
Copy Copy the shape from the diagram to the clipboard.

Paste Paste the content from the clipboard into the diagram.

Select All Shapes Select all the shapes in the diagram.

Delete Delete a shape from the diagram.

Color Change the color of the shape.

Border Color Change the color of the shape's border.

Only for rectangle, ellipse, user, database, cloud, trigger, server, desktop

and mobile.
Bring to Front Bring the shape to the foreground.
Send to Back Move the shape to the background.

Add Layers

Layers are used to help organize objects (e.g. tables, notes, images, etc) on the canvas. You can add all related

objects to the same layer. For example, you may choose to add all your sales related tables to one layer. To add a new

layer, click the Y& putton from the toolbar and click anywhere on the canvas.
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The pop-up menu options of the layer object in canvas include:

Option Description

Cut Remove the layer from the diagram and put it on the clipboard.
Copy Copy the layer from the diagram to the clipboard.

Paste Paste the content from the clipboard into the diagram.

Select All Layers Select all layers in the diagram.

Delete Delete a layer from the diagram.

Color Change the color of the layer.

Size to Fit Resize the layer automatically to fit its contents.

Bring to Front Bring the layer to the foreground.

Send to Back Move the layer to the background.

Reverse Engineering

Reverse Engineering is one of the key features of Model. This feature allows you to load already existing database

structures to create new diagrams. It supports importing databases, schema, tables or views.
Navicat provides a step-by-step wizard for you to complete the task:

1. Choose File -> Import from Database.

2. Select a connection.

3. Select databases, schemas, tables or views you want to import.

4. Click Start.

You can also simply create a new model using reverse engineering in the Navicat main window. Control-click an
opened database/schema, tables or views and select Reverse Database to Model, Reverse Schema to Model,

Reverse Tables to Model or Reverse Views to Model from the pop-up menu.

Forward Engineering

Synchronize to Database

The Synchronize to Database feature allows you to compare a model with an existing database or schema, states the

differences between their structures, and offers synchronizing the structures in model to the target connection.
Navicat provides a step-by-step wizard for you to complete the task:

1. Choose File -> Synchronize to Database.

2. Select the source database, schema, and select the target connection, database, schema.

3. Click Options and select the compare / advanced options.
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4. Click Compare to show the differences between source and target objects.

5. Select the objects you want to synchronize.

6. Click Deploy to generate a set of scripts.

7. Click Execute.

Choose Connections

The first step is to define connections, databases and/or schemas for the source model and the target connection.

Choose Comparing Options

Then, click the Options button to select the compare / advanced options for the synchronization process.

Note: The following options depend on the diagram database type you are chosen and sort in ascending order.

Compare auto increment value

Check this option if you want to compare the auto increment values of tables.

Compare character set

Check this option if you want to compare the character sets of tables.

Compare checks

Check this option if you want to compare checks.

Compare collation

Check this option if you want to compare the collations of tables.

Compare definers

Check this option if you want to compare the definers of views.

Compare excludes

Check this option if you want to compare excludes.

Compare foreign keys

Check this option if you want to compare table foreign keys.

Compare identity last value

Check this option if you want to compare the identity last values of tables.

Compare indexes
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Check this option if you want to compare indexes.

Compare owners

Check this option if you want to compare the owners of the objects.

Compare partitions

Check this option if you want to compare table partitions.

Compare primary keys

Check this option if you want to compare table primary keys.

Compare rules

Check this option if you want to compare rules.

Compare storage

Check this option if you want to compare table storages.

Compare table options

Check this option if you want to compare other table options.

Compare tables

Check this option if you want to compare tables.

Compare triggers

Check this option if you want to compare triggers.

Compare uniques

Check this option if you want to compare uniques.

Compare views

Check this option if you want to compare views.

Drop with CASCADE

Check this option if you want to drop the dependent database objects with the CASCADE option.

Identifier Case Sensitivity

Ignore or consider the case of identifiers when mapping, or use the server default setting.

Start Comparison
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Click the Compare button to compare the source model and the target database.

View Comparison Results

After comparing structures, the tree view shows the differences between the source and target databases or schemas.
All objects are checked in the tree view by default. Uncheck the objects you do not want to apply to the target. You can

expand the table objects to view the detailed structure.

sakila3.ndm2 = MySQL5.7
Group by Operation o sakila = sakila
Source Object Operation Target Object
v = Objects to be modified (2 of 2 selected)
¥ @ [ country =  FF country
country_id country_id
country country
name name
X T last_update
(Primary Key) (Primary Key)
(Table Options) (Table Options)
» B city 5 [T city

» [ + Objects to be created (0 of 0 selected)
» ) X Objects to be deleted (1 of 1 selected)

> No operation (13 ohjects)

You can choose to group the objects in the tree views by object type or operation by selecting Group by Object Type

or Group by Operation.

Operation Description

=y Object exists in both source and target databases/schemas, but they have

different definition. The target object will be modified based on the source object.

+ Object does not exist in the target database/schema. It will be created in the
target.

x Object does not exist in the source database/schema. The target object will be
deleted.

Object exists in both source and target databases/schemas and they have

identical definition. No operation will be applied.

When you selected an object in the tree view, the DDL Comparison tab shows the DDL statements of that object in the
source and the target, and the Deployment Script tab shows the detailed SQL statements of the object that will be

executed in the target databases.
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Source Object

Operation  Target Object

v & Objects to be modified (2 of 2 selected)

= country

| country_id

| country

| name

] (Primary Key)

(Table Options)
» B city

% country

ECREME TABELE “sakila’.’ country’

EE2 country
country_id
country
name

¥ [ last_update
{Primary Key)

(Table Options)

= ity
DDL Comparisan Deployment Script
@ country

( ECREATE TABLE ‘sakila’. country’ |

| “country_id® smallint(5) UNSIGNED NOT NULL AUTO_INCREM | ‘country_id" smallint(5) UNSIGNED NOT NULL AUTO_INCRE

| “country’ warchar(90) CHARACTER SET utf8 COLLATE utf&_
1 | name’ wvarchar(255) CHARACTER SET utf8 COLLATE utf8_ge
5 L PRIMARY KEY (" country_id') USING BTREE

‘country” varchar(9@) CHARACTER SET utf8 COLLATE utfi
last_update’ timestamp NOT NULL DEFAULT CURRENT_TIME
‘name’ wvarchar(255) CHARACTER SET utf8 COLLATE utf8_g

} ENGINE = InnoDB AUTO_INCREMENT = 118 CHARACTER SET = u 6 L PRIMARY KEY ("country_id" ) USING BTREE

} ENGINE = InnoDB AUTO_INCREMENT = 118 CHARACTER SET =

Click the Deploy button to show the scripts of all selected objects.

Edit & Execute Selected Scripts

You can view all scripts that will be executed in the target database in the Deployment Script tab.

Deployment Options Button

Description

Deployment Options Continue on error - Ignore errors that are encountered during the
execution process if necessary.
Edit Script Open the Edit Deployment Script window to rearrange the order

of the scripts.

Copy Script to Clipboard

Copy all scripts from the Deployment Script tab to the clipboard.

Open Script in Query Editor

Open a new query window and display the scripts.

In the Edit Deployment Script window, use the arrow buttons to move the scripts.
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@ Synchronize to Database
+ ¥+

SET FOREIGN_KEY_CHECKS=@

[ ALTER TABLE “sakila". country® DROP COLUMN " last_update’

A ALTER TABLE 'sakila'.'city’ MODIFY COLLMN “city’ varchar(55) CHARACTER SET utf8 COLLATE utf8 general_ci
@ ALTER TABLE “sakila’. city’ DROP COLUMN "last_update®

DROP TABLE “sakila".category’

SET FOREIGN_KEY_CHECKS=1

AFTEI

Save Profile - Load Profile Deployment Options Back Recompare Execute

Then, click the Execute button to execute the scripts. The window will display the execution progress, execution time,

and success or failure messages.

Export SQL

After finishing your model, you can save table structures and relations from the model into a script file. The Export SQL
feature generates a SQL file for the script. To start the Export SQL feature, choose File -> Export SQL from the menu

bar.

General Properties

Export to File

Set the output file name and location.

Select objects to export

Choose objects in the model you wish to export.

Advanced Properties

Note: The following options depend on the diagram database type you are chosen and sort in ascending order.
Drop with CASCADE

Include drop object SQL statements with CASCADE option in the SQL file with this option in on.

Include auto increment
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Include table auto increment in the SQL file with this option is on.

Include character set

Include table and field character set in the SQL file with this option is on.

Include checks

Include checks in the SQL file with this option is on.

Include collation

Include table collation in the SQL file with this option is on.

Include Drop SQL

Include drop object SQL statements in the SQL file with this option in on.

Include excludes

Include excludes in the SQL file with this option is on.

Include foreign keys

Include foreign keys in the SQL file with this option is on.

Include indexes

Include indexes in the SQL file with this option is on.

Include primary keys

Include primary keys in the SQL file with this option is on.

Include rules

Include rules in the SQL file with this option is on.

Include schema name

Include the schema name in the SQL file with this option is on. Otherwise, only object names are included in SQL

statements.

Include triggers

Include triggers in the SQL file with this option is on.

Include uniques

Include uniques in the SQL file with this option is on.
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Server Version

Select the server version for the SQL file.

Model Conversion

Navicat allows you to convert your models from one database type to another database type, e.g. MariaDB 10.0

physical model to PostgreSQL 9.0 physical model.

During the conversion, all data types are converted automatically. The conversion process does not change the SQL
syntax of views if converting from one database type to another. If the target database version is MySQL 4.0 or below,

all views will be removed.

With Navicat Premium, you can also convert your models from one model type to another model type. If you covert a

physical model to logical/conceptual model, all views will be converted to entities.

To convert an opened model file, choose File -> Convert Model To. Then, choose the Model Type and select the

target Database and Version if necessary.

Print & Export Model

Print to a printer
Choose File -> Print to send your diagram directly to the printer. You can set the printer option in the pop-up window.
Export to afile

Choose File -> Export To and choose the file format to create a PDF, PNG, SVG or JPG file of your diagram.

Model Hints and Tips

Navicat provides some useful hints to work on the model more effectively.

Locate Object in the Diagram Canvas
Object selected in the Explorer's Diagram tab will be highlighted in the Diagram Canvas.
Double-click an object in the Explorer's Diagram tab will jump to the corresponding object in the Diagram Canvas.

Delete Object from Model

Select an object in the Diagram Canvas and press SHIFT-DELETE.

Open Table/Entity/View Designer

Double-click a table/entity/view in the Explorer's Model Tab or the Diagram Canvas.

Get Table/View Structure (SQL Statement)
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Select and copy a table/view in the Diagram Canvas, and paste it to other text editors.

Design Field without Table/Entity Designer

Select and click a table/entity name and press DOWN ARROW to add/edit fields. Navicat will predict field types

according to field names you entered.
INTEGER/int/int4/NUMBER
e suffix "id", "no" (if it is the first column, it will be predicted as a primary key)

e suffix "num"

e "gty", "number"

e exactly "age", "count"

DECIMAL(10,2)/decimal(10,2)/NUMBER/REAL/money

e suffix "price", "cost", "salary"

FLOAT/double/float8/NUMBER/REAL /float

e "size", "height", "width", "length", "weight", "speed", "distance"
DATE/datetime/date/TEXT/datetime2

e "date", "time"
VARCHAR(255)/varchar(255)/VARCHAR2(255)/TEXT

e other field names

Enter * before the field name to recognize as primary key. e.g. *itemNo:int.

Enter : between field name and field type to custom field type, e.g. itemName:varchar(255).

Reorder Field

Select a table/entity in Diagram Canvas, then press and hold the SHIFT key. Use 8 to drag the field to a desired

location.

Delete Field

Select a table/entity in Diagram Canvas, then press and hold the SHIFT key. Use “ to drag the desired field out of
the table/entity.
Add Vertex to Foreign Key/Relation/Line/Arrow

Select a foreign key/relation/line/arrow in Diagram Canvas. Press and hold the SHIFT key and click on it to add vertex.
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Delete Vertex on Foreign Key/Relation/Line/Arrow

Select a foreign key/relation/line/arrow in Diagram Canvas. Press and hold the SHIFT key and click on the vertex.

Switch to Hand Mode

Press and hold the SPACE key, then move the diagram.
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Chapter 9 - Debugger (Available only in

Non-Essentials Edition)
About Debugger

Navicat provides two code debuggers: Oracle PL/SQL Debugger and PostgreSQL PL/pgSQL Debugger. With the

debuggers, you can toggle breakpoints, fetch call stacks, view variable values, trace the code, etc.

Oracle PL/SQL Debugger

Oracle PL/SQL Debugger provides step-by-step code debugging for functions, procedures, packages and queries. To

launch the debugger, click the 0 button in the designer of the mentioned objects.

0 @ Debugger
Call Stack ’ . ,..p !, !. !.'H
Line Mumber Function Mame
10 SUBPTXT2 1 = |procedure subptxt2({name varchar2, subname varchar2, usr
varchar2,
12 SUBPTXT2 2 dbname varchar2, dbowner varchar2,
3 b txt in out warchar2) is
4 status diutil.ubd;
5
6 [—lbegin main
7 diutil.subptxt(name, subname, usr, dbname, dbowner, txt,
status);
8 [ if (status <= diutil.s_ok) then
9 El if (status = diutil.s_subpNotFound) then
10 @ | txt := "5%% s_subpNotFound';
Local Variables [EEIETUESTEE  Watch List 1 H elsif (status = diutil.s_stubToolong} then
12 @ | txt := "5%% s_stubToolong';
Mame Value 13 El elsif (status = diutil.,s_logic) then
name John'
subname 'Ti' Try to start debugging
e John' Success: Debugging started
dbname 'HR! Try to add break point te line 18
dbowner 'HR' Success: break point is added to line 18
txt 0 Try to add break point to line 12

Success: break point is added to line 12

Cancel
You can perform the most commonly used actions for debugging on the toolbar or menu:
Button Description
> Start running code in debug mode. Enter the Input Parameters if necessary. The

debugger executes your code until the end of the code or the next breakpoint is reached.

[ Stop stepping the code. The execution will stop and cannot resume it.

tad Resume the execution. The current line will be executed. If the line is a procedure or
function call, it will bypass the procedure or function. The counter will then move to the
next line of code.

M Resume the execution. The current line will be executed. If the line is a procedure or
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function call, the counter goes to the first statement in the procedure or function.

Otherwise, the counter will move to the next line of code.

H Resume the execution. The remaining part of the code within the current procedure or
function will be executed. Subsequently, the counter will jump to the line which is just

after the caller of the procedure or function.

Fad

Resume the execution. The counter will jump to the last line of the procedure or function.

The Code pane shows the code of the procedure or function. You can add/remove breakpoints for debugging by

clicking ® inthe grey area beside each statement.
The Breakpoints pane displays all the breakpoints.

The Call Stack pane displays a list of procedures and functions as they are called. To jump to a procedure or function,

control-click it and select Jump To.

The Local Variables pane displays all local variables and their values. To add a variable to the watch list, control-click
it and select Add to Watch List.

The Parameters pane displays the inputted parameters. To add a parameter to the watch list, control-click it and select
Add to Watch List.

The Watch List pane displays information about the variables being watched, allowing you to delete or edit watch
variables. To edit the value of a watch variable, control-click it and select Set Value. To delete a watch variable,

control-click a variable and select Remove Variable.

The Log pane displays the message log when debugging the code and the results after the procedure or function has

completed the execution.

PostgreSQL PL/pgSQL Debugger

PostgreSQL PL/pgSQL Debugger provides step-by-step code debugging for PL/pgSQL procedures/functions. To

launch the debugger, click the ] button in the function designer.
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Q Debugger

Ereak Points Call Stack ’ . ~~ + 1+

Line Number Function Name

1
4 unnest_rownumi{anyarray) 2 I_':_|BEGIN
7 unnest_rownumi{anyarray) 3 | id := 1;
4@ | FOREACH element IN array %1
5 | Loop
6 | RETURN NEXT;
7@ | id :=id + 1;
& L END LOOP;
a RETURN;
1@ END
11
Local Variables Watch List
Mame Value
g1 {A,B} Try to start debugging
id NULL Success: Debugging started
element NULL Try to add break point to line 7

Success: break point is added to line 7
Try to add break point to line 4
Success: break point is added to line 4

Cancel

You can perform the most commonly used actions for debugging on the toolbar or menu:

Button Description

> Start running code in debug mode. Enter the Input Parameters if necessary. The
debugger executes your code until the end of the code or the next breakpoint is

reached. Keyboard shortcut: F9

[ | Stop stepping the code. The execution will stop and cannot resume it.

N

Resume the execution. The current line will be executed. If the line is a procedure or
function call, it will bypass the procedure or function. The counter will then move to the

next line of code. Keyboard shortcut: F10

¥ Resume the execution. The current line will be executed. If the line is a procedure or
function call, the counter goes to the first statement in the procedure or function.
Otherwise, the counter will move to the next line of code. Keyboard shortcut: F11

H Resume the execution. The remaining part of the code within the current procedure or

function will be executed. Subsequently, the counter will jump to the line which is just

after the caller of the procedure or function. Keyboard shortcut: COMMAND-F11

The Code pane shows the code of the procedure or function. You can add/remove breakpoints for debugging by

clicking ® inthe grey area beside each statement.
The Breakpoints pane displays all the breakpoints.

The Call Stack pane displays a list of procedures or functions as they are called. To jump to a procedure or function,

control-click it and select Jump To.
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The Local Variables pane displays all local variables and their values. To add a variable to the watch list, control-click

it and select Add to Watch List.

The Parameters pane displays the inputted parameters. To add a parameter to the watch list, control-click it and select

Add to Watch List.

The Watch List pane displays information about the variables being watched, allows you to delete or edit watch
variables. To edit the value of a variable, control-click it and select Set Value. To delete a variable, control-click it and

select Remove Variable.

The Log pane displays the message log when debugging the code and the results after the procedure or function has

completed the execution.
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Chapter 10 - Data Migration Tools
About Data Migration Tools

Navicat provides a number of powerful tools for working with data, including Import Wizard, Export Wizard, Data
Transfer, Data Synchronization, Structure Synchronization, Dump SQL File and Execute SQL File. With those tools,

you can migrate your data between different servers, databases and formats easily.

Import Wizard

About Import Wizard

Import Wizard allows you to import data to tables/collections from CSV, TXT, XML, DBF and more. You can save your

settings as a profile for future use or setting automation tasks. To open the Import Wizard window, click = from the
object toolbar.

Note: Navicat Essentials edition only supports to import text-based files, such as TXT, CSV, XML and JSON.

Hint: You can drag a supported file to the Table/Collection's Objects tab or a database/schema in the Navigation pane.
Navicat will pop up the Import Wizard window automatically. If an existing table/collection is highlighted, Navicat will

import the file to the highlighted table/collection. Otherwise, it will import the file to a new table/collection.

Choose File Format

Select one of the available import types for the source file.
Choose Files
Click Add File or Add URL to add import source files. Select the Encoding for the source file.
Note: You can add more than one file to import.
ODBC
Setting up an ODBC Data Source Connection
1. Install suitable ODBC Administrator and the corresponding driver for file.

2. In Applications, select Utilities -> ODBC Administrator; or in Navicat, click the ODBC Administrator button

in this step.
3. Click the Add button in the User DSN tab.
4. Select the appropriate ODBC driver and click the OK button.
5. Enter required information.

6. Click the Finish button to see your ODBC Driver in the list.
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Note: You can consult with the driver provider about how to setup the DSN.
Connecting to ODBC Data Source in Navicat
1. Click J in Import from.
2. Choose the data source from the Connection drop-down menu and provide valid username and password.

3. All available tables will be included in the list in the next step if connection is success.

Choose Record Format / File Options

TXT, CSV

Field Delimiter

Specify the field separator.

Record Delimiter

Specify the record separator of the file.

Text Qualifier

Specify the character that encloses text values.

XML

Tag that identifies a table row / Tag that identifies a collection row
Define a tag to identify rows.

Consider tag attributes as table field / Consider tag attributes as collection field
For example:

<row age="17">

<id>1</id>

<name>sze</name>

</row>

With this option is on, Navicat will recognizes "age" as a field together with "id" and "name", otherwise, only "id" and

"name" will be imported as fields.

Note: Navicat does not support multiple level of XML file.

Excel
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Sheets will be shown in the list.

ODBC, Access

The Add Query button allows you to construct a query to import only certain rows from your source tables. In other

words, import only rows that satisfy the criteria set by you. Tables or queries will be shown in the list.
Choose Format Options

The following options depend on the file format chose in the first step.

Field Name Row

Indicate which row should Navicat recognize as field names.

Data Row

Indicate which row should Navicat start and stop reading the actual data.

Note: If no field names are defined for the file, uncheck the Field Name Row option.

Date Format

Specify the format for date.

Four Digit Years

Check this option to display four digits for years.

Date Delimiter

Specify the date separator.

Time Delimiter

Specify the time separator.

Decimal Symbol

Specify the decimal separator for decimal number.

Thousand Separator

Specify the thousand separator for number.

Map Tables / Collections

You are allowed to define a new name or choose to import into an existing table/collection from the drop-down menu.
Note: If you type a new name in Target Table / Target Collection, the box in Is New will be shown YES automatically.
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Source File Target Table Is Mew
jobs & jobs L YES

For importing multiple tables/collections, all tables/collections will be shown in the list.

Source File Target Table Is New
countries B2 countries =
departments @ departments .
duty time @ duty_time .
employees @ employees .
job_history M job_history =
jobs fH jobs T
locations @ locations .
regions 23] regions H

Map Fields

Navicat will make assumption on the field types and length in the source table/collection. You are allowed to choose

desired type from the drop-down menu.

Hint: For importing multiple tables/collections, select other tables/collections from the drop-down menu.

@ employees <- employees B
Source File Field Target Table Field Type Length Scale Primary Key
FIRST_NAME FIRST_NAME varchar H 120 0 B
LAST_NAME LAST_NAME varchar . 150 0 8
EMAIL EMAIL varchar . 150 0 .
PHONE_NUMBER PHONE_NUMBER varchar . 120 0 B
HIRE_DATE HIRE_DATE timestamp . 0 0 B
JOB_ID JOB_ID varchar . 60 0 B
SALARY SALARY float8 s 0 0 8
COMMISSION_PCT COMMISSION_PCT float8 . 0 ] B
DEPARTMENT_ID DEPARTMENT_ID float8 . 0 0 B
BIRTHDATE BIRTHDATE timestamp = 0 0 8
EMPLOYEE_ID EMPLOYEE_ID int4 . 0 0
MANAGER_ID MANAGER_ID intd s 0 0 -

If you are importing data into existing tables/collections, you might need to map the source field names manually to the
target or control-click and select Smart Match All, Ordinally Match All and Unmatch All from the pop-up menu for

quick mapping.

Source File Field . EMPLOYEE ID . Prlmar{ Key
FIRST_NAME FIRST_NAME 1

LAST NAME LAST_NAME ;

EMAIL EMAIL b o
PHONE_NUMBER PHONE_NUMBER B
HIRE_DATE HIRE_DATE ; B
108D §
SALARY SALARY H B
COMMISSION_PCT COMMISSION_PCT  ; 8
DEPARTMENT.ID MANAGER_ID b B
BIRTHDATE DEPARTMENT_ID . =
EMPLOYEE_ID BIRTHDATE } 8
MANAGER_ID MANAGER_ID 3 B
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Source File Field Target Table Field Primary Key

FIRST_NAME FIRST_NAME e
LAST_NAME LAST NAME 2 |
EMAIL EMAIL
PHONE_NUMBER pHONE  Ordinally Match All
HIRE_DATE HRED o el
JOB_ID JOB_ID - .
SALARY SALARY = o
COMMISSION_PCT COMMISSION_PCT 2
DEPARTMENT_ID DEPARTMENT.ID &
BIRTHDATE BIRTHDATE s
EMPLOYEE_ID EMPLOYEE_ID s
MANAGER_ID MANAGER_ID 2

If you are importing via ODBC, the Condition Query button opens the WHERE dialog where you can specify a
WHERE clause to import only certain rows from your source. In other words, import only rows that satisfy the criteria

set by you.

Hint: Do not include the word WHERE in the clause.

Choose Import Mode

Select the import mode that defines how the data being imported.

Import Mode

° Append: add records to the destination table
Naote: Append will be used for new table whichever import mode is selected.

" Update: update record in destination with matching record from source

) Append/Update: if record exists in destination, update it. Otherwise, add it
" Delete: delete records in destination that match records in source

) Copy: delete all records in destination, repopulate from the source

Hint: To activate the remaining options, you must enable Primary Key in the previous step.

Source File Field Target Table Field Primary Key
FIRST_NAME FIRST_NAME s
LAST_NAME LAST_NAME <

EMAIL EMAIL <
PHOME_NUMBER PHOMNE_NUMBER <
HIRE_DATE HIRE_DATE s

JOB_ID JOB_ID <
SALARY SALARY Z
COMMISSION_PCT COMMISSION_PCT £
DEPARTMENT_ID DEPARTMENT_ID v
BIRTHDATE BIRTHDATE <
EMPLOYEE_ID EMPLOYEE_ID 2
MANAGER_ID MAMNAGER_ID <

Click the Advanced button for more settings. The following options depend on the connection server type.

Run multiple queries in each execution

Execute multiple SQL statements at once, which will make the import process faster.

Use empty string as NULL

Import NULL value if the source data field contains empty string.

Ignore foreign key constraint
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Ignore the checking of foreign key constraints during the import process.
Continue on error
Ignore errors that are encountered during the import process.

Save and Start Import

Click the Start button to begin the import process. The wizard will display the import progress, execution time, and

success or failure messages.
After the import process finished, you can click the View Log button to open the log file.

Hint: Click the Save Profile button to save your settings as a profile.

Export Wizard

About Export Wizard

Export Wizard allows you to export data from tables, collections, views, or query results to any available formats. You

can save your settings as a profile for future use or setting automation tasks. To open the Export Wizard window, click

B, B2 or B from the object toolbar.

Note: Navicat Essentials edition only supports to export text-based files, such as TXT, CSV, HTML, XML, SQL and
JSON.

Choose File Format

Select one of the available export formats for the target file.

Choose Saving Path

You can set the exported file name and location in this step. Click the Change button to change the default export

location.

Check the box next to the object name that you want to export. The highlighted object in the object pane is checked
automatically. The file extension changes according to the selected export type in the first step. If you are exporting
selected objects into the same target file, set them with the same file name, you can control-click the grid and select

Export Selected to Same File. When the file format is Excel, each object will be exported as a sheet in the Excel file.

Note: For exporting query results, ensure the query is saved before running Export Wizard. Otherwise, no source

object displayed in here.

Encoding

Select the encoding for the exported file.
Add timestamp
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Check this option if you want your file name specifies the timestamp of the export is run. Select the date/time format

from the drop-down menu.

| EH cities cities.xlsx

. @ countries countries.xlsx

. @ jobs_copy jobs_copy.xlsx

8 @ spatial_ref_sys spatial_ref_sys.xlsx
| [ jobs jobs.xlsx

FH duty_time hir.xlsx

8 @ employees employees.x|sx
. E locations locations.xlsx
[ job_history hr.xlsx

. @ departments departments.xlsx
BN regions regions.xlsx

Choose Table / Collection Fields

You can select what fields to export. All the fields are selected in the list by default. If you want to omit some fields to be

exported, uncheck the All fields option first and then uncheck those fields in the list.
Note: For exporting query result, the wizard will skip this step.

Choose Additional Options

The following options depend on the file format chose in the first step.

Include column titles

Field names will be included into the exported file if this option is on.

Blank if zero

Leave it blank if the field content is O.

Append on output file(s)

Append records to the existing file

Continue on error

Ignore errors that are encountered during the export process.

Record Delimiter, Field Delimiter, Text Qualifier

Specify the record separator, the field separator and the character that encloses text values.
Date Order, Date Delimiter

Specify the format for date and the date separator.

Zero Padding Date

Add a leading zero to pad days and months to two digits if necessary.
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Time Delimiter

Specify the time separator.

Decimal Symbol

Specify the decimal separator for decimal number.

Binary Data Encoding

Set binary data are exported as Base64 encoded or no encoding in the file.

Save and Start Export

Click the Start button to begin the export process. The wizard will display the export progress, execution time, and

success or failure messages.

Hint: Click the Save Profile button to save your settings as a profile.

Data Transfer (Available only in Non-Essentials Edition)

About Data Transfer

Navicat allows you to transfer objects from one database/schema to another, or to a sql file (RDBMS) or a Javascript
file (MongoDB). The target database and/or schema can be on the same server as the source or on another server. To

open the Data Transfer window, choose Tools -> Data Transfer from the menu bar.

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the

Load Profile button and select a profile from the list.

Hint: Profiles are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft CyberTech/Navicat

CC/Common/Profiles

Hint: You can drag tables/collections to a database/schema in the Navigation pane. If the target database/schema is
within the same connection, Navicat will copy the tables/collections directly. Otherwise, Navicat will pop up the Data

Transfer window.

Choose Connections & Advanced Options (Step 1)

Choose Source and Target Connections

In the Data Transfer window, define connections, databases and/or schemas for Source Database and Target

= .
Database. You can click += to swap the source and target settings.

You can also transfer your selected database objects directly to a text file. Select the File option. Choose the target

path, SQL Format and Encoding for the file.
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Note: Navicat Premium supports transferring table with data across different server types, e.g. from MySQL to Oracle.

If the source connection is MongoDB, Navicat Premium only can transfer data to MongoDB server.

Choose Advanced Options

Then, click the Options button to set the advanced options. The options depend on the source and target connection

server types and sort in ascending order.

Continue on error

Ignore errors that are encountered during the transfer process.

Convert object name to

Check this option if you require convert object names to Lower case or Upper case during the process.

Create collections

Check this option if you want to create collections in the target database. Suppose this option is unchecked and

collections already exist in the target database, then all data will be appended to the destination collections.

Create tables

Check this option if you want to create tables in the target database. Suppose this option is unchecked and tables

already exist in the target database/schema, then all data will be appended to the destination tables.

Create target database/schema if not exist

Create a new database/schema if the database/schema specified in the target server does not exist.

Drop target objects before create

Check this option if database objects already exist in the target database and/or schema, the existing objects will be

deleted once the data transfer starts.

Drop with CASCADE

Check this option if you want to drop the dependent database objects with the cascade option.

Include auto increment

Include auto increment in the table with this option is on.

Include character set

Include character set in the table with this option is on.

Include checks

Include checks in the table with this option is on.



Include definers

Include the definers of the objects with this option is on.

Include engine/table type

Include table type with this option is on.

Include excludes

Include exclusion constraints in the table with this option is on.

Include foreign key constraints

Include foreign keys in the table with this option is on.

Include indexes

Include indexes in the table with this option is on.

Include other collection options

Include other options in the collection with this option is on.

Include other table options

Include other options in the table with this option is on.

Include owners

Include the owners of the objects with this option is on.

Include rules

Include rules in the table with this option is on.

Include triggers

Include triggers in the table with this option is on.

Include uniques

Include uniques in the table with this option is on.

Insert records

Check this option if you require all records to be transferred to the destination database and/or schema.

Lock source tables

Lock the tables in the source database and/or schema during the data transfer process.
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Lock target tables

Lock the tables in the target database and/or schema during the data transfer process.

Use complete insert statements

Insert records using complete insert syntax.

Example:

INSERT INTO “users™ ('ID Number’, "User Name’, “User Age’) VALUES ('1', 'Peter McKindsy"', '23");

INSERT INTO “users™ ('ID Number’, "User Name’, "User Age’) VALUES ('2', 'Johnson Ryne', '56");

INSERT INTO “users™ ('ID Number’, "User Name’, "User Age’) VALUES ('0', 'katherine', '23";

Use DDL from SHOW CREATE TABLE

If this option is on, DDL will be used from SHOW CREATE TABLE.

Use DDL from sqlite_master

If this option is on, DDL will be used from the SQLITE_MASTER table.

Use delayed insert statements

Insert records using DELAYED insert SQL statements.

Example:

INSERT DELAYED INTO “users™ VALUES ('1', 'Peter McKindsy', '23");

INSERT DELAYED INTO “users™ VALUES ('2', 'Johnson Ryne', '56");

INSERT DELAYED INTO “users™ VALUES ('0', 'katherine', '23");

Use extended insert statements

Insert records using extended insert syntax.

Example: INSERT INTO ‘users’ VALUES ('1', 'Peter McKindsy', '23"), ('2', '‘Johnson Ryne', '56"), ('0', 'Katherine', '23");

Use hexadecimal format for BLOB

Insert BLOB data as hexadecimal format.

Use single transaction

Check this option if you want to use a single transaction during the data transfer process.

Use transaction
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Check this option if you want to use transaction during the data transfer process.

Choose Objects & Transfer Mode (Step 2)

Choose Objects to Transfer

All the database objects are unselected in the Database Objects list by default. Check the database objects that you

want to transfer.

Database Objects:

v [ Tables (0/17)
% All tables during execution { * )
» B [ custom (4/17) ) Auto
v [ views (0/8)
Fc,ﬂ All views during execution { *}
v & B custom (2/8)
% actor_full_name

Transfer Mode:
© Advanced
Target Name: sales_by_film_category

Transfer as table
Mumber of rows per batch: | 1000

Foﬂ actor_info
Pé";, customer_list
FER film_list
Foﬁ nicer_but_slower_film_list
ﬁ, sales_by_film_category(Advanced)
Fc,ﬂ sales_by store
FE2 staff list
¥ Jfx Functions (*)
Jj\‘ All functions during execution ( * )
> fx custom (0/8)
¥ (1) Events [ *)
G} All events during execution [ *)
» [T custom (01

All <objects> during execution All the database objects being transferred to the target
* database/schema, all newly added database objects will also be

transferred without amending the data transfer profile.

Custom Only the checked database objects will be transferred. However, if
you add any new database objects in the source database and/or
schema after you create your data transfer profile, the newly added
database objects will not be transferred unless you manually

modify the Database Objects list.

Choose Transfer Mode for Tables / Views

You can customize the Transfer Mode for the selected table/view. If you choose Auto, Navicat will transfer the
table/view using the default settings. If your want to customize the transfer settings, choose Advanced and set the

following options:

Options Description

Target Name

Enter the name of the table / view that will be created in the target

database.

All fields

Transfer all fields in the table.

Custom fields

You can choose which fields to transfer. Click + and select the fields.

Change the name of the target field if necessary.

All rows

Transfer all records in the table.

Number of rows per batch

Specify the number of rows of data per batch. If it is not enabled, all data
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in the table is sent to the target server as a single transaction.

Custom recordsets Filter the records for transfer. Click + and enter a expression.

Recordset Generator If your table is large, you may want to divide it to several record sets to
avoid connection timeout. The Recordset Generator can divide the
records into a number of recordsets as evenly as possible between the
start and end values of a field. Set Field Name, Start Value, End Value

and Number of Recordsets in the pop-up window.

SQL Preview Show the SQL statements for returning the recordsets.

Use transaction for each Use a transaction for each recordset during the data transfer process.

recordset

Transfer as table The view will be transferred to the target database as a new table.

Confirm & Start Data Transfer (Step 3)

A summary table lists all selected objects that is being transferred to the target database.

Summary:

4 tables, 6 views, All events, All functions

Source Object Target Object Made
@ category category Advanced(Custom fields, All rows, Number of rows per batch: 1000)
3 fim filmn Auto
B fim_text film_text Auto
@ language language Advanced(All fields, All rows)
ﬁ, actor_info actor_info Advanced(Transfer as table, Number of rows per batch: 1000)
2 film_list film_list Auto
F  nicer_but_slower_film_list nicer_but_slower_film_list Auto
PO% sales_by_film_category sales_by_film_category Auto
Po% sales_by _store sales_by store Auto
F2 staff_list staff_list Auto
P All functions during execution ( * )
@ All events during execution ( *)

Click the Start button to execute the data transfer process. The window will display the execution progress, execution

time, and success or failure messages.

Data Synchronization (Available only in Non-Essentials Edition)

About Data Synchronization

Navicat allows you to transfer data from one database and/or schema to another with detailed analytical process. In
other words, Navicat provides the ability for data in different databases and/or schemas to be kept up-to-date so that
each repository contains the same information. To open the Data Synchronization window, choose Tools -> Data

Synchronization from the menu bar.

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the

Load Profile button and select a profile from the list.

Hint: Profiles are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft CyberTech/Navicat

CC/Common/Profiles
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Note: SQL Server 2000 does not support this feature. For Oracle server, BLOB, CLOB, NCLOB, LONG and LONG
RAW data are skipped during the data synchronization process. TIMESTAMP primary key cannot synchronize (insert,
update) with Database Link to 9i server. RAW primary key cannot synchronize (insert, update, delete) with Database

Link to any server, without error.

Hint: Navicat Premium and Navicat for MySQL support synchronizing between MySQL and MariaDB.
Choose Connections & Comparing Options (Step 1)

Choose Source and Target Connections

In the Data Synchronization window, define connections, databases and/or schemas for Source Database and Target

Database. You can click - to swap the source and target settings.
Choose Comparing Options

Then, click the Options button to set the comparing options.

Insert

Insert records if the records do not exist in the target.

Delete

Delete extra records from the target.

Update

Update the target if the record is different from the source.

Choose Table / Collection Mapping (Step 2)

In this step, only tables/collections which contain identical names between the source and target are mapped in the list
by default. If you do not want some tables/collections to be synchronized, disable them manually from the drop-down

menu.

Keys and fields which contain identical names are also mapped. You can change the mapping in the Key Mapping and

Field Mapping columns.

View Data Comparison Results (Step 3)

After comparing data, the window shows the number of records that will be inserted, updated or deleted in the target.
Uncheck the Show identical table and others / Show identical collection and others option to hide the
tables/collections with identical data and the tables/collections with different structures. All tables/collections with

different data and all actions are checked by default. Uncheck the checkbox that you do not want to apply to the target.
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Show identical table and others

Source Table

A actor

v [ category
£ city

T country
A customer

7 film

MySQL
sakila

Target Table

A actor

[T category
ﬁ city
 country
fFH customer

F film

—
—]

=]
L—

Testing Server 02

sakila

Insert

Update

Delete Same

@
@

Remark

< < J< BN

@ﬁlm_actor
@film_u::ateg(:ryI
v [ film_text
% inventory

ﬁ film_actor
ﬁ film_category
I film_text

ﬁ inventory

@:

When you selected a table/collection in the list, the bottom pane shows data in the source and target. Values that differ

between the source and target are highlighted. To view multiple lines data, control-click the grid and select Show

Assistant Viewer. Uncheck the records that you do not want to apply to the target.

Choose an option from the drop-down menu to show the data.

Option Description
All Rows Show all records in the source and target.
Difference Show all records that are different in the source and target.
Insert Only show the records that do not exist in the target.
Update Only show the records that exist in both source and target, but they have
different values.
Delete Only show the records that do not exist in the source.
Same Show the records that exist in both source and target and they have identical
values.
All Rows a
E .payment § .payment
payment_id customer_id staff_id rental_id payment_id customer_id staff_id rental_id
V1 1 1 76 1 1 1 78
2 1 573 1 573
3 1 1185 3 1 1185
Joo4 1 2 1422 4 1 2 1422
v 8 1 2 1476 5 1 2 1476
v B 1 1 1725 3] 1 1 1725
v 7 1 1 2308 7 1 1 2308
v 8 1 2 2363 g 1 2 2363
v 9 1 1 3284 9 1 1 3284
10 1 2 4528 10 1 2 4526
YoM 1 1 4611 M 1 1 461

Click the Deploy button to show the scripts of all selected tables/collections and records.

Edit & Execute Selected Scripts (Step 4)

You can view all scripts that will be executed in the target database in the Deployment Script tab.

Deployment Options Button

Description

Deployment Options

Use transaction - Rollback all data when error occurs.
Continue on error - Ignore errors that are encountered during the

execution process if necessary.
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Run multiple queries in each execution - Execute multiple SQL
statements at once, which will make the synchronization process
faster.

Edit Script Open the Edit Deployment Script window to rearrange the order of
the scripts.

Copy Script to Clipboard Copy all scripts from the Deployment Script tab to the clipboard.

Open Script in Query Editor Open a new query window and display the scripts.

In the Edit Deployment Script window, use the arrow buttons to move the scripts.

[ ] Data Synchronization
+ ¥

[ SET FOREIGN_KEY_CHECKS = @

3 UPDATE ‘sakila_copy'. customer’ SET ‘store_id" = 1, “first_name® = 'ELIZABETH', ‘last_name’ = 'BROWN', '
| UPDATE “sakila_copy’ . customer’ SET “store_id’ = 2, “first_name” = 'JBWNIFER', “last_name’ = 'DAVIS', ‘¢
| UPDATE “sakila_copy’. customer® SET ‘store_id' = 1, “first_name’ = 'MARIA', 'last_name’ = 'MILLER', “em
3 UPDATE ‘sakila_copy'. customer® SET “store_id” = 2, "first_name’ = 'SUSAN', 'last_name’ = 'WILSON', “em
) UPDATE ‘sakila_copy'. customer’ SET “store_id" = 2, “first_name® = 'LISA', “last_name® = 'ANDERSON', ‘ery
3 SET FOREIGN_KEY_CHECKS = 1

Save Profile - Load Profile Deployment Options - Back Recompare Execute

Then, click the Execute button to execute the scripts. The window will display the execution progress, execution time,

and success or failure messages.

Structure Synchronization (Available only in Non-Essentials

Edition)

About Structure Synchronization

Navicat allows you to compare and modify the table structures and other objects with detailed analytical process. In
other words, Navicat compares objects between two databases and/or schemas and states the differential in structure.

To open the Structure Synchronization window, choose Tools -> Structure Synchronization from the menu bar.

You can save your settings as a profile for future use. To open a saved profile, click the Load Profile button and select

a profile from the list.

Hint: Profiles are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft CyberTech/Navicat

CC/Common/Profiles



Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server and MariaDB. Navicat Premium and Navicat for
MySQL support synchronizing between MySQL and MariaDB.

Choose Connections & Comparing Options (Step 1)

Choose Source and Target Connections

In the Structure Synchronization window, define connections, databases and/or schemas for Source Database and

. = .
Target Database. You can click + o swap the source and target settings.

Choose Comparing Options

Then, click the Options button to set the database/schema comparing options. The options depend on the connection

server type and sort in ascending order.

Compare auto increment value

Check this option if you want to compare the auto increment values of tables.
Compare character set

Check this option if you want to compare the character sets of tables.
Compare checks

Check this option if you want to compare checks.

Compare collation

Check this option if you want to compare the collations of tables.
Compare definers

Check this option if you want to compare the definers.

Compare events

Check this option if you want to compare events.

Compare excludes

Check this option if you want to compare table excludes.

Compare foreign keys

Check this option if you want to compare table foreign keys.
Compare functions

Check this option if you want to compare functions.
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Compare identity last value

Check this option if you want to compare the identity last values of tables.

Compare indexes

Check this option if you want to compare indexes.

Compare owners

Check this option if you want to compare the owners of the objects.

Compare partitions

Check this option if you want to compare table partitions.

Compare primary keys

Check this option if you want to compare table primary keys.

Compare rules

Check this option if you want to compare rules.

Compare sequences

Check this option if you want to compare sequences.

Compare storage

Check this option if you want to compare storage.

Compare table options

Check this option if you want to compare other table options.

Compare tables

Check this option if you want to compare tables.

Compare tablespace and physical attributes

Check this option if you want to compare tablespace and physical attributes.

Compare triggers

Check this option if you want to compare triggers.

Compare uniques

Check this option if you want to compare table uniques.
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Compare views

Check this option if you want to compare views.

Drop with CASCADE

Check this option if you want to drop the dependent database objects with the CASCADE option.
Identifier Case Sensitivity

Ignore or consider the case of identifiers when mapping, or use the server default setting.

Start Comparison

Click the Compare button to compare the source and target databases.

View Structure Comparison Results (Step 2)

After comparing structures, the tree view shows the differences between the source and target databases or schemas.
All objects are checked in the tree view by default. Uncheck the objects you do not want to apply to the target. You can

expand the table objects to view the detailed structure.

Group by Operation T Do:th-rpequCI}.‘I; E :;SLz’:ﬁj?)L
Source Object Operation Target Object
v =# Objects to be modified (3 of 3 selected)
v 2 7 duty_time - 7 duty_time
Mo Ho
[H] emPLOYEE_ID [E] EMPLOYEE_ID
] on_DUTY ] on_DUTY
[l oFF pUTY ] oFF_BUTY
[ nam +
x  [FIs.AcTIvE
/0 duty_time_pkey A duty_time_pkey
& duty_time_ EMPLOYEE_ID_fkey & duty_time_EMPLOYEE_ID_fkey
fF (Table Options) £ (Table Options)
» B T employees =» T employees
» @5 location_details_report =» 7 location_details_report

»| | 4 Objects to be created (0 of 20 selected)
» ) 3 Objects to be delsted (6 of 6 selacted)

> Mo operation (4 objects)

You can choose to group the objects in the tree views by object types or operations by selecting Group by Object

Type or Group by Operation.

Operation Description

=y Object exists in both source and target databases/schemas, but they have different

definition. The target object will be modified based on the source object.

+ Object does not exist in the target database/schema. It will be created in the target.

X Object does not exist in the source database/schema. The target object will be deleted.

Obiject exists in both source and target databases/schemas and they have identical

definition. No operation will be applied.
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When you selected an object in the tree view, the DDL Comparison tab shows the DDL statements of that object in the

source and the target, and the Deployment Script tab shows the detailed SQL statements of the object that will be

executed in the target databases.

Source Object Operation  Target Object

v[& =» Objects to be modified (3 of 3 selected)

¥/ g88 duty_time 22 duty_time
@H o Mo
(] EMPLOYEEID ] EMPLOYEE_ID
@[f]onpuTy [H] on_DUTY
@[] oFF DUTY [H] oFF_DUTY
@ nam +
»x [l i1s.AcTIVE
Deployment Seript
[ duty time [0 duty time
1 E_‘CREATE TABLE "public"."duty_time" ( 1 E_‘CREATE TABLE "backup"."duty_time" (
2 "ID" intd NOT NULL, 2 ‘ "ID" intd NOT NULL,
i ‘ "EMPLOYEE_ID" floats, i ‘ "EMPLOYEE_ID" floats,
4 ‘ "ON_DUTY" timestamp(6), 4 ‘ "ON_DUTY" timestamp(6),
b ‘ "OFF_DUTY" timestamp(6), g ‘ "OFF_DUTY" timestamp(G),
6 ‘ "nam" "public"."range_type", 6 ‘ "IS_ACTIVE" varchar(255) COLLATE "pg_catalog"."
7 ‘ CONSTRAINT "duty_time_pkey" PRIMARY KEY ("ID"), 7 ‘ CONSTRAINT "duty_time_pkey" PRIMARY KEY ("ID"),
8 ‘ CONSTRAINT "duty_time_EMPLOYEE_ID_fkey" FOREIGN 8 ‘ CONSTRAINT "duty_time_EMPLOYEE_ID_fkey" FOREIGR
] L
95 ) 8)
18- ; 10 ;
11 11
12 ALTER TABLE "public"."duty_time" OWNER TO “test"; 12 ALTER TABLE "backup"."duty_time" OWNER TO “test";

Click the Deploy button to show the scripts of all selected objects.

Edit & Execute Selected Scripts (Step 3)

You can view all scripts that will be executed in the target database in the Deployment Script tab.

Deployment Options Button Description

Deployment Options Continue on error - Ignore errors that are encountered during the

execution process if necessary.

Edit Script Open the Edit Deployment Script window to rearrange the order
of the scripts.

Copy Script to Clipboard Copy all scripts from the Deployment Script tab to the clipboard.

Open Script in Query Editor Open a new query window and display the scripts.

In the Edit Deployment Script window, use the arrow buttons to move the scripts.
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oe Structure Synchronization
+ 4

% public"."customel usthio 0a N ompai varch.
CREATE TABLE "public"." r ( "CusthNo" float8 NOT NULL DEFAULT @, "C ' h.
Ld ALTER TABLE "public"."customer" OWNER TO "postgres"
p postg
@3 ALTER TABLE "public"."duty_time" ADD COLUMN "IS_ACTIVE" varchar(255) COLLATE 'pg_catalog.
- B "public"."duty_time" “nam"
=Ie ALTER TABLE bl d t DROP COLUMN CASCADE

; [ ALTER TABLE "public"."employees" DROP CONSTRAINT "employees_JOB_ID_fkey" CASCADE
3 | ALTER TABLE "public"."employees" ALTER COLUMN "FIRST_NAME" TYPE wvarchar(65) COLLATE "pg_.
4 9 CREATE TABLE “public"."job" ( "JOB_ID" varchar(3@) COLLATE “pg_catalog"."default™ NOT N.
5 ALTER TABLE "public"."job" OWNER TO "postgres"

6 A CREATE TABLE "public"."staff" ( "id" int4)

7 ALTER TABLE "public"."staff" OWNER TO “"postgres"

8 7 ALTER TABLE "public"."employees" ADD CONSTRAINT '‘employees_JOB ID_fkey" FOREIGN KEY ("JO..
g9 CREAT‘E OR REPLACE VIEW "public"."location_details report" AS SELECT countries."COUNTRY L.
18
11
12
13
14
15
16 -)
17 H
18
15 Al
28
21 Al fault";
22 )
e - 4 Cancel
Corr

Save Profile « Deployment Script  « Back Recompare Execute

Then, click the Execute button to execute the scripts. The window will display the execution progress, execution time,

and success or failure messages.

Dump & Execute SQL / Script File

The Dump SQL File, Execute SQL File, Dump Script File and Execute Script File features allow you to dump your
database, schema, tables or collections to a SQL or .js file or execute SQL or .js files in your connection, database or

schema.
To dump afile

1. In the main window, control-click an opened database/schema or control-click the selected tables/collections,

and select Dump SQL File or Dump Script File -> Structure Only or Structure + Data.
2. Browse the save location and enter a file name.
3. Click Save.

To execute a file

1. Inthe main window, control-click an opened connection, database or schema and select Execute SQL File or

Execute Script File.

2. Browse your SQL or .js file, choose the encoding of the file and enable appropriate options.

Option Description

Continue on error Ignore errors that are encountered during the execution process.

Run multiple queries in Execute multiple SQL statements at once, which will make the
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each execution execution process faster.

SET AUTOCOMMIT=0/ | Disable auto commit mode.

No Auto Commit

3. Click Start.

Hint: You can drag and drop a .sgl or .js file to an opened connection, database or schema in the Navigation pane.

Navicat will pop up the Execute SQL File or Execute Script File window automatically.

Mongolmport & MongoExport

About Mongolmport & MongoExport

MongoDB provides two utilities for import and export data: Mongolmport and MongoExport. You can import or export

the data according to the specified conditions.
Mongolmport
Mongolmport allows you to import data from a JSON, CSV or TSV file into MongoDB database.
Note: You must have mongoimport executable for this feature to work.
To import a file
1. In Navicat main window, control-click your database and select Mongolmport.

2. In the General and Advanced tabs, select the input file path, the target collection, the file type, and the

appropriate import options.

3. Click the Start button to begin the import process. The Message Log tab will display the import progress,

execution time, and success or failure messages.

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the

Load Profile button and select a profile from the list.

Hint: Profiles are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft CyberTech/Navicat

CC/Common/Profiles

MongoExport

MongoExport allows you to export MongoDB collections to a JSON or CSV file.
Note: You must have mongoexport executable for this feature to work.

To export collections

1. In Navicat main window, control-click your database and select MongoExport.
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2. In the General and Advanced tabs, select the export file path, the source collection, the file type, and the

appropriate export options.

3. Click the Start button to begin the export process. The Message Log tab will display the export progress,

execution time, and success or failure messages.

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the

Load Profile button and select a profile from the list.

Hint: Profiles are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft CyberTech/Navicat

CC/Common/Profiles
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Chapter 11 - Charts (Available only in Navicat

Premium and Enterprise Edition)
About Charts

Charts feature allows you to create visual representations of your database data. In the main window, click 1% charts
to open the workspace object list.

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server and MariaDB.
Some of key features are listed here:

e Support 20 chart types.

e Customize multiple pages dashboard.

e Visualize live data.

* Add interactive controls.

Hint: Workspace files (.ncharts) are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft
CyberTech/Navicat CC/Navicat Premium/Profiles. To open the folder, control-click a workspace file and select Show in

Finder.
Open an external workspace file
1. Control-click anywhere in the Objects tab and select Open External Workspace from the pop-up menu.
2. Browse the file and click Open in the dialog window.
Save an opened external file as a Navicat workspace
1. In Workspace Designer, choose File -> Save to Navicat.
2. Enter the workspace name and choose the save location.
3. Click OK.
Save a Navicat workspace as an external file
1. In Workspace Designer, choose File -> Save As External File.
2. Choose the save path and enter the file name.

3. Click Save.
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Workspace

A workspace is the place that comprises dashboards, charts and data sources. You can create multiple dashboards,

charts and data sources in a workspace.

eo0e
3 b B D

Workspace { salesChart “Z salesData [Ed Dashboard 2

a

1]
o

All Data Source Chart Dashboard

Total

4
E

§Eg8E=8AgRAE 3
H i §FrE £

i

Employee Attend

ance Chart 8 Sales Chart 8 Customer Order

Monm Untited Payment lstros

Customize Workspace

You can view and sort items in the workspace. To change from one view to another, click the = List or ¥ Grid
button at the bottom of the window. Alternatively, choose View -> List or Grid.

List View displays additional information about each item. You can sort items in List View, click the column header by

which you want to sort the items.

Grid View displays your items as a grid of thumbnail images. You can filter the items by clicking a category (All, Data

Source, Chart, Dashboard) in this view.

Data Source

About Data Source

Data sources reference tables in your connections and can select data from tables on different server types. The fields
in the dataset can be used to construct a chart. When building a chart, you will need to specify the data source that the

chart uses.

164



Workspace = Employee Data

e FvyEE ¢ (@
¥ Y mysaL @ TLive @ Archive

=1

£ report @
- " public.duty_time hr.employees
» £ sakila

¥ (i3 PostgresQL

¥ EMR

&2 backup
7 actor
FH cities 3 dutytimel $f duty_timeEMPLOYEEID B} duty time.ON.DUTY [ duty time.OFF.DUTY #f employees EMPLOYEEID A employees FIRST.NAN
FH countries 1 100 2008-10-0108:38:05  2008-10-01 18:17:27 100 Steven
I departments 2 101 2008-10-010Bi58:36  2008-10-0118:09:22 101 Neena @
3 102 2008-10-0108:35:39  2008-10-0118:21:04 102 Lex
2 duty.time 4 103 2008-10-010B:44:58  2008-10-01 18:00:59 103 Alexander
] employees 5 104 2008-10-0108:43:51  2008-10-0118:08:58 104 Bruce
£ iob_histary 5 105 2008-10-0108:43:18  2008-10-0118:26:30 105 David
T jobs 7 106 2008-10-0108:43:07  2008-10-0118:17:43 106 Vali
8 107 2008-10-010B:44:31  2008-10-01 18:08:02 107 Diana
& locations 9 108 2008-10-0108:37:43  2008-10-0118:38:18 108 Nancy
£ regions 10 109 2008-10-0108:35:53  2008-10-0118:25:41 109 Daniel
[ spatial_ref_sys " 110 2008-10-0108:02:15  2008-10-01 18:08:08 110 John
ez 12 111 2008-10-0108:54:52  2008-10-01 18:13:20 111 Ismael
13 112 2008-10-0109:02:14  2008-10-0118:00:05 12 Jose Manuel
5. geometry_columns i 113 2008-10-0108:58:38  2008-10-01 18:16:44 113 Luis
7, job._details 15 114 2008-10-0108:04:10  2008-10-01 18:02:14 114 Den
7 location_details_report 16 115 2008-10-0108:01:14  2008-10-0118:26:55 115 Alexander
BEmmen 7 116 2008-10-0109:00:57  2008-10-0118:41:06 16 Shell
18 117 2008-10-0108:47:00  2008-10-01 18:43:50 17 Sigal
T raster_overviews 19 118 2008-10-0108:04:28  2008-10-01 18:12:54 18 Guy
T2, staff list 20 119 2008-10-0108:06:48  2008-10-0118:30:44 19 Karen
3317 records fetched | Last Updated Time: 2019-11-14 16:46:24 K=+ =+ 5 &
|r-1-\|

/4 Connection Pane

b,

The Connection pane is the basic way to navigate with connections, databases, tables, queries. If the Connection pane

is hidden, choose View -> Show Connection from the menu bar.

ey

2} Data Source Toolbar

The Data Source Toolbar provides controls that you can use to manipulate the data.
e .

L%) Design Pane

The Design pane allows you to build the data source visually.

Navicat provides two modes for connecting your data: Live and Achieve.

Live mode retrieves data from your servers whenever the data source is being used / loaded. It offers the convenience

of real-time updates, with any changes in the underlying data reflected.

Archive mode retrieves data from your servers during the data source creation, and stored the retrieved data in the

workspace for later use by building charts.
L )
L4) Preview Pane

The Preview pane displays the data of the data source.

Create Data Source

The essential steps to create a data source are:

1. Inthe Workspace window, click .

2. Enter the name of the data source and select the desired connections or existing data sources.
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3. Click OK.

4. A tab will open for you to edit the data source.

5. Drag and drop tables / queries from the Connections pane to the Design pane.
6. Drag and drop a node to another to create the join.

7. Configure the join type and join fields if necessary.

public.duty_time hr.employees
e

~
duty_time | . ) ¥ employees
Left field Operator Right field
Jduty_time.EMPLOYEE_ID s = .employees.EMPLOYEE_ID =
+ -+ 4 Cancel oK

Hint: After creating the join, you can change the join settings at any time by clicking the join icon on the

connector.

8. Choose Live mode or Archive mode.

9. Click Apply & Refresh Data to view the data.

Add Query to Data Source

You can save query results for creating a new dataset.

To create a new query

1. On the Connections pane, double-click New Query.

2. Enter the name of the query and write the statement in SQL Editor. You can also use Query Builder to build the

query visually.

To add an existing query

1. On the Connections pane, double-click New Query.

2. Click Existing Queries.

3. Drag and drop a query from the left pane to the editor.
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Filter / Sort / Project Data

If your data source has many data or fields, you may find it easier to limit the data or fields to just the ones you want so

you can simplify the data selections.

Filter Data

Filter pane allows you to facilitate creating and applying filter criteria that you specify for the data. Click ¥ from the
toolbar to activate the Filter pane.

1. To add a new condition to the criteria, just simply click . If you want to add a condition with parentheses,

click

Hint: To add parentheses to existing conditions, simply control-click on the selected conditions and select
Group with Bracket. To remove the parentheses, control-click a bracket and select Delete Bracket or Delete

Bracket and Conditions.
2. Click on the field name (next to the checkbox) and choose a field from the list.

3. Click on the operator (next to the field name) and choose a filter operator.

Filter Operator Operator Description

= The field is equal to 'value'.

I= The field is not equal to 'value'.

< The field is less than 'value'.

<= The field is less than or equal to 'value'.

> The field is greater than 'value'.

>= The field is greater than or equal to 'value'.
contains The field contains 'value'.

does not contain The field does not contain 'value'.

begin with The field starts with 'value'.

does not begin with The field does not start with 'value'.

end with The field ends with 'value'.

does not end with The field does not end with 'value'.

is null The field is NULL.

is not null The field is NOT NULL.

is empty The field is empty.

is not empty The field is not empty.

is between The field is between 'valuel' and 'value2'.

is not between

The field is not between 'valuel' and 'value2'.

is in list

The field is in the list of (‘'valuel','value2',...).

is not in list

The field is not in the list of ('valuel','value2',...).

4. Click on <?> to activate the appropriate editor and enter the criteria values. The editor used in the criteria

values box is determined by the data type assigned to the corresponding field.
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5. Click on the logical operator (next to the criteria values) to choose and or or.
6. Repeat step 1-5 to add another new condition.
7. Click Apply & Refresh Data to see the result of the filtering you made.

Hint: If you want to reverse the meaning of the conditions, control-click the selected conditions and select Toggle

Negator.
Sort Data
Navicat offers the ability to sort and order data. Click 1= from the toolbar to activate the Sort pane.
1. To add a new criteria, just simply click
2. Click on the field name (next to the checkbox) and choose a field from the list.
3. Click on the sorting order to choose ASC or DESC.
4. Repeat step 1-3 to add another new criteria.

5. Click Apply & Refresh Data to see the result of the sorting you made.

Project Data

You can choose which fields to include or exclude in the data source. Click - from the toolbar to activate the
Projection pane.

1. Choose to Include or Exclude fields.

2. To add a new criteria, just simply click

3. Click on the field name (next to the checkbox) and choose a field from the list.
4. Repeat step 2-3 to add another new criteria.

5. Click Apply & Refresh Data to see the result of the projection you made.

Chart

About Chart

A chart provides visual representations of the data in your data source. It maps to a single data source, and can display

correlations between several fields in the data. You can even make the chart interactive by adding a control chart.

Note: You must add a data source before you can begin building charts.
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@ Data Source Pane

The Data Source pane is the basic way to navigate with the data sources. If the Data Source pane is hidden, choose

View -> Show Data Source from the menu bar.
@ Chart Toolbar
The Chart Toolbar provides controls that you can use to manipulate the data.

@ Metric Pane

The Metric pane allows you to choose the chart type and add fields to the shelves from the Data Source Pane. If the

Metric pane is hidden, choose View -> Show Metric from the menu bar.
@ Preview Pane

The Preview pane displays the chart.

® Properties Pane

The Properties pane includes the basic layout settings, data format settings and so on. The properties vary with the

type of the chart. If the Properties pane is hidden, choose View -> Show Properties from the menu bar.
Build Chart
The essential steps to create a chart are:

1. Inthe Workspace window, click m&

2. Select the data source and enter the name of the chart.

3. Atab will open for you to edit the chart.

4. Choose the Chart Type on the middle pane.
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Hint: The type of chart you will use is normally determined by the type of the data.

5. Drag fields to the corresponding shelf in the Metric pane to set axis, values, etc.

6. Select the properties on the right pane which can be further customized for your chart.
Hint: Each chart type has different properties.

7. The chart shows on the Preview pane.

Shop1 by Week

15,000

10,000
EIUOD I I

2005 W21 2005 W22 2005 W24 2005 W25 2005 W27 2005 W28 2005 W30 2005W31 2005 W33 2005 W34 2006 WO7
Week

Amount

Set Field Alias

You can create aliases for fields so that their labels appear differently in the chart.
1. Click the down arrow in the field box.

2. Select Set Alias.

Aggregate 4
Filter »
Sort >

Delete

3. Enter the alias name.

Filter / Sort Data

Filter Data

You can filter the data in 3 ways:

e Click the down arrow in the field box and select Filter.
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Aggregate >

Equals...

Does Mot Equals...

Greater Than or Equal To...
Less Than or Equal To...

Set Alias
Delete
Ou Show Filter Pane

Remove Filter
Remove All Filters

e Use the Filter pane.

e Control-click a series / data points on the chart.

Show data label
Show data value

Show data percentage
+ Show legend

Include
Exclude
Value >= 2.000000
Value <= 2.000000

Hint: If you want to clear the filter, you need to use the Filter pane.

Sort Data

You can sort the data in 2 ways:

e Click the down arrow in the field box and select Sort.

amount {Sum) L + Drag Fields Here
Aggregate >
Filter > [

Sort Ascending
Sort Descending

Sort

| Remove All Sorts

e Use the Sort pane.

Apply Aggregate Function

Aggregate functions allow you to summarize or change the granularity of your data.

1. Click the down arrow in the field box.
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Aggregate 4 Sum

Filter > Average
Sort » Count
i . CountDistinct
Set Alias ¢
Delete P
Median

Select Aggregate and choose a aggregate function.

Function Description

Number

Sum Return the sum of all values. Null values are ignored.

Average Return the average of all the values. Null values are ignored.

Count Return the number of items. Null values are not counted.

Count(Distinct) Return the number of distinct items. Null values are not counted.

Min Return the minimum value across all records. Null values are
ignored.

Max Return the maximum value across all records. Null values are
ignored.

Median Return the median value across all records. Null values are ignored.

DateTime

Count Return the number of items. Null values are not counted.

Count(Distinct) Return the number of distinct items. Null values are not counted.

Year Return the year of the date (0000-9999).

Quarter Return the quarter of the year (Q1-Q4).

Month Return the month of the date (01-12).

Week Return the week of the year (W01-W52, start of week is Sunday).

Day Return the day of the date (01-31).

Hour Return the hour of the time (00-23).

Minute Return the minute of the time (00-59).

Second Return the second of the time (00-59).

String

First Return the value of the first record.

Last Return the value of the last record.

Count Return the number of items. Null values are not counted.

Count(Distinct) Return the number of distinct items. Null values are not counted.

Chart Types

About Chart Types

Navicat provides a variety of different chart types so data can be displayed in a meaningful way.
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Here is a complete list of available chart types:

e Vertical Bar Chart

e Vertical Stacked Bar Chart

e Horizontal Bar Chart

e Horizontal Stacked Bar Chart

e Line Chart

e Area Chart

e Stacked Area Chart

e Bar and Line Chart

e Stacked Bar and Line Chart

e Pie Chart

e Donut Chart

e Scatter Chart

e Heatmap
e Treemap
* Value

e Trend

e KPI

e Table

e Pivot Table
e Control
Bar Chart
A bar chart provides high-level overviews of data trends by comparing values within a specific category.
e Vertical Bar Chart
e Vertical Stacked Bar Chart

e Horizontal Bar Chart



Horizontal Stacked Bar Chart
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Once you have selected a chart type, you can customize the chart by changing its properties:

Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.
Data

Show data values

Display the values of the data series.

Use 100% stacked

Use 100% stacked bars to show values for hierarchical data. (Each bar

height is 100%, and the colored bar segments represent the components

relative contributions to the total bar.)

Show data percentages

Display the data percentages of the bars.

Data Label Color

Set the color of the data labels on the bars.

Value Option

Select the value that will be displayed on the chart.

Show only top #

Only the top # data are displayed.

Color

Set the color palette of the data series.

All Data Colors

Allow setting the color for each series.

Data Formats - Number

Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.
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Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime

Date / Time Choose the date and time format of the data.
Custom Customize the date and time format.

X-Axis

Show X-Axis title Display the title of X-Axis.

X-Axis Title Specify the title of X-Axis.

Font Set the font style of X-Axis title.

Show title at the end of

axis

Display the title at the end of X-Axis.

Continuous

Use a continuous axis. The data series are positioned according to their

domain value.

Show X-Axis labels

Display labels on X-Axis.

Show X-Axis Display X-Axis line.
X-Axis Color Set the color of X-Axis line.
Y-Axis

Show Y-Axis title

Display the title of Y-Axis.

Y-AXis title

Specify the title of Y-Axis.

Font

Set the font style of Y-Axis title.

Show title at the end of

Display the title at the end of Y-Axis.

axis

Show Y-Axis labels Display labels on Y-Axis.
Show Y-Axis Display Y-Axis line.

Y-Axis Color Set the color of Y-Axis line.
Show grid line Display the grid line of Y-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph

drawing beyond this range will be clipped off.

Use Custom Interval

Change the Interval on Y-Axis.

Tick Interval Set the interval of the tick marks in axis units.
Legend

Show legend Display the legend container.

Position Set the position for the legend.

Align Set the horizontal alignment of the legend.

Line / Area Chart

A line or area chart displays information as a series of data points connected by straight line segments.
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e Line Chart
e Area Chart

e Stacked Area Chart
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Chart Properties

Once you have selected a chart type, you can customize the chart by changing its properties:

Option Description

General

Background Color Set the background color of the chart area.

Show Border Display the outer chart border.

Border Color Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.

Data

Show Values Display the values of the data points.

Show Area Values Display the values of the data points.

Value Option Select the value that will be displayed on the chart.

Show markers Display the marker points on the line / area.

Use 100% stacked Use 100% stacked areas to show values for hierarchical data. (The area
height is 100%, and the colored area segments represent the
components' relative contributions to the total area.)

Show only top # Only the top # data are displayed.

Color Set the color palette of the data series.

Data Formats - Number
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Prefix

Add prefix characters to all the numeric data on the chart.

Unit Choose the unit to shorten the numeric data.
Suffix Specify the suffix to label the customized unit.
Divider Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime

Date / Time Choose the date and time format of the data.
Custom Customize the date and time format.

X-AXis

Show X-Axis title Display the title of X-Axis.

X-Axis Title Specify the title of X-Axis.

Font Set the font style of X-Axis title.

Show title at the end of

axis

Display the title at the end of X-Axis.

Continuous

Use a continuous axis. The data series are positioned according to their

domain value.

Show X-Axis labels

Display labels on X-Axis.

Show X-Axis Display X-Axis line.
X-Axis Color Set the color of X-Axis line.
Y-AXxis

Show Y-Axis title

Display the title of Y-Axis.

Y-AXxis title

Specify the title of Y-Axis.

Font

Set the font style of Y-Axis title.

Show title at the end of

axis

Display the title at the end of Y-Axis.

Show Y-Axis labels

Display labels on Y-Axis.

Show Y-Axis Display Y-Axis line.
Y-Axis Color Set the color of Y-Axis line.
Show grid line Display the grid line of Y-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph

drawing beyond this range will be clipped off.

Use Custom Interval

Change the Interval on Y-Axis.

Tick Interval Set the interval of the tick marks in axis units.
Legend

Show legend Display the legend container.

Position Set the position for the legend.

Align Set the horizontal alignment of the legend.
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Combination Chart

Mixing bar and line chart in the same visual is a good way to emphasize the difference between series while still

maintaining their relationship.
* Bar and Line Chart

e Stacked Bar and Line Chart
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Chart Properties

Once you have selected a chart type, you can customize the chart by changing its properties:

Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.
Data

Show bar data values

Display the values of the data series for the bars.

Use 100% stacked bar

Use 100% stacked bars to show values for hierarchical data. (Each bar
height is 100%, and the colored bar segments represent the

components' relative contributions to the total bar.)

Show bar data

percentages

Display the data percentages of the bars.

Bar Data Label Color

Set the color of the data labels on the bars.

Show Line Values

Display the data value for the line.
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Value Option

Select the values that will be displayed on the chart.

Show line markers

Display the marker points on the line.

Show only top #

Only the top # data are displayed.

Color

Set the color palette of the data series.

All Bar Data Colors

Allow setting the color for each series.

Data Formats - Number

Prefix Add prefix characters to all the numeric data on the chart.
Unit Choose the unit to shorten the numeric data.

Suffix Specify the suffix to label the customized unit.

Divider Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime

Date / Time Choose the date and time format of the data.
Custom Customize the date and time format.

X-AXxis

Show X-Axis title Display the title of X-Axis.

X-Axis Title Specify the title of X-Axis.

Font Set the font style of X-Axis title.

Show title at the end of

axis

Display the title at the end of X-Axis.

Continuous

Use a continuous axis. The data series are positioned according to their

domain value.

Show X-Axis labels

Display labels on X-Axis.

Show X-Axis

Display X-Axis line.

X-Axis Color

Set the color of X-Axis line.

Y-Axis / Secondary Y-Axis

Show Y-Axis title / Show
Secondary Y-AXxis title

Display the title of Y-Axis.

Y-Axis title / Secondary
Y-Axis title

Specify the title of Y-Axis.

Font

Set the font style of Y-Axis title.

Show Y-Axis title at the
end of axis / Show
Secondary Y-Axis title at

the end of axis

Display the title at the end of Y-Axis.

Show Y-Axis labels /
Show Secondary Y-Axis

labels

Display labels on Y-Axis.
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Show Y-Axis / Show

Secondary Y-Axis

Display Y-Axis line.

Y-Axis Color / Secondary
Y-Axis Color

Set the color of Y-Axis line.

Show grid line

Display the grid line of Y-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph

drawing beyond this range will be clipped off.

Use Custom Interval

Change the Interval on Y-Axis.

Tick Interval Set the interval of the tick marks in axis units.
Legend

Show legend Display the legend container.

Position Set the position for the legend.

Align Set the horizontal alignment of the legend.

Pie / Donut Chart

A pie or donut chart displays data in a series of segments of a circle, with larger segments representing larger data

values.

e Pie Chart

e Donut Chart

Chart Properties
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Once you have selected a chart type, you can customize the chart by changing its properties:

Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.
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Border Color Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.

Slice Separator Add white borders between pie / donut slices.
Data

Show data labels Display data labels that clarify the data series.
Show data values Display the values of the data series.

Show data percentages Display the data percentages of the slices.

Show label inside slice Position the slice labels inside the slice.

Data Label Color Set the color of the data label.

Value Option Select the value that will be displayed on the chart.
Show only top # Only the top # data are displayed.

Slice Group the small slices to a single slice (called Others).
Color Set the color palette of the data series.

Data Formats - Number

Prefix Add prefix characters to all the numeric data on the chart.
Unit Choose the unit to shorten the numeric data.

Suffix Specify the suffix to label the customized unit.

Divider Specify the divider for the customized unit.

Thousand Separator Choose the thousands separator for numeric data.
Decimal Separator Choose the decimal separator for numeric data.

Decimal Places Specify decimal places for numeric data.

Negatives Choose the format negative numbers are displayed.

Data Formats - DateTime

Date / Time Choose the date and time format of the data.
Custom Customize the date and time format.

Group

Show group title Display the title of the group.

Group Title Specify the title of the group.

Group Title Font Set the font style of the group title.

Legend

Show legend Display the legend container.

Position Set the position for the legend.

Align Set the horizontal alignment of the legend.

Scatter Chart

A scatter chart plots data with individual data points placed along the X and Y axes.
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Once you have selected a chart type, you can customize the chart by changing its properties:
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Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.
Data

Color Set the color palette of the data series.

Show size values

Display the size of the bubbles.

Data Formats - Number

Prefix Add prefix characters to all the numeric data on the chart.
Unit Choose the unit to shorten the numeric data.

Suffix Specify the suffix to label the customized unit.

Divider Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime
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Date / Time

Choose the date and time format of the data.

Custom Customize the date and time format.
X-Axis

Show X-Axis title Display the title of X-Axis.

X-Axis Title Specify the title of X-Axis.

Font Set the font style of X-Axis title.

Show title at the end of

axis

Display the title at the end of X-Axis.

Continuous

Use a continuous axis. The data series are positioned according to their

domain value.

Show X-Axis labels

Display labels on X-Axis.

Show X-Axis Display X-Axis line.
X-Axis Color Set the color of X-Axis line.
Show grid line Display the grid line of X-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph

drawing beyond this range will be clipped off.

Use Custom Interval

Change the Interval on X-Axis.

Tick Interval Set the interval of the tick marks in axis units.
Y-AXis

Show Y-Axis title Display the title of Y-Axis.

Y-AXxis title Specify the title of Y-Axis.

Font Set the font style of Y-Axis title.

Show title at the end of

axis

Display the title at the end of Y-Axis.

Continuous

Use a continuous axis. The data series are positioned according to their

domain value.

Show Y-Axis labels

Display labels on Y-Axis.

Show Y-Axis Display Y-Axis line.
Y-Axis Color Set the color of Y-Axis line.
Show grid line Display the grid line of Y-Axis.

Use custom range

Set the range of the grid lines. Enter values in Start and End. The graph
drawing beyond this range will be clipped off.

Use Custom Interval

Change the Interval on Y-Axis.

Tick Interval Set the interval of the tick marks in axis units.
Legend

Show legend Display the legend container.

Position Set the position for the legend.

Align Set the horizontal alignment of the legend.
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Heatmap

A heatmap represents data in a tabular format as a range of color. A more intense color represents a larger aggregated

value for a particular data point.
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Chart Properties

Once you have selected a chart type, you can customize the chart by changing its properties:

Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.
Data

Show data values

Display the values of the data series.

Data Label Color

Set the color of the data label.

Diverging

Use diverging color scale.

Min Color

Set the color of the minimum value in the colormap.

Center Color

Set the color of the value at which to center the colormap.

Max Color Set the color of the maximum value in the colormap.
Min Value Specify the minimum value.
Max Value Specify the maximum value.

Data Formats - Number
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Prefix Add prefix characters to all the numeric data on the chart.
Unit Choose the unit to shorten the numeric data.
Suffix Specify the suffix to label the customized unit.
Divider Specify the divider for the customized unit.
Thousand Separator Choose the thousands separator for numeric data.
Decimal Separator Choose the decimal separator for numeric data.
Decimal Places Specify decimal places for numeric data.
Negatives Choose the format negative numbers are displayed.
Data Formats - DateTime
Date / Time Choose the date and time format of the data.
Custom Customize the date and time format.
Column
Show column title Display the title of the column.
Column Title Specify the title of the column.
Column Title Font Set the font style of the column title.
Show column label Display the column label.
Column Label Color Set the color of the column label.
Row
Show row title Display the title of the row.
Row Title Specify the title of the row.
Row Title Font Set the font style of the row title.
Show row label Display the row label.
Row Label Color Set the color of the row label.
Legend
Show legend Display the legend container.
Position Set the position for the legend.

Treemap

A treemap is an alternative way of visualizing the hierarchical structure while also displaying quantities for each

category via area size.
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Once you have selected a chart type, you can customize the chart by changing its properties:
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Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.
Data

Show data point name

Display the names of the data points.

Show data values

Display the values of the data points.

Show data percentages

Display the data percentages of the data points.

Data Label Color

Set the color of the data label.

Color Set the color palette of the data points.
Legend

Show legend Display the legend container.

Position Set the position for the legend.

Align Set the horizontal alignment of the legend.

Data Formats - Number
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Prefix

Add prefix characters to all the numeric data on the chart.

Unit Choose the unit to shorten the numeric data.
Suffix Specify the suffix to label the customized unit.
Divider Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime

Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

Chart Properties

A value displays a single aggregated value from a data field, e.g. total.

Total

$259,619.25

Once you have selected a chart type, you can customize the chart by changing its properties:

Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.
Data

Data Label Font

Set the font style of the data label.

Data Formats - Number

Prefix Add prefix characters to all the numeric data on the chart.
Unit Choose the unit to shorten the numeric data.

Suffix Specify the suffix to label the customized unit.

Divider Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.
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Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime

Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

Trend

A trend displays that the current value is trending up or down compared to the previous value, and the percentage

change.

Chart Properties

514.18

2,523.01

Once you have selected a chart type, you can customize the chart by changing its properties:

Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.
Data

Show previous value

Display the previous value.

Show difference

Display the Value / Percentage difference between the current value

and the previous value.

Show Indicator

Display the up or down indicator.

Main Label Font

Set the font style of the main label.

Previous Value Color

Set the color of the previous value.

Target Met Color

Set the color of the indicator and the percentage when the value is

trending up.

Target Missed Color

Set the color of the indicator and the percentage when the value is

trending down.

Data Formats - Number

Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.
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KPI

Suffix

Specify the suffix to label the customized unit.

Divider

Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

A KPI displays a comparison between a key value and its target value with a progress bar.

Chart Properties

4.20

Target: 11.99

Once you have selected a chart type, you can customize the chart by changing its properties:

Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.
Data

Main Label Displayed

Display the Actual value or the Comparison percentage in the main label.

Main Label Font

Set the font style of the main label.

Sub Label Color

Set the color of the sub-label on the bar.

Target Caption

Specify the caption of the target label.

Target Label Color

Set the color of the target label.

Target Met Color

Set the color of the bar when the value reaches the target.

Target Missed Color

Set the color of the bar when value does not reach the target.

Data Formats - Number

Prefix

Add prefix characters to all the numeric data on the chart.

Unit

Choose the unit to shorten the numeric data.
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Suffix Specify the suffix to label the customized unit.

Divider Specify the divider for the customized unit.

Thousand Separator Choose the thousands separator for numeric data.

Decimal Separator Choose the decimal separator for numeric data.

Decimal Places Specify decimal places for numeric data.

Negatives Choose the format negative numbers are displayed.

Table

A table represents data in a tabular view and calculates the total at the end of each column.

Chart Properties

Job Title No. of Employees

AC_ACCOUNT 31
AC_MGR Y
AD_ASST 31
AD_PRES Y
AD_vP 62
FI_ACCOUNT 155
FI_MGR 3
HR_REP 31
IT_PROG 155
MK_MAN a1
WK_REP k)
PR_REP a1
PU_CLERK 155
PU_WAN 2
SA_MAN 155
SA_REP 930
SH_CLERK 620
ST_CLERK 620
ST_WAN 155

3317.00

Once you have selected a chart type, you can customize the chart by changing its properties:

Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.

Data

Font Set the font style of the field names and data.

Show Alternate Row

Colors

Apply color to alternate rows.

Show Vertical Grid Line

Display the vertical grid line.

Show Horizontal Grid Line

Display the horizontal grid line.
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Color Set the color palette of the data series.

Data Formats - Number

Prefix Add prefix characters to all the numeric data on the chart.
Unit Choose the unit to shorten the numeric data.

Suffix Specify the suffix to label the customized unit.

Divider Specify the divider for the customized unit.

Thousand Separator Choose the thousands separator for numeric data.
Decimal Separator Choose the decimal separator for numeric data.

Decimal Places Specify decimal places for numeric data.

Negatives Choose the format negative numbers are displayed.

Data Formats - DateTime

Date / Time Choose the date and time format of the data.
Custom Customize the date and time format.
Total
Show Total Display totals in the last row of the table.
Total Color Set the color of the total values.

Pivot Table

A pivot table shows measure values for the intersection of two dimensions and represents data in a tabular view.

Monthly State Sales Report

State Apr May Jun Jul Aug Sep oct Total

BC §7,885 $0,055 17840.00
CA $971.70 7259.55
Corfu 766.80
FL 5281470 $0 $32793 $10,712 46319.70
GA 50 518,532 18532.00
HI $3,115 58,524 $64,050 91054.00
Jamaica 2032175 534380 7,807 $787.80 31070.20
OR $5,201 50 $3,632 8833.00
Ontario 54,096 4996.00
St Croix 50 6,500 $25210 §1,238 32948.00
Total 7885.00 4204845 005500 66870.80 30482.00 12410.70 64837.80 250619.25

Chart Properties

Once you have selected a chart type, you can customize the chart by changing its properties:

Option Description

General

Background Color Set the background color of the chart area.
Show Border Display the outer chart border.

Border Color Set the color of the outer chart border.
Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.
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Align Set the horizontal alignment of the title.
Data
Font Set the font style of the field names and data.

Show Alternate Row

Colors

Apply color to alternate rows.

Show Vertical Grid Line

Display the vertical grid line.

Show Horizontal Grid Line

Display the horizontal grid line.

Color

Set the color palette of the data series.

Data Formats - Number

Prefix Add prefix characters to all the numeric data on the chart.
Unit Choose the unit to shorten the numeric data.

Suffix Specify the suffix to label the customized unit.

Divider Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime

Date / Time Choose the date and time format of the data.
Custom Customize the date and time format.
Total

Show Row Total

Display totals in the last row of the table.

Enter the name of the row total and set the color of the name and values.

Show Column Total

Display totals in the last column of the table.
Enter the name of the column total and set the color of the name and

values.

Control

Chart Properties

A control allows you to filter the data series of all charts in a dashboard during presentation.

Month

April

May

June

July
August
September
October
MNovemnber
December

Movemnber

Once you have selected a chart type, you can customize the chart by changing its properties:
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Option

Description

General

Background Color

Set the background color of the chart area.

Show Border

Display the outer chart border.

Border Color

Set the color of the outer chart border.

Show title Display the chart's main title.

Title Specify the title of the chart.

Title Font Set the font style of the title.

Position Set the position of the title.

Align Set the horizontal alignment of the title.
Data

Data Label Color

Set the color of the data label.

Style

Show the data as a list or a range.

Data Formats - Number

Prefix Add prefix characters to all the numeric data on the chart.
Unit Choose the unit to shorten the numeric data.

Suffix Specify the suffix to label the customized unit.

Divider Specify the divider for the customized unit.

Thousand Separator

Choose the thousands separator for numeric data.

Decimal Separator

Choose the decimal separator for numeric data.

Decimal Places

Specify decimal places for numeric data.

Negatives

Choose the format negative numbers are displayed.

Data Formats - DateTime

Date / Time

Choose the date and time format of the data.

Custom

Customize the date and time format.

DateTime Formats

The following table shows specifiers you can use to create user-defined data formats for DateTime fields in a chart.

Specifier Description

D Display the day as a number without a leading zero (1-31).

DD Display the day as a number with a leading zero (01-31).

M Display the month as a number without a leading zero (1-12).

MM Display the month as a number with a leading zero (01-12).

MMM Display the month as an abbreviation (Jan-Dec).

MMMM Display the month as a full month name (January-December).

YY Display the year in two-digit numeric format with a leading zero (00-99).

YYYY Display the year in four-digit numeric format (0000-9999).

h Display the hour as a number without a leading zero using the 12-hour clock
(1-12).

hh Display the hour as a number with a leading zero using the 12-hour clock (01-12).
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H Display the hour as a number without a leading zero using the 24-hour clock
(0-23).

HH Display the hour as a number with a leading zero using the 24-hour clock (00-23).

m Display the minute as a number without a leading zero (0-59).

mm Display the minute as a number with a leading zero (00-59).

S Display the second as a number without a leading zero (0-59).

SS Display the second as a number with a leading zero (00-59).

wd Display the day as a single letter abbreviation (S-S).

wd Display the day as an abbreviation (Sun-Sat).

WD Display the day as a full name (Sunday-Saturday).

w Display the week of the year (1-52, start of week is Sunday).

WWwW Display the week of the year (W01-W52, start of week is Sunday).

q Display the quarter of the year (1-4).

QQ Display the quarter of the year (Q1-Q4).

p Display an uppercase AM with any hour before noon; display an uppercase PM
with any hour between noon and 11:59 P.M.

Dashboard

About Dashboard

Dashboard is a collection of charts which allows you to create and view your data visualizations. When you modify a

chart, any dashboards containing it will reflect the changes.

Workspace [22] Dashboard 2
Page + a C @ Chart 10
N @ T ] 38% v Position |go0 |2 120 | T
! ® o
Size - -
. | ~y 560 (I 480
. < > Width  Height
Employee Attend Payment Methoc
,,,,,, Chart 10 Customer Order _ ance Chart Month Control Monthly Sales Payment Control
— S———

259,619.25 @

Fayment Moto

(1) Pages Pane

The Pages pane shows thumbnail images of each page in the dashboard. If the Pages pane is hidden, choose View ->

Show Pages from the menu bar.
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(2) pashboard Toolbar
The Dashboard Toolbar provides controls that you can use to refresh the data and present the dashboard.
(@ control List Pane

The Control List pane allows you to design the dashboard, such as adding charts, labels, images. If the Control List

pane is hidden, choose View -> Show Control List from the menu bar.
@ Design Pane

You can design your dashboard on the Design pane. All added objects can be moved (by dragging them with mouse or

by keyboard), resized, aligned to the grid, etc.
(8) Properties Pane

The Properties pane includes the basic layout settings. The properties vary with the type of the object. If the Properties

pane is hidden, choose View -> Show Properties from the menu bar.
Build Dashboard
The essential steps to create a dashboard are:
1. Inthe Workspace window, click R
2. Enter the name of the dashboard.
3. Click OK.
4. A tab will be opened for your newly created dashboard.
5. Design your dashboard.
6. Select the properties on the right pane which can be further customized for your dashboard.
Note: Each object has different properties.

Hint: You can refresh dashboard to update data in charts with the most current data from their respective data sources.
Iz_

To manually refresh the dashboard, click C.

Working with Grids

Show Grid
To turn the grid on in the dashboard, choose View -> Show Grid from the menu bar.
Snap to Grid

To align objects on the dashboard with the grid, choose View -> Show Grid from the menu bar.
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Arrange Objects

Move Objects Forward / Backward

To send an object to the back of the dashboard, control-click it and select Send to Back.
To send an object one step toward the back, control-click it and select Send Backward.
To bring an object to the front of the dashboard, control-click it and select Bring to Front.
To bring an object one step closer to the front, control-click it and select Bring Forward.
Align Objects

To align objects on the dashboard, select more than one object, then control-click and select Alignment -> Align Left,

Align Center, Align Right, Align Top, Align Middle or Align Bottom.
Change Objects Distribution

To distribute objects on the dashboard, select more than one object, then control-click and select Distribute ->

Horizontal or Vertical.
Add Pages
The Pages pane shows all pages in the dashboard. It displays thumbnails of your dashboard pages.
To add a new page
1. On the Dashboard tab, click the + button on the Pages pane.
2. A blank page will be added and selected.

Properties

The available properties of a page:

Option Description
Page Size Customize the size of pages in the dashboard.
Background Set the background color of pages. If you choose Image Fill, you can

choose the image file and the scaling option.

Opacity Set the opacity of the image.

Add Charts

Charts provide visual representations of the data in your data source.

To add a chart

1. On the Dashboard tab, click I"—".
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2. Allavailable charts in the workspace will be shown as thumbnails. If no charts are available, click I—a to create

one. For detailed instructions on creating charts, see Build Charts.

3. Drag a chart to the Design pane.

Properties

The available properties of a chart:

Option Description
Position Customize the position of the chart.
Size Customize the size of the chart.

Add Text Labels

Text labels are typically used to help document the dashboard, such as adding a dashboard title, URL links.
To add a text label

1. On the Dashboard tab, click T

2. Place it on the dashboard.

3. Enter the caption.

Properties

The available properties of a text label:

Option Description
Position Customize the position of the label.
Size Customize the size of the label.
Caption Enter the caption of the label.
Alignment Specify the text alignment of the label caption.
Font Set the font style of the label caption.
Bold Apply a bold style to the label caption.
Italic Apply an italic style to the label caption.
Background Color Set the background color of the label.
URL Enter URL path to display a hyperlink.
Add Images

You can insert images (BMP, JPG, JPEG or PNG files) to your dashboard for design or identification purposes.
To add an image

1. On the Dashboard tab, click ad]
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2. Select an image file in the Open dialog box.

Properties

The available properties of an image:

Option Description

Opacity Set the opacity of the image.

Position Customize the position of the image.

Size Customize the size of the image.

Original Size Reset the image to its original size.

URL Enter URL path to set the image as a hyperlink.
Add Shapes

Navicat includes some pre-defined shapes for creating a dashboard: line, arrow.

To add a shape

1. Onthe Dashboard tab, click B" and choose a shape type.

2. Place it on the dashboard.

Properties

The available properties of a shape:

Option Description

Position Customize the position of the shape.
Color Set the color of the shape.

Line Width Choose the thickness of the line/arrow.
Cap Style Choose the cap style of the line/arrow.
Dash Style Choose the dash style of the line/arrow.
Join Style Choose the join style of the line/arrow.
Begin Arrow Style Choose the style of the arrow's back.
End Arrow Style Choose the style of the arrow's front.

Present Dashboard

You can present the dashboard using the whole screen. The title bar, toolbar, tab bar, Pages pane, Control List and

Properties pane will be hidden while in this mode. To open a dashboard in present view, click n
If you have added a control chart to your dashboard, you can filter the data series of all charts by using the control.

To exit present view, press the ESC key and the workspace window will be returned to its previous state.
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Print & Export Dashboard

Print to a printer

Choose File -> Print to send your dashboard pages directly to the printer. You can set the printer option in the pop-up

window.
Export to afile

Choose File -> Export and choose the file format to create a PDF, PNG, SVG or JPG file of your dashboard pages.

Switch Theme

Charts are not affected by the OS system theme. If you want use a Dark theme for your charts, click o to change the

theme.
e0e
Bl g L B | & O s R |
Workspace [E2] Dashboard 2
Page + » &) Page 1
& : Juh T r 28% Page Size
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Chart 10 Customer Order ~ ance Chart Month Control Monthly Sales No Fill -

199



Chapter 12 - Automation (Available only in
Non-Essentials Edition)

About Automation

Navicat allows you to automate executing jobs at one or more regular intervals. Automation can be created for Query,
Backup, Data Transfer, Data Synchronization, Import, Export, MongoDump, Mongolmport, MongoExport, MapReduce.

You can define a list of jobs to be performed within one batch job, either run it manually, at the specified time or

periodically. In the main window, click %9 Automation to open the automation object list.

Hint: Batch Job files are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft

CyberTech/Navicat CC/Navicat Premium/Profiles

Hint: You can run a batch job in Terminal with this command:

ProgramPath --batch-jobs BatchJobName

Example: ./"Navicat Premium.app"/Contents/MacOS/"Navicat Premium" -batchjob jobl

Create Batch Job (Step 1)

Add Jobs to Batch Job

In the bottom pane of the General tab, select the job type, and then browse the connection, database and/or schema to

locate jobs if necessary.

e0ce
Untitled
BB 0@ &R R
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Selected Job Type Connection Type Connection Project Mame
:"'-‘:. data_sync_profile Data Sync MYSQL
..E.. data_transfer_profile Data Transfer PREMIUM
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Backup public Backup PGSQL PostgreSQL
Backup sakila Backup MYSQL MySQL
ﬂ?; export_job_duty Export Table PGSQL PostgreSQL
Backup hr Backup MYSQL Testing Server 02 Project DT-00562
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Move selected jobs or all jobs from the Available Job list to the Selected Job list by clicking “< or Bx. To delete
[m[m}
LY

selected jobs or all jobs from the Selected Jobs list, click or “%. You are allowed to run profiles from different

servers in a single batch job.
To rearrange the sequence of the selected jobs, drag a job to the desired location in the Selected Job list.

If you want to backup whole server, you can select the connection and select Backup Server xxx.

Exported files can be added to the batch job as mail attachment. Select the job in the Selected Job list and click fo or

fs to add or remove the mail attachment.

Set Email Notification

Navicat allows you to generate and send personalized emails with results returned from a schedule. The results can be

emailed to multiple recipients. Check the Send Email option in the Advanced tab and enter required information.
From

Specify email address of sender. For example, someone@navicat.com.

To, CC

Specify email addresses of each recipient, separating them with a comma or a semicolon (;).

Subject

Specify the email subject with customized format.

Body

Write email content.

Host (SMTP Server)

Enter your Simple Mail Transfer Protocol (SMTP) server for outgoing messages.

Port

Enter the port number you connect to your outgoing email (SMTP) server.

Use authentication

Check this option and enter Username and Password if your SMTP server requires authorization to send email.
Secure Connection

Specify the connection to use TLS, SSL secure connection or Never.

Send Test Mail
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Navicat will send you a test mail indicating success or failure.

Save / Run Batch Job

Before setting schedule, click the button to save the batch job.

You can run the batch job manually by clicking the g5 button. The Message Log tab displays the execution progress,

execution time, and success or failure messages.

Schedule Batch Job (Step 2)

You can click & to set schedule for running a batch job and click C& to remove the schedule.

"Hour" and "Minute" fields must be specified. If a field is left without a value, then all the values will be used. For
example, if the "Weekday" field is empty, then the system will treat the field to be entered with "0, 1, 2, 3, 4, 5, 6". Use
commas to separate values. For example, "0, 1, 3, 6". Use hyphen, without spaces to indicate values. For example,
"0-4".

Example: The batch job will be executed at 6:30pm every weekday.

Schedule

Run the Batch Job whenever the clock
matches this pattern:

Hour*: 18 0-23
Minute*: 30 0-59
Weekday: 1-5 W 0-8
Day: 1-31
Month: 1-12

Note: Please save the batch job before setting schedule. Passwords must be saved in the Connection window before

running your schedule.

Host: 192.168.1.68
Peort: 3357
User Name: root

| Edit Password:

Save Password
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Chapter 13 - Backup & Restore
About Backup & Restore

A secure and reliable server is closely related to performing regular backups, as failures will probably occur sometimes

- caused by attacks, hardware failure, human error, power outages, etc.

Navicat provides a built-in backup and restore tool for users to backup/restore MySQL, PostgreSQL, SQLite and

MariaDB database objects. For Oracle, SQL Server and MongoDB, users can use the following features:
e Oracle Data Pump
* SQL Server Backup & Restore

¢ MongoDump & MongoRestore

Built-in Backup & Restore Tool (Available only in Non-Essentials

Edition)

About Built-in Backup & Restore Tool

The built-in backup & restore tool allows you to backup/restore database objects for your database. You can save your

settings as a profile for future use or setting automation tasks. In the main window, click Backup to open the

backup object list.

Hint: Backup files are saved under the Settings Location. To open the folder, control-click a backup file and select

Show in Finder.

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB.

Backup

General Properties

In this tab, you can view the server and database information. Enter a comment for the backup file if necessary.

Object Selection

In this tab, choose database objects you wish to backup.

All <objects> during execution All the database objects being backed up, all newly added database

* objects will also be backed up without amending the backup profile.

Custom Only the checked database objects will be backed up. However, if

you add any new database objects in the database and/or schema

after you create your backup profile, the newly added database
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objects will not be backed up unless you manually modify the Objects

list.

Advanced Properties

Note: The following options depend on the connection server type and sort in ascending order.

Lock all tables

Lock all objects while backup is being processed.

Use single transaction (InnoDB only)

If a table uses InnoDB storage engine, with this option is on, Navicat uses transaction before the backup process starts.
Use specified file name

Define your file name for backup. Otherwise, your backup file will be named with "YYYYMMDDhhmmss" format.

Restore

Restore feature will firstly drop the selected objects of the database, then recreate the new objects according to your

backup. Finally, inserting the data.
Restore a backup to an existing database/schema
1. Inthe main window, open a database/schema.
2. Click Backup and select an existing backup file.
3. Click s from the object toolbar.
4. Choose the restore options and click Start.
Restore a backup to a new database/schema
1. Create and open a new database/schema.
2. Click Backup.
3. Inthe Objects tab, control-click anywhere and select Restore Backup from.
4. Browse the backup file.
5. Choose the restore options and click Start.
Hint: You can also restore Navicat Windows and Linux backups.

Note: You must have Create, Drop and Insert privileges (MySQL/MariaDB or PostgreSQL) to run the restore.
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General Properties

In this tab, you can view the target server and database information and the backup file information.

Object Selection

In this tab, choose database objects you wish to restore.

Advanced Properties

Note: The following options depend on the connection server type, the backup file version and sort in ascending order.

Continue on error

Ignore errors that are encountered during the restore process.

Create indexes

Create indexes for the restored table with this option is on.

Create tables

Create tables during the restore process with this option is on.

Create records

Restore table records with this option is on. Otherwise, only table structures will be restored.

Create triggers

Create triggers for the restored table with this option is on.

Empty table

Delete all table records in the database/schema.

Lock tables for write

Lock the tables to prevent user to modify tables during the restore process.

Overwrite existing events

Overwrite if events already exist in the database/schema.

Overwrite existing functions

Overwrite if functions already exist in the database/schema.

Overwrite existing indexes

Overwrite if indexes already exist in the database/schema.
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Overwrite existing sequences
Overwrite if sequences already exist in the database/schema.
Overwrite existing tables
Overwrite if tables already exist in the database/schema.
Overwrite existing triggers
Overwrite if triggers already exist in the database/schema.
Overwrite existing types
Overwrite if types already exist in the database/schema.
Overwrite existing views
Overwrite if views already exist in the database/schema.
Use extended insert statements
Check this option if you want to insert records using extended insert syntax.
Example: INSERT INTO “users™ VALUES ('1', 'Peter McKindsy', '23"), ('2', 'Johnson Ryne', '56"), (‘'0', 'Katherine', '23");
Use transaction
Check this option if you want to rollback all data when error occurs.
Extract SQL
Extract SQL allows extracting SQL into a SQL file from your backup file.
Extract a backup file that is in your database/schema
1. Open a database/schema.
2. Click Backup and select an existing backup file.
3. Click B4 from the object toolbar.
4. Choose the Extract SQL options and click Start.
5. Choose a path for the SQL file.
Extract a backup file that is in any location
1. Open any one of your databases/schemas.

2. Click Backup.
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3. Inthe Objects tab, control-click anywhere and select Extract SQL from.
4. Browse the backup file.
5. Choose the Extract SQL options and click Start.

6. Choose a path for the SQL file.

Oracle Data Pump (Available only in Non-Essentials Edition)

About Oracle Data Pump

Data Pump includes two utilities: Data Pump Export and Data Pump Import. Data Pump Export is for unloading data
and metadata into a dump file set. Data Pump Import is for loading an export dump file set into a target system. In the

main window, click € Data Pump to open the data dump object list.

To change the directory of the dump file set, control-click anywhere in the Objects tab and select Change Directory.

Note: Data Pump is added in Oracle 10g or later. You require SYSDBA role to perform it. Dump file sets are stored in

servers.

Oracle Data Pump Export

Before executing Data Pump Export, select the SQL Preview tab to review the SQL statements. Then, you can click

the Start button to run the export process.

You can save the Data Pump Export settings to a profile for future use. Data Pump Export profiles (.nbakora) are saved

under the Settings Location.

To show the hidden tabs (advanced options), check the Show Advanced Options option.
General Properties

Job Name

Specify the name of the job.

Mode

Choose the export mode: FULL, TABLESPACE, SCHEMAS, TABLE.

Content

Choose which data to export.

Export Data

Select which objects to export. If you select the TABLE export mode, choose a schema in the Schema drop-down

menu.
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Dump Files

Add dump files to the dump file set for the export.

Metadata Filter

In this tab, you can include or exclude specific objects types.

Data Filter

Query

Specify a subquery that is added to the end of the SELECT statement for a table.

Sample

Specify a percentage for sampling the data blocks to be moved.

Remap Data

In this tab, you can specify remap functions for column data.

Encryption

Encryption Content

Choose what to encrypt in the dump file set.

Encryption Algorithm

Choose a cryptographic algorithm to perform encryption.

Encryption Mode

Choose the encryption mode: Transparent, Encryption Password, Dual.

Encryption Password

If you choose the Encryption Password or Dual encryption mode, enter a password to encrypt data written to the dump

file.

Confirm Password

Re-type your password.

Advanced Properties

Thread Number

Enter the maximum number of worker processes that can be used for the job.
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Reuse file

Check this option to overwrite a preexisting file.

Enable XMLCLOBS

Check this option to enable data options for XMLCLOBS.

Enable cluster

Check this option to start workers on instances usable by the job.

Service Name

Specify a service name that used to constrain the job to specific instances or to a specific resource group.

Version

Specify the version of database objects to be extracted.

Database Link

Choose a database link to the remote database that will be the source of data and metadata for the job.

Estimate

Choose the estimate method for the size of the tables should be performed before starting the job.

Compression Type

Specify which data to compress before writing to the dump file set.

Transportable

If you select the TABLE export mode, choose to never or always use the transportable option.

Access Method

Choose an alternative method to unload data if the default method does not work.

Source Edition

Specify the application edition.

Directory

Choose the directory for saving the log file.

Log File Name

Enter the name of the log file.
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Flashback SCN

Enter the system change number (SCN) that used to enable the Flashback Query utility.
Flashback Time

Select a timestamp for finding a SCN.

Oracle Data Pump Import

Before executing Data Pump Import, select the SQL Preview tab to review the SQL statements. Then, you can click

the Start button to run the import process.

To show the hidden tabs (advanced options), check the Show Advanced Options option.

General Properties

Job Name

Specify the name of the job.

Mode

Choose the import mode: FULL, TABLESPACE, SCHEMAS, TABLE.

Content

Choose which data to import.

Table Exists Action

Specify the action to be performed when data are loaded into a preexisting table.

Import Data

Select which objects to import. If you select the TABLE import mode, specify the schema name in the Schema text box.
Dump Files

Add dump files to the dump file set for the import.

Network

Database Link

Choose a database link to the remote database that will be the source of data and metadata for the job.
Estimate

Choose the estimate method for the size of the tables should be performed before starting the job.
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Flashback SCN

Enter the system change number (SCN) that used to enable the Flashback Query utility.

Flashback Time

Select a timestamp for finding a SCN.

Transportable

If you select the TABLE export mode, choose to never or always use the transportable option.

Datafile Path

Specify the full file specification for a datafile in the transportable tablespace set.

Filters

Include/Exclude

Include or exclude specific objects types.

Query

Specify a subquery that is added to the end of the SELECT statement for a table.

Remap Data

Remap Data

Specify remap functions for column data.

Remap DataFiles

Specify the remapping for data files.

Remap Objects

Remap Schemas

Specify the remapping for schemas.

Remap Tablespaces

Specify the remapping for tablespaces.

Remap Tables

Specify remap functions for tables.
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Advanced Properties

Number of worker processes to be used

Enter the maximum number of worker processes that can be used for the job.

Reuse datafiles

Check this option to reuse existing data files for creating tablespace.

Skip unusable indexes

Check this option to skip loading tables that have indexes that were set to the Index Unusable state.

Skip const error

Check this option to skip constraint violations and continue the load.

Disable append hint

Check this option to prevent the append hint from being applied to the data load.

Cluster

Check this option to start workers on instances usable by the job.

Service Name

Specify a service name that used to constrain the job to specific instances or to a specific resource group.

Version

Specify the version of database objects to be extracted.

Streams configuration

Check this option to import any general Streams metadata that may be present in the export dump file

Partition Options

Choose how to handle partitioned tables during the import operation.

Access Method

Choose an alternative method to unload data if the default method does not work.

Encryption Password

Enter the password if an encryption password was specified in Data Pump Export.

Target Edition
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Specify the database edition into which objects should be imported.
Segment Attributes, Segment Creation, Storage, OID, PCTSpace
Choose the objects that the transformations to be applied to.
Directory

Choose the directory for saving the log file.

Log File Name

Enter the name of the log file.

SQL Server Backup & Restore (Available only in Non-Essentials

Edition)

About SQL Server Backup & Restore

The SQL Server Backup feature provides an important safeguard for protecting your SQL Server data. In the main

window, click SQL Server Backup to open the backup object list.

If you want to backup with the setting of an existing backup file, you can control-click a backup file in the Objects tab

and select Backup From This Setting.
Note: Backup files are stored in servers.

If you want to restore from a backup file that is not listed in the Objects tab, you can control-click anywhere in the

Objects tab and select Restore From File.

SQL Server Backup

Before starting the backup process, click the Generate SQL button to review the SQL statements. Then, you can click

the Start button to run the backup process.

You can save the backup settings to a profile for future use. Backup profiles (.nbakmssql) are saved under the Settings

Location.

To show the hidden tabs (advanced options), check the Show Advanced Options option.
General Properties

Backup Set Name

Specify the name of the backup set.

Description
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Specify the description of the backup set.

Backup Type

Choose the type of the backup that you want to perform: Full Backup, Differential Backup, Transaction-Log Backup.

Copy-only

Check this option to specify that the backup is a copy-only backup.

New media set

Create a new media set for this backup. To add backup devices or files to the list, click the Add device button.

Existing media set

Choose an existing media set for the backup.

Components

In this tab, you can choose to backup the whole database, the partial database, or specific files or groups.

Advanced Properties

Never expire

Specify the backup set never expires.

Expire after

Specify the number of days that must elapse before this backup media set can be overwritten.

Expire on

Specify when the backup set expires and can be overwritten.

Password

Enter a password for the backup set.

Format media set

Check this option to specify that a new media set be created.

New Name

Enter the name of the new media set.

Description

Specify the description of the media set.
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Overwrite all backups

Check this option to specify that all backup sets should be overwritten, but preserves the media header.
Check media name and backup set expiration

Check this option to check the expiration date and time of the backup sets on the media before overwriting them.
Media Set Name

Specify the media name for the entire backup media set.

Password

Enter a password for the media set.

Truncate the transaction log

Choose this option to truncate the transaction log.

Back up the tail of the log and leave the database in the restoring state

Choose this option to back up the tail of the log and leaves the database in the RESTORING state.
Verify backup

Check this option to verify the backup.

Perform checksum

Check this option to enable the backup checksums.

Continue on error

Ignore errors (such as invalid checksums or torn pages) that are encountered during this backup.
Compression

Choose whether backup compression is performed on this backup.

SQL Server Restore

Before starting the restore process, click the Generate SQL button to review the SQL statements. Then, you can click

the Start button to run the restore process.

General Properties

Restore to database

Select a database to restore.
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Source of backup set

If you chose Restore From File in the Objects tab, you can add backup devices or files to the list by clicking the Add

device button.

Latest possible

Choose this option if do not have the restore point.

Specific time

Choose this option to specify that the database be restored to the state it was in as of the date and time.

Marked transaction

Choose this option to recover to a specified recovery point.

Include marked transaction

Check this option to include the specified transaction in the recovery.

Restore plan

If you chose Restore From File in the Objects tab, you can choose the database backup files from the list.

Advanced Properties

Restore database files to

Specify that the data or log file should be moved by restoring it to the Restore To location.

WITH REPLACE

Check this option to include the WITH REPLACE argument.

WITH RESTRICTED_USER

Check this option to include the WITH RESTRICTED_USER argument.

WITH KEEP_REPLICATION

Check this option to include the WITH KEEP_REPLICATION argument.

RECOVERY

Choose this option to roll back all uncommitted transactions.

NORECOVERY

Choose this option to not roll back the uncommitted transactions.
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STANDBY

Specify a Standby file that allows the recovery effects to be undone.

MongoDump & MongoRestore

About MongoDump & MongoRestore

MongoDB provides two utilities for backup and restore operations: MongoDump and MongoRestore. They are useful

for creating backups of small database and restoring data.
MongoDump
MongoDump can read data from a MongoDB database and create high fidelity BSON files.
Note: You must have mongodump executable for this feature to work.
To dump afile
1. In Navicat main window, control-click your database or collection and select MongoDump.
2. Inthe General and Advanced tabs, select the output path and the appropriate dump options.

3. Click the Start button to begin the dump process. The Message Log tab will display the dump progress,

execution time, and success or failure messages.

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the

Load Profile button and select a profile from the list.

Hint: Profiles are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft CyberTech/Navicat

CC/Common/Profiles
MongoRestore
MongoRestore can load data from a binary database dump created by MongoDump into a MongoDB database.
Note: You must have mongorestore executable for this feature to work.
To restore database
1. In Navicat main window, control-click your database and select MongoRestore.
2. Inthe General and Advanced tabs, select the input file/directory path and the appropriate restore options.

3. Click the Start button to begin the restore process. The Message Log tab will display the restore progress,

execution time, and success or failure messages.

You can save your settings as a profile for future use. To open a saved profile, click the Load Profile button and select

a profile from the list.
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Hint: Profiles are saved under the default path, e.g. ~/Library/Application Support/PremiumSoft CyberTech/Navicat

CC/Common/Profiles
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Chapter 14 - Server Security

About Server Security

Navicat provides a powerful tool for you to manage server user accounts and the privileges of database objects. All

. - .. - . . - -
information of users and privileges are stored in the server. In the main window, click <= User to open the user/role

object list.

MySQL / MariaDB User & Role Management
User Designer

General Properties

User Name

Define a name for the user account.

Host

Enter a host name or an IP address where the user connected from. % means any host.
Plugin

Select the account authentication plugin for the user.

Password

Specify a login password for the user.

Confirm Password

Re-type the login password.

Expire Password Policy

Select the password expiration policy for the user account.

Member Of

Note: Roles are available for MySQL 8.0 or later or MariaDB 10.0.5 or later.

In the grid, check the Granted or Default option against the role listed in Name to assign this user to be a member of

the selected role.

Advanced Properties
Maximum Queries Per Hour, Maximum Updates Per Hour, Maximum Connections Per Hour

219



Specify the maximum number of queries, updates, and connections that a user can perform during any given one-hour

period. 0 means no limit.

Maximum User Connection

Specify the maximum number of simultaneous connections that a user can make.

Use OLD_PASSWORD encryption

Use the OLD_PASSWORD() function to generate a hash value for storing user password.
SSL Type

Specify the SSL/TLS-related options for the user account.

ANY Require SSL encryption when the user connects.

SPECIFIED Require a valid certificate when the user connects. Provide SSL Cipher,

Certificate Issuer, or Certificate Subject.

X509 Require a valid certificate when the user connects.

Server Privileges

In the grid, check the Grant option against the server privilege listed in Privilege to assign this user to have that

privilege. To grant or revoke all privileges, control-click on the grid and select Grant All or Revoke All.
Object Privileges
To edit specific object privileges for the user, click % to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. In the grid, check the Grant option against the privilege listed in Privilege to assign this user to have that

privilege. To grant or revoke all privileges, control-click on the grid and select Grant All or Revoke All.

Role Designer

Note: Roles are available for MySQL 8.0 or later or MariaDB 10.0.5 or later.

General Properties

Role Name

Define a name for the role.

Members
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In the grid, check the Granted option against the role listed in Name to assign the selected role/user to be a member of

this role.

Member Of

In the grid, check the Granted option against the role/user listed in Name to assign this role to be a member of the

selected role.

Server Privileges

In the grid, check the Grant option against the server privilege listed in Privilege to assign this role to have that

privilege. To grant or revoke all privileges, control-click on the grid and select Grant All or Revoke All.

Object Privileges

To edit specific object privileges for the role, click & to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. In the grid, check the Grant option against the privilege listed in Privilege to assign this role to have that

privilege. To grant or revoke all privileges, control-click on the grid and select Grant All or Revoke All.

Oracle User & Role Management
User Designer

General Properties

User Name

Define a name for the user.

Authentication

Select the authentication method.

PASSWORD Create a user. Specify a Password and re-type it in Confirm Password. Check the
Expire Password option to force the user to change the password on the first attempted

login.

EXTERNAL Create a user authorised by an external service. Enter the certificate distinguished name

or the Kerberos principal name in External Name.

GLOBAL Create a user authorised by the enterprise directory service. Enter the X.509 name at the

enterprise directory service that identifies the user in X.500 Distinguished Name.

Default Tablespace
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Choose the default tablespace for objects that the user creates.

Temporary Tablespace

Choose the tablespace or tablespace group for the user's temporary segments.
Profile

Choose the profile that assign to the user.

Locked Account

Lock the user's account and disable access.

Enable Editions

Allow the user to create multiple versions of editionable objects in this schema.

Roles

In the grid, check the Grant, Admin Option or Default option against the role listed in Role Name to assign this user to
be a member of the selected role.

Quotas

In the grid, specify the maximum amount of space that the user can allocate in the tablespaces. Enter the Quota and
choose the Unit. Unlimited lets the user allocate space in the tablespace without bound. Multiple tablespaces can be

set.

Server Privileges

In the grid, check the Grant or Admin Option option against the server privilege listed in Privilege to assign this user
to have that privilege. To grant or revoke all privileges, control-click on the grid and select Grant All, Grant All With

Admin Option or Revoke All.

Object Privileges

To edit specific object privileges for the user, click % to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. Inthe grid, check the Grant or Grant Option option against the privilege listed in Privilege to assign this user
to have that privilege. To grant or revoke all privileges, control-click on the grid and select Grant All, Grant All

With Grant Option or Revoke All.
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Role Designer
General Properties

Role Name

Define a name for the role.
Authentication

Select the authentication method.

PASSWORD Create a role. Specify a Password and re-type it in Confirm Password.
EXTERNAL Create a role authorised by an external service.

GLOBAL Create a role authorised by the enterprise directory service.

NOT IDENTIFIED Create a role without a password.

Roles

In the grid, check the Granted or Admin Option option against the role listed in Role Name to assign this role to be a

member of the selected role.

Members

In the grid, check the Granted or Admin Option option against the user listed in Name to assign the selected user to

be a member of this role.

Server Privileges

In the grid, check the Grant or Admin Option option against the server privilege listed in Privilege to assign this role to
have that privilege. To grant or revoke all privileges, control-click on the grid and select Grant All, Grant All With

Admin Option or Revoke All.

Object Privileges

To edit specific object privileges for the role, click % to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. In the grid, check the Granted option against the privilege listed in Privilege to assign this role to have that

privilege. To grant or revoke all privileges, control-click on the grid and select Grant All or Revoke All.
Maintain User
Navicat provides a complete solution for maintaining Oracle users.

1. Inthe main window, select users in the Objects tab.



2. Control-click the selected users.

3. Choose Maintain, and then choose a maintain option the from the pop-up menu.

Option Description

Lock User Lock the user account and disable access.
Unlock User Unlock the user account and enable access.
Expire User Set the password of the user account to expire.

PostgreSQL User, Group & Role Management

User Designer

Note: Users are available for PostgreSQL 8.0 or below.

General Properties

User Name

Define a name for the user.

User ID

Specify an ID for the user.

Password

Specify a login password for the user.

Confirm Password

Re-type the login password.

Password Encryption

Choose whether the password is stored ENCRYPTED or UNENCRYPTED in the system catalogs.
Expiry Date

Set a datetime that the user's password will expire. If this option is omitted, the password will be valid for all time.
Superuser

Check this option to determine the user is a superuser.

Can create databases

Check this option to allow the user to create databases.
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Members Of

In the grid, check the Granted option against the group listed in Group Name to assign this user to be a member of the

selected group.

Object Privileges

To edit specific object privileges for the user, click % to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. Inthe grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this
user to have that privilege. To grant or revoke all privileges, control-click on the grid and select Grant All,

Grant All With Grant Option or Revoke All.

Group Designer

Note: Groups are available for PostgreSQL 8.0 or below.
General Properties

Group Name

Define a name for the group.

Group ID

Specify an ID for the group.

Members

In the grid, check the Granted option against the user listed in Member to assign the selected user to be a member of

this group.

Object Privileges

To edit specific object privileges for the group, click % to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. Inthe grid, check the Granted option against the privilege listed in Privilege to assign this group to have that

privilege. To grant or revoke all privileges, control-click on the grid and select Grant All or Revoke All.

Role Designer

Note: Roles are available for PostgreSQL 8.1 or later.
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General Properties

Role Name

Define a name for the role.

Role ID

Specify an ID for the role.

Can Login

Check this option to allow the role to log in.

Password

Specify a login password for the role.

Confirm Password

Re-type the login password.

Password Encryption

Choose whether the password is stored ENCRYPTED or UNENCRYPTED in the system catalogs.

Connection Limit

Specify how many concurrent connections the role can make. -1 means no limit.

Expiry Date

Set a datetime that the role's password will expire. If this option is omitted, the password will be valid for all time.

Can create databases

Check this option to allow the role to create databases.

Superuser

Check this option to determine the role is a superuser.

Can modify catalog directly

Check this option to allow the role to update system catalog.

Inherits rights from parent roles

Check this option to determine the role inherits the privileges of roles it is a member of.

Can create roles
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Check this option to allow the role to create roles.

Can replicate

Check this option to allow the role to initiate streaming replication or put the system in and out of backup mode.
Can bypass RLS

Check this option to allow the role to bypasses every row-level security (RLS) policy.

Members

In the grid, check the Granted or Admin Option option against the role listed in Member to assign the selected role to

be a member of this role.

Members Of

In the grid, check the Granted or Admin Option option against the role listed in Role Name to assign this role to be a

member of the selected role.

Object Privileges

To edit specific object privileges for the role, click & to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. In the grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this
role to have that privilege. To grant or revoke all privileges, control-click on the grid and select Grant All, Grant
All With Grant Option or Revoke All.

SQL Server Login, Role & User Management

Login Designer

Note: The following options and tabs depend on the server version and the authentication type.
General Properties

User Name

Define a name for the login.

Authentication Type

Select the authentication type of the login.

Password
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Specify a password for the login.

Confirm Password

Re-type the login password.

Specify Old Password

Check this option to enter the old password used by this account when editing the login.

Enforce password policy

Check this option to force password to follow password policy of SQL Server.

Enforce password expiration

Check this option to force password to have expiry date.

User must change password at next login

Check this option to force user to change password every time when login.

Default Database

Select the default database when login.

Default Language

Select the default display language when login.

Certificate Name

Select the certificate to be used for the login.

Asymmetric Key Name

Select the asymmetric key to be used for the login.

Credential

Select the credentials to be mapped to the login.

Enabled

Check this option to enable the login.

User Mappings

In the grid, check the Database and enter the User and Default Schema to create user for login the database and

specify the first schema will be searched by the server.
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Roles

In the list, assign this server login to be a member of the selected server role.

Server Permissions

In the grid, check the Grant, Grant Option or Deny option against the server permissions listed in Privileges to assign
this login to have that permission. To grant, deny or revoke all permissions, control-click on the grid and select Grant
All, Grant All With Admin Option, Deny All or Revoke All.

Login Permissions

In the grid, check the permissions against the endpoint listed in Login to assign this login to have that login permission.
Click the checkbox twice to grant the permission with Grant Option. Click the checkbox three times to deny the

permission.

Endpoint Permissions

In the grid, check the permissions against the endpoint listed in Endpoint to assign this login to have that endpoint
permission. Click the checkbox twice to grant the permission with Grant Option. Click the checkbox three times to deny

the permission.

Server Role Designer

Note: Azure SQL Database does not support Server Role.

In the Members tab, assign the selected login to be a member of this server role.

Database User Designer

Note: The following options and tabs depend on the server version and the user type.
General Properties

User Name

Define a name for the database user.

Authentication

Select the security type for database user.

User Name

Assign a SQL Server login that the database user uses.

Default Schema

Select the default schema that will own objects created by the database user.
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Certificate Name

Select the certificate to be used for the database user.
Asymmetric Key Name

Select the asymmetric key to be used for the database user.

Roles

In the list, assign this database user to be a member of the selected database role.

Owned Schemas

In the list, check the schemas that are owned by the database user.

Database Permissions

In the grid, check the Grant, Grant Option or Deny option against the database permissions listed in Privilege to
assign this database user to have that permission. To grant, deny or revoke all permissions, control-click on the grid
and select Grant All, Grant All With Admin Option, Deny All or Revoke All.

Object Privileges

To edit specific object permissions for the database user, click % to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. Inthe grid, check the Grant, Grant Option or Deny option against the permission listed in Privilege to assign
this database user to have that permission. To grant, deny or revoke all permissions, control-click on the grid

and select Grant All, Grant All With Grant Option, Deny All or Revoke All.

Database Role Designer

Note: The following options and tabs depend on the server version.
General Properties

Role Name

Define a name for the database role.

Owner

Assign the owner for the database role.

Members
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In the list, assign the selected database users and roles to be a member of this database role.

Members Of

In the list, assign this database role to be a member of the selected database roles.

Owned Schemas

In the list, check the schemas that are owned by the database role.

Database Permissions

In the grid, check the Grant, Grant Option or Deny option against the database permissions listed in Privilege to
assign this database role to have that permission. To grant, deny or revoke all permissions, control-click on the grid and
select Grant All, Grant All With Admin Option, Deny All or Revoke All.

Object Privileges

To edit specific object permissions for the database role, click % to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. Inthe grid, check the Grant, Grant Option or Deny option against the permission listed in Privilege to assign
this database role to have that permission. To grant, deny or revoke all permissions, control-click on the grid

and select Grant All, Grant All With Grant Option, Deny All or Revoke All.

Application Role Designer

Note: Azure SQL Database does not support Application Role. The following options and tabs depend on the server

version.

General Properties

Role Name

Define a name for the application role.
Password

Specify a password for the application role.
Confirm Password

Re-type the password.

Default Schema

Select the default schema that will own objects created by the application role.
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Owned Schemas

In the list, check the schemas that are owned by the application role.

Database Permissions

In the grid, check the Grant, Grant Option or Deny option against the database permissions listed in Privilege to
assign this application role to have that permission. To grant, deny or revoke all permissions, control-click on the grid

and select Grant All, Grant All With Admin Option, Deny All or Revoke All.

Object Privileges

To edit specific object permissions for the application role, click & to open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the object to show the grid on the right pane.

3. Inthe grid, check the Grant, Grant Option or Deny option against the permission listed in Privilege to assign
this application role to have that permission. To grant, deny or revoke all permissions, control-click on the grid
and select Grant All, Grant All With Grant Option, Deny All or Revoke All.

SQLite User Management

Note: By default, a SQLite database does not require user authentication (no-authentication-required database). After
you created a user, the database will be marked as requiring authentication (authentication- required database). Then,

user need to provide username and password when connecting to the database file.
General Properties

User Name

Define a name for the user account.

Password

Specify a login password for the user.

Confirm Password

Re-type the login password.

Administrator

Check this option to give the admin privilege to the user.
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MongoDB User & Role Management
User Designer

General Properties

User Name

Define a name for the user.

Password

Specify a login password for the user.

Confirm Password

Re-type the login password.

Password Digestor

Indicate whether the server or the client digests the password.
Mechanisms

Specify the SCRAM mechanisms for creating SCRAM user credentials.

Custom Data

In this tab, you can enter any information associated with this user.

Built-in Roles

In the list, assign this user to be a member of the selected built-in role.

User-defined Roles

In the list, assign this user to be a member of the selected user-defined role.

Authentication Restrictions

To edit specific authentication restrictions that the server enforces on the user, click
Client Source

Specify a list of IP addresses or CIDR ranges to restrict the client’s IP address.
Server Address

Specify a list of IP addresses or CIDR ranges to which the client can connect.
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Role Designer
General Properties

Role Name

Define a name for the role.

Built-in Roles

In the list, assign this role to be a member of the selected built-in role.

User-defined Roles

In the list, assign this role to be a member of the selected user-defined role.

Members (Roles)

In the list, assign the selected role to be a member of this role.

Members (Users)

In the list, assign the selected user to be a member of this role.

Authentication Restrictions

To edit specific authentication restrictions that the server enforces on the role, click =&.

Client Source

Specify a list of IP addresses or CIDR ranges to restrict the client’s IP address.

Server Address

Specify a list of IP addresses or CIDR ranges to which the client can connect.

Privileges

To edit specific object privileges for the role, click & (o open the window and follow the steps below:
1. Expand the node in the tree view until reaching to the target object.
2. Check the objects that you want to grant the privileges on.

3. In the grid, check the State option against the privilege listed in Privilege to assign this role to have that

privilege. To grant or revoke all privileges, control-click on the grid and select Grant All or Revoke All.
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Privilege Manager

Besides setting privileges in each user, Privilege Manager provides another view on privileges in a connection and its

database objects.
Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server, MariaDB and MongoDB.
To add privileges, click @ from the user object toolbar and follow the steps below:

1. Expand the node in the tree view until reaching to the target object.

2. Choose the object and click % to open the window.

3. Check the user on the left pane.

4. In the grid, check the relevant options against the privileges listed in Privilege to assign the selected user to

have that object privilege.
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Chapter 15 - Other Advanced Tools

Server Monitor (Available only in Non-Essentials Edition)

Navicat provides Server Monitor to view properties of selected servers. Chosoe Tools -> Server Monitor and choose

the preferred server type from the menu bar.
Note: Available only for MySQL, Oracle, PostgreSQL, SQL Server, MariaDB and MongoDB.

Process List

This tab displays a list of processes from all selected servers. The process list provides the following detailed

information. It depends on the database type you are chosen.
* Server name that is given while setting the connection.
* Process ID on the server.
e Serial number of the process.
e Current user who log in to the server.
* Host from which the user is connected.
* Database that the user is currently used.
e Last command that was issued by the user.
* Time, state and info of the process.
* CPU time and state of the process.

If you want to take action on auto-refreshing the process list in assigned seconds, choose Server Monitor -> Set Auto
Refresh Time and enter a refresh time value. To enable or disable the Auto Refresh feature, choose Server Monitor

-> Auto Refresh.
Note: Effect will take once you assign the value.

To set a selected process always show on the top of the grid, control-click and select Set Always On Top -> Always

On Top. To cancel this setting, choose Cancel / Cancel All.

To stop a selected process, click the 8% button.

Variables

Note: Available only for MySQL, Oracle, PostgreSQL, MariaDB and MongoDB.

This tab displays a list of all server variables and their values.
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You can edit MySQL, MariaDB and Oracle variable values here. Click J to open an editor for editing.
Status
Note: Available only for MySQL, Oracle, PostgreSQL, MariaDB and MongoDB.

This tab displays a list of all server status and their values.

Schema Analysis (Available only in Non-Essentials Edition)

Schema Analysis is used for verifying your schemas, visualizing data distributions and identifying data outliers. To start,

select a collection or a view in the Objects tab and click IL, or click [l in the data viewer.
Note: Available only for MongoDB.

Hint: Schema Analysis Profiles (.nsatmongodb) are stored under the Settings Location.

Toolbar
Option / Button Description
Y Filter the documents for analyzing.
2- Include or exclude fields for analyzing.
Analyze: Select the sample documents from the collection for analyzing.
> Start analyzing the sample documents.
[ | Stop analyzing the sample documents.
Results

After the analysis has completed, you will see the schema analysis results. The results visually display information

about the type and data distribution of all fields.

If a field has multiple field types, you can click the field type bar on the left, and the chart will show the data distribution

chart of that type.
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Virtual Grouping (Available only in Non-Essentials Edition)

DEPARTMENT_ID
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Virtual Group aims to provide a platform for logical grouping objects by categories, so that all objects are effectively
preserved. It can be applied on Connection, Table, Collection, View, Materialized View, Function, Index, Trigger,

MapReduce, GridFS, Query, Backup, Automation, Model and Charts.

Hint: The vgroup.json file is saved under the default path, e.g. ~/Library/Application Support/PremiumSoft

CyberTech/Navicat CC/Navicat Premium/Profiles

If you want to hide the group structure, choose View -> Navigation Pane -> Flatten Connection and choose View ->
Flatten Object List.

Create a new group

1. Inthe main window, control-click on the Navigation pane or the Objects tab and select New Group or Manage

Group -> New Group.

2. Enter a name for the new group.

Move an object to a group

1. Inthe main window, control-click an object and select Manage Group -> Add to Group.

2. Select an existing group.

Move an object to the top-level
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1. Inthe main window, control-click an object and select Manage Group -> Exclude From Group.

Hint: You can also use the drag and drop method to move objects.

Connection Colorings

Navicat provides highlighting connections by colors for identifying connections and their database objects. It lets you
immediately know which connection you're connected to when you working on database objects. The highlighted color

displays in the Navigation pane and the tab of its object window.

To highlight a connection, control-click a connection in the Navigation pane and select Color.
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Find in Database/Schema (Available only in Non-Essentials

Edition)

Navicat provides a Find in Database/Schema feature offers searching table and view records or object structures

within a database and/or schema. To open the Find in Database/Schema window,

Database/Schema from the menu bar.

1. Select atarget Connection, Database and/or Schema.

2. Enter the search string in Find.

3. Choose to find Data or Structure in the Look in drop-down menu.

4. Choose the Search Mode: Contains, Whole Word, Prefix or Regular Expression.
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5. Check the Case Insensitive box to disable case sensitive search if necessary.

6. When finding Structure, you can choose to search different objects: Tables, Collections, Views, Functions,

Queries, Indexes, Triggers, Events and/or Materialized Views.

7. Click the Find button and then double-click an object in the Find Results list to view the record or the

structure.

Print Structure (Available only in Non-Essentials Edition)

Navicat allows you to view and print database, schema and table structures, including table names, field names, field
types and other field properties. In the main window, control-click a database, a schema or tables and select Print

Database, Print Schema or Print Tables.

Note: Available only for MySQL, Oracle, PostgreSQL, SQLite, SQL Server and MariaDB.

Console

Console allows you to use a command-line interface to work with your server. In other words, it provides interactive
text-based screen for you to query input and result output from databases. To open the Console window, open a

connection and choose Tools -> Console from the menu bar or press COMMAND-SHIFT-C.
Hint: You are allowed to open multiple console windows which each represents a different connection.

Oracle

For Oracle servers, you must have SQL*Plus executable for this feature to work. By default, Navicat will look for
SQL*Plus under client folder (e.g. ORACLE_HOME\bin). However, if Navicat cannot locate SQL*Plus under the

SQL*Plus Executable Path, you are prompted to locate the executable.
Note: SQL*Plus does not support Unicode.

MongoDB

For MongoDB servers, you must have Mongo Shell executable for this feature to work. If Navicat cannot locate Mongo

Shell under the Mongo Shell default path, you are prompted to locate the executable.

Favorites (Available only in Non-Essentials Edition)

Favorites are links to database objects that you visit frequently. By adding a path to your favorites list, you can go to
that database objects with a single click, instead of having to navigate the connection, database and/or schema in the

Navigation pane.
Add alink to Favorites

1. Open an object, e.g. table.
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2. Choose Favorites -> Add to Favorites or press OPTION-SHIFT-#.

3. Enter Favorite Name and select Favorite ID.

Open an object from Favorites

1. Choose Favorites -> favorite_name or press CONTROL-SHIFT-#.

Remove links from Favorites

* Choose Favorites -> Clear Favorites -> favorite_name to remove a link.

e Choose Favorites -> Clear Favorites -> Clear All to remove all links from the favorites list.

Note: # represents 1, 2, 3,4, 5,6, 7,8 or 9.

Search Filter

Navicat provides search filters for searching your objects in the Navigation pane, the Objects tab, the Model Designer

window and other tree structures.

Simply enter a search string in the Search text box directly. If connections have opened in the Navigation pane, the

filter will also apply to their database objects.

You can remove the filter by deleting the search string.
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Chapter 16 - Configurations

Preferences Settings

Navicat provides several options for customizing its user interface and performance.

To open the Preferences window, choose Navicat XXX -> Preferences from the menu bar.

General

Main Window

Show objects under schemain navigation pane

Display database objects using the tree structure in the Navigation pane. To expand a node, simply double-click it.
Hint: Reopen the database/schema to take effect.

Font

Define the font and its size used by the object list.

Use default font

Check this option to use the default font settings.

Database items

Warn if no primary keys found in table

Check this option if you require notification while opening the table with no primary key being set.
Show function wizard

Display the function wizard (MySQL, Oracle, PostgreSQL, SQL Server or MariaDB) when you create a new

function/procedure.

Usage Data

Share Usage Data

Check this option to let your device sends us information about how you use Navicat to help us improve it. You can

view the information being shared by clicking the Usage Data button.

Update

Automatically check for updates
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Check this option to allow Navicat checks for new version automatically at a selected time.
Include anonymous system profile

Check this option to send us your system information, such as your macOS version to improve our Navicat when

Navicat checks for updating.

Tabs

On Startup

Control what tabs appear when you launch Navicat:

Option Description

Open Obijects tab only Open the Objects tab only, and no other tabs.

Continue where you left | Open the Objects tab, and reopen the same tabs you were opened when you last

off quit Navicat.
Open a specific tab or Open the Objects tab, and open the tabs you choose in Set Tabs.
set of tabs

Open Tabs

Open new tab in

Set new pop-up windows to open as:

Option Description

Main Window Open a new tab in the main window.

Last Tab Window Open a new tab in the last opened window.

Last Tab Window Open a new tab in the last opened window, or a new window if there isn't any

(Except Main Window) opened windows.

New Window Open a new window.

Allow opening multiple forms for same object

Check this option to allow opening multiple instances of an object.

Tab Bar Style

Always show the tab bar

Always show the tab bar when you open a window.

Query

Code Completion
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Use code completion (Available only in Non-Essentials Edition)

When you type the . (dot) symbol or a character, the editor will offer you a pop-up list that showing some suggestions

for the code completion.
Auto update code completion info (Available only in Non-Essentials Edition)

With this option is on, Navicat will get the latest database information for code completion from your server
automatically when you open the database/schema. Otherwise, you will need to update it manually in the Query

window.

See SQL Editor or Script Editor.

Query

Ask to save new queries/profiles before closing

With this option is on, Navicat will prompt you to save new queries or profiles every time when you quit the relevant

sub-window.
Autosave modified queries

Save automatically after modifications in Query Editor by defining the interval (e.g. Every 30 seconds).

Editor

Disable syntax highlight and code completion if SQL larger than: [ ] MB

The highlighting and code completion features can be limited by setting the maximum file size (e.g. 10) to increase

performance.

Show

Show line number

Display line numbers at the side of the editor for easily reference.

Use code folding

Code folding allows codes to collapse as a block and only the first line displayed in the editor.
Use brace highlighting

Highlight the pair of braces when your cursor moves to either one brace for easily reference.
Use syntax highlighting

Syntax highlight helps viewing codes clearly. Codes are highlighted in the editor with different colors and fonts

according to the categories they belong to.
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Text Layout
Tab Width: [ ] spaces

Enter the number of characters that a tab occupies, e.g. 5.
Use word wrap

Enable the word wrap mode in the editor.

Font and Colors

Font

Define the font and its size used by the editor.

Use default font

Check this option to use the default font settings.

Syntax Colors

Format your queries in the editor with colored syntax highlighting to improve readability. Set font colors to mark out
different text fragments: Common, Keyword, String, Number, Comment and Background. Click on the color boxes and

choose your desired color from the Colors dialog window.

Records

Records
Limit records [ ] records per page

Check this option if you want to limit the number of records showed on each page in the grid globally. Otherwise, all

records will be displayed in one single page.
Note: To adjust the settings for particular table/collection, see Data Viewer.
Auto begin transaction

Check this option to start a new transaction automatically when changing records in the table/collection. Otherwise,

auto commit is on and you need click the 58 button in Data Viewer to start a transaction manually.

When starting a transaction in Data Viewer, you can use the 55 or 5 button to commit or rollback the changes. See
Data Viewer.

Synchronize record after modifying

When updating/inserting a row in the grid (if primary key exists), it will reload this record from the server.
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For example: a table with 3 columns - id, name and timestamp. If you update the name column, the timestamp will

update immediately in the grid.
Enable batch update mode

With this option is on, data changes will not be posted to the server when selecting another row, until clicking the v
button.

Grid

Font

Define the font and its size used by the grid.
Use default font

Check this option to use the default font settings.

Logs

Log Path

Specify the location for storing the log files.

Write log for executed queries

Store all SQL statements of all the operations executed over databases and database objects in Navicat.
Hint: Restart Navicat to take effect.

Write log for batch jobs (Available only in Non-Essentials Edition)

Store information for Navicat command line process and all operations while running batch jobs.

Environment

Executables

SQL*Plus Executable Path (Available only for Oracle)

Specify the location for SQL*Plus used in console of Oracle connection. SQL*Plus is included in Oracle Instant Client.
SQLite3 Dynamic Library Path

Specify the location for SQLite3 Dynamic Library.

Hint: Restart Navicat to take effect.

Mongo Shell Path (Available only for MongoDB)



Specify the location for Mongo Shell used in the console of MongoDB connections.

MongoDump Executable Path (Available only for MongoDB)

Specify the location of the mongodump executable that used for MongoDump.

MongoRestore Executable Path (Available only for MongoDB)

Specify the location of the mongorestore executable that used for MongoRestore.

Mongolmport Executable Path (Available only for MongoDB)

Specify the location of the mongoimport executable that used for Mongolmport.

MongoExport Executable Path (Available only for MongoDB)

Specify the location of the mongoexport executable that used for MongoExport.

External Editor

Choose the file path of an external editor for opening queries.

OCI Environment (Available only for Oracle)

Hint: Restart Navicat to take effect.

DYLD_LIBRARY_PATH

Specify the location which contains Oracle libraries for instant client and SQL*Plus (e.g. ORACLE_HOME/Ilib). Always

required.

Use bundled instant client

Oracle Instant Client has already included in Navicat. Check this option to use the bundled one in Navicat, e.g.

/Applications/Navicat Premium.app/Contents/OCI.

Oracle Instant Client is the simplest way to deploy a full Oracle Client application built with OCI, OCCI, JDBC-OCI, or
ODBC drivers. It provides the necessary Oracle Client libraries in a small set of files. You can also download Oracle

Instant Client through -

Oracle Instant Client

Download the appropriate Instant Client packages for your platform and the CPU. All installations REQUIRE the Basic

or Basic Lite package. Unzip the packages and set the path points to it.

ORACLE_HOME

Specify the location of ORACLE_HOME for full client only. Instant client should leave it blank.

TNS_ADMIN
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http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html

Specify the location of the tnsnames.ora file (e.g. ORACLE_HOME/network/admin). It is optional. Required when using

TNS connection.
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Chapter 17 - Hot Keys & Touch Bar

Hot Keys

Common
Keys Action
COMMAND-R Refresh
COMMAND-N New Object
COMMAND-D Design Object

SHIFT-COMMAND-D

Duplicate Object

OPTION-SHIFT-# (# represents 1 to 9)

Add to Favorites

CONTROL-SHIFT-# (# represents 1 to 9)

Open Favorites Link

COMMAND-} or COMMAND-{

Select Next / PreviousTab

COMMAND-> or COMMAND-<

Select Next / Previous Page

COMMAND-Y New Query
COMMAND-S Save
SHIFT-COMMAND-S Save As
COMMAND-W Close Tab

SHIFT-COMMAND-W

Close Window

Navicat Main Window

Keys Action
COMMAND-1 Show / Hide Navigation Pane
COMMAND-2 Show / Hide Information Pane

OPTION-COMMAND-T

Show / Hide Toolbar

CONTROL-COMMAND-F Full Screen
SHIFT-COMMAND-C Console
SHIFT-COMMAND-H History Log

SHIFT-COMMAND-.

Close Connection / Database / Schema

SHIFT-COMMAND-T

Data Transfer

SHIFT-COMMAND-F

Find in Database/Schema

ER Diagram View

Keys Action

ESC Select

H Move Diagram

R New Foreign Key

DELETE Delete Selected Foreign Key
COMMAND-Mousewheel Up Zoom In
COMMAND-Mousewheel Down Zoom Out
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COMMAND-0 Reset Zoom
Table / Collection Designer

Keys Action

COMMAND-0 Open Table / Collection

COMMAND-+ Add Field

COMMAND-D Duplicate Field

COMMAND-- Delete Field

SHIFT-COMMAND-K

Set Field as Primary Key

COMMAND-UP ARROW Move Up
COMMAND-DOWN ARROW Move Down
COMMAND-F Find Field
COMMAND-G Find Next Field

SHIFT-COMMAND-G

Find Previous Field

Data Viewer
Keys Action
COMMAND-D Design Object (Table, Collection, View,

Materialized View)

SHIFT-COMMAND-Y

Query Object (Table, Collection)

COMMAND-F

Find Text

COMMAND-G

Find Next Text

SHIFT-COMMAND-G

Find Previous Text

OPTION-COMMAND-F

Find and Replace

COMMAND-UP ARROW

Sort Ascending

COMMAND-DOWN ARROW

Sort Descending

CONTROL-OPTION-COMMAND-F Filter Wizard
COMMAND-+ Add Record
COMMAND-- Delete Records

COMMAND-RETURN

Apply Record Changes

COMMAND-ESC

Discard Record Changes

COMMAND-.

Stop Loading Data

CONTROL-0

Set to NULL

CONTROL-SHIFT-B

Toggle Image Editor

CONTROL-SHIFT-T

Toggle Text Editor

CONTROL-SHIFT-H

Toggle Hex Editor

CONTROL-SHIFT-W

Toggle Web Editor

SHIFT-COMMAND-V Switch View
View / Materialized View Designer
Keys Action
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Query Editor

COMMAND-R Preview
COMMAND-. Stop

Query Designer
Keys Action
COMMAND-R Run / Run Selected
SHIFT-COMMAND-R Run Current Statement
COMMAND-. Stop
Keys Action
COMMAND-F Find Text
COMMAND-G Find Next Text

SHIFT-COMMAND-G

Find Previous Text

OPTION-COMMAND-F

Find and Replace

COMMAND-UP ARROW

Go to the Beginning of Page

COMMAND-DOWN ARROW

Go to the End of Page

COMMAND-LEFT ARROW

Go to the Beginning of Current Line

COMMAND-RIGHT ARROW

Go to the End of Current Line

COMMAND-] Increase Indent
COMMAND-[ Decrease Indent
COMMAND-/ Toggle Comment
COMMAND-+ Zoom In
COMMAND-- Zoom Out
COMMAND-0 Reset Zoom
Debugger
Keys Action
F9 Run
F10 Step Over
F11 Step In
COMMAND-F11 Step Out
Model
Keys Action
SHIFT-COMMAND-P Page Setup
COMMAND-P Print Diagram
ESC Select

Move Diagram

New Table/Entity

New View

251




R New Foreign Key/Relation
L New Layer
A New Label
N New Note
| New Image
COMMAND-B Bold Selected Table, Entity, View, Foreign Key,
Relation or Shape
COMMAND-Mousewheel Up Zoom In
COMMAND-Mousewheel Down Zoom Out
COMMAND-0 Reset Zoom
Charts
Keys Action
COMMAND-D Design Object
COMMAND-R Refresh Data
F11 Present Dashboard
Touch Bar

Navicat supports Touch Bar on the MacBook Pro. The Touch Bar controls change based on which windows or forms

you are focusing on.

All Navicat Windows

New Query: Tap Be New Query to open a new query form.

Navigation Pane

Show only active objects: Tap $ to show the opened objects only in the Navigation pane.

Search: Tap ©. and enter a search string to filter the connections, databases, objects in the Navigation pane.
Object Pane

Objects tab: Tap Objects to switch to the Objects tab.

Other opened tabs: Tap an opened tab to switch to it.

Data Viewer - Table, Collection, View, Materialized View, Query

Add Record: Tap *+ {0 add a new record.

Delete Records: Tap to delete the current record.

Apply Changes: Tap ¥ to apply the changes.
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Discard Changes: Tap % to remove all edits made to the current record.
Previous Page: Tap * to move to the previous page.

Next Page: Tap * to move to the next page.

Grid View: Tap FEH to switch to grid view.

Form View: Tap to switch to form view.

Tree View: Tap to switch to tree view.

JSON View: Tap to switch to JSON view.

Object Designer - View, Function, Materialized View, MapReduce, Query
Run / Execute / Preview: Tap > 0 run, execute or preview the object.
Stop: Tap LI stop the execution.

Debugger

Run: Tap P o start running code in debug mode.

Step Over: Tap 7 to execute the current line and bypass the function in current line.
Step In: Tap ¥ to execute the current line and step into the function.
Step Out: Tap ¥ tofinish executing a function call you have stepped into.
Step End: Tap i to jump to the last line of the function.

Stop: Tap L% stop the execution.

Model - Explorer Pane & Properties Pane

Diagram: Tap to switch to the Diagram tab.

Model: Tap to switch to the Model tab.

Object: Tap & to switch to the Object tab.

Model - Diagram Canvas

Auto Layout: Tap 8% o apply Auto Layout to the current diagram.

Zoom In/Out: Adjust the slider to zoom in or zoom out the current diagram.
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Chapter 18 - Trace Logs
Log Files

Navicat provides number of log files to keep track on the actions have been performed in Navicat and they are located
in the default folder, e.g. ~/Library/Application Support/PremiumSoft CyberTech/Navicat CC/Navicat Premium/Logs.

You are allowed to change the log files location under Preferences.

File Description

QueryExec.log Store the statements or scripts of all operations executed over databases and database objects
in Navicat. To open the QueryExec.log file in History Log Viewer, choose Tools -> History
Log or press SHIFT-COMMAND-H.

Note: This log will be overwritten while Navicat is being restarted.

cmdline.log Store information for Navicat command line process and all operations while running batch jobs.

LogIimport.txt Record detailed information on every error (indicating success or failure) that occurred during
the import process.

Note: This log will be overwritten on each import.

History Log Viewer

History Log Viewer shows the statements or scripts that are executed or executing in Navicat. If you just want to display

error messages, click El. You can also change the information shown by choosing from the View menu -
*  Show Date
*  Show Time
*  Show Server Name
*  Show Session ID
*  Show Connection Type
*  Show Execute Time

Note: When you click I , any actions that you do while history is paused will show after resuming.
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[ JoN |
History Log

m = &N a

[2017-05-22 17:10:27.908][MySQLI[000055][MYSQLI[
SHOW VARIABLES LIKE 'lower_case_%";
Time: 0.001s

[2017-05-22 17:10:28.36][MySQL][000055][MYSQL]]

SELECT TABLE_SCHEMA, TABLE_NAME, TABLE_TYPE FROM information_schema. TABLES ORDER BY TABLE_SCHEMA,
TABLE_TYFE

Time: 0.356s

[2017-05-22 17:10:28.746][MySQL][000055][MYSQL][]

SELECT TABLE_SCHEMA, TABLE_NAME, COLUMN_NAME, COLUMN_TYPE FROM information_schema.COLUMNS ORDER BY
TABLE_SCHEMA, TABLE_NAME

Time: 0.354s

[2017-058-22 17:10:29.192][MySQL][000055]MYSQL[

SELECT DISTINCT ROUTINE_SCHEMA, ROUTIMNE_NAME, PARAMS.PARAMETER FROM information_schema ROUTINES LEFT JOIN
( SELECT SPECIFIC_SCHEMA, SPECIFIC_NAME, GROUP_CONCAT(CONCAT(DATA_TYFE, "', PARAMETER_NAME) ORDER BY
ORDINAL_POSITION SEFARATOR ', ) PARAMETER, ROUTINE_TYPE FROM information_schema.PARAMETERS GROUP BY
SPECIFIC_SCHEMA, SPECIFIC_NAME, ROUTINE_TYPE ) PARAMS ON ROUTINES.ROUTINE_SCHEMA =

PARAMS SPECIFIC_SCHEMA AND ROUTINES.ROUTINE_NAME = PARAMS.SPECIFIC_NAME AND ROUTIMES.ROUTINE_TYPE =
PARAMS ROUTINE_TYPE ORDER BY ROUTINE_SCHEMA

Time: 0.061s

[2017-05-22 17:10:58.333][MySQL][000055][MYSQLI[
SHOW TABLE STATUS
Time: 0.003s

[2017-058-22 17:10:59.342][MySQL][000055]MYSQL[

SELECT TABLE_NAME, CHECK_OPTION, IS_UFDATABLE, SECURITY_TYPE, DEFINER FROM INFORMATION_SCHEMA.VIEWS
WHERE TABLE_SCHEMA = 'sakila' ORDER BY TABLE_NAME ASC

Time: 0.002s
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