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Report Management Tools (Available only in Navicat Premium and 

Enterprise Version)   

Just simply click to open an object pane for Report . A right -click displays the popup menu 

or using the object pane toolbar, allowing you to create new, view, edit and delete the 

selected report. You can save your reports for setting schedule.  

Create Report  

To create a new report  

¶ Select anywhere on the object pane.  

¶ Click the New Report  from the object pane toolbar.  

or  

¶ Right -click and select New Report  from the popup menu.  

¶ Edit report on the appropriate tabs of  the Report Builder.  

Hint:  To create new report you can also right -click the Reports node of the navigation 

pane and select the New Report  from the popup menu.  

To create a new report with the same properties as one of the existing reports has (using 

popu p menu)  

Apply to:  current database {same connection}  

¶ Select the report(s) for copying in the navigation pane/object pane.  

¶ Right -click and select the Copy  from the popup menu.  

¶ Select anywhere on the object pane.  

¶ Right -click and select the Paste  from the popup menu.  

¶ The newly created report(s) will be named as "reportname -  Copy ".  
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To create a new report with the same properties as one of the existing reports has (using 

drag and drop method)  

Apply to:  current database {same connection}  

¶ Select the report(s) for copying in the navigation pane/object pane.  

¶ Right -click and drag the chosen report(s) to the target location.  

¶ Select one of the following options:  

o Copy here  

o Move here  

o Cancel  

¶ The newly created report(s) will be named as "report name -  Copy "  

Apply to:  different database {same connection}  

 
different database {different connection}  

¶ Select the report(s) for copying in the navigation pane/object pane.  

¶ Right -click and drag the chosen report(s) to the target location.  

¶ Select one of  the following options:  

o Copy here  

o Move here  

o Cancel  

To create a new report with modification as one of the existing reports  

¶ Select the report for modifying in the navigation pane/object pane.  

¶ Right -click and select the Design Report  from the popup menu . 

or  

¶ Click the Design Report  from the object pane toolbar.  

¶ Modify report on the appropriate tabs of the Report Builder.  

¶ Click Save As .  
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Edit Report   

To edit the existing report  

¶ Select the report for editing in the navigation pane/object pane.  

¶ Right -click and select the Design Report  from the popup menu.  

or  

¶ Click the Design Report  from the object pane toolbar.  

¶ Modify report on the appropriate tabs of the Report Builder.  

To change the name of the report  

¶ Select the report for editing in the navigation pane/object pane.  

¶ Right -click and select the Rename  from the popup menu.  

View Report  

To view a report  

¶ Select the report for viewing in the navigation pane/object pane.  

¶ Right -click and select the Open Repo rt  from the popup menu or simply 

double -click the report.  

or  

¶ Click the Open Report  from the object pane toolbar.  

To view an archive report  

¶ Right -click anywhere on the object pane and select the Open Report Archive  

from the popup menu.  

or  

¶ Click the Op en Report Archive  from the object pane toolbar.  

¶ Browse your archive file.  
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Print Report (set schedule)  

To print a report (using popup menu)  

¶ Select the report for printing in the navigation pane/object pane.  

¶ Right -click and select Print Report  from the  popup menu.  

To print a report from the command line  

¶ Create and save the report.  

¶ In terminal, type the command (see Command for details)  

Print Report to File (set schedule)   

To print report to file (using popup menu -  PDF and HTML)  

¶ Select the report for printing in the navigation pane/object pane.  

¶ Right -click and select one of the options from the popup menu.  

o Print Report As Pdf  

o Print Report As HTML  

To print report to file (setting under Report Tree windows -  Text/Report Emulatio n Text, PDF, 

Excel, HTML/XHTML, RTF etc.)  

Hint:  AllowPrintToFile  must be enabled in Report Tree  windows to show a list of file 

formats that Report Builder supports.  

¶ Select the report for printing in the navigation pane/object pane.  

¶ Right -click and select the Design Report  from the popup menu.  

or  

¶ Click the Design Report  from the object pane toolbar.  

¶ In  Report Tree  windows, enable AllowPrintToFile  under Output -  File  section.  

¶ Choose the file type you wish to print in the Print Dia log.  

Print Report to Archive File   

To print report to archive file (using popup menu)  

¶ Select the report for printing in the navigation pane/object pane.  

¶ Right -click and select Print Report As Archive  from the popup menu.  
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To print report to archive file  (setting under Report Tree windows)  

Hint:  AllowPrintToArchive  must be enabled in Report Tree  windows.  

¶ Select the report for printing in the navigation pane/object pane.  

¶ Right -click and select the Design Report  from the popup menu.  

or  

¶ Click the Design Report  from the object pane toolbar.  

¶ In  Report Tree  windows, enable AllowPrintToArchive  under Output -  File  section.  

¶ Choose Archive File  in the Print Dialog.  

Delete Report  

To delete a report  

¶ Select the report for deleting in the navigation pane/object p ane.  

¶ Right -click and select the Delete Report  from the popup menu.  

or  

¶ Click the Delete Report  from the object pane toolbar.  

¶ Confirm deleting in the dialog window.  

Achieve Report Information  

To achieve a report information  

¶ Select the report in the obj ect pane.  

¶ Right -click the selected report and choose Object Information  from the popup menu.  

or  

¶ Choose View -> Object Information in the main menu.  
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Report Designer   

Report Designer  is the basic Navicat tool for working with reports. It allows you to create 

new report and edit the existing report properties.  

¶ Report Data   

¶ Report Design   

¶ Report Preview  
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Report Data   

The Data  tab allows us to select and manipulate the data needed for a report. These tasks 

are accomplished via two visual tools: the Query Wizard  and the Query Designer . These 

tools greatly simplify the often -difficult task of data selection by giving us the ability to select 

data without requiring an in -depth knowledge of databases.  

¶ Query Wizard   

¶ Query Designer   
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Report Query Wizard   

You can select data from your database using an SQL query. This functionality is provided via 

query -based dataviews, which can be visually created using the Query Wizard  and visually 

maintained using the Query Designer.  

Create a Simple Query - Based Dataview  

The following series of screenshots shows how to create a simple query -based dataview via 

the Query Wizard.  

1.  Select File - > New... under Data tab. The New Dialog will be  displayed. 

Double - click the Query Wizard icon.  
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2.  Select the first table for the query. The customer table has been selected.  

 

3.  Select the second table for the query. The orders table has been selected and 

the Join dialog was automatically displayed. The d ialog already contains the 

correct field linking (CustNo), so all we have to do is click OK.  
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4.  When we return to the query wizard, both tables are shown as selected.  

 

5.  Skip the fields page, since we want to select all fields.  
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6.  Skip the calculations page,  since this query will not contain calculations.  

 

7.  Skip the groups page, since this query will not be grouped.  
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8.  Skip the search criteria page; all records will be selected.  

 

9.  Set the order to CustNo, then OrderNo.  
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10. The query (data pipeline) name is auto matically generated. The next action 

will be to preview the query.  

 

11. View the data to make sure the correct records have been selected.  
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12. Close the preview window. The dataview is then created.  
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Report Query Designer   

The Query Designer  is used to modify query -based dataviews created by Query Wizard. 

The Query Designer presents a series of notebook tabs; each tab represents a different part 

of the query.  

¶ Add Search Criteria   

¶ Create a Group Sum   

¶ Concatenate Fields   

¶ Edit SQL  
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Add Search Criteria   

You can use the Query Designer to add or remove search criteria from your query. Perform 

these steps in order  to add search criteria:  

1.  Click on the Search icon of the dataview to launch the Query Designer.  
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2.  From the list of fields at the top of the search page, double - click on the field 

for which criteria needs to be entered.  

 

3.  Click on the field that has been added to the list of criteria at the bottom and 

select the operator.  
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4.  Click in the edit box and enter the search criteria value. This criteria will find 

all customer id that are greater than 120.  

 

5.  Click on the SQL tab to make sure the criteria value is  valid.  
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6.  Close the Query Designer and click on the Preview icon.  

 

7.  Preview the data and make sure that the intended records are selected.  
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Create a Group Sum   

The SQL 'GROUP BY' clause allows you to eliminate rows in your query where the field values 

repeat. For example, let's assume we have a database table that contains order records. 

Each order record has the customer number and the amount paid. If we viewed the data in 

this table, we would see that the value in the customer number field repe ats where there are 

multiple orders for a customer.  

We can use SQL to select data from the orders table and calculate the total amount paid for 

each customer. We can do this by specifying a group on the customer number field. By 

specifying the group, we ar e saying to the SQL engine: create one row in the result set for 

each customer number found. When the SQL engine runs the query, it will find multiple 

records for some customers; these records will be eliminated from the result set. SQL allows 

us to perfor m calculations on these repeated records and store the result in a new field of the 

result set.  

These types of calculations can be created on the Calc tab of the Query Designer. Perform 

these steps in order to sum the amount paid for all customers in the orders table:  

1.  Click the 'Calc' icon to launch the Query Designer.  
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2.  Double - click the 'Amount Paid' field from the selection list at the top of the 

page. Amount Paid will be added to the list of calculations.  

 

3.  Select 'Sum' as the function type for the ca lculation.  
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4.  Enter the Field Alias you would like to use for this calculated field.  

 

5.  Click the Group Tab, check the grouping.  
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6.  Click the SQL tab to make sure the generated SQL is valid.  

 

7.  Close the Query Designer and click the Preview icon to preview t he data.  
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8.  Check the data to make sure the sum is calculated as expected.  
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Concatenate Fields   

You can enter SQL expressions from the Calcs  tab of the Query Designer. The following 

query selects data from a table of employees. The table has a first name and last name field. 

Perform these steps in order to concatenate these two fields together using the Query 

Designer:  

1.  Click the 'Calcs' icon t o launch the Query Designer.  
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2.  Double - click the 'First Name' field from the selection list at the top of the 

page. 'First Name' will be added to the list of calculations.  

 

3.  Select 'Expression' as the function type for the calculation.  
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4.  Modify the widths of the 'Field SQL Alias' and 'Function' columns in the 

calculations list at the bottom of the page so that there is enough space to 

enter the expression. The figure below illustrates a sample expression.  

 

5.  Enter the Field Alias you would  like to use for this calculated field.  

 



 

Report  Management  Tools  30  

6.  Click the SQL tab to make sure the generated SQL is valid.  
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Edit SQL   

There may be times when you need to utilize advanced features of SQL that cannot be 

accessed via the visual interface of the Query Designer . In these cases, you can edit the SQL 

manually in the Query Designer. Once you have edited the SQL manually, you must always 

use the SQL tab of the Query Designer to make future modifications.  

Note:  Once you manually edit the SQL, you can no longer use th e visual design tabs to 

modify the query.  

Perform these steps in order to edit the SQL generated by the Query Designer:  

1.  Click on the SQL icon to launch the Query Designer.  
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2.  Right - click over the SQL text to display the popup - menu.  

 

3.  Click Yes to the message dialog. You can now edit the SQL.  
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Report Design   

The Design  tab to build and design reports. The design workspace is divided into two areas: 

the workbench and the canvas. The workbench is comprised of toolbars, component palettes, 

rulers, and other tools that can be used to manipulate the canvas. The canvas is the  area that 

contains the report layout. This is where we place the bands and components that will 

ultimately control the content of each page of the report.  

¶ Report Wizard   

¶ Report Design Toolbars   

¶ Dialogs   

¶ Report Layouts   
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Report Wizard   

The Report Wizard  is one of the many parts of ReportBuilder that reflects a level of 

professionalism and attention to detail found in no  other reporting product. If you or your 

end users have utilized standard Windows wizards in other products, then you will be able to 

quickly recognize and use the ReportBuilder Report Wizard.  

The Report Wizard can be accessed via the File  -> New...  menu option of the Report Design 

tab. A series of screens are presented, each requesting information about the report. When 

the last page is reached, either a preview or design option can be selected. When the Finish 

button is clicked, it causes a report to be created and displayed as requested.  

¶ Create a Simple Report   

¶ Create a Group -Based Report   
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Create a Simple Report   

The following screenshots step through the creation of a si mple report via the Report Wizard.  

1.  Select the fields.  

 

2.  Skip the groups page.  
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3.  Select the layout.  

 

4.  Select the style.  
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5.  Select Design or Preview and Finish.  

 

6.  Report as it appears in the Preview tab.  

 



 

Report  Management  Tools  38  

7.  Report as it appears in the Design tab.  
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Create a Group - Based Report   

The following screenshots step through the creation of a group -based report via the Report 

Wizard.  

1.  Select the fields.  

 

2.  Select a group field.  
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3.  Select the layout.  

 

4.  Select the style.  
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5.  Select Design or Preview and Finish.  

 

6.  Report as it  appears in the Preview tab.  
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7.  Report as it appears in the Design tab.  
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Report Design Toolbars   

The various toolbars accessible from the design workspace are documented in this section. 

The toolbars are dockable. The toolbars are accessible from the Vie w  -> Toolbars  menu 

option of the Report Designer or by right -clicking on the docking area at the top of the Report 

Designer.  

¶ Standard Component Palette   

¶ Data Component Palette   

¶ Advanced Component Palette   

¶ Report Tree   

¶ Data Tree   

¶ Align or Space Toolbar   

¶ Size  Toolbar   

¶ Nudge Toolbar   

¶ Draw Toolbar   

¶ Edit Toolbar   

¶ Standard Toolbar   

¶ Format Toolbar   
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Standard Component Palette   

To access this toolbar, select the View  -> Toolbars  -> Standard Components  menu 

option from the Report Designer main menu. This toolbar will assist in creating the most 

commonly used report components.  

 

Label  

Used to display t ext. Assign the Caption property to control the text value. To resize the label 

automatically so it fits a changing caption, set the Auto -Size property to True.  

Memo  

Prints multiple lines of plain text in a report. To set the value, assign a string list t o the Lines 

property. To dynamically resize the memo during printing, set the Stretch property to True. 

Use the ShiftRelativeTo property to define dynamic relationships with other stretchable 

objects.  

RichText  

Prints formatted text. To set the value, assi gn the RichText property or use the LoadFromFile 

orLoadFromRTFStream methods. Use the ShiftRelativeTo property to define dynamic 

relationships with other stretchable objects. At design - time you can use the ReportBuilder's 

built - in RTF Editor to load, modif y, and save rich text data stored in files.  

SystemVariable  

Used to display common report information such as page number, page count, print date and 

time, date, time, etc. The type of information displayed is controlled by the VarType property. 

The format  is controlled by the DisplayFormat property.  

Variable  (Navicat Report does not support this control)  

Used for calculations via an Object Pascal event handler assigned to the OnCalc event or a 

RAP event handler assigned to the OnCalc event. Access the Cal culations dialog (via the 

speed menu) or the Calc tab of the Report Designer to code a RAP calculation for this 

component.  
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Image  

Used to display bitmaps and windows metafiles in reports. Assign the Picture property of this 

component in order to place an  image in your report. Use the Report Designer's built - in 

picture dialog to load images at design - time.  

Shape  

Use this component to print various shapes (squares, rectangles, circles, ellipses). Set the 

Shape property to select a type of shape. Use the Brush and Pen properties to control the 

color and border respectively.  

Line  

Displays single and double lines (either vertical or horizontal.) Set the Style property to 

control whether the line is single or double. Set the Weight property to control the li ne 

thickness in points. Set the Position property to control whether the line is vertical or 

horizontal.  

BarCode  

Used to render barcodes. The string value assigned to the Data property is encoded based on 

the Bar -CodeType. If the data to be encoded is in a database, use DBBarCode. The following 

symbologies are supported: Codabar, Code 128, Code 39, EAN -13, EAN -8, FIM 

A,B,C,Interleaved 2 of 5, Post -Net, UPC -A, UPC-E. 

2DBarCode  

Used to render two -dimensional barcode symbologies. Supports PDF417 and MaxiCode  

barcode types.  

Chart  

Used to display standard (non -data -aware) Charts. This component enables you to use Chart 

inside the Report Designer. You can access the Chart editor via a popup menu.  
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Data Component Palette   

To access this toolbar, select the View  -> Toolbars  -> Data Components  menu option 

from the Report Designer main menu. This toolbar will assist in creating data -aware report 

components.  

 

DBText  

Used for displaying values from all types of database fields. Use the DisplayFormat property 

to for mat the value.  

DBMemo  

Used to print plain text from a memo field of a database table. This control will automatically 

word -wrap the text. Set the Stretch property to True and the component will dynamically 

resize to print all of the text. Use the ShiftRel ativeTo property to define dynamic relationships 

with other stretchable objects.  

DBRichText  

Used to print formatted text from a memo or BLOB field of a database table. This control will 

automatically word -wrap the text. Set the Stretch property to True an d the component will 

dynamically resize to print all of the text. Use the ShiftRelativeTo property to define dynamic 

relationships with other stretchable objects.  

DBCalc  

Used for simple database calculations (Sum, Min, Max, Count and Average). The value c an 

be reset when a group breaks using the ResetGroup property.  

DBImage  

Used to print bitmaps or windows metafiles, which are stored in a database BLOB field.  

DBBarCode  

Used to render barcodes based on the BarCode -Type and the value supplied via the 

DataF ield property. The following symbologies are supported: Codabar, Code 128, Code 39, 

EAN-13, EAN -8, FIM A,B,C, Interleaved 2 of 5, PostNet, UPC -A, UPC-E. 
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DB2DBarCode  

Used to render two -dimensional barcode based on the BarCode Type and the value supplied 

via the DataField property. The following symbologies are supported: PDF417, MaxiCode.  

DBChart  

Allows data -aware Charts to be placed within a report.  
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Advanced Component Palette   

To access this toolbar, select the View  -> Toolbars  -> Advanced Components  menu 

option from the Report Designer main menu. This toolbar will assist in creating advanced 

report components.  

 

Region  

Used to logically group components together. Use the ShiftRelativeTo property to move the 

region in relation to another dynamically resizing component (such as Memo, RichText, or 

child - type Sub -Report).  

SubReport  

Used to handle multiple master details, create sideby -side reporting effects, and hook 

reports together as one. If you need a report to print within the context of a band, us e a 

child - type subreport. If you need to hook reports together, use a section type subreport. The 

PrintBehavior property determines the subreport type.  

PageBreak  

The TppPageBreak component is a report control that allows the user to force a new page 

durin g report generation. Placing a TppPageBreak component on a report will cause all 

objects created after the PageBreak (Z -Order) to be moved to the next page in the report 

relative to the PageBreak object's top position.  

PaintBox  

Create a paintbox area for drawing.  

CrossTab  

Used to present summarized data in a grid format.  
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Report Tree   

To access this tool window, select the View  -> Toolbars  -> Report Tree  menu option from 

the Report Designer main menu. This tool window is dockable on the left and right sides of 

the Report Designer. It can be used to organize components within each band. Components 

selected in the Report Tree are selected in the report layo ut. The upper portion of the Report 

Tree shows the main report object and any subreports nested within it. This feature can be 

helpful for organizing your subreports.  
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Data Tree   

To access this tool window, select the View -> Toolbars -> Data Tree menu option from  the 

Report Designer main menu. This tool window is dockable on the left and right sides of the 

Report Designer. It can be used to create components within any band. Simply select a set 

of fields and drag the selection into the band. A set of co rresponding data -aware components 

will be created.  

The Data Tree has two tabs:  

 

 

Data Tab  

In the top tree view, the Data tab contains a 

list of data pipelines to which the report has 

access. In the bottom list view, all of the 

fields for the currently selected data 

pipeline are displayed. Fields can be 

selected from the bottom list view and 

dragged to any part of the report layout. 

The data -aware component that is 

appropriate for the given field will then be 

created along with a label and border.  

Layout  Tab  

This tab allows you to control 

drag -and -drop behavior. A label and 

border are created for each data -aware 

component by default. You can turn the 

label and the border off, control the color of 

the label or border, and control the font of 

the label and data -aware component from 

this tab. Once you've set the 

drag -and -drop behavior, it will be retained 

for future design sessions.  
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Align or Space Toolbar   

To access this toolbar, select the View  -> Toolbars  -> Align or Space  menu option from 

the Report Designer main menu. This toolbar will assist in positioning components relative to 

one another and relative to the band in which they appear.  

 

Align Left  

Aligns a group of components with the leftmost position of the compone nt that was selected 

first.  

Align Middle  

Centers a group of components based on the horizontal center of the component that was 

first selected.  

Align Right  

Aligns a group of components with the rightmost position of the component that was selected 

first.  

Align Top  

Aligns a group of components with the topmost position of the component that was selected 

first.  

Align Center  

Aligns a group of components based on the vertical center of the component that was first 

selected.  

Align Bottom  

Aligns a group of c omponents with the bottommost position of the component that was 

selected first.  

Space Horizontally  

Spaces a set of components based on the leftmost position of the first component selected 

and the rightmost position of the last component selected.  
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Space  Vertically  

Spaces a set of components based on the topmost position of the first component selected 

and the bottommost position of the last component selected.  

Center Horizontally in Band  

Centers a component horizontally within a band.  

Center Vertically  in Band  

Centers a component vertically within a band.  
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Size Toolbar   

To access this toolbar, select the View  -> Toolbars  -> Size  menu option from the Report 

Designer main menu.  

 

Shrink Width to Smallest  

Determines the minimum width of all the selected  components, and then sets the width of 

the components to that value.  

Grow Width to Largest  

Determines the maximum width of all the selected components, and then sets the width of 

the components to that value.  

Shrink Height to Smallest  

Determines the min imum height of all the selected components, and then sets the height of 

the components to that value.  

Grow Height to Largest  

Determines the maximum height of all the selected components, and then sets the height of 

the components to that value.  
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Nudge To olbar   

To access this toolbar, select the View  -> Toolbars  -> Nudge  menu option from the Report 

Designer main menu.  

 

Nudge Up  

Moves all selected components one pixel up.  

Nudge Down  

Moves all selected components one pixel down.  

Nudge Left  

Moves all selected components one pixel to the left.  

Nudge Right  

Moves all selected components one pixel to the right.  
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Draw Toolbar   

To access this toolbar, select the View  -> Toolbars  -> Draw  menu option from the Report 

Designer main menu. This toolbar will assi st in setting the colors and borders of components.  

 

Fill Color  

For shapes, lines, and region components only. Sets the Brush.Color property. To set the 

color of a textual component, check the Highlight Color action of the Format toolbar.  

Line Color  

For  shapes, lines, and region components only. Sets the Pen.Color property.  

Line Thickness  

For use with a Line component only. Sets the Weight property.  

Line Style  

For use with a Line component only. Sets the Pen.Style property.  
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Edit Toolbar   

To access this toolbar, select the View  -> Toolbars  -> Edit  menu option from the Report 

Designer main menu. This toolbar will assist in setting the most important property or 

properties for the currently selected component.  

1.  No component selected  

 

2.  Data - aware component selected  

 

This configuration allows the data pipeline and data field for the component to be set. 

The drop -down list on the left shows the data pipeline. The drop -down list on the right 

shows the field name.  

3.  Label component selected  

 

Here a label component has been selected in the Report Designer. The Edit toolbar 

displays an edit box from which the label's caption can be set.  
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4.  Shape component selected  

 

Here a shape component has been selected in the Report Designer. The Edit toolba r 

displays the different shape types.  

5.  Line component selected  

 

This configuration allows you to move the line to the top, bottom, left, or right within 

the line's selection handles.  
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Standard Toolbar   

To access this toolbar, select the View  -> Toolbars  -> Standard  menu option from the 

Report Designer main menu. This toolbar will assist with saving the report layout, accessing 

the print and print preview options, and accessing the cut and paste operations.  

 

New  

Creates a blank report layout.  

Open  

Displays the Open dialog, allowing you to open an existing report layout.  

Save  

Saves a report layout to file.  

Page Setup  

Displays the Page Setup dialog, allowing you to set the paper size and configure the layout 

for the report.  

Print  

Displays the Print  dialog before sending the report to the printer.  

Print Preview  

Displays the Print Preview window.  

Cut  

Cuts the currently selected components into the clipboard.  

Copy  

Copies the currently selected components into the clipboard.  

Paste  

Pastes the compone nts in the clipboard into the report.  
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Format Toolbar   

To access this toolbar, select the View  -> Toolbars  -> Format  menu option from the 

Report Designer main menu. This toolbar will assist with setting the font and colors. It will 

also assist with layeri ng the components.  

 

Font Name  

Selects the font name for textual components.  

Font Size  

Selects the font size. You can also type in this box to set the font size exactly.  

Bold  

Sets the font to bold.  

Italic  

Sets font to italic.  

Underline  

Sets font to underline.  

Left Justify  

Left justifies the text in the component.  

Center  

Centers the text in the component.  

Right Justify  

Right justifies the text in the component.  

Justify  

Justifies the text in the component.  

Font Color  

Sets the font color.  
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Highligh t Color  

Sets the background color of the textual component.  

Anchors  

Specifies how a report component is anchored to its parent. Use Anchors to ensure that a 

report element maintains its current position relative to an edge of its parent control (i.e. 

Band /Region), even if the parent is resized.  

Border  

Specifies which of the outside border lines of a report component are rendered.  

Bring to Front  

Brings the component to the front. The components in the front print last, and the 

components in the back print  first. Use the Report Tree to see the exact layering of 

components within the band.  

Send to Back  

Sends the component to the back. The components in the front print last, and the 

components in the back print first. Use the Report Tree to see the exact lay ering of 

components within the band.  
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Dialogs   

Navicat Report Designer allows you to perform extra tasks: print reports, report page setup, 

adding groups and outline settings, etc.  

¶ Print Dialog   

¶ Page Setup Dialog   

¶ Groups Dialog   

¶ Print to File Setup Dialog   

¶ Data Dialog   

¶ Grid Options   

¶ Outline Settings   

¶ Find Text Settings   
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Print Dialog   

The Print Dialog is automatically displayed when the report is sent to the printer, allowing 

you to select the pages, number of copies, an d printer for the report. When the 

AllowPrintToFile  or AllowPrintToArchive  properties of the Report are enabled, this 

dialog displays additional print to file options.  

1.  The print job settings can be set via the standard dialog.  
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2.  Dialog with the print to file options.  

 

3.  Dialog with the print to archive options.  
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Page Setup Dialog   

The Page Setup dialog can be accessed from the File  -> Page Setup...  menu option of the 

Report Designer. You can set the following properties from within the Page Setup dialog :  

1.  Printer  

 

2.  Paper Size and orientation  
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3.  Paper Source  

 

4.  Layout for Columnar Reports  

 

5.  Margins  
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Groups Dialog   

The Groups dialog is accessible via the Report  -> Groups...  menu option of the Report 

Designer. You can separate your report into different sections using groups. A number of 

options are available to control the behavior of each group. For example, you may want each 

group to start on a new page or to reprint the g roup header when the group continues on 

additional pages. Another powerful feature is the Keep group together option, which can be 

used to ensure that all of the information for a group fits on a page.  

 

  



 

Report  Management  Tools  67  

Print to File Setup Dialog   

The Print to File Setu p dialog is accessible via the File  -> Print to File Setup...  menu option 

of the Report Designer. This dialog is used to specify the format and content of the ASCII file 

that will be created if the report is printed to file.  
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Data Dialog   

The Data dialo g can be accessed from the Report  -> Data...  menu option of the Report 

Designer. It can be used to specify the data pipeline for the report.  

 

  



 

Report  Management  Tools  69  

Grid Options   

The Grid Options dialog is accessible via the View  -> Grid Options...  menu of the Report 

Designer. Use the Grid Options dialog to control how the workspace grid is drawn and 

whether layout elements automatically snap to the grid points.  
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Outline Settings   

The Outline Settings dialog is accessible via the Report  -> Outlin e Settings...  menu option 

of the Report Designer. Use this dialog to control the behavior of report outline generation. 

When enabled, an outline tree structure is dynamically generated by the report engine and 

rendered by the report previewer.  
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Find Text Settings   

The Find Text Settings dialog is accessible via the Report  -> Find Text Settings...  menu 

option of the Report Designer. Use this dialog to configure the find text options used by the 

report previewer. When enabled, the previewer can be used to find and highlight text that 

appears in the pages of the report.  
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Report Layout   

There are many special options to set the layout. You can simply right -click the components 

and enable the following options:  

AutoDisplay  

Determine whether to automatica lly display the contents of a BLOB in a database field in a 

Memo or Image component.  

AutoSize  

The report component resizes the width and length.  

AutoSizeFont  

Set the human readable text to a standard accepted font size based on the size of the 

barcode co mponent.  

Child  

The report prints to completion, using the subreport components width as the page width 

and stretching over several pages until printing is complete.  

DirectDraw  

Indicate the image will be sent directly to the printer or to an intermediate bitmap and then 

copied to the printer.  

Fixed  

A single page prints based on the dimensions and position of the subreport component.  

MaintainAspectRatio  

Maintain image original width to height ratio.  

NewPrintJob  

Determine whether a new print job is started w hen the subreport is sent to the printer.  

GraphicType  

Indicate the kind of the graphic object: Bitmap, GIF, Icon, JPEG and Metafile.  

KeepTogether  

Control the pagination of the component when the contents cannot fit on the current page.  
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LookAhead  

Display summary calculations in the title band, page footer calculations in the page header 

band, group footer calculations in the group header band and column footer calculations in 

the column header.  

ParentHeight  

Force the height of the component to match heigh t of the parent component. The parent may 

be either a band or a region.  

ParentWidth  

Force the width of the component to match width of the parent component.  

ParentPrinterSetup  

Determines whether the values for the PrinterSetup property should be copied fr om the 

parent report.  

PrintHumanReadable  

Output the human readable version of the bar code (i.e. the actual letters or numbers).  

ReprintOnOverFlow  

Use to print non -stretching components when stretching components are printing on 

additional pages.  

ReprintOnSubsequent  

Use in conjunction with the SuppressRepeatedValues property. When 

SuppressRepeatedValues is set to True, and detail lines have overflowed onto a new page, 

you can force the value to reprint on the first detail line of the new page by se tting 

ReprintOnSubsequent to True.  

ResetPageNo  

Enable subset page numbering. In subset page numbers, the page numbers and page count 

of the subreport are displayed instead of the master report page numbers.  

Section  

The report prints as a separate section, starting a new page when it begins and finishing the 

last page when it ends. The PrinterSetup property is used to determine the page size and 

printer settings.  
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ShiftRelativeTo  

Use to specify the vertical positioning that should take place between multiple  stretching 

components in a band.  

Stretch  

Determine whether the image is scaled to fit inside the component.  

StretchWithParent  

Allow a shape or line to expand or contract based on the change in height of the band or 

region in which it is contained.  

Suppr essRepeatedValues  

When the value of a field (as determined by the DataField property) is the same across 

several records, the SuppressRepeatedValues property allows you to print the value only 

once each time the field value changes.  

TraverseAllData  

Indicat e that the subreport will continue to print (print on additional pages in the same exact 

position) until all data is traversed. By default the fixed type subreport truncates the data.  

  



 

Report  Management  Tools  75  

Report Preview   

The Preview  tab contains the rendered report. The report can be printed to the printer or to 

various file formats.  

¶ Preview and Print   

¶ Search   
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Preview and Print   

The Preview form enables the user to con trol and view report output. An outline of page 

nodes is displayed on the left side of the form, adjacent to the page viewer.  

Use the Print button to send report output to the printer or to an output file, such as PDF.  
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Search   

To create a Search Report, enable the AutoSearch option in the Query Designer.  

 

Then you can click the Search Data  icon to enter the searching criteria.  

 

  




































































































































