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Oracle Database Object Management

The following list contains the most common Oracle database objects supported by Navicat.

Hint: Oracle interprets non-quoted object identifiers as uppercase. In Navicat, all objects
identifier will be quoted. That is, Navicat saves exactly what you have inputted.

e Tables
e Views
e Functions/Procedures

o Database Links

o Indexes
e Java
e Materialized Views

o Materialized View Logs

o Packages
e Sequences
e Synonyms
o Triggers

o Types

¢ XML Schemas

e Recycle Bin
o Directories

e Tablespaces
e Public Database Links

e Public Synonyms

Oracle Database Object Management 5
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Oracle Debugger (Available only in Full Version)

Navicat provides Oracle PL/SQL debugger for debugging Oracle functions, procedures,

packages and queries.

e Code Window
e Views
o« Debugger Toolbar

File ‘iew Run Window Help

B Run oo Step Crwer ? Skep In '/E\‘ Skep Cwk % Skep End . Skop

Call stack 53 | [ HRSECURE DML x|
HRSECURE_DML (Line: 5) 1 CREATE OR REPLACE
2 PROCEDURE secure_dml
3 IS
4 BEGIN
5@LC IFTO CHAR (SYSDATE, 'HH24:MI') NOT BETWEEN '08:00
- [ OR TO_CHAR (SYSDATE, 'DY') IM ('SAT', 'SUN") THEN
el =3 21| 7@0 RAISE APPLICATION ERROR (-20205,
Variable Name | Variablevalue ||| 8@ - 'vou may only make changes during normal office hot
9 END IF;
10 EMD secure_dmil;
11
Log @
Error 5etting breakpoint ;I
Breakpoint has beemn set on HR.SECURE_DML (Line:7)
Breakpoint has beemn set on HR.SECURE_DML (Line:5)
Source breakpoint at line 5 of HR.SECURE_DML (Source: IF TO_CHAR (SYSDATE, "HH24:MI') NOT BETWEEN
'08:00" AND "18:00' j

1!

Log x | Ereakpaints X| DEMS Cutput X|
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Oracle Debugger Code Window

The Code Window shows the code of the procedure/function. You can add/remove
breakpoints for debugging by clicking @in the grey area beside each statement.

To add a variable to the watch list, simply right-click the highlighted code and choose Add to
watch list.

To show the debug tips, simply mouse-over the code.

CREATE OR REPLACE
PROCEDURE secure_dml
15
BEGIN
@ IFTO_CHAR (SYSDATE, 'HH24:MI') NOT BETWEEN '08:00' AND '18:00'
OR TO_CHAR (S5YSDATE, 'DY') IN ('SAT', 'SUN') THEN
& ] RAISE_APPLICATION_ERROR (-20205,
You may only make changes during normal office hours');
EMD IF;
EMD secure_dml;

—
L= T = R Y L L N

11
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Oracle Debugger Views

Under menu View, you can choose to show/hide the following view windows.
You can choose View -> Default Layout to restore the Layout to the default one.

o Breakpoints

o (Call Stack

e DBMS Output
« log

e Smart Data

o Watch List

Oracle Database Object Management 8
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Repositioning Oracle Debugger Views

To re-arrange the workspace items, click on any pane in the workspace, then hold down your
cursor and drag the pane to the desired area, and release the cursor. The selected pane will

appear in its new position.

Hint: As you drag a pane to its new position, a Pane Sticker will appear and a bright blue
indicator will mark the insertion point.

Oracle Debugger

File ‘iew Run | Window | Help

B Run Step Over ? Step In %\‘ Step Out @ Step End . Stop .
Call Stack 53]| HRSECURE DML x |

HR.SECURE_DML (Line: 5) CREATE OR REPLACE

PROCEDURE secure_dml

Is
BEGIN

@ IFTO_CHAR (SYSDATE, 'HH24:MI') NOT BETWEEN '08:00' AND '18:00'
e OR TO_CHAR (SYSDATE, 'MY') TN ('SAT', 'SUM') THEN
Watch List &) @] RAISE_APPLICATION_ERRO 5,
Variable Name | Variable Value | "You may enly make chan; 1g normal office hours');
END IF;

END secure_d

r—
= == B I = RV R S WU ]

Smart Data @

Variable Name I Variable Value |

O

Log 123
Source breakpoint at line 5 of HR.SECURE_DML (Source: IF TO_CHAR (SYSDATE, 'HH24:MI') NOT BETWEEN '08:00' AND *18:00' j
)
Breakpoint has been removed from HR.SECURE_DML{Line 5)
Breakpoint has been set om HR.SECURE_DML {Line:5)
Error removing breakpoint from HR.SECURE_DML{Line 8) j
-

Log x | Breakpaints x| DBMS Cutput X |
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Oracle Debugger Breakpoints

The Breakpoints view displays all the breakpoints which allowing you to delete, enable or
disable breakpoints.

To enable/disable a breakpoint, simply check/uncheck the check box.

Also, you can delete a breakpoint or all breakpoints, simply right-click a breakpoint and
choose Remove Breakpoint or Remove All Breakpoints.

To jump to the line of a breakpoint, right-click it and choose Goto Function.

Ereakpoints

Source

[®F HR.SECURE by

Goto Function

Remove Breakpoint

Remove All Breakpoints

log X Breakpaints | DEMS Output X
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Oracle Debugger Call Stack

The Call Stack view displays the procedure or function calls of the current line.

To jump to a procedure or function, right-click it and choose Goto Function.

Oracle Database Object Management 11
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Oracle Debugger DBMS Output

The DBMS Output view displays the results after the function or procedure has completed
the execution.
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Oracle Debugger Log

The Log view shows the message log when debugging the code.
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Oracle Debugger Smart Data

The Smart Data view displays information about the variables associated with breakpoints.

To add a variable to the watch list, simply right-click a variable and choose Add to watch
list.

You can adjust the value of a watch variable by simply right-click the variable and choose
Adjust Value.

Oracle Database Object Management 14
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Oracle Debugger Watch List

The Watch List view displays information about the variables being watched, allowing you
to add, delete or edit watch variables.

To add a watch variable, simply right-click anywhere of Watch List view and choose Add
Variable. Then, enter the Variable Name. Also, you can right-click the highlighted code in
the Code Window or the variable in the Smart Data view and choose Add to watch list.

You can adjust the value of a watch variable by right-click the variable and choose Adjust
Value.

To delete a watch variable or all watch variables, simply right-click a variable and choose
Remove Variable or Remove All Variable.

Oracle Database Object Management 15
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Oracle Debugger Toolbar

You can perform the most commonly used actions for debugging on the toolbar or menu:

P> Run
Start running code in debug mode by clicking P Run or pressing F9. The debugger executes
your code until the end of the code or the next breakpoint is reached.

*Step Over

While execution of your code is paused, you can resume it by clicking “*Step Over or
pressing F8. Then, the current line will be executed. If the line is a procedure or function call,
it will bypass the procedure or function. The counter will then move to the next line of code.

?Step In

While execution of your code is paused, you can resume it by clicking ?Step In or pressing
F7. Then, it executes the current line. If the line is a procedure or function call, the counter
goes to the first statement in the procedure or function. Otherwise, the counter will move to
the next line of code.

7 Step Out

While execution of your code is paused, you can resume it by clicking ?Step Out or
pressing Shift+F7. Then, the remaining part of the code within the current procedure or
function will be executed. Subsequently, the counter will jump to the line which is just after
the caller of the method.

'&Step End
While execution of your code is paused, you can resume it by clicking %Step End. Then, the
counter will jump to the last line of the procedure or function.

M stop
While execution of your code is paused, you can stop stepping the code by clicking .Stop.
Then, the execution will stop and cannot resume it.

Oracle Database Object Management 16
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Editing Oracle Physical Attributes/Default Storage Characteristics

% Free

Specify a whole number representing the percentage of space in each data block of the
database object reserved for future updates to rows of the object. The value must be from 0
to 99. A value of 0 means that the entire block can be filled by inserts of new rows. The
default value is 10.

% Used

Specify a whole number representing the minimum percentage of used space that Oracle
maintains for each data block of the database object. A block becomes a candidate for row
insertion when its used space falls below this value. The value must be from 0 to 99 and
defaults to 40.

Initial Transactions
Specify the initial number of concurrent transaction entries allocated within each data block
allocated to the database object. This value can range from 1 to 255 and defaults to 1.

Note: The default value for an index is 2.

Maximum Transactions
Specify the maximum number of concurrent update transactions allowed for each data block
in the segment.

Storage

Initial

Specify the size of the first extent of the object. Use the dropdown list K, M, G, T, Por E
to specify the size in kilobytes, megabytes, gigabytes, terabytes, petabytes, or exabytes.
If you do not specify any of the abbreviations, then the size is interpreted as bytes.

Next

Specify the size of the next extent to be allocated to the object. Use the dropdown list K,
M, G, T, P or E to specify the size in kilobytes, megabytes, gigabytes, terabytes,
petabytes, or exabytes. If you do not specify any of the abbreviations, then the size is
interpreted as bytes.

Min Extents
Specify the total number of extents to allocate when the object is created.

Oracle Database Object Management 17
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Max Extents
Specify the total number of extents, including the first, that Oracle can allocate for the
object. Check Unlimited if you want extents to be allocated automatically as needed.

Max Size

Specify the maximum size of the storage element. Use the dropdown list K, M, G, T, P or
E to specify the size in kilobytes, megabytes, gigabytes, terabytes, petabytes, or
exabytes. If you do not specify any of the abbreviations, then the size is interpreted as
bytes. Check Unlimited if you do not want to limit the disk space of the storage
element.

% Increase
Specify the percent by which the third and subsequent extents grow over the preceding
extent. The default value is 50.

Freelists
For objects other than tablespaces and rollback segments, specify the number of free
lists for each of the free list groups for the table, partition, cluster, or index.

Freelist Group
Specify the number of groups of free lists for the database object you are creating. The
default and minimum value for this parameter is 1.

Optimal

Specify an optimal size for a rollback segment. Use the dropdown list K, M, G, T, Por E
to specify the size in kilobytes, megabytes, gigabytes, terabytes, petabytes, or exabytes.
If you do not specify any of the abbreviations, then the size is interpreted as bytes.
Check Null for no optimal size for the rollback segment.

Buffer Pool

DEFAULT
Choose this to indicate the default buffer pool. This is the default for objects not
assigned to KEEP or RECYCLE.

KEEP

Choose this to put blocks from the segment into the KEEP buffer pool. Maintaining
an appropriately sized KEEP buffer pool lets Oracle retain the schema object in
memory to avoid I/O operations. KEEP takes precedence over any NOCACHE clause
you specify for a table, cluster, materialized view, or materialized view log.

Oracle Database Object Management 18
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RECYCLE

Choose this to put blocks from the segment into the RECYCLE pool. An appropriately
sized RECYCLE pool reduces the number of objects whose default pool is the
RECYCLE pool from taking up unnecessary cache space.

Oracle Database Object Management 19
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Oracle Tables

Relational databases use tables to store data. All operations on data are done on the tables
themselves or produce another table as the result. A table is a set of rows and columns, and
their intersections are fields. From a general perspective, columns within a table describe the
name and type of data that will be found by row for that column'’s fields. Rows within a table
represent records composed of fields that are described from left to right by their
corresponding column's name and type. Each field in a row is implicitly correlated with each
other field in that row.

Just simply click o open an object pane for Table. A right-click displays the popup menu
or by using the object pane toolbar, allowing you to create new, edit, open and delete the
selected table.

Create Table
To create a new table

e Select anywhere on the object pane.

o Click the CiNew Table from the object pane toolbar together with the '“down arrow
to choose the type Normal / External / Index Organized.
or

e Right-click and select EdNew Table to choose the type Normal / External / Index
Organized from the popup menu.

o Edit table properties and fields on the appropriate tabs of the Table Designer.

Hint: To create new table you can also right-click the Tables node of the navigation
pane and select the L5New Table from the popup menu.

To create a new table with the same properties as one of the existing tables has (using popup
menu)

Apply to: current schema {same connection}

e Select the table(s) for copying in the navigation pane/object pane.
e Right-click and select the Duplicate Table from the popup menu.
e The newly created table(s) will be named as "tablename_copy".

Oracle Database Object Management 20
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To create a new table with modification as one of the existing tables

e Select the table for modifying in the navigation pane/object pane.
e Right-click and select the ﬁDesign Table from the popup menu.
or
e Click the ﬁDesign Table from the object pane toolbar.
e Modify table properties and fields on the appropriate tabs of the Table Designer.
« Click #dSave As.

Edit Table
To edit the existing table (manage its fields, indexes, foreign keys and triggers etc)

e Select the table for editing in the navigation pane/object pane.
e Right-click and select the ﬁDesign Table from the popup menu.
or
e Click the ﬁDesign Table from the object pane toolbar.
o Edit table properties and fields on the appropriate tabs of the Table Designer.

To change the name of the table

o Select the table for editing in the navigation pane/object pane.
e Right-click and select the Rename from the popup menu.

Open Table (manage table data)
To open a table

e Select the table for opening in the navigation pane/object pane.

e Right-click and select the f_!!Open Table from the popup menu or simply double-click
the table.
or

e Click the T_!!Open Table from the object pane toolbar.

Note: This option is only applied if you do wish Navicat loads all your images while
opening the table. To open the graphical table with faster performance, use T_!!Open
Table (Quick) below.

Oracle Database Object Management 21
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To open a table with graphical fields

e Select the table for opening in the navigation pane/object pane.
o Right-click and select the f_:'!Open Table (Quick) from the popup menu.

Note: Faster performance for opening the graphical table, as BLOB fields (images) will
not be loaded until you click on the cell.

Empty Table
To empty a table

e Select the table in the navigation pane/object pane.
e Right-click the selected table and choose Empty Table from the popup menu.

Note: This option is only applied when you wish to clear all the existing records without
resetting the auto-increment value. To reset the auto-increment value while emptying
your table, use Truncate Table below.

Truncate Table
To truncate a table

e Select the table in the navigation pane/object pane.
e Right-click the selected table and choose Truncate Table from the popup menu.

Delete Table
To delete a table

o Select the table for deleting in the navigation pane/object pane.

e Right-click and select the CeDelete Table from the popup menu.
or

o Click the CaDelete Table from the object pane toolbar.

e Confirm deleting in the dialog window.

Oracle Database Object Management 22
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Achieve Table Information
To achieve a table information

e Select the table in the navigation pane/object pane.

e Right-click the selected table and choose Object Information from the popup menu.
or

e Choose View -> Object Information in the main menu.

Oracle Database Object Management 23
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Oracle Normal Tables

Tables are the basic unit of data storage in an Oracle database. Data is stored in rows and
columns. You define a table with a table name and set of columns.

In a normal (heap-organized) table, data is stored as an unordered collection (heap).

Oracle Database Object Management 24
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Table Designer for Oracle Normal Tables (/Index Organized Tables)

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit
and drop table's fields, indexes, foreign keys, and much more.

Note that Table Designer for Index Organized Tables differs from Normal Tables only
on the Options tab.

e Managing Table Fields

e Managing Table Indexes

e Managing Table Foreign Keys

¢ Managing Table Unigues

e Managing Table Checks

e Managing Table Triggers

¢ Managing Table Options

e Managing Table Comment
e Table SQL Preview

Oracle Database Object Management 25
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Oracle Table Fields

Table fields are managed on the Fields tab of the Table Designer. Just simply click a field for
editing. A right-click displays the popup menu or by using the field toolbar, allowing you to
create new and drop the selected field.

Add Field
To add a field to the table

e Open the table in the Table Designer.

e Open the Fields tab.

« Right-click and select the '“#Add Field from the popup menu or click the “#Add Field
from the toolbar.

o Edit field properties.

To add a new field with modification as one of the existing fields

e Open the table in the Table Designer.

e Open the Fields tab.

o Select field.

e Right-click and select the Duplicate Field from the popup menu.
o Edit field properties.

Edit Field
To edit the table field

e Open the table in the Table Designer.
e Open the Fields tab.
e Simply click on the field to edit.

Oracle Database Object Management 26
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Delete Field
To delete the table field

e Open the table in the Table Designer.

e Open the Fields tab.

o Right-click and select the FEDelete Field from the popup menu or click the FEDelete
Field from the toolbar.

e Confirm deleting in the dialog window.

Oracle Database Object Management 27
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Setting Oracle Table Field Properties

Mame Type Length Scale Allow Mull

P EMPLOYEE_ID NUMBER 6 0 [l 531
START_DATE DATE 7 0 O ,5@?_
END_DATE DATE 7 0 ]
|OB_ID WARCHARZ 10 0 O
DEPARTMENT_ID NUMBER 4 0

Name

The Name is a descriptive identifier for a field that can be up to 30 bytes by default (letters
or numbers) including spaces. The names should be descriptive enough that anyone can
easily identify them when viewing or editing records. For example, LastName, FirstName,
StreetAddress, or HomePhone.

Use the Name edit box to set the field name. Note that the name of the field must be unique
among all the field names in the table.

Type

After you name a field, you choose a data type for the data to be contained in the field. When
you choose a field's data type, you are deciding:

o« What kind of values to allow in the field. You cannot store text in field with the
Numeric data type.

e How much storage space Oracle is to set aside for the data in that field.

e What types of operations can be performed on the values in that field.

The Type dropdown list defines the type of the field data.

The following table shows all the built-in general-purpose data types.

Name Description

CHAR fixed-length character strings

NCHAR fixed-length Unicode character data
VARCHAR?2 variable-length character strings
VARCHAR variable-length character strings
NVARCHAR?2 variable-length Unicode character data
CLOB database character set data

NCLOB Unicode national character set data

Oracle Database Object Management 28
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L)

variable-length character data containing up to 2

LONG . } .

gigabytes of information
NUMBER fixed and floating-point numbers
DATE point-in-time values (dates and times)

INTERVAL DAY TO SECOND

period of time in terms of days, hours, minutes,
and seconds

INTERVAL YEAR TO MONTH

stores a period of time using the YEAR and MONTH
datetime fields

TIMESTAMP

point-in-time values (dates and times) (includes
fractional seconds)

TIMESTAMP WITH TIME
ZONE

TIMESTAMP with explicit time zone information

BLOB unstructured binary data in the database

BEILE unstructured binary data in operating-system files
outside the database

RAW can be indexed and is used for data that is not to
be interpreted by Oracle Database

LONG RAW cannot be indexed and is used for data that is not
to be interpreted by Oracle Database

ROWID the address (rowid) of every row in the database

CHARACTER =CHAR !

CHARACTER VARYING =VARCHAR2 !

CHAR VARYING =VARCHAR2 !

NATIONAL CHARACTER =NCHAR !

NATIONAL CHAR =NCHAR !

NATIONAL CHARACTER
VARYING

=NVARCHAR2 !

NATIONAL CHAR VARYING

=NVARCHAR2 !

NCHAR VARYING

=NVARCHAR2 !

NUMERIC =NUMBER *
DECIMAL =NUMBER !
INTEGER =NUMBER(38) !
INT =NUMBER(38) !
SMALLINT =NUMBER(38) *
FLOAT =FLOAT(126) !

DOUBLE PRECISION

=FLOAT(126) !

Oracle Database Object Management
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REAL =FLOAT(63) !

Note: These are ANSI datatypes and datatypes from the IBM products SQL/DS and DB2.
Oracle recognizes these datatypes and converts them to the equivalent Oracle datatype.
Click here for detailed description on these datetypes.

Length and Scale

Use the Length edit box to define the precision (total number of digits) of the field and use
Scale edit box to define the scale (number of digits to the right of the decimal point) for
numeric column.

Note: Be careful when shortening the field length as it might result in data loss.

How scale factors affect numeric data storage:

Input Data Specified As Stored As

7,456,123.89 NUMBER 7456123.89

7,456,123.89 NUMBER(*,1) 7456123.9

7,456,123.89 NUMBER(9) 7456124

7,456,123.89 NUMBER(9,2) 7456123.89

7,456,123.89 NUMBER(9,1) 7456123.9

7,456,123.89 NUMBER(6) not accepted, exceeds precision
7,456,123.89 NUMBER(7,-2) 7456100

M Allow Null
Allow the NULL values for the field.
ﬁPrimary Key

A Primary Key is a single field or combination of fields that uniquely defines a record. None
of the fields that are part of the primary key can contain a null value.

Primary Key Name

Right-click and select Primary Key Name from the popup menu to enter the primary key
constraint name.
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Setting Other Oracle Table Field Properties

For INTERVAL DAY TO SECOND data type:

Leading Field Precision
Set the number of digits in the leading field. Accepted values are 0 to 9. The default is 2.

Fractional Seconds Precision
Set the number of digits in the fractional part of the SECOND datetime field. Accepted
values are 1 to 9.

For INTERVAL YEAR TO MONTH data type:

Year Precision
Set the number of digits in the year. The default is 2.

For TIMESTAMP, TIMESTAMP WITH TIME ZONE, TIMESTAMP WITH LOCAL TIME
ZONE data types:

Fractional Seconds Precision
Set the number of digits in the fractional part of the SECOND datetime field. Accepted
values are 1 to 9.

For CHAR, VARCHAR?2 data types:

Unit
Set the unit either in BYTE or CHAR.

For COMPLEX data types:

Object Schema
Set the object schema for the field.

Object Type
Set the object type for the field.

For most data types:

Default
Set the default value for the field.
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For all data types:

Comment
Set any optional text describing the current field.
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Oracle Table Indexes

Indexes are optional structures associated with tables and clusters. You can create indexes
on one or more columns of a table to speed SQL statement execution on that table. An Oracle
Database index provides a faster access path to table data. Indexes are the primary means
of reducing disk I/O when properly used.

You can create many indexes for a table as long as the combination of columns differs for
each index. You can create more than one index using the same columns if you specify
distinctly different combinations of the columns.

Table indexes are managed on the Indexes tab of the Table Designer. Just simply
click/double-click an index field for editing. A right-click displays the popup menu or using
the index toolbar, allowing you to create new, edit and delete the selected index field.

Add Index
To add a table index

e Open the table in the Table Designer.

e Open the Indexes tab.

« Right-click and select the E#Add Index from the popup menu or click the EAdd
Index from the toolbar.

o Edit index properties.

Edit Index
To edit a table index

e Open the table in the Table Designer.
e Open the Indexes tab.
e Just simply click/double-click on the index to edit.
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Delete Index
To delete a table index

e Open the table in the Table Designer.

e Open the Indexes tab.

« Right-click on the index to delete and select the E&Delete Index from the popup
menu or click the E&Delete Index from the toolbar.

e Confirm deleting in the dialog window.
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Setting Oracle Table Index Properties

Mame Fields Index Type
B EMP_DEPARTMEMNT IX DEPARTMENT_ID ASC J Mon-Unigue
EMP_JOB_IX JOB_ID ASC Mon-Unigue
EMP_MAMNAGER_IX MAMNAGER_ID ASC Mon-Unigue
EMP_MAME_IX LAST_MAME ASC, FIRST_MAME ASC Mon-Unigue

Use the Name edit box to set the index name.

To include field(s) in the index, just simply double-click the Fields field or click ﬂto open
the editor for editing.

The Index Type dropdown list defines the type of the table index. Oracle Database provides

several indexing schemes.

Non-unique
Non-unique indexes do not impose the restriction of unique indexes on the column

values.

Unique
Unique indexes guarantee that no two rows of a table have duplicate values in the key

column (or columns).

Bitmap
In a bitmap index, a bitmap for each key value is used instead of a list of rowids.

¥ Parallel With Degree
Parallel indexing can improve index performance when you have a large amount of data, and

have multiple CPUs. Enter the degree that determines the number of separate indexing

processes.

Tablespace
The tablespace in which to create the index. An index can be created in the same or different

tablespace as the table it indexes.
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Schema
The schema in which to create the index.

Note:

To create an index in your own schema, at least one of the following conditions must be
true:

e The table or cluster to be indexed is in your own schema.
e You have INDEX privilege on the table to be indexed.
e You have CREATE ANY INDEX system privilege.

To create an index in another schema, all of the following conditions must be true:

e You have CREATE ANY INDEX system privilege.
e« The owner of the other schema has a quota for the tablespaces to contain
the index or index partitions, or UNLIMITED TABLESPACE system privilege.
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Oracle Table Foreign Keys

A foreign key specifies that the values in a column (or a group of columns) must match the
values appearing in some row of another table. We say this maintains the referential
integrity between two related tables.

Foreign Keys are managed on the Foreign Keys tab of the Table Designer. Just simply
click/double-click a foreign key field for editing. A right-click displays the popup menu or
using the foreign key toolbar, allowing you to create new, edit and delete the selected foreign
key field.

Add Foreign Key
To add a foreign key

e Open the table in the Table Designer.

e Open the Foreign Keys tab.

e Right-click and select the =sAdd Foreign Key from the popup menu or click the =
Add Foreign Key from the toolbar.

o Edit foreign key properties.

Edit Foreign Key
To edit a foreign key

e Open the table in the Table Designer.
e Open the Foreign Keys tab.
e Just simply click/double-click on the foreign key to edit.

Delete Foreign Key
To delete a foreign key

e Open the table in the Table Designer.

e Open the Foreign Keys tab.

e Right-click on the foreign key to delete and select the =sDelete Foreign Key from
the popup menu or click the =sDelete Foreign Key from the toolbar.

e Confirm deleting in the dialog window.
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Setting Oracle Table Foreign Key Properties

MName Reference Schema  Reference Table Reference Constraint  Reference Fields Fields On Delete Enable
EMP_DEPT_FK  HR DEPARTMENTS  DEPT_ID_PK DEPARTMENT ID  DEPARTMENT_ID
B EMP_|OB_FK HR |OBS JOB_ID_PK |OB_ID JOB_ID J
EMP_MANAGER_| HR EMPLOYEES EMP_EMP_ID_PK EMPLOYEE_ID MANAGER_ID

Use the Name edit box to enter a name for the new key and then select a table field to
include in the key from the Fields group.

Use the Reference Schema, Reference Table and Reference Constraint dropdown lists
to select a foreign schema, table and constraint respectively.

To include field(s) to the key, just simply double-click the Fields field or click ﬂto open the
editor(s) for editing.

The On Delete dropdown list defines the type of the actions to be taken.

No Action (default)
Referenced key values will not be updated or deleted.

Cascade
Delete any rows referencing the deleted row, or update the value of the referencing
column to the new value of the referenced column, respectively.

Set Null
Set the referencing column(s) to null.

M Enable
You can choose whether to enable / disable the foreign key constraint by checking /

unchecking the box.
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Oracle Table Uniques

Unique constraints ensure that the data contained in a column or a group of columns is
unique with respect to all the rows in the table.

Uniques are managed on the Uniques tab of the Table Designer. Just simply
click/double-click an unique field for editing. Using the unique toolbar, allowing you to create
new, edit and delete the selected unique field.

Add Unique
To add an unique

e Open the table in the Table Designer.

e Open the Uniques tab.

e Right-click and select the E2Add Unique from the popup menu or click the E2Add
Unique from the toolbar.

o Edit unique properties.

Edit Unique
To edit an unique

e Open the table in the Table Designer.
e Open the Uniques tab.
e Just simply click on the unique to edit.

Delete Unique
To delete an unique

e Open the table in the Table Designer.

e Open the Uniques tab.

e Right-click on the unique to delete and select the feDelete Unique from the popup
menu or click the EeDelete Unique from the toolbar.

e Confirm deleting in the dialog window.
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Setting Oracle Table Unique Properties

Mame Fields Enable
P EMP_EMAIL UK EMAIL J

Use the Name edit box to set the unique name.

Fields
To set field(s) as unique, just simply double-click the Fields field or click ﬂto open the
editor(s) for editing.

M Enable
You can choose whether to enable / disable the unique constraint by checking / unchecking

the box.
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Oracle Table Checks

A check constraint is the most generic constraint type. It allows you to specify that the value
in a certain column must satisfy a Boolean (truth-value) expression.

Checks are managed on the Checks tab of the Table Designer. Just simply click/double-click
a check field for editing. Using the check toolbar, allowing you to create new, edit and delete
the selected check field.

Add Check
To add a check

e Open the table in the Table Designer.

e Open the Checks tab.

e Right-click and select the @Add Check from the popup menu or click the @Add
Check from the toolbar.

o Edit check properties.

Edit Check
To edit a check

e Open the table in the Table Designer.
e Open the Checks tab.
e Just simply click on the check to edit.

Delete Check
To delete a check

e Open the table in the Table Designer.

e Open the Checks tab.

e Right-click on the check to delete and select the @Delete Check from the popup
menu or click the @Delete Check from the toolbar.

e Confirm deleting in the dialog window.
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Setting Oracle Table Check Properties

Use the Name edit box to set the check name.

Check

Set the condition for checking, e.g. "field_namel > 0 AND field_name2 > field_namel" in
the Check edit box. A check constraint specified as a column constraint should reference
that column's value only, while an expression appearing in a table constraint may reference
multiple columns.

Definition
Type in the definition for the check constraint.

M Enable
You can choose whether to enable / disable the check constraint by checking / unchecking

the box.
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Oracle Table Triggers

A trigger is a specification that the database should automatically execute a particular
function whenever a certain type of operation is performed. Triggers can be defined to
execute either before or after any INSERT, UPDATE, or DELETE operation, either once per
modified row, or once per SQL statement.

Triggers are managed on the Triggers tab of the Table Designer. Just simply click a trigger
field for editing. A right-click displays the popup menu or using the trigger toolbar, allowing
you to create new, edit and delete the selected trigger field.

Add Trigger
To add a trigger

e Open the table in the Table Designer.

e Open the Triggers tab.

o Right-click and select the ‘endd Trigger from the popup menu or click the ‘eAdd
Trigger from the toolbar.

o Edit trigger properties.

Edit Trigger
To edit a trigger

e Open the table in the Table Designer.
e Open the Triggers tab.
e Just simply click on the trigger to edit.

Delete Trigger
To delete a trigger

e Open the table in the Table Designer.

e Open the Triggers tab.

e Right-click on the trigger to delete and select the léDelete Trigger from the popup
menu or click the 'éDelete Trigger from the toolbar.

e Confirm deleting in the dialog window.
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Setting Oracle Table Trigger Properties

Name
Set the trigger name.

Compound
Check to set the trigger as a compound trigger.

Row trigger
Check to set the trigger as a row trigger.

Fires
Specify the trigger timing whether the trigger action is to be run before or after the triggering
statement.

INSERT - fires the trigger whenever an INSERT statement adds a row to a table or adds
an element to a nested table.

UPDATE - fires the trigger whenever an UPDATE statement changes a value in one of the
columns specified in Update of Fields. If no Update of Fields are present, the trigger will
be fired whenever an UPDATE statement changes a value in any column of the table or
nested table.

DELETE - fires the trigger whenever a DELETE statement removes a row from the table
or removes an element from a nested table.

Update Of Fields
Specify the fields for UPDATE statement trigger upon necessary.

M Enable
You can choose whether to enable / disable the trigger constraint by checking / unchecking
the box.

Definition
Type in the definition for the trigger.

Example:
BEGIN
add_job_history(:old.employee_id, :old.hire_date, sysdate,
:old.job_id, :old.department_id);
END;
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Advanced

When Clause

Specify the trigger condition, which is a SQL condition that must be satisfied for the
database to fire the trigger. This condition must contain correlation names and cannot
contain a query.

Referencing Old
Specify correlation names. The default correlation names are OLD and NEW.

Referencing New
Specify correlation names. The default correlation names are OLD and NEW.

Follows
Specify the relative firing order of triggers of the same type.

Schema
Define the trigger on the current schema.
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Oracle Table Options

Tablespace
Define a tablespace different from the default tablespace to create a table.

Logging
Specify whether creation of a database object will be logged in the redo log file (LOGGING)
or not (NOLOGGING).

Compression
Specify whether to compress data segments to reduce disk use. It is valid only for
heap-organized tables.

e COMPRESS - enables table compression.

e COMPRESS FOR ALL OPERATIONS - attempts to compress data during all DML
operations on the table.

e COMPRESS FOR DIRECT_LOAD OPERATIONS - attempts to compress data during
direct-path INSERT operations when it is productive to do so.

e NOCOMPRESS - disables table compression.

Cache
Indicate how blocks are stored in the buffer cache.

e CACHE - indicates that the blocks retrieved for this table are placed at the most
recently used end of the least recently used (LRU) list in the buffer cache when a full
table scan is performed.

e NOCACHE - indicates that the blocks retrieved for this table are placed at the least
recently used end of the LRU list in the buffer cache when a full table scan is
performed.

M parallel With Degree
Specify the degree of parallelism, which is the number of parallel threads used in the parallel
operation.

¥ Row Movement
With the option on, it allows the database to move a table row. It is possible for a row to
move, for example, during table compression or an update operation on partitioned data.

Physical Attributes
Refer to Editing Physical Attributes/Default Storage Characteristics.
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Oracle External Tables

External tables access data in external sources as if it were in a table in the database. While
creating external tables, you are actually creating metadata in the data dictionary that
enables you to access external data.

Note that external tables are read only. No DML operations are possible and no index can be
created.
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Table Designer for Oracle External Tables

Table Designer for External Tables allows you to create, edit table's fields, external
properties and access parameters etc.

e Managing External Table Fields

¢ Managing External Table External Properties

¢ Managing External Table Access Parameters

o External Table SQL Preview
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Fields for Oracle External Tables

Table fields are managed on the Fields tab of the Table Designer. Just simply click a field for
editing. A right-click displays the popup menu or by using the field toolbar, allowing you to
create new and drop the selected field.

Add Field
To add a field to the table

e Open the table in the Table Designer.

e Open the Fields tab.

« Right-click and select the '“#Add Field from the popup menu or click the “#Add Field
from the toolbar.

o Edit field properties.

To add a new field with modification as one of the existing fields

e Open the table in the Table Designer.

e Open the Fields tab.

o Select field.

e Right-click and select the Duplicate Field from the popup menu.
o Edit field properties.

Edit Field
To edit the table field

e Open the table in the Table Designer.
e Open the Fields tab.
e Simply click on the field to edit.
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Delete Field
To delete the table field

e Open the table in the Table Designer.
e« Open the Fields tab.

o Right-click and select the FEDelete Field from the popup menu or click the FEDelete
Field from the toolbar.
e Confirm deleting in the dialog window.
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Setting Field Properties for Oracle External Tables

Name Type Length Scale
P EMPLOYEE_ID NUMBER b 0
START_DATE DATE 7 0
END_DATE DATE 7 0
JOB_ID VARCHARZ 10 0
DEPARTMENT_ID NUMBER 4 0

Name

The Name is a descriptive identifier for a field that can be up to 30 characters by default
(letters or numbers) including spaces. The names should be descriptive enough that anyone
can easily identify them when viewing or editing records. For example, LastName, FirstName,
StreetAddress, or HomePhone.

Use the Name edit box to set the field name. Note that the name of the field must be unique
among all the field names in the table.

Type

After you name a field, you choose a data type for the data to be contained in the field. When
you choose a field's data type, you are deciding:

e« What kind of values to allow in the field. You cannot store text in field with the
Numeric data type.

e How much storage space Oracle is to set aside for the data in that field.

e What types of operations can be performed on the values in that field.

The Type dropdown list defines the type of the field data.

The following table shows all the built-in general-purpose data types.

Name Description

CHAR fixed-length character strings

NCHAR fixed-length Unicode character data
VARCHAR?2 variable-length character strings
VARCHAR variable-length character strings
NVARCHAR?2 variable-length Unicode character data
CLOB database character set data

NCLOB Unicode national character set data
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L)

variable-length character data containing up to 2

LONG ) ) .

gigabytes of information
NUMBER fixed and floating-point numbers
DATE point-in-time values (dates and times)

INTERVAL DAY TO
SECOND

period of time in terms of days, hours, minutes,
and seconds

INTERVAL YEAR TO
MONTH

stores a period of time using the YEAR and MONTH
datetime fields

TIMESTAMP

point-in-time values (dates and times) (includes
fractional seconds)

TIMESTAMP WITH TIME
ZONE

TIMESTAMP with explicit time zone information

BLOB unstructured binary data in the database

BEILE unstructured binary data in operating-system files
outside the database

RAW can be indexed and is used for data that is not to
be interpreted by Oracle Database

LONG RAW cannot be indexed and is used for data that is not
to be interpreted by Oracle Database

ROWID the address (rowid) of every row in the database

CHARACTER =CHAR !

CHARACTER VARYING |=VARCHAR2 !

CHAR VARYING =VARCHAR2 *

NATIONAL CHARACTER |=NCHAR !

NATIONAL CHAR =NCHAR !

NATIONAL CHARACTER
VARYING

=NVARCHAR2 !

NATIONAL CHAR

=NVARCHAR2 !

VARYING

NCHAR VARYING =NVARCHAR2 !
NUMERIC =NUMBER *
DECIMAL =NUMBER *
INTEGER =NUMBER(38) !
INT =NUMBER(38) *
SMALLINT =NUMBER(38) *
FLOAT =FLOAT(126) *
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DOUBLE PRECISION =FLOAT(126) !
REAL =FLOAT(63) !

Note: These are ANSI datatypes and datatypes from the IBM products SQL/DS and DB2.
Oracle recognizes these datatypes and converts them to the equivalent Oracle datatype.
Click here for detailed description on these datetypes.

Length and Scale

Use the Length edit box to define the precision (total number of digits) of the field and use
Scale edit box to define the scale (number of digits to the right of the decimal point) for
numeric column.

Note: Be careful when shortening the field length as it might result in data loss.

How scale factors affect numeric data storage:

Input Data Specified As Stored As
7,456,123.89 NUMBER 7456123.89
7,456,123.89 NUMBER(*,1) 7456123.9
7,456,123.89 NUMBER(9) 7456124
7,456,123.89 NUMBER(9,2) 7456123.89
7,456,123.89 NUMBER(9,1) 7456123.9
7,456,123.89 NUMBER(6) not ?C_Cepted’ exceeds
precision
7,456,123.89 NUMBER(7,-2) 7456100
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Setting Other Field Properties for Oracle External Tables

For INTERVAL DAY TO SECOND data type:

Leading Field Precision
Set the number of digits in the leading field. Accepted values are 0 to 9. The default is 2.

Fractional Seconds Precision
Set the number of digits in the fractional part of the SECOND datetime field. Accepted
values are 1 to 9.

For INTERVAL YEAR TO MONTH data type:

Year Precision
Set the number of digits in the year. The default is 2.

For TIMESTAMP, TIMESTAMP WITH TIME ZONE, TIMESTAMP WITH LOCAL TIME
ZONE data types:

Fractional Seconds Precision
Set the number of digits in the fractional part of the SECOND datetime field. Accepted
values are 1 to 9.

For CHAR, VARCHAR?2 data types:

Unit
Set the unit either in BYTE or CHAR.

For COMPLEX data types:

Object Schema
Set the object schema for the field.

Object Type
Set the object type for the field.
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External Properties for Oracle External Tables

Default Directory
Specify the default directory for the external table.

Directory
Set the external directory.

Location
Set the external source location.

Access Driver
Specify the access driver for the external table. The default type for external tables is
ORACLE_LOADER.

Reject Limit
Specify the limit on the number of errors that can occur during a query of the external data.

I parallel With Degree
Check to enable parallel query on the data sources and specify the degree of parallel access.
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Access Parameters for Oracle External Tables

Describe the mapping of the external data to the Oracle Database data columns.

M Using CLOB
Check this option to get a CLOB data value of the returned query.
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Oracle Index Organized Tables

An index-organized table has a storage organization that is a variant of a primary B-tree.
Data for an index-organized table is stored in a B-tree index structure in a primary key sorted
manner. Each leaf block in the index structure stores both the key and nonkey columns.

Index-organized tables have full table functionality. They support features such as
constraints, triggers etc with additional features such as key compression.
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Table Designer for Oracle Index Organized Tables

Table Designer for Index Organized Tables allows you to create, edit and drop table's
fields, indexes, foreign keys, and much more.

Note that Table Designer for Index Organized Tables differs from Normal Tables only
on the Options tab. Therefore, we will refer to Table Designer for Normal Table(/Index
Organized Table) on the following similar chapters:

e Managing Table Fields

e Managing Table Indexes

e Managing Table Foreign Keys

¢ Managing Table Unigues

e Managing Table Checks

e Managing Table Triggers

e Managing Table Comment
e Table SQL Preview

Options tab for Index Organized Table:

e Managing Table Options
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Options for Oracle Index Organized Tables

Tablespace
Define a tablespace different from the default tablespace to create a table.

Logging
Specify whether creation of a database object will be logged in the redo log file (LOGGING)
or not (NOLOGGING).

I parallel With Degree
Specify the degree of parallelism, which is the number of parallel threads used in the parallel
operation.

M Row Movement
With the option on, it allows the database to move a table row. It is possible for a row to
move, for example, during table compression or an update operation on partitioned data.

Physical Attributes
Refer to Editing Physical Attributes/Default Storage Characteristics.

IOT Properties

MKey Compress

Check this option to enable key compression. Upon necessary, you can also specify the
prefix length (as the number of key columns), which identifies how the key columns are
broken into a prefix and suffix entry.

Mapping Table
Specify if there is a mapping table for the index-organized table. Note that a mapping
table is required for creating bitmap indexes on an index-organized table.

% Threshold
When an overflow segment is being used, it defines the maximum size of the portion of
the row that is stored in the index block, as a percentage of block size.

I Overflow Properties
Check to enable an overflow storage area.

Note: After saving the table, this option cannot be unchecked.
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Overflow Column
Specify the column to be put in a separate overflow data segment.

Overflow Tablespace
Specify the tablespace in which the overflow segment to be stored.

Overflow Logging

Specify whether creation of a database object will be logged in the redo log file
(LOGGING) or not (NOLOGGING).

Overflow Physical Attributes
Refer to Editing Physical Attributes/Default Storage Characteristics.
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Oracle Views

Views are useful for allowing users to access a set of relations (tables) as if it were a single
table, and limiting their access to just that. Views can also be used to restrict access to rows
(a subset of a particular table).

Just simply click %#to open an object pane for View. A right-click displays the popup menu
or using the object pane toolbar, allowing you to create new, edit, open and delete the
selected view.

Create View
To create a new view

e Select anywhere on the object pane.
o Click the ®2New View from the object pane toolbar.
or
« Right-click and select ¥2New View from the popup menu.
o Edit view properties on the appropriate tabs of the View Designer.

Hint: To create new view you can also right-click the Views node of the navigation
pane and select the 2New View from the popup menu.

To create a new view with modification as one of the existing views

e Select the view for modifying in the navigation pane/object pane.
« Right-click and select the ®*Design View from the popup menu.
or
« Click the 5*Design View from the object pane toolbar.
e Modify view properties on the appropriate tabs of the View Designer.
« Click kdsave As.

To create a new view with loading from a SQL file

e Select anywhere on the object pane.
o Click the 2New View from the object pane toolbar.
or
o Right-click and select *®New View from the popup menu.
« Click “Load.
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Edit View
To edit the existing view (manage its SQL definition etc)

e Select the view for editing in the navigation pane/object pane.

« Right-click and select the *Design View from the popup menu.
or

« Click the Design View from the object pane toolbar.

o Edit view properties on the appropriate tabs of the View Designer.

To change the name of the view

e Select the view for editing in the navigation pane/object pane.
e Right-click and select the Rename from the popup menu.

Open View
To open a view (manage view data)

e Select the view for opening in the navigation pane/object pane.

« Right-click and select the 20Open View from the popup menu or simply double-click
the view.
or

« Click the ¥20Open View from the object pane toolbar.

Maintain View
To maintain a view

e Select the view for maintaining in the object pane.
e Right-click and select the Maintain from the popup menu.
o Compile
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Delete View
To delete a view

o Select the view for deleting in the navigation pane/object pane.

« Right-click and select the “®&Delete View from the popup menu.
or

o Click the ®®Delete View from the object pane toolbar.

e Confirm deleting in the dialog window.

Achieve View Information
To achieve a view information

e Select the view in the navigation pane/object pane.

e Right-click the selected view and choose Object Information from the popup menu
or

e Choose View -> Object Information in the main menu.
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Oracle View Designer

View Designer is the basic Navicat tool for working with views. It allows you to create new
view and edit the existing view definition (view name and the SELECT statement it
implements).

¢ Working with View Builder
¢ Editing View SQL Definition
o Setting Advanced View Properties

o Editing View Comment
e View SQL Preview
e View Preview

e View Explain
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Working with Oracle View Builder (Available only in Full Version)

View Builder allows you to build views visually. It allows you to create and edit views
without knowledge of SQL. See Query Builder for details.
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Editing Oracle View SQL Definition

The Definition tab allows you to edit the view definition as SQL statement (SELECT
statement it implements).

Example:
SELECT
HR.EMPLOYEES.EMPLOYEE_ID
FROM
HR.EMPLOYEES

Hint: To customize the view of the editor and find out more features for sql editing, see Editor
View and More Features.
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Setting Advanced Oracle View Properties
The Advanced tab allows you to restrict the defining query of the view.

M Restrict Query
Specify the name. If you omit this identifier, then Oracle automatically assigns a name of the

form SYS_Cn, where n is an integer that makes the constraint name unique within the

database.

Read Only
Indicate that the table or view cannot be updated.

Check option
Indicate that Oracle Database prohibits any changes to the table or view that would

produce rows that are not included in the subquery.

¥ Force On Create
Check this option if you want to create the view regardless of whether the base tables of the

view or the referenced object types exist or the owner of the schema containing the view has

privileges on them.
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Oracle View Preview

To preview the result of the view, click *®Preview on the toolbar. If the query statement is
correct, the Result and Message tabs will be opened.

The Result tab displays the data of the view as a grid and the Message tab displays the
message log.
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Oracle View Explain

To show the Explain Plan of the query, click E3Exp|ain on the toolbar. If the query
statement is correct, the Explain tab opens with the columns in the PLAN_TABLE.

Column Description
Operation Name of the internal operation performed in this step.
Object Name of the table or index.
Optimizer Current mode of the optimizer.

Cost of the operation as estimated by the optimizer's
query approach. Cost is not determined for table
access operations. The value of this column does not
Cost have any particular unit of measurement; it is merely
a weighted value used to compare costs of execution
plans. The value of this column is a function of the
CPU_COST and IO_COST columns.

Estimate by the query optimization approach of the

Cardinality .
number of rows accessed by the operation.
Bt Estimate by the query optimization approach of the
es
Y number of bytes accessed by the operation.
Partition Start Start partition of a range of accessed partitions.
. Step that has computed the pair of values of the
Partition ID
PARTITION_START and PARTITION_STOP columns.
Predicates used to locate rows in an access structure.
Access Predicates For example, start or stop predicates for an index
range scan.
Filter Predicates Predicates used to filter rows before producing them.
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Oracle View Viewer

View Viewer displays the view data as a grid. Data can be displayed in three modes:
Grid View, [~IForm View and Text/Blob/BFile View. See Data View for details.

The toolbars of View Viewer provides the following functions for managing data:

Commit

Make permanent all changes performed in the transaction.

Hint: The Commit button is visible only when Auto Commit is disabled under
Option Settings.

« Rollback
Undo work done in the current transaction.

Hint: The Rollback button is visible only when Auto Commit is disabled under
Option Settings.

e Export Data
Export data to TXT, DBF, HTML, SQL, RTF and more.

o Filter Data
Allow you to filter records by creating and applying filter criteria for the data grid.

o Edit TEXT/BLOB/BFile
Allow you to view and edit the content of TEXT, BLOB and BFile fields.
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File Edit View Window Help

.. Commit & Rollback | & Export Wizard | Filter Wizard | N
EMPLOYEEID _ JOB_ID MANAGER_ID DEPARTMENT_ID LOCATION_ID +
100 (OO 90 1
101 AD_VP 100 20 1
102 AD_VP 100 90 1
103 IT_PROG 102 60
104 IT_PROG 103 60 1
105 IT_PROG 103 60 1
106 IT_PROG 103 60 1
107 IT_PROG 103 60 1
108 FI_MGR 101 100 1
109 FI_ACCOUNT 108 100 1
110 FI_ACCOUNT 108 100 1
111 FI_ACCOUNT 108 100 1
112 FI_ACCOUNT 108 100 1
113 FI_ACCOUNT 108 100 1
114 PU_MAN 100 30 1
115 PU_CLERK 114 30 1
v
4 | _'|_I
I I P I - e w1 B e o
| SELECT * FROM (SELECT "NAVICAT_TABLE".*, ROWNU |Record 1 of 106 in page 1 A
4 J
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Oracle Functions/Procedures

A procedure or function is a schema object that consists of a set of SQL statements and other
PL/SQL constructs, grouped together, stored in the database, and run as a unit to solve a
specific problem or perform a set of related tasks.

Procedures and functions are identical except that functions always return a single value to
the caller, while procedures do not.

Just simply click ¥&to open an object pane for Function. A right-click displays the popup
menu or using the object pane toolbar, allowing you to create new, edit and delete the
selected function/procedure.

Create Function/Procedure
To create a new function/procedure

e Select anywhere on the object pane.

o Click the /eNew Function from the object pane toolbar.
or

e Right-click and select JeNew Function from the popup menu.

o Edit function/procedure properties on the appropriate tabs of the Function/Procedure
Designer.

Hint: To create new function/procedure you can also right-click the Function node of
the navigation pane and select the JeNew Function from the popup menu.

Edit Function/Procedure
To edit the existing function/procedure

e Select the function/procedure for editing in the navigation pane/object pane.

e Right-click and select the -fﬁDesign Function from the popup menu or simply
double-click the function/ procedure.
or

e Click the -fﬁDesign Function from the object pane toolbar.

o Edit function/procedure properties on the appropriate tabs of the Function/Procedure
Designer.
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Run Function/Procedure
To run a function/procedure in the navigation pane/object pane

e Select the function/procedure for executing in the navigation pane/object pane.
« Click the J#Execute Function from the object pane toolbar.
or
e Right-click and select fuExecute Function from the popup menu.
e View the returned data on the DBMS Output tab.

To run a function/procedure in the Function/Procedure Designer

o Create a new function/procedure or open the existing function/procedure.
« Click PRun.
e View the returned data on the DBMS Output tab.

Debug Function/Procedure
To debug a function/procedure in the object pane

e Select the function/procedure for debugging in the object pane.
e Right-click and select the Debug Function from the popup menu.
e Debug the function/procedure in the Debugger.

To debug a function/procedure in the Function/Procedure Designer

o Create a new function/procedure or open the existing function/procedure.
e Click Ef’HDebug.
o Debug the function/procedure in the Debugger.

Maintain Function/Procedure
To maintain a function/procedure

e Select the function/procedure for maintaining in the object pane.
e Right-click and select the Maintain from the popup menu.

o Compile

o Compile for Debug
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Delete Function/Procedure
To delete a function/procedure

o Select the function/procedure for deleting in the navigation pane/object pane.
e Right-click and select the JeDelete Function from the popup menu.
or
o Click the JeDelete Function from the object pane toolbar.
e Confirm deleting in the dialog window.

Achieve Function/Procedure Information
To achieve a function/procedure information

e Select the function/procedure in the navigation pane/object pane.

o Right-click the selected function/procedure and choose Object Information from the
popup menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Function Wizard

Click the /eNew Function from the object pane toolbar. The Function Wizard will pop up
and it allows you to create a procedure/function easily.

¢ Setting Routine Type

¢ Setting Parameters for Procedure/Function

e Setting Return Type for Function

You are allowed not to show the Function Wizard when create new procedure/function.

Hint: Once uncheck the Show wizard next time, you can go to Options to enable it.
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Setting Oracle Routine Type

Specify the Name of the routine.

Select the type of the routine: Procedure or Function
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Setting Parameters for Oracle Procedure/Function

Define the parameter(s) of the procedure/function. Set the parameter Name, Type, Mode
and Default Value under corresponding columns.
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Setting Return Type for Oracle Function

Select the Return Type from the list.

Note: Only function supports return type.
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Oracle Function/Procedure Designer

Function/Procedure Designer allows you to edit the existing function/procedure
definition and more.

o Editing Function/Procedure Definition

e Function/Procedure SQL Preview
e Viewing Function/Procedure Result

¢ Debugging Function/Procedure
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Editing Oracle Function/Procedure Definition

Edit the function/procedure definition under the Definition tab.

The Code Outline window displays information about the function/procedure including
parameter, code body, etc. To show the Code Outline window, simply choose View -> Code
Outline.

Note: Available only in Full Version.

Refresh the code outline.

Show the detail view of the code outline.

Turn mouse over highlight on or off.

Expand the selected item.

Collapse the selected item.

& F | F | %llo

Toggle sorting by position.

The SQL statements for creating procedures are CREATE PROCEDURE. In practice, it is best
to use a CREATE OR REPLACE statement. The general form of these statements follows.

CREATE OR REPLACE
PROCEDURE "" AS
BEGIN
-- routine body goes here, e.qg.
-- DBMS_OUTPUT.PUT_LINE('Navicat for Oracle');
END;

Hint: To customize the view of the editor and find out more features for sql editing, see Editor
View and More Features.
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Viewing Oracle Function/Procedure Result

To run the function/procedure click > Run on the toolbar. If the SQL statement is correct,
the statement will be executed and, if the statement is supposed to return data, the
Message and DBMS Output tabs open with the message log and data returned by the
function/procedure. If an error occurs while executing the function/procedure, execution
stops, the appropriate error message is displayed.

If the function/procedure requires input parameter, the Input Parameters box will popup.

Oracle Database Object Management 81



: ™ A
Navicat

Debugging Oracle Function/Procedure

To debug the function/procedure click ﬁDebug on the toolbar to launch the Oracle
Debugger.

You can add/remove breakpoints for debugging by clicking ®in the grey area beside each
statement.

Enter the Input Parameters if necessary.

CREATE OR REPLACE
PROCEDURE secure_dmil
15
BEGIN
@ IFTO_CHAR (SYSDATE, 'HH24:MI') MOT BETWEEN '08:00' AND
"18:00'
b OR TO_CHAR (S5YSDATE, 'DY') IN ("SAT', 'SUMN') THEN
7 [l RAISE_APPLICATION_ERROR (-20205,
B@ | 'Youmayonly make changes during normal office hours');

[Ea I S WUy N

9 r ENDIF;
10  EMD secure_dml;
1
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Oracle Database Links

Database link is a named schema object that describes a path from one database to another
and are implicitly used when a reference is made to a global object name in a distributed
database. After you have created a database link, you can use it to refer to tables and views
on the other database.

Just simply click £.-> patabase Link to open an object pane for Database Link. A
right-click displays the popup menu or using the object pane toolbar, allowing you to create
new and delete the selected database link.

Create Database Link
To create a new database link

e Select anywhere on the object pane.
e Click the =!New Database Link from the object pane toolbar.
or
e Right-click and select “2New Database Link from the popup menu.
o Edit database link properties on the appropriate tabs of the Database Link Designer.

Delete Database Link
To delete a database link

e Select the database link for deleting in the object pane.

e Right-click and select the =@Delete Database Link from the popup menu.
or

e Click the =8Delete Database Link from the object pane toolbar.

e Confirm deleting in the dialog window.

Achieve Database Link Information
To achieve a database link information

e Select the database link in the object pane.

e Right-click the selected database link and choose Object Information from the
popup menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Database Link Designer

Database Link Designer is the basic Navicat tool for working with database links. It allows
you to create new database link.

o Editing Database Link General
o Database Link SQL Preview
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Edit Oracle Database Link General

Service Name
Specify the service name of a remote database.

User Name
The user name used to connect to the remote database using a fixed user database link.

Password
The password for connecting to the remote database.

M Current user
With this option checked, a current user database link is created. The current user must be
a global user with a valid account on the remote database.

M shared

Fill in Authentication username and Authentication password when Shared option
is enabled.
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Oracle Indexes

Index provides a faster access path to table data. It is created using one or more columns of
a table to speed SQL statement execution on that table.

Just simply click £-> Index to open an object pane for Index. A right-click displays the

popup menu or using the object pane toolbar, allowing you to create new, edit and delete the
selected Index.

Create Index
To create a new index

e Select anywhere on the object pane.
o Click the ¥¥New Index from the object pane toolbar.
or
o Right-click and select ¥New Index from the popup menu.
o Edit index properties on the appropriate tabs of the Index Designer.

To create a new index with modification as one of the existing index

e Select the index for modifying in the object pane.

« Right-click and select the E'Design Index from the popup menu or simply
double-click the index.
or

o Click the ¥*Design Index from the object pane toolbar.

e Modify index properties on the appropriate tabs of the Index Designer.

« Click ¥save As.

Edit Index
To edit the existing index (manage its properties etc)

o Select the index for editing in the object pane.

« Right-click and select the E'Design Index from the popup menu or simply
double-click the index.
or

o Click the ¥*Design Index from the object pane toolbar.

o Edit index properties on the appropriate tabs of the Index Designer.
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To change the name of the index

e Select the index for editing in the object pane.
e Right-click and select the Rename from the popup menu.

Maintain Index
To maintain an index

e Select the index for maintaining in the object pane.
e Right-click and select the Maintain from the popup menu.
o Rebuild
o Make Unusable
o Coalesce
o Compute Statistics
o Monitoring Usage
o No Monitoring Usage

Delete Index
To delete an index

e Select the index for deleting in the object pane.

« Right-click and select the E&Delete Index from the popup menu.
or

o Click the ¥8Delete Index from the object pane toolbar.

e Confirm deleting in the dialog window.

Achieve Index Information
To achieve an index information

e Select the index in the object pane.

e Right-click the selected index and choose Object Information from the popup menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Index Designer

Index Designer is the basic Navicat tool for working with indexes. It allows you to create
new index and edit the existing index properties.

o Editing Index General

o Editing Advanced Index Properties

e Index SQL Preview
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Editing Oracle Index General

Type
The types of the index.

Normal
Normal Index (A B-tree index)

Unique
Unique Index (No two rows of a table have duplicate values in the key columns)

Bitmap
Bitmap Index (A bitmap for each key value)

Domain
Domain Index (Instances of an application-specific index)

Cluster
Cluster Index
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Oracle Normal Index

A normal index does not impose restrictions on the column values.

Type
Choose between Normal, Unique, Bitmap, Domain and Cluster.

Table schema
The schema that contains the index.

Table name
The table name.

Fields
Use the Name dropdown list to select the field name and Descend dropdown list to define
the order of the index (ASC or DESC).
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Oracle Unique Index

A unique index indicates that no two rows of a table have duplicate values in the key
columns.

Type
Choose between Normal, Unique, Bitmap, Domain and Cluster.

Table schema
The schema that contains the index.

Table name
The table name.

Fields
Use the Name dropdown list to select the field name and Descend dropdown list to define
the order of the index (ASC or DESC).
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Oracle Bitmap Index

A bitmap index created with a bitmap for each distinct key, rather than indexing each row
separately. Bitmap indexes store the rowids associated with a key value as a bitmap. Each bit
in the bitmap corresponds to a possible rowid.

Type
Choose between Normal, Unique, Bitmap, Domain and Cluster.

Table schema
The schema that contains the index.

Table name
The table name.

Fields
Use the Name dropdown list to select the field name and Descend dropdown list to define
the order of the index (ASC or DESC).

 Bitmap Join Index

In addition to a bitmap index on a single table, you can create a bitmap join index, which is
a bitmap index for the join of two or more tables. A bitmap join index is a space efficient way
of reducing the volume of data that must be joined by performing restrictions in advance.

Fields
Use the Schema, Table and Name dropdown lists to select the schema, table and field
name and Descend dropdown list to define the order of the index (ASC or DESC).

Bitmap Join
Use the InnerSchema, InnerTable, InnerField, OuterSchema, OuterTable and
OuterField dropdown lists to select joined schemas, tables and fields respectively.
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Oracle Domain Index

A domain index is an index designed for a specialized domain, such as spatial or image
processing. Users can build a domain index of a given type after the designer creates the
indextype.

Type
Choose between Normal, Unique, Bitmap, Domain and Cluster.

Table schema
The schema that contains the index.

Table name
The table name.

Column
The column which the index is based.

Index Type

Schema
The schema of the indextype.

Type
Select the created or built-in indextypes.

Parameters

Information about the path table and about the secondary indexes corresponding to the
components of XMLIndex. The maximum length of the parameter string is 1000
characters.
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Oracle Cluster Index

A cluster index is an index designed for a cluster.

Type
Choose between Normal, Unique, Bitmap, Domain and Cluster.

Table schema
The schema that contains the index.

Cluster name
The name of the cluster.
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Editing Advanced Oracle Index Properties

MUnusable
An unusable index must be rebuilt, or dropped and re-created, before it can be used.

Tablespace
The name of the tablespace to hold the index.

M Compress
To enable key compression, which eliminates repeated occurrence of key column values and

may substantially reduce storage.
Note: No compression for Bitmap Indexes.

¥ Parallel
The creation of the index will be parallelized.

M Reverse
To store the bytes of the index block in reverse order, excluding the rowid.

Logging

Logging
The creation of the index will be logged in the redo log file.

No Logging
The creation of the index will be not logged in the redo log file.

Visibility

Visible
Specify the index is visible to the optimizer.

Invisible
Specify the index is invisible to the optimizer.

Create / Rebuild Option

¥ Online
To indicate that DML operations on the table will be allowed during creation of the index.
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MNo Sort
To indicate to the database that the rows are already stored in the database in ascending
order, so that Oracle Database does not have to sort the rows when creating the index.

Physical Attributes
Set the physical attributes of an index.
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Oracle Java

Java is an object-oriented programming language efficient for application-level programs.
You can write and load applications within the database.

Just simply click £-> Javato open an object pane for Java. A right-click displays the popup

menu or using the object pane toolbar, allowing you to create new, edit and delete the
selected Java.

Create Java
To create a new Java

e Select anywhere on the object pane.
o Click the TeNew Java from the object pane toolbar.
or
« Right-click and select TeNew Java from the popup menu.
e Edit Java properties on the appropriate tabs of the Java Designer.

To create a new Java with modification as one of the existing Java

e Select the Java for modifying in the object pane.

« Right-click and select the ©’Design Java from the popup menu or simply
double-click the Java.
or

o Click the ©’Design Java from the object pane toolbar.

e Modify Java properties on the appropriate tabs of the Java Designer.

« Click ¥save As.

Edit Java
To edit the existing Java(manage its general, advanced etc)

e Select the Java for editing in the object pane.

« Right-click and select the ©’Design Java from the popup menu or simply
double-click the Java.
or

« Click the ©Design Java from the object pane toolbar.

o Edit Java properties on the appropriate tabs of the Java Designer.
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Maintain Java
To maintain a Java

e Select the Java for maintaining in the object pane.

e Right-click and select the Maintain from the popup menu.
o Compile or Resolve
o Set AuthID Current User
o Set AuthID Definer

Delete Java
To delete a Java

e Select the Java for deleting in the object pane.

o Right-click and select the TeDelete Java from the popup menu.
or

« Click the TeDelete Java from the object pane toolbar.

e Confirm deleting in the dialog window.

Achieve Java Information
To achieve a Java information

e Select the Java in the object pane.

e Right-click the selected Java and choose Object Information from the popup menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Java Designer

Java Designer is the basic Navicat tool for working with Java. It allows you to create new
Java and edit the existing Java properties.

o Editing Java General

o Setting Advanced Java Properties

e Java SQL Preview
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Editing Oracle Java General

You can create a Java source, class, or resource using the Java Designer.

e Java Source
e Java Class
e Java Resource
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Oracle Java Source

Type
Choose between Java Source, Java Class and Java Resource.

Create from

BFile
Select the Directory and type the Server Filename.

Load from file
Browse the File Path of Java source file.

Plain source
Type the source code in the Source box.
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Oracle Java Class

Type
Choose between Java Source, Java Class and Java Resource.

Create from

BFile
Select the Directory and type the Server Filename.

Load from file
Browse the File Path of the Java class file.
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Oracle Java Resource

Type
Choose between Java Source, Java Class and Java Resource.

Create from

BFile
Select the Directory and type the Server Filename.

Load from file
Browse the File Path of the Java resource file.
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Setting Advanced Oracle Java Properties

Invoker Rights

Select CURRENT_USER to indicate that the methods of the class execute with the privileges
of CURRENT_USER or DEFINER indicates that the methods of the class execute with the
privileges of the owner of the schema in which the class resides, and that external names
resolve in the schema where the class resides.

Resolver
Specify a mapping of the fully qualified Java name to a Java schema object.

¥ Compile or Resolve
Check this to specify that Oracle Database should attempt to resolve the Java schema object

that is created if this statement succeeds.

MNo Force

Check this to roll back the results of the CREATE command of Java if you have enabled
Compile or Resolve and the resolution or compilation fails. If you do not specify this option,
then Oracle Database takes no action if the resolution or compilation fails, and the created
schema object remains.
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Oracle Materialized Views

Materialized view is a schema object that can be used to summarize, compute, replicate, and
distribute data.

Just simply click £-> Materialized View to open an object pane for Materialized View.
A right-click displays the popup menu or using the object pane toolbar, allowing you to create
new, edit and delete the selected materialized view.

Create Materialized View
To create a new materialized view

e Select anywhere on the object pane.

e Click the =ZNew Materialized View from the object pane toolbar.
or

e Right-click and select “2New Materialized View from the popup menu.

o Edit materialized view properties on the appropriate tabs of the Materialized View
Designer.

To create a new materialized view with modification as one of the existing materialized view

o Select the materialized view for modifying in the object pane.

e Right-click and select the ZZDesign Materialized View from the popup menu.
or

e Click the =ZDesign Materialized View from the object pane toolbar.

o Modify materialized view properties on the appropriate tabs of the Materialized View
Designer.

« Click ¥save As.

To create a new materialized view with loading from a SQL file

e Select anywhere on the object pane.
e Click the =2New Materialized View from the object pane toolbar.
or
e Right-click and select “2New Materialized View from the popup menu.
e Click ©“Load.
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Edit Materialized View
To edit the existing materialized view (manage its properties etc)

o Select the materialized view for editing in the object pane.

e Right-click and select the =“Design Materialized View from the popup menu.
or

e Click the =’Design Materialized View from the object pane toolbar.

o Edit materialized view properties on the appropriate tabs of the Materialized View
Designer.

Open Materialized View
To open a materialized view (manage materialized view data)

o Select the materialized view for opening in the object pane.

e Right-click and select the “=Open Materialized View from the popup menu or
simply double-click the materialized view.
or

e Click the E=ZOpen Materialized View from the object pane toolbar.

Maintain Materialized View
To maintain a materialized view

e Select the materialized view for maintaining in the object pane.
e Right-click and select the Maintain from the popup menu.

o Enable Row Movement

o Shrink

o Compile

o Force Refresh

Delete Materialized View
To delete a materialized view

o Select the materialized view for deleting in the object pane.

e Right-click and select the ==Delete Materialized View from the popup menu.
or

e Click the =@Delete Materialized View from the object pane toolbar.

e Confirm deleting in the dialog window.
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Achieve Materialized View Information

To achieve a materialized view information (Materialized View Owner, Compile State and
DDL, etc)

e Select the materialized view in the object pane.

o Right-click the selected materialized view and choose Object Information from the
popup menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Materialized View Designer

Materialized View Designer is the basic Navicat tool for working with materialized views.
It allows you to create new materialized view and edit the existing materialized view
properties.

¢ Working with Materialized View Builder
¢ Editing Materialized View SQL Definition
o Setting Advanced Materialized View Properties

o Editing Materialized View Comment
o Materialized View SQL Preview
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Working with Oracle Materialized View Builder (Available only in Full

Version)

View Builder allows you to build views visually. It allows you to create and edit materialized
views without knowledge of SQL. See Query Builder for details.
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Editing Oracle Materialized View SQL Definition

The Definition tab allows you to edit the view definition as SQL statement (SELECT
statement it implements).

Example:
SELECT
HR.EMPLOYEES.EMPLOYEE_ID
FROM
HR.EMPLOYEES

Hint: To customize the view of the editor and find out more features for sql editing, see Editor
View and More Features.
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Setting Advanced Oracle Materialized View Properties

Refresh Options
When

Demand
The materialized view will be refreshed on demand by calling one of the three
DBMS_MVIEW refresh procedures.

Commit
A fast refresh is to occur whenever the database commits a transaction that
operates on a master table of the materialized view.

Automatic
The database automatically refresh the materialized view with the automatic
refresh time.

Never
The materialized view will not be refreshed with any Oracle Database refresh
mechanism or packaged procedure.

Method

FORCE
When a refresh occurs, Oracle Database will perform a fast refresh if one is possible
or a complete refresh if fast refresh is not possible.

FAST
A incremental refresh method, which performs the refresh according to the changes
that have occurred to the master tables.

COMPLETE
A complete refresh method, which is implemented by executing the defining query
of the materialized view.

Start On
A datetime expression for the first automatic refresh time.

Oracle Database Object Management 111



: ™ &
Navicat ~

Next
A datetime expression for calculating the interval between automatic refreshes.

Note: To edit the datetime, just simply click ... and choose / enter the desired data.
Type

Primary Key
A primary key materialized view. This is the default.

Row ID
A rowid materialized view.

Rollback Segment

M Master
The remote rollback segment is used at the remote master site for the individual
materialized view.

 Local
The remote rollback segment is used for the local refresh group that contains the
materialized view. This is the default.

Constraints

Enforced
Oracle Database use enforced constraints during the refresh operation.

Trusted

Oracle Database use dimension and constraint information that has been declared
trustworthy by the database administrator but that has not been validated by the
database.

Create Options

MNo Index
Check this to suppress the creation of the default index.
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Build Type

Immediate
The materialized view is to be populated immediately. This is the default.

Deferred
The materialized view is to be populated by the next refresh operation.

Prebuilt
To register an existing table as a preinitialized materialized view.

Materialized View Options
Reduced Precision

With

To authorize the loss of precision that will result if the precision of the table or
materialized view columns do not exactly match the precision returned by
subquery.

Without

To require that the precision of the table or materialized view columns match
exactly the precision returned by subquery, or the create operation will fail. This is
the default.

Compress
Data segments are compressed to reduce disk and memory use.

Parallel

Choose NOPARALLEL for serial execution or PARALLEL if you want Oracle to select a
degree of parallelism equal to the number of CPUs available on all participating instances
times the value of the PARALLEL_THREADS_PER_CPU initialization parameter.

With Degree
Set the default degree of parallelism for queries and DML on the materialized view after
creation.

Logging

Choose LOGGING for logging the creation of Materialized view in the redo log file.
Choose NOLOGGING for no logging.
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Tablespace
Choose the tablespace in which the materialized view is to be created.

Physical Attributes
Set the physical attributes of the materialized view.

M Enable Cache
The blocks retrieved for the table are placed at the most recently used end of the least
recently used (LRU) list in the buffer cache when a full table scan is performed.

M For Update

Check this to allow a subquery, primary key, object, or rowid materialized view to be
updated. When used in conjunction with Advanced Replication, these updates will be
propagated to the master.

M Enable Query Rewrite
The materialized view is used for query rewrite.

Using Index Clause

Tablespace
Choose the tablespace of the index.

Physical Attributes

Set the physical attributes for the default index Oracle Database uses to maintain the
materialized view data.
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Oracle Materialized View Preview

To preview the result of the view, click =éPreview on the toolbar. If the query statement is
correct, the Result and Message tabs will be opened.

The Result tab displays the data of the view as a grid and the Message tab displays the
message log.
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Oracle Materialized View Explain

To show the Explain Plan of the query, click E3Exp|ain on the toolbar. If the query
statement is correct, the Explain tab opens with the columns in the PLAN_TABLE.

Column Description
) Name of the internal operation performed in this step.
Operation ]
In the first row generated for a statement.
Object Name of the table or index.
Optimizer Current mode of the optimizer.
Cost of the operation as estimated by the optimizer's
query approach. Cost is not determined for table
access operations. The value of this column does not
Cost have any particular unit of measurement; it is merely
a weighted value used to compare costs of execution
plans. The value of this column is a function of the
CPU_COST and IO_COST columns.
o Estimate by the query optimization approach of the
Cardinality .
number of rows accessed by the operation.
Bytes Estimate by the query optimization approach of the
number of bytes accessed by the operation.
Partition Start Start partition of a range of accessed partitions.
. Step that has computed the pair of values of the
Partition ID
PARTITION_START and PARTITION_STOP columns.
Predicates used to locate rows in an access structure.
Access Predicates For example, start or stop predicates for an index
range scan.
Filter Predicates Predicates used to filter rows before producing them.
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Oracle Materialized View Logs

Materialized view log is a schema object that records changes to a master table's data so that
a Materialized View defined on the master table can be refreshed incrementally.

Just simply click £-> Materialized View Log to open an object pane for Materialized
View Log. A right-click displays the popup menu or using the object pane toolbar, allowing
you to create new, edit and delete the selected materialized view log.

Create Materialized View Log
To create a new materialized view log

e Select anywhere on the object pane.

e C(lick the "==New Materialized View Log from the object pane toolbar.
or

e Right-click and select "==New Materialized View Log from the popup menu.

o Edit materialized view log properties on the appropriate tabs of the Materialized View
Log Designer.

To create a new materialized view log with modification as one of the existing materialized
view log

e Select the materialized view log for modifying in the object pane.

e Right-click and select the EZDesign Materialized View Log from the popup menu or
simply double-click the materialized view log.
or

e Click the =Design Materialized View Log from the object pane toolbar.

o Modify materialized view log properties on the appropriate tabs of the Materialized
View Log Designer.

« Click ksave As.
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Edit Materialized View Log
To edit the existing materialized view log (manage its general, advance, etc)

o Select the materialized view log for editing in the object pane.

e Right-click and select the =EDesign Materialized View Log from the popup menu or
simply double-click the materialized view log.
or

o C(Click the "=EDesign Materialized View Log from the object pane toolbar.

o Edit materialized view log properties on the appropriate tabs of the Materialized View
Log Designer.

Open Materialized View Log Table
To open a materialized view log table (manage materialized view log data)

o Select the materialized view log table for opening in the object pane.

¢ Right-click and select the Z==Open Materialized View Log Table from the popup
menu
or

e Click the E=Open Materialized View Log Table from the object pane toolbar.

Maintain Materialized View Log
To maintain a materialized view log

o Select the materialized view log table for maintaining in the object pane.
e Right-click and select the Maintain from the popup menu.

o Enable Row Movement

o Disable Row Movement

o Shrink Space

Delete Materialized View Log
To delete a materialized view log

o Select the materialized view log for deleting in the object pane.

e Right-click and select the "=Delete Materialized View Log from the popup menu.
or

e Click the '=mDelete Materialized View Log from the object pane toolbar.

e Confirm deleting in the dialog window.
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Achieve Materialized View Log Information
To achieve a materialized view log information

e Select the materialized view log in the object pane.

o Right-click the selected materialized view log and choose Object Information from
the popup menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Materialized View Log Designer

Materialized View Log Designer is the basic Navicat tool for working with materialized
view logs. It allows you to create new materialized view log and edit the existing materialized
view log definition.

¢ Editing Materialized View Log General

o Materialized View Log SQL Preview
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Editing Oracle Materialized View Log General

Edit the materialized view log general properties under the General tab.

Table
The table of the materialized view log.

Tablespace
The tablespace of the materialized view log.

Logging
To specify either LOGGING or NOLOGGING to establish the logging characteristics for the
materialized view log.

Cache

CACHE
The blocks retrieved for this log are placed at the most recently used end of the least
recently used (LRU) list in the buffer cache when a full table scan is performed.

NOCACHE
The blocks are placed at the least recently used end of the LRU list. This is the default.

New Values

INCLUDING
To save both new and old values in the log.

EXCLUDING
To disable the recording of new values in the log.

M pParallel With Degree
To determine the number of parallel threads used in the parallel operation.

Physical Attributes
Set the physical attributes of a materialized view log.
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With

¥ Object ID
The system-generated or user-defined object identifier of every modified row should be
recorded in the materialized view log.

M Primary Key
The primary key of all rows changed should be recorded in the materialized view log.

M Row ID
The rowid of all rows changed should be recorded in the materialized view log.

¥ Sequence
A sequence value providing additional ordering information should be recorded in the
materialized view log.

Fields

Choose the fields whose values you want to be recorded in the materialized view log for
all rows that are changed.
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Oracle Packages

Packages are encapsulated collections of related procedures, stored functions, and other
program objects stored together in the database. Package bodies, specified subsequently,
defines these objects. An package consists of two parts: a specification and a body.

Just simply click 2 Package to open an object pane for Package. A right-click displays

the popup menu or using the object pane toolbar, allowing you to create new, edit and delete
the selected package.

Create Package (Package Specification)
To create a new package

e Select anywhere on the object pane.
o Click the ENew Package from the object pane toolbar.
or
e Right-click and select ENew Package from the popup menu.
o Edit package properties on the appropriate tabs of the Package Designer.

Edit Package
To edit the existing package (manage its definition etc)

e Select the package for editing in the object pane.

o Right-click and select the ijesign Package from the popup menu or simply
double-click the package.
or

e Click the jﬁDesign Package from the object pane toolbar.

o Edit package properties on the appropriate tabs of the Package Designer.

Delete Package
To delete a package

e Select the package for deleting in the object pane.

e Right-click and select the fDelete Package from the popup menu.
or

o Click the fDelete Package from the object pane toolbar.

e Confirm deleting in the dialog window.
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Create Package Body (Package Body)
To create a new package body

o Select the package for modifying in the object pane.
e Right-click and select ENew Package Body from the popup menu.
o Edit package body properties on the appropriate tabs of the Package Body Designer.

Edit Package Body
To edit the existing package body (manage its definition etc)

e Select the package for editing in the object pane.
e Right-click and select the @Design Package Body from the popup menu.
o Edit package body properties on the appropriate tabs of the Package Body Designer.

Delete Package Body
To delete a package body

e Select the package for deleting in the object pane.
e Right-click and select the [Epelete Package Body from the popup menu.
e Confirm deleting in the dialog window.

Run Package
To run a package in the object pane

o Select the package for executing in the object pane.
« Click the FExecute Package from the object pane toolbar.
or
e Right-click and select #Execute Package from the popup menu.
e View the returned data on the DBMS Output tab.

To run a package in the Package Designer

o Create a new package/open the existing package.
« Click PRun.
e View the returned data on the DBMS Output tab.
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Debug Package
To debug a package

e Select the package for debugging in the object pane.
e Right-click and select the Debug Package from the popup menu.
o Debug the package in the Debugger.

To debug a package in the Package Designer

o Create a new package/open the existing package.
e Click ﬁDebug.
e Debug the package in the Debugger.

Maintain Package
To maintain a package

e Select the package for maintaining in the object pane.

e Right-click and select the Maintain from the popup menu.
o Compile
o Compile Debug

Achieve Package Information
To achieve a package information

e Select the package in the object pane.

e Right-click the selected package and choose Object Information from the popup
menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Package Designer

Package Designer is the basic Navicat tool for working with packages. It allows you to
create new package and edit the existing package definition.

¢ Editing Package Definition

o Package SQL Preview
e Viewing Package Result

¢ Debugging Package

After saving the package, you can edit the Package Body. Just click |§Design Package
Body to open the Package Body Designer.
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Editing Oracle Package Definition

Edit the package definition under the Definition tab.

The Code Outline window displays information about the package including function,
procedure, parameter, code body, etc. To show the Code Outline window, simply choose
View -> Code Outline.

Note: Available only in Full Version.

Refresh the code outline.

Show the detail view of the code outline.

Turn mouse over highlight on or off.

Expand the selected item.

Collapse the selected item.

& F | F | %llo

Toggle sorting by position.

The SQL statements for creating packages are CREATE PACKAGE. In practice, it is best to use
a CREATE OR REPLACE statement. The general form of these statements follows.

CREATE OR REPLACE
PACKAGE /*PACKAGE NAME*/ AS

/* TODO enter package declarations (types, exceptions, methods etc) here */
end;

Hint: To customize the view of the editor and find out more features for sql editing, see Editor
View and More Features.
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Oracle Package Body Designer

Package Body Designer is the basic Navicat tool for working with package bodies. It allows
you to create new package body and edit the existing package body definition.

o Editing Package Body Definition

o Package Body SQL Preview
e Viewing Package Result

« Debugging Package

To edit the Package Specification, click j‘éDesign Package Specification to open the
Package Designer.
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Editing Oracle Package Body Definition

Edit the package body definition under the Definition tab.

The Code Outline window displays information about the package body including function,
procedure, parameter, code body, etc. To show the Code Outline window, simply choose
View -> Code Outline.

Note: Available only in Full Version.

Refresh the code outline.

Show the detail view of the code outline.

Turn mouse over highlight on or off.

Expand the selected item.

Collapse the selected item.

& F | F | %llo

Toggle sorting by position.

The SQL statements for creating procedures are CREATE PACKAGE BODY. In practice, it is
best to use a CREATE OR REPLACE statement. The general form of these statements follows.

CREATE OR REPLACE
PACKAGE BODY /*PACKAGE NAME*/ AS

END;

Hint: To customize the view of the editor and find out more features for sql editing, see Editor
View and More Features.
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Viewing Oracle Package Result

To run the package click [»Run on the toolbar. If the SQL statement is correct, the
statement will be executed and, if the statement is supposed to return data, the Message
and DBMS Output tabs open with the message log and data returned by the package. If an
error occurs while executing the package, execution stops, the appropriate error message is
displayed.

Select the function/procedure and enter the parameter(s) if the function/procedure has
input parameter(s).
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Debugging Oracle Package

To debug the package click ﬁDebug on the toolbar to launch the Oracle Debugger.

You can add/remove breakpoints for debugging by clicking ®in the grey area beside each
statement.

Select the function/procedure and enter the parameter(s) if the function/procedure has

input parameter(s).

1 CREATE OR REPLACE

2 PACKAGE emp_mgmt AS

3 FUMCTION hire (last_name VARCHARZ, job_id VARCHARZ,
diT manager_id NUMEER, salary NUMBER,

5 commission_pct NUMBER, department_id NUMBER)

(3] RETURN NUMEBER;

7 FUMCTION create_deptidepartment_id NUMBER, location_id

MUMEER)
8@ RETURN NUMBER;
9 PROCEDURE remove_emp({employee_id NUMBER);
10 PROCEDURE remove_dept{department_id MUMBER);
11 PROCEDURE increase_sal{employee_id MUMBER, salary_incr
NUMBER);

12 PROCEDURE increase_commi{employee_id NUMBER,
comm_incr NUMBER);

13 no_comm EXCEPTION;

14 no_sal EXCEPTION;

15 EMD emp_mgmt;

16
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Oracle Sequences

Sequence involves creating and initializing a new special single-row table. It is usually used
to generate unique identifiers for rows of a table.

Just simply click s> Sequence to open an object pane for Sequence. A right-click

displays the popup menu or using the object pane toolbar, allowing you to create new, edit
and delete the selected sequence.

Create Sequence
To create a new sequence

e Select anywhere on the object pane.
o Click the "“4New Sequence from the object pane toolbar.
or
e Right-click and select 24 New Sequence from the popup menu.
o Edit sequence properties on the appropriate tabs of the Sequence Designer.

To create a new sequence with modification as one of the existing sequence

e Select the sequence for modifying in the object pane.
« Right-click and select the 2’Design Sequence from the popup menu or simply
double-click the sequence.
or
« Click the '2*Design Sequence from the object pane toolbar.
e Modify sequence properties on the appropriate tabs of the Sequence Designer.
« Click %save As.

Edit Sequence
To edit the existing sequence(manage its general etc)

e Select the sequence for editing in the object pane.

o Right-click and select the 1%;‘Design Sequence from the popup menu or simply
double-click the sequence.
or

e Click the 1%9“Design Sequence from the object pane toolbar.

o Edit sequence properties on the appropriate tabs of the Sequence Designer.
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Delete Sequence
To delete a sequence

e Select the sequence for deleting in the object pane.

e Right-click and select the 24Delete Sequence from the popup menu.
or

o Click the “éDelete Sequence from the object pane toolbar.

e Confirm deleting in the dialog window.

Achieve Sequence Information
To achieve a sequence information

e Select the sequence in the object pane.

e Right-click the selected sequence and choose Object Information from the popup
menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Sequence Designer

Sequence Designer is the basic Navicat tool for working with sequence. It allows you to
create new sequence and edit the existing sequence properties.

o Editing Sequence General

e Sequence SQL Preview
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Editing Oracle Sequence General

Increment

To specify which value is added to the current sequence value to create a new value. A
positive value will make an ascending sequence, a negative one a descending sequence. The
default value is 1.

Start with
To specify the first sequence number to be generated.

Minimum
The minimum value a sequence can generate.

Maximum
The maximum value for the sequence.

Cache

To specify how many values of the sequence the database preallocates and keeps in memory
for faster access. The minimum value for this parameter is 2. (The database caches 20
sequence numbers by default.)

MNo Cache
This option indicates that values of the sequence are not preallocated.

M cycled

This option allows the sequence continues to generate values after reaching either its
maximum or minimum value. After an ascending sequence reaches its maximum value, it
generates its minimum value. After a descending sequence reaches its minimum, it
generates its maximum value.

¥ order
This option guarantees that sequence numbers are generated in order of request.
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Oracle Synonyms

Synonym is an alias for any table, view, materialized view, synonym, procedure, function,
package, type, Java class schema object, user-defined object type, or another synonym.
Because a synonym is simply an alias, it requires no storage other than its definition in the
data dictionary.

Just simply click . - Synonym to open an object pane for Synonym. A right-click displays
the popup menu or using the object pane toolbar, allowing you to create new, edit and delete
the selected synonym.

Create Synonym
To create a new synonym

e Select anywhere on the object pane.
« Click the %:New Synonym from the object pane toolbar.
or
« Right-click and select ®:New Synonym from the popup menu.
e Edit synonym properties on the appropriate tabs of the Synonym Designer.

To create a new synonym with modification as one of the existing synonym

e Select the synonym for modifying in the object pane.

« Right-click and select the ¥ Design Synonym from the popup menu or simply
double-click the synonym.
or

« Click the ¥Design Synonym from the object pane toolbar.

e Modify synonym properties on the appropriate tabs of the Synonym Designer.

« Click ksave As.
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Edit Synonym
To edit the existing synonym(manage its general etc)

e Select the synonym for editing in the object pane.

« Right-click and select the ¥Design Synonym from the popup menu or simply
double-click the synonym.
or

« Click the ¥ Design Synonym from the object pane toolbar.

o Edit synonym properties on the appropriate tabs of the Synonym Designer.

To change the name of the synonym

e Select the synonym for editing in the object pane.
e Right-click and select the Rename from the popup menu.

Delete Synonym
To delete a synonym

e Select the synonym for deleting in the object pane.

« Right-click and select the %Delete Synonym from the popup menu.
or

e Click the %Delete Synonym from the object pane toolbar.

e Confirm deleting in the dialog window.

Achieve Synonym Information
To achieve a synonym information

e Select the synonym in the object pane.

e Right-click the selected synonym and choose Object Information from the popup
menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Synonym Designer

Synonym Designer is the basic Navicat tool for working with synonym. It allows you to
create new synonym and edit the existing synonym properties.

¢ Editing Synonym General

e Synonym SQL Preview
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Editing Oracle Synonym General

Object DataBase Link
A complete or partial database link to create a synonym for a schema object on a remote

database where the object is located.

Object Schema
The schema in which the object resides.

Object Type
The object type.

Object
The object for which the synonym is created.
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Oracle Triggers

Triggers are similar to procedures. A trigger stored in the database can include SQL and
PL/SQL or Java statements to run as a unit and can invoke procedures.

See Triggers for details.

Just simply click & > Trigger to open an object pane for Trigger. A right-click displays the
popup menu or using the object pane toolbar, allowing you to create new, edit and delete the
selected trigger.

Create Trigger
To create a new trigger

e Select anywhere on the object pane.
« Click the "sNew Trigger from the object pane toolbar.
or
e Right-click and select /éNew Trigger from the popup menu.
o Edit trigger properties on the appropriate tabs of the Trigger Designer.

To create a new trigger with modification as one of the existing trigger

e Select the trigger for modifying in the object pane.

o Right-click and select the ':?"’Design Trigger from the popup menu or simply
double-click the trigger.
or

e Click the E"‘Design Trigger from the object pane toolbar.

e Modify trigger properties on the appropriate tabs of the Trigger Designer.

« Click kdsave As.
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Edit Trigger
To edit the existing trigger (manage its general, advance, etc)

o Select the trigger for editing in the object pane.

o Right-click and select the ';?Design Trigger from the popup menu or simply
double-click the trigger.
or

e Click the ':?Design Trigger from the object pane toolbar.

o Edit trigger properties on the appropriate tabs of the Trigger Designer.

To change the name of the trigger

e Select the trigger for editing in the object pane.
e Right-click and select the Rename from the popup menu.

Maintain Trigger
To maintain a trigger

e Select the trigger for maintaining in the object pane.
e Right-click and select the Maintain from the popup menu.

o Enable
o Disable
o Compile

o Compile for Debug
Delete Trigger
To delete a trigger

e Select the trigger for deleting in the object pane.

e Right-click and select the léDelete Trigger from the popup menu.
or

« Click the 'éDelete Trigger from the object pane toolbar.

e Confirm deleting in the dialog window.
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Achieve Trigger Information
To achieve a trigger information

o Select the trigger in the object pane.

e Right-click the selected trigger and choose Object Information from the popup
menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Trigger Designer

Trigger Designer is the basic Navicat tool for working with triggers. It allows you to create
new trigger and edit the existing trigger definition.

o Editing Trigger General

o Setting Advanced Trigger Properties
o Editing Trigger Definition

e Trigger SQL Preview
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Editing Oracle Trigger General

TABLE
To define the trigger on the selected table.

VIEW
To define the trigger on the selected view.

SCHEMA
To define the trigger on the selected schema.

DATABASE
To define the trigger on the entire database.

Oracle Database Object Management 144



: ™ A
Navicat

Oracle Table Trigger

Trigger Type
Choose the type of trigger: TABLE, VIEW, SCHEMA and DATABASE

¥ Enable
An enabled trigger runs its trigger action if a triggering statement is issued and the trigger
restriction (if any) evaluates to true.

Table Schema
The table schema of the trigger.

Table name
The table you wish to create the trigger.

F Compound
A compound trigger is a single trigger on a table that allows you to specify actions for each
of four timing points:

Timing Point Section
) ) BEFORE
Before the triggering statement executes
STATEMENT
After the triggering statement executes AFTER STATEMENT

Before each row that the triggering statement affects BEFORE EACH ROW
After each row that the triggering statement affects = AFTER EACH ROW
Note: Support from Oracle 11g or later and you can edit the SQL in Trigger Definition.

Fire
When defining a trigger, you can specify the trigger timing - whether the trigger action is to
be run BEFORE or AFTER the triggering statement.

For Each

Oracle Database fires a ROW trigger once for each row that is affected by the triggering
statement and fires a STATEMENT trigger only once when the triggering statement is issued
if the optional trigger constraint is met.

When
To specify the trigger condition, which is a SQL condition that must be satisfied for the
database to fire the trigger.
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On Event
It indicates the kind of statement that activates the trigger.

VInsert
The trigger is activated whenever adding a row to a table or adds an element to a nested
table.

MDelete
The trigger is activated whenever removing a row from the table or removes an element
from a nested table.

M update
The trigger is activated whenever changing a value in one of the fields selected in
Update Of Fields.
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Oracle View Trigger

Trigger Type
Choose the type of trigger: TABLE, VIEW, SCHEMA and DATABASE

¥ Enable
An enabled trigger runs its trigger action if a triggering statement is issued and the trigger
restriction (if any) evaluates to true.

Table Schema
The table schema of the trigger.

Table name
The table you wish to create the trigger.

M Nested Table Field
To select the nested table field.

M Compound
To specify the Instead Of Trigger.

Note: Support from Oracle 11g or later and you can edit the SQL in Trigger Definition.

On Event
It indicates the kind of statement that activates the trigger.

MInsert
The trigger is activated whenever adding a row to a table or adds an element to a nested
table.

MDelete
The trigger is activated whenever removing a row from the table or removes an element
from a nested table.

M update
The trigger is activated whenever changing a value in a row.
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Oracle Schema Trigger

Trigger Type
Choose the type of trigger: TABLE, VIEW, SCHEMA and DATABASE

¥ Enable
An enabled trigger runs its trigger action if a triggering statement is issued and the trigger
restriction (if any) evaluates to true.

Table Schema
The table schema of the trigger.

Fire
When defining a trigger, you can specify the trigger timing - whether the trigger action is to
be run BEFORE or AFTER the triggering statement.

When
To specify the trigger condition, which is a SQL condition that must be satisfied for the
database to fire the trigger.

Events
The kind of statement that activates the trigger.
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Oracle Database Trigger

Trigger Type
Choose the type of trigger: TABLE, VIEW, SCHEMA and DATABASE

¥ Enable
An enabled trigger runs its trigger action if a triggering statement is issued and the trigger
restriction (if any) evaluates to true.

Fire
When defining a trigger, you can specify the trigger timing - whether the trigger action is to
be run BEFORE or AFTER the triggering statement.

When
To specify the trigger condition, which is a SQL condition that must be satisfied for the
database to fire the trigger.

Events
The kind of statement that activates the trigger.

Oracle Database Object Management 149



: ™ &
Navicat ~

Setting Advanced Oracle Trigger Properties

The Advanced tab is available when the trigger type is TABLE or VIEW.

Referencing Old
Correlation names of the old nested table.

Referencing New
Correlation names of the new nested table.

Referencing Parent
Correlation names of the parent table.

Follows
To indicate that the trigger should fire after the specified triggers.

Use the Schema dropdown list to select the schema name and Trigger dropdown list to
select the trigger.

To add triggers, just simply press plus button. To remove triggers, select a trigger and press
the cross button.

Note: Support from Oracle 11g or later.
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Editing Oracle Trigger Definition

The Definition tab allows you to edit valid SQL or procedure statements in the trigger
definition inside BEGIN and END.
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Oracle Types

Type is an user-defined datatype that model the structure and behavior of the data in an
application. An object type consists of two parts: a specification and a body. The type body
always depends on its type specification. A collection type is a named varying array (varray)
or a nested table type.

Just simply click s> Type to open an object pane for Type. A right-click displays the
popup menu or using the object pane toolbar, allowing you to create new, edit and delete the
selected type.

Create Object Type (Object Type Specification)
To create a new object type

e Select anywhere on the object pane.
e Click the ":New Object Type from the object pane toolbar.
or
e Right-click and select #:New Object Type from the popup menu.
o Edit object type properties on the appropriate tabs of the Object Type Designer.

Edit Object Type
To edit the existing object type (manage its definition etc)

e Select the object type for editing in the object pane.

e Right-click and select the ®2Design Type from the popup menu or simply
double-click the object type.
or

o Click the #2Design Type from the object pane toolbar.

o Edit object type properties on the appropriate tabs of the Object Type Designer.
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Delete Object Type
To delete an object type

o Select the object type for deleting in the object pane.

e Right-click and select the %eDelete Type from the popup menu.
or

o Click the "eDelete Type from the object pane toolbar.
e Confirm deleting in the dialog window.

Create Type Body (Object Type Body)
To create a new type body

o Select the object type for modifying in the object pane.
e Right-click and select & New Type Body from the popup menu.
o Edit type body properties on the appropriate tabs of the Type Body Designer.

Edit Type Body
To edit the existing type body (manage its definition etc)

o Select the object type for editing in the object pane.
o Right-click and select the |!£1‘Design Type Body from the popup menu.
o Edit type body properties on the appropriate tabs of the Type Body Designer.

Delete Type Body
To delete a type body

e Select the object type for deleting in the object pane.
e Right-click and select the dpelete Type Body from the popup menu.
e Confirm deleting in the dialog window.
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Create Collection Type
To create a new collection type

e Select anywhere on the object pane.
« Click the ®New Collection Type from the object pane toolbar.
or
« Right-click and select *New Collection Type from the popup menu.
o Edit collection type properties on the appropriate tabs of the Collection Type Designer.

To create a new collection type with modification as one of the existing collection type

e Select the collection for modifying in the object pane.

e Right-click and select the ®:Design Type from the popup menu or simply
double-click the collection type.
or

o Click the #2Design Type from the object pane toolbar.

e Modify collection type properties on the appropriate tabs of the Collection Type
Designer.

« Click bdsave As.

Edit Collection Type
To edit the existing collection type(manage its general etc)

e Select the collection type for editing in the object pane.

e Right-click and select the ®:Design Type from the popup menu or simply
double-click the collection type.
or

o Click the #2Design Type from the object pane toolbar.

o Edit collection type properties on the appropriate tabs of the Collection Type Designer.

Delete Collection Type
To delete a collection type

e Select the collection type for deleting in the object pane.
e Right-click and select the #eDelete Type from the popup menu.
or

e Click the %eDelete Type from the object pane toolbar.
e Confirm deleting in the dialog window.
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Maintain Type
To maintain a type

e Select the type for maintaining in the object pane.

e Right-click and select the Maintain from the popup menu.
o Compile
o Compile for Debug

Achieve Type Information
To achieve a type information

e Select the type in the object pane.

o Right-click the selected type and choose Object Information from the popup menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Object Type Designer

Object Type Designer is the basic Navicat tool for working with object types. It allows you
to create new object type and edit the existing object

o Editing Object Type Definition

e Object Type SQL Preview

After saving the object type, you can edit the Object Type Body. Just click |!’.ﬁ}Design Object
Type Body to open the Type Body Designer.
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Editing Oracle Object Type Definition

Edit the object type definition under the Definition tab.

The Code Outline window displays information about the object type including declaration,
etc. To show the Code Outline window, simply choose View -> Code Outline.

Note: Available only in Full Version.

Refresh the code outline.

Show the detail view of the code outline.

Turn mouse over highlight on or off.

Expand the selected item.

Collapse the selected item.

& F | F | %llo

Toggle sorting by position.

The SQL statements for creating object types are CREATE TYPE. In practice, it is best to use
a CREATE OR REPLACE statement. The general form of these statements follows.

CREATE OR REPLACE
TYPE /*TYPE NAME*/ AS OBJECT (
/* TODO enter type specification (methods, attributes etc) here */

Hint: To customize the view of the editor and find out more features for sql editing, see Editor
View and More Features.
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Oracle Type Body Designer

Type Body Designer is the basic Navicat tool for working with object type bodies. It allows
you to create new type body and edit the existing type body definition.

o Editing Type Body Definition

e Type Body SQL Preview

To edit the Object Type Specification, click #2Design Object Type Specification to open
the Object Type Designer.
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Editing Oracle Type Body Definition

Edit the type body definition under the Definition tab.

The Code Outline window displays information about the type body including declaration,
etc. To show the Code Outline window, simply choose View -> Code Outline.

Note: Available only in Full Version.

Refresh the code outline.

Show the detail view of the code outline.

Turn mouse over highlight on or off.

Expand the selected item.

Collapse the selected item.

& F | F | %llo

Toggle sorting by position.

The SQL statements for creating type bodies are CREATE TYPE BODY. In practice, it is best
to use a CREATE OR REPLACE statement. The general form of these statements follows.

CREATE OR REPLACE
TYPE BODY /*TYPE NAME*/ AS

END;

Hint: To customize the view of the editor and find out more features for sql editing, see Editor
View and More Features.
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Oracle Collection Type Designer

Collection Type Designer is the basic Navicat tool for working with collection types. It
allows you to create new collection type and edit the existing collection type definition.

o Editing Collection Type General

e Collection Type SQL Preview
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Editing Oracle Collection Type General

Nested table
Create a nested table type.

VArray
Create a varray type.

Array Size
Determine the array size of the varray type.

Data Type
Select the Oracle Database built-in datatype or user-defined type of the attribute.

Data Type Parameter
Determine the corresponding data type parameters.
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Oracle XML Schemas

XML Schema is a schema definition language written in XML. It can be used to describe the
structure and various other semantics of conforming instance documents.

Just simply click £-> XML Schema to open an object pane for XML Schema. A right-click

displays the popup menu or using the object pane toolbar, allowing you to create new, edit
and delete the selected XML Schema.

Create XML Schema
To create a new XML Schema

e Select anywhere on the object pane.
« Click the "$New XML Schema from the object pane toolbar.
or
e Right-click and select PdNew XML Schema from the popup menu.
e Edit XML Schema properties on the appropriate tabs of the XML Schema Designer.

Maintain XML Schema
To maintain an XML Schema

e Select the XML Schema for maintaining in the object pane.
e Right-click and select the Maintain from the popup menu.
o Compile
o Purge

Delete XML Schema
To delete an XML Schema

e Select the XML Schema for deleting in the object pane.

e Right-click and select the bdpelete XML Schema from the popup menu.
or

o Click the MDelete XML Schema from the object pane toolbar.

e Confirm deleting in the dialog window.
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Achieve XML Schema Information
To achieve an XML Schema information

e Select the XML Schema in the object pane.

o Right-click the selected XML Schema and choose Object Information from the
popup menu.
or

e Choose View -> Object Information in the main menu.
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Oracle XML Schema Designer

XML Schema Designer is the basic Navicat tool for working with XML Schemas. It allows
you to create new XML Schema.

e Editing XML Schema Doc
e Setting Advanced XML Schema Properties
e XML Schema SQL Preview
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Editing Oracle XML Schema Doc

Enter a valid XML schema document under the Schema Doc tab. The general form follows.

<?xml version="1.0" encoding="UTF-8"?>
<xsd:schema xmins:xsd="http://www.w3.0rg/2001/XMLSchema" >
</xsd:schema>
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Setting Advanced Oracle XML Schema Properties

M Local
Check this to register as local schemas.

¥ Force on schema registration
Check this to ignore errors generated during schema evolution.

Generate

I Object Types
Check this to enable the schema compiler to generate object types.

¥ Java Beans
Check this to enable the schema compiler to generate Java beans.

M Default Tables
Check this to enable the schema compiler to generate default tables.

Options

¥ REGISTER_NODOCID
Check this to prevent the creation of this column if the user wishes to optimize on

storage.

M REGISTER_BINARYXML
Check this to register the schema for Binary XML.

MREGISTER_NT_AS_IOT
Check this to store nested tables created during schema registration as index organized

tables.

M REGISTER_AUTO_OOL
Check this to automatically move large types out of line.

Enable Hierarchy

ENABLE_HIERARCHY_NONE
Enable hierarchy will not be called on any tables created while registering that schema.
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ENABLE_HIERARCHY_CONTENTS
Enable hierarchy will be called for all tables created during schema registration with
hierarchy_type as DBMS_XDBZ.ENABLE_CONTENTS.

ENABLE_HIERARCHY_RESMETADATA
Enable hierarchy will be called on all tables created during schema registration with
hierarchy_type as DBMS_XDBZ.ENABLE_RESMETADATA.
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Oracle Recycle Bin

Recycle bin is actually a data dictionary table containing information about dropped objects.
Dropped tables and any associated objects such as indexes, constraints, nested tables, and
the likes are not removed and still occupy space. They continue to count against user space
quotas, until specifically purged from the recycle bin or the unlikely situation where they
must be purged by the database because of tablespace space constraints.

Just simply click 2. Recycle Bin to open an object pane for Recycle Bin. A right-click
displays the popup menu or using the object pane toolbar, allowing you to flashback tables
or purge the deleted objects.

Restore tables
To restore table from recycle bin

e Choose a table in recycle bin.
« Click the WFlashback Table from the object pane toolbar.
or
« Right-click and select @ Flashback Table from the popup menu.

Purge Objects
To remove an object in the recycle bin

e Select an object for purging in the object pane.

« Right-click and select the ®Purge Object from the popup menu.
or

o Click the ®Purge Object from the object pane toolbar.

e Confirm deleting in the dialog window.

To remove all objects in the recycle bin

e Right-click and select the Purge Recycle Bin from the popup menu.
e Confirm deleting in the dialog window.
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To remove all objects in the recycle bin of every user

e Log in a user has the SYSDBA privilege.
e Right-click and select the Purge DBA Recycle Bin from the popup menu.
e Confirm deleting in the dialog window.

Achieve Recycle Bin Object Information
To achieve an object information in recycle bin

e Select the object in the object pane.

e Right-click the selected object and choose Object Information from the popup menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Directories

A directory object specifies an alias for a directory on the server file system where external
binary file LOBs (BFILEs) and external table data are located. All directories are created in a
single namespace and are not owned by an individual schema.

Just simply click 2 Directory to open an object pane for Directory. A right-click displays

the popup menu or using the object pane toolbar, allowing you to create new, edit and delete
the selected directory.

Create Directory
To create a new directory

e Select anywhere on the object pane.
o Click the t2New Directory from the object pane toolbar.
or
e Right-click and select LoNew Directory from the popup menu.
o Edit directory properties on the appropriate tabs of the Directory Designer.

To create a new directory with modification as one of the existing directory

o Select the directory for modifying in the object pane.

« Right-click and select the “’Design Directory from the popup menu or simply
double-click the directory.
or

« Click the “’Design Directory from the object pane toolbar.

e Modify directory properties on the appropriate tabs of the Directory Designer.

« Click ¥save As.

Edit Directory
To edit the existing directory(manage its general etc)

e Select the directory for editing in the object pane.

e Right-click and select the JDesign Directory from the popup menu or simply
double-click the directory.
or

e Click the %fDesign Directory from the object pane toolbar.

o Edit directory properties on the appropriate tabs of the Directory Designer.
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Delete Directory
To delete a directory

e Select the directory for deleting in the object pane.

e Right-click and select the LeDelete Directory from the popup menu.
or

o Click the “eDelete Directory from the object pane toolbar.

e Confirm deleting in the dialog window.

Achieve Directory Information
To achieve a directory information

e Select the directory in the object pane.

e Right-click the selected directory and choose Object Information from the popup
menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Directory Designer

Directory Designer is the basic Navicat tool for working with directories. It allows you to
create new directory and edit the existing directory definition.

o Editing Directory General

o Directory SQL Preview
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Editing Oracle Directory General

Edit the directory general properties under the General tab.

Directory Path
Specify the full path name of the operating system directory of the server where the files are
located. The path name is case sensitive.
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Oracle Tablespaces

Tablespaces are the allocation of space in the database that can contain schema objects.

Just simply click s> Tablespace to open an object pane for Tablespace. A right-click
displays the popup menu or using the object pane toolbar, allowing you to create new, edit
and delete the selected tablespace.

Create Tablespace
To create a new tablespace

e Select anywhere on the object pane.
o Click the ZNew Tablespace from the object pane toolbar.
or
e Right-click and select ZNew Tablespace from the popup menu.
o Edit tablespace properties on the appropriate tabs of the Tablespace Designer.

To create a new tablespace with modification as one of the existing tablespace

o Select the tablespace for modifying in the object pane.
o Right-click and select the :}Design Tablespace from the popup menu or simply
double-click the tablespace.
or
e Click the :}Design Tablespace from the object pane toolbar.
e Modify tablespace properties on the appropriate tabs of the Tablespace Designer.
« Click %save As.

Edit Tablespace
To edit the existing tablespace (manage its properties etc)

e Select the tablespace for editing in the object pane.

o Right-click and select the :}Design Tablespace from the popup menu or simply
double-click the tablespace.
or

e Click the :}Design Tablespace from the object pane toolbar.

o Edit tablespace properties on the appropriate tabs of the Tablespace Designer.
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To change the name of the tablespace

e Select the tablespace for editing in the object pane.
e Right-click and select the Rename from the popup menu.

Maintain Tablespace
To maintain a tablespace

e Select the tablespace for maintaining in the object pane.
e Right-click and select the Maintain from the popup menu.
o [Read Only]

o Read Write
o Online
o Offline
= Normal

= Temporary
= Immediate
o Coalesce
o Shrink Space

Delete Tablespace
To delete a tablespace

e Select the tablespace for deleting in the object pane.

e Right-click and select the ZDelete Tablespace from the popup menu.
or

« Click the ZSDelete Tablespace from the object pane toolbar.

e Confirm deleting in the dialog window.

Achieve Tablespace Information
To achieve a tablespace information

o Select the tablespace in the object pane.

e Right-click the selected tablespace and choose Object Information from the popup
menu.
or

e Choose View -> Object Information in the main menu.
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Oracle Tablespace Designer

Tablespace Designer is the basic Navicat tool for working with tablespaces. It allows you to
create new tablespace and edit the existing tablespace properties.

o Editing Tablespace General

o Editing Tablespace Storage
o Setting Advanced Tablespace Properties

e Tablespace SQL Preview
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Editing Oracle Tablespace General

Tablespace Type

PERMANENT
A permanent tablespace contains persistent schema objects. Objects in permanent
tablespaces are stored in datafiles.

TEMPORARY
A temporary tablespace contains schema objects only for the duration of a session.
Objects in temporary tablespaces are stored in tempfiles.

UNDO

An undo tablespace is a type of permanent tablespace used by Oracle Database to
manage undo data if you are running your database in automatic undo management
mode.

Data File
Use the Name and Size edit box to set the datafile / tempfile name and size.

The Unit drop-down list defines the unit of the size of the datafile / tempfile. Specify the
maximum disk space allowed for automatic extension of the datafile. Use the dropdown
list K, M, G, T, P or E to specify the size in kilobytes, megabytes, gigabytes, terabytes,
petabytes, or exabytes. If you do not specify any of the abbreviations, then the size is
interpreted as bytes.

¥ Reuse
To allow Oracle to reuse an existing file.

Path
Specify the path of the datafile / tempfile.

Auto Extend
To ON (enable) or OFF (disable) the automatic extension of a new or existing datafile or
tempfile.

Next Size
Specify the size in bytes of the next increment of disk space to be allocated automatically
when more extents are required. The default is the size of one data block. Use the dropdown
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list K, M, G, T, P or E to specify the size in kilobytes, megabytes, gigabytes, terabytes,
petabytes, or exabytes. If you do not specify any of the abbreviations, then the size is
interpreted as bytes.

M Unlimited Max
Unlimited disk space that Oracle can allocate to the datafile or tempfile.

Max Size

Specify the maximum disk space allowed for automatic extension of the datafile. Use the
dropdown list K, M, G, T, P or E to specify the size in kilobytes, megabytes, gigabytes,
terabytes, petabytes, or exabytes. If you do not specify any of the abbreviations, then the
size is interpreted as bytes.
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Editing Oracle Tablespace Storage

File Type

BIGFILE

A bigfile tablespace contains only one datafile or tempfile, which can contain up to
approximately 4 billion (23%) blocks. The maximum size of the single datafile or tempfile
is 128 terabytes (TB) for a tablespace with 32K blocks and 32TB for a tablespace with 8K
blocks.

SMALLFILE
A smallfile tablespace is a traditional Oracle tablespace, which can contain 1022 datafiles
or tempfiles, each of which can contain up to approximately 4 million (222) blocks.

Min Extent Size

The minimum size of an extent in the tablespace. Use the dropdown list K, M, G, T, P or E to
specify the size in kilobytes, megabytes, gigabytes, terabytes, petabytes, or exabytes. If you
do not specify any of the abbreviations, then the size is interpreted as bytes.

Block Size
The block size for the tablespace.

Default Storage Options
Set the default storage characteristics for objects created in the tablespace.

Table Compression
Use the dropdown list to select the type of compressing data segments to reduce disk use.

M Manual Segment Management
To manage the free space of segments in the tablespace using free lists.

Extent Management
To specify how the extents of the tablespace will be managed.

Extent Management

DICTIONARY
Extent management by the data dictionary.
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LOCAL
Extent management by the bitmaps.

Local Extent

AUTOALLOCATE
The tablespace is system managed.

UNIFORM
The tablespace is managed with uniform extents of size.

Uniform Size

The size of uniform extent. The default size is 1 megabyte. Use the dropdown list K, M,
G, T, P or E to specify the size in kilobytes, megabytes, gigabytes, terabytes, petabytes,
or exabytes. If you do not specify any of the abbreviations, then the size is interpreted

as bytes.
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Setting Advanced Oracle Tablespace Properties

Logging

LOGGING
Log all objects within the tablspace in the redo log file.

NOLOGGING
No operations are logged.

I Force Logging
Oracle Database will log all changes to all objects in the tablespace except changes to

temporary segments, overriding any NOLOGGING setting for individual objects.

¥ Offline
The tablespace is unavailable immediately (offline) after creation.

M Retention Guarantee
Oracle Database should preserve unexpired undo data in all undo segments of tablespace

even if doing so forces the failure of ongoing operations that need undo space in those

segments.

Tablespace Group
To determine whether tablespace is a member of a tablespace group.

Flashback

ON
Oracle Database will save Flashback log data for this tablespace and the tablespace can

participate in a FLASHBACK DATABASE operation.

OFF
Oracle Database will not save any Flashback log data for this tablespace.

Encryption

MUse Encryption
Enable the encryption properties of the tablespace.

Algorithm
To select the encryption algorithm.
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Oracle Public Database Links

Public database Link is a database link created by a DBA on a local database that is accessible
to all users on that database.

See Database Link for details.
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Oracle Public Synonyms

Public synonym is a synonym owned by the special user group named PUBLIC and every user
in a database can access it.

See Synonyms for details.
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